Subject: [Drip] real-world drone id experience

From: Andrei Gurtov <[email-masked]>
Date: Fri, 11 Sep 2020 14:30:48 +0200

Just want to share an experience with flying a drone DJI Phantom
(according to current rules) near SAAB airport in Linkoping, Sweden.

The flying spot was about 4km from runway end, so according to rules no
drone flying without the tower approval. And in 5-20km ATC zone, max 10m
from the ground without approval.

So I called the tower with a cell phone and asked for permission. The
tower is actually remotely operated from another city (500 km away).

They said traffic is busy, but asked for my GPS position and labeled me
at ATC screen with my cell phone number as ID and asked for duration. I
said 2h. So just phone #, no name, drone type, serial number etc

Then I was called 3 times in next 2 hours and given a permission to lift
off up to 400ft (120m) and then ordered to land down when other traffic
came after 5-10minutes.

It was fun, but obviously not scalable as the ATC had to talk on radio
to airplanes and to my phone same time. So they can't really accommodate
many drone users at the moment. Also what they gonna do if my phone runs
out of battery while the drone is flying? Close whole airspace? Send a
patrol car to my location?

A strange thing is that restrictions apply only when the tower is open.
So e.g. on an evening it is allowed to come and fly a drone by the
runway, which could be really dangerous for VFR airplanes in
not-controlled airspace. This will change soon, ATC said.

On the other hand, it makes little sense to restrict drones from flying
at 400ft further than few hundred meters from the runway. Airplanes are
not allowed to fly that low anyway when not in takeoff/landing.

So the system currently relies on cooperation and compliance as in
traditional aviation. Also, my drone has my name and phone number
written on it as required for "drone id".

I was told though that DJI has already implemented some hidden drone id
and backdoor to own drones with a special police app.

br Andrei

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 11 Sep 2020 15:31:33 +0200

> and backdoor to own drones with a special police app.

- it is good to know it is possible to test as you did.

- one would benefit from asking DJI organisation what is the 'hidden 
drone id' that they programmed in a Phantom.

- the described method of identifcation by using a mobile phone number 
and drone type makes sense. It makes think about putting them in a X.509 
certificate, maybe advertised in an RA, maybe a related Human-Readable 
QR code painted on the drone frame (hrqr.org).

My drone ID would be "+33662344214 DJI Phantom" with hrqr:

*http://hrqr.org/?%2B33662344214%20DJI%20Phantom*

(the http should be a https, and it should work over IPv6, and the 
address might need to be containing a public key if appropriate)

(too, the hours of flight discussion is a very important one; it affects 
the population at large with the noise aspects; any new technology 
should consider these societal and ethical viewpoints).

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 11 Sep 2020 15:53:46 +0200

Le 11/09/2020 à 14:30, Andrei Gurtov a écrit :
> [...]
> They said traffic is busy, but asked for my GPS position

To quickly tell them one's GPS position, I heard about this method 
'what3words'.

In French (Ennglish and Swedish are possible), your position near the 
SAAB Linköping airport is: "///opérationnel.transitif.déchargeur"

It is a localisation technique which could have saved lives of people 
calling emergency services who have a difficulty of saying where 
precisely they are.

Alex

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Fri, 11 Sep 2020 19:20:39 +0000

In NA, FAA has published the UAS fly map, https://faa.maps.arcgis.com/apps/webappviewer/index.html?id=9c2e4406710048e19806ebf6a06754ad

AFAIK, Whoever participating the LANNC program who has to follow the limitation set based on the map unless was told otherwise.

Best,
Shuai Zhao

From: Tm-rid <[email-masked]> on behalf of Andrei Gurtov <[email-masked]>
Date: Friday, September 11, 2020 at 05:31
To: "[email-masked]" <[email-masked]>
Subject: [Drip] real-world drone id experience(Internet mail)

br Andrei

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 12 Sep 2020 21:02:56 +0200

Thanks for the map.

I searched in it an ID of a flying device.

I could not find an ID for a flying device.

Does this map show somewhere an ID of a flying device?

For areas (not flying devices), I could 128bit IDs for areas.  For 
exampple this Global ID 84e388ea-39b8-4b35-8c70-cb913abd2147 which seems 
to be a 16byte hex value, ie 128bit, like an IPv6 address:

Alex

Le 11/09/2020 à 21:20, shuaiizhao(Shuai Zhao) a écrit :
>
> In NA, FAA has published the UAS fly map, 
> https://faa.maps.arcgis.com/apps/webappviewer/index.html?id=9c2e4406710048e19806ebf6a06754ad
>
> AFAIK, Whoever participating the LANNC program who has to follow the 
> limitation set based on the map unless was told otherwise.
>
> Best,
>
> Shuai Zhao
>
> *From: *Tm-rid <[email-masked]> on behalf of Andrei Gurtov 
> <[email-masked]>
> *Date: *Friday, September 11, 2020 at 05:31
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[Drip] real-world drone id experience(Internet mail)
>
> [email-masked] <mailto:[email-masked]>
>

---

From: Stephan Wenger <[email-masked]>
Date: Sun, 13 Sep 2020 19:40:11 +0000

Hi Andrei and all,
Let me add a few things into this report from a pilot's experience (that includes a fair bit of working with ATC in various countries).  Very long email, but perhaps of interest to those of you without a lot of international aviation background.  And there is some drone stuff spinkled in :-)
Stephan

On 9/11/20, 5:31 AM, "Tm-rid on behalf of Andrei Gurtov" <[email-masked] on behalf of [email-masked]> wrote:

    The flying spot was about 4km from runway end, so according to rules no
    drone flying without the tower approval. 

Regulations are different from country to country, but this one is in my experience fairly consistent, and it makes a lot of sense from a pilot's perspective, especially if the drone has only manual altitude control and/or relies on a non-expert to judge the altitude correctly (which is the case for most cheaper drones nowadays).  Most approach paths have a 3 degree glidepath, and larger aircraft follow these paths closely.  For your spot at 4km distance--roughly 2.2 nautical miles--that would mean that a jet approaching right on the glideslope would be around 700 ft altitude, at 140 knots or so, gears and flaps down, with very limited forward visibility for the pilots due to the attitude of the aircraft in this phase of flight.  Which in practice could mean anywhere between say 600 and 800 ft above ground, especially when its bumpy, and the pilots have their hands full.  No wonder that the tower asked you for a hole in the traffic before allowing your drone to take off.  These guys are responsible for keeping aircraft traffic safe, and they like safety margins.  And it's unlikely a non-suspecting or even a forewarned pilot could see and avoid small drone when approaching at 250+ km/h.  Nor has a single drone pilot (without spotter) much of a chance to take meaningful action before it may be too late.

    And in 5-20km ATC zone, max 10m from the ground without approval.

That's one example where regulations defer, and the US is both more and less drone-friendly than the Europe.  In the US, there is no umbrella authorization for 10 meters in controlled airspace (though a lot of people, including commercial drone pilots, ignore the regs).  OTOH, the granularity of allowed drone ops (usually up to 400 ft) is much finer.  See the chart Shuai posted for info how the minimum altitude is published for non-ATC authorized drone ops in the US.  

That's quite common in the US also.

That's exactly the protocol a heli pilot would expect if they had work to do in the approach path (aerial pictures, pipeline inspection, etc.).  Perhaps they treated you like a heli :-). 
What likely happened at the first call was that they put up NOTAM of possible drone activity with your location, for a specified time and for a specified maximum altitude (but without your name, ID etc.).  Drone pilots in the US can do something similar without ATC involvement now, hours or days in advance, and you see them now during flight planning quite regularly (to the point they start to become a nuisance).  Then, when they called you, they "activated" that NOTAM.  Some modern aircraft receive such information in close to real-time, and can display warning messages etc. if the avionics judge a drone may be in your flight path.  But that info is transmitted over ADSB-In, which has severe bandwidth limitations and will not scale to large numbers of drones, even if the activation process were somewhat automated.
  
    It was fun, but obviously not scalable as the ATC had to talk on radio
    to airplanes and to my phone same time. So they can't really accommodate
    many drone users at the moment. 

Right: that system does not scale.

    Also what they gonna do if my phone runs
    out of battery while the drone is flying? Close whole airspace? Send a
    patrol car to my location?

No.  When they cleared you for takeoff, they gave (or should have given) you a "clearance limit", in this case a time-based one.  It's a timeout--if you don't hear back from them after x minutes, you have to land.  Again, doing so is common for heli ops, except they receive their clearance (including the clearance limit) via VFR radio.

This is again a common thing in ATC regulations around the world.  Generally put, aviation distinguishes between controlled and uncontrolled airspace.  "Controlled" is everything above a certain height above ground or sea level.  Close to the ground, airspace is generally "uncontrolled", which means that ATC does not take responsibility for your aircraft to fly into another one.  The exception is for certain areas specifically identified in aeronautical charts, and mostly centered around towered airports, or busy non-towered ones.  The "controlling" can obviously only happen as long as the tower (or other ATC facility) is staffed.  When the tower shuts down, the airspace usually controlled by it becomes uncontrolled, and you as a pilot are on your own.  And, you can do stupid things with your drone endangering other people, legally.

For small aircraft, in most countries the lowest legal altitude to fly (except during takeoff and approach/landing) is 500ft.  For helicopters, it's lower.  That's where the 400 ft present in most drone regulations comes from, and again, there's only 100 ft of safety margin build in, which is way(!) too little for my comfort.  Bouncing your altitude by 100 ft, takes only seconds of inattention even in a comparatively slow aircraft.  In a jet--you probably have no idea.
  
Does anyone sensible, outside of ground reference training scenarios, fly even a little Cessna at 500ft or thereabouts?  No.  But it's legal, and it was more common in the early days of aviation.  And helis operate at 500 ft quite routinely, especially if there's a low ceiling. 

    traditional aviation. 

Right.

    Also, my drone has my name and phone number written on it as required for "drone id".

That's the law now in most countries.  It's obviously more suited for accident investigation than for anything else.  I believe the need for a "drone id" as we discuss it here is more along the call sign of an aircraft or the phone number you provided, plus the need to stay in contact when feasible (i.e. absent equipment failures).  It's a link to the pilot during the operation, and incident/accident related uses are an important but still secondary use. 

    br Andrei

    -- 
    Tm-rid mailing list
    [email-masked]

---

From: Stephan Wenger <[email-masked]>
Date: Sun, 13 Sep 2020 19:41:27 +0000

The map provides for the maximum allowed altitude for drone operations without ATC clearance, nothing else.
S.

From: Tm-rid <[email-masked]> on behalf of Alexandre Petrescu <[email-masked]>
Date: Saturday, September 12, 2020 at 12:03 PM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Drip] real-world drone id experience(Internet mail)

Thanks for the map.

For areas (not flying devices), I could 128bit IDs for areas.  For exampple this Global ID 84e388ea-39b8-4b35-8c70-cb913abd2147 which seems to be a 16byte hex value, ie 128bit, like an IPv6 address:

Alex

Best,
Shuai Zhao

From: Tm-rid <[email-masked]><mailto:[email-masked]> on behalf of Andrei Gurtov <[email-masked]><mailto:[email-masked]>
Date: Friday, September 11, 2020 at 05:31
To: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: [Drip] real-world drone id experience(Internet mail)

br Andrei

---

From: Robert Moskowitz <[email-masked]>
Date: Sun, 13 Sep 2020 17:22:15 -0400

Stephan,

Thank you for adding your experience and knowledge to the discussion.

There really is a lot at stake here, and we have an opportunity to add 
significantly to the safe use of our airspace.

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 14 Sep 2020 12:12:04 +0200

> without ATC clearance, nothing else.
Ah, I see, it clarifies it.  So that map might use 128bit identifiers 
for areas.

But there is a website that displays live identification of aircraft. 
E.g. flightradar24.com displays 'FBPIK' printed on the tail of a small 
plane near me right now.

I was thinking there might be a similar website displaying live drones 
or helicopters or model planes?  Maybe that website says whether they 
identify drones also by mobile phone number and modeltype.

(flightradar24.com says that the 'label' of an aicraft could be one of 
Callsign, FlightNumber, Type&Registration; I suspect none of these 
'labels' is valid for drones).

Alex

> *From: *Tm-rid <[email-masked]> on behalf of Alexandre 
> Petrescu <[email-masked]>
> *Date: *Saturday, September 12, 2020 at 12:03 PM
> *To: *"shuaiizhao(Shuai Zhao)" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [Drip] real-world drone id experience(Internet mail)
>
> Thanks for the map.
>
> exampple this Global ID 84e388ea-39b8-4b35-8c70-cb913abd2147 which 
> seems to be a 16byte hex value, ie 128bit, like an IPv6 address:
>
> Alex
>
>     AFAIK, Whoever participating the LANNC program who has to follow
>     the limitation set based on the map unless was told otherwise.
>
>     Best,
>
>     Shuai Zhao
>
>     *From: *Tm-rid <[email-masked]>
>     <mailto:[email-masked]> on behalf of Andrei Gurtov
>     <[email-masked]> <mailto:[email-masked]>
>     *To: *"[email-masked]" <mailto:[email-masked]> <[email-masked]>
>     <mailto:[email-masked]>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 14 Sep 2020 12:31:45 +0200

Le 13/09/2020 à 21:40, Stephan Wenger a écrit :
[...]
> I believe the need for a "drone id" as we discuss it here is more 
> along the call sign of an aircraft or the phone number you provided, 
> plus the need to stay in contact when feasible (i.e. absent equipment
> failures).

It seems to make sense to me.

If a drone ID is potentially as we discuss it here, and if that drone ID
needs to contain something like a phone number (a 'call sign' so one can
call the phone) and a model type... then the IMEI (a unique label
printed in the phone, associated to the phone number) in an IPv6 address
draft-dupont-ipv6-imei-01 of year 2002 might be of some relevance.

Alex

> It's a link to the pilot during the operation, and incident/accident 
> related uses are an important but still secondary use.
> 
> I was told though that DJI has already implemented some hidden drone
>  id and backdoor to own drones with a special police app.
> 
> br Andrei
> 
> -- Tm-rid mailing list [email-masked]

---

From: "Card, Stu" <[email-masked]>
Date: Mon, 14 Sep 2020 10:22:47 -0400

Such a website for UAS would be what ASTM calls a "Network RID Display
Provider" (equivalent to what the US FAA calls a USS providing the "RID
Display Service", I don't know what the EASA will call it as they add
Network RID to their previous Broadcast RID centric approach).

On Mon, Sep 14, 2020 at 6:12 AM Alexandre Petrescu <
[email-masked]> wrote:

> Ah, I see, it clarifies it.  So that map might use 128bit identifiers for
> areas.
>
> But there is a website that displays live identification of aircraft. E.g.
> flightradar24.com displays 'FBPIK' printed on the tail of a small plane
> near me right now.
>
> I was thinking there might be a similar website displaying live drones or
> helicopters or model planes?  Maybe that website says whether they identify
> drones also by mobile phone number and modeltype.
>
> Callsign, FlightNumber, Type&Registration; I suspect none of these 'labels'
> is valid for drones).
>
> Alex
>
>
>
>
>
> *From: *Tm-rid <[email-masked]> <[email-masked]> on
> behalf of Alexandre Petrescu <[email-masked]>
> <[email-masked]>
> <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]> <[email-masked]>
> <[email-masked]>
> exampple this Global ID 84e388ea-39b8-4b35-8c70-cb913abd2147 which seems to
> be a 16byte hex value, ie 128bit, like an IPv6 address:
>
>
>
> Alex
>
> *From: *Tm-rid <[email-masked]> <[email-masked]> on
> behalf of Andrei Gurtov <[email-masked]> <[email-masked]>
> *To: *"[email-masked]" <[email-masked]> <[email-masked]>
> <[email-masked]>

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 14 Sep 2020 17:41:45 +0000

A few words about flightradar24 from a very satisfied user:

Flightradar24 nowadays relies mostly on ADS-B broadcasts transmitted from aircraft.  Originally, they tapped into whatever public ATC position data is/was available in each country (which was generally somewhat censored, and often delayed by 10 minutes or so, and the format was country-specific, and changed occasionally).  Nowadays, they get their raw data mostly through crowdsourcing except for overseas travel: people have an ADS-B antenna in their attics, connected to a Raspberry PI or something, and upload what they receive over the Internet to the flighradar24 site in Sweden.  Note that this amateur ADS-B setup is receive-only and by no means comparable with the complexity of the ground stations.

The five or six letter tail number (FBPIK in your example) indeed a callsign.  The tail number is like a car license plate, and if one were to accept the not insubstantial fees and paperwork hassle, one could change it during the lifetime of the aircraft  Airlines also use a combination of airline name and flight number as a callsign over the voice radios, to enable equipment flexibility (filing flight plans without knowing in advanced which specific aircraft will fly the route on a given day/hour).

Aircraft don’t send the tail numbers or callsigns callsign over ADS-B.  Instead they send a 24 bit ICAO address (informally: Mode-S Hex Code), which unique to each aircraft and never changes.  Flightradar24 calls this info the “Serial Number”, and it’s usually hidden unless you pay them to display it.  The 24 bit ICAO addresses were introduced around 1975 with Mode-S transponders.

The mapping between the IACO address the tail number, and finally the airline and flight number happens in flightradar24’s servers based on publicly available databases run by ATC authorities, IATA, and the airlines .  The format of some of those databases change and differ from country to country.   Sorting out that puzzle is one of the main values of flightradar24.

Stephan

From: Alexandre Petrescu <[email-masked]>
Date: Monday, September 14, 2020 at 3:12 AM
To: Stephan Wenger <[email-masked]>, "shuaiizhao(Shuai Zhao)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Drip] real-world drone id experience(Internet mail)

Ah, I see, it clarifies it.  So that map might use 128bit identifiers for areas.

But there is a website that displays live identification of aircraft. E.g. flightradar24.com displays 'FBPIK' printed on the tail of a small plane near me right now.

I was thinking there might be a similar website displaying live drones or helicopters or model planes?  Maybe that website says whether they identify drones also by mobile phone number and modeltype.

(flightradar24.com says that the 'label' of an aicraft could be one of Callsign, FlightNumber, Type&Registration; I suspect none of these 'labels' is valid for drones).

Alex

From: Tm-rid <[email-masked]><mailto:[email-masked]> on behalf of Alexandre Petrescu <[email-masked]><mailto:[email-masked]>
Date: Saturday, September 12, 2020 at 12:03 PM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]><mailto:[email-masked]>
Cc: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: Re: [Drip] real-world drone id experience(Internet mail)

Thanks for the map.

Alex

Best,
Shuai Zhao

br Andrei

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 14 Sep 2020 13:56:06 -0400

On 9/14/20 1:41 PM, Stephan Wenger wrote:
> Flightradar24 nowadays relies mostly on ADS-B broadcasts transmitted 
> from aircraft.  Originally, they tapped into whatever public ATC 
> position data is/was available in each country (which was generally 
> somewhat censored, and often delayed by 10 minutes or so, and the 
> format was country-specific, and changed occasionally).  Nowadays, 
> they get their raw data mostly through crowdsourcing except for 
> overseas travel: people have an ADS-B antenna in their attics, 
> connected to a Raspberry PI or something, and upload what they receive 
> over the Internet to the flighradar24 site in Sweden. Note that this 
> amateur ADS-B setup is receive-only and by no means comparable with 
> the complexity of the ground stations.
>
> The five or six letter tail number (FBPIK in your example) indeed a 
> callsign.  The tail number is like a car license plate, and if one 
> were to accept the not insubstantial fees and paperwork hassle, one 
> could change it during the lifetime of the aircraft
>

In ICAO calls I have been on, this has been identified as a 'common' 
occurrence (i.e. design for it).  Often involving leased aircraft 
changing leasers/operators, but not limited to that.

> Airlines also use a combination of airline name and flight number as a 
> callsign over the voice radios, to enable equipment flexibility 
> (filing flight plans without knowing in advanced which specific 
> aircraft will fly the route on a given day/hour).
>
> Aircraft don’t send the tail numbers or callsigns callsign over 
> ADS-B.  Instead they send a 24 bit ICAO address (informally: Mode-S 
> Hex Code), which unique to each aircraft and never changes.  
> Flightradar24 calls this info the “Serial Number”, and it’s usually 
> hidden unless you pay them to display it.  The 24 bit ICAO addresses 
> were introduced around 1975 with Mode-S transponders.
>

And it is not the airframe serial number.  That is something assigned by 
the manufacturer and the 1st owner presents this number as part of the 
1st-time airframe certification application.  This number only changes 
if the fuselage or wings change (according to call participants that 
include FAA).  It seems to happen, as one participant related what it 
was like to physically remove the original, non-removable, serial plate 
and install a new non-removable plate.

There is no standard for these serial numbers.

I wonder if when the added winglets, they had to re-serialize the airframes?

> The mapping between the IACO address the tail number, and finally the 
> airline and flight number happens in flightradar24’s servers based on 
> publicly available databases run by ATC authorities, IATA, and the 
> airlines .  The format of some of those databases change and differ 
> from country to country.   Sorting out that puzzle is one of the main 
> values of flightradar24.
>
> Stephan
>
> *From: *Alexandre Petrescu <[email-masked]>
> *Date: *Monday, September 14, 2020 at 3:12 AM
> *To: *Stephan Wenger <[email-masked]>, "shuaiizhao(Shuai Zhao)" 
> <[email-masked]>
>     The map provides for the maximum allowed altitude for drone
>     operations without ATC clearance, nothing else.
>
>     S.
>
>     <mailto:[email-masked]> on behalf of Alexandre Petrescu
>     <[email-masked]> <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     *Cc: *"[email-masked]" <mailto:[email-masked]> <[email-masked]>
>     <mailto:[email-masked]>
>         AFAIK, Whoever participating the LANNC program who has to
>         follow the limitation set based on the map unless was told
>         otherwise.
>
>         Best,
>
>         Shuai Zhao
>
>         *To: *"[email-masked]" <mailto:[email-masked]>
>         <[email-masked]> <mailto:[email-masked]>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 16 Sep 2020 15:04:24 +0200

Le 14/09/2020 à 19:41, Stephan Wenger a écrit :
> connected to a Raspberry PI or something, and upload what they 
> receive over the Internet to the flighradar24 site in Sweden.  Note 
> that this amateur ADS-B setup is receive-only and by no means 
> comparable with the complexity of the ground stations.
> 
> could change it during the lifetime of the aircraft  Airlines also 
> use a combination of airline name and flight number as a callsign 
> over the voice radios, to enable equipment flexibility (filing
> flight plans without knowing in advanced which specific aircraft will
> fly the route on a given day/hour).
> 
> Hex Code),

This Mode-S Hex Code 24bit ICAO address could be put into an IPv6
address, maybe in an Interface Identifier, maybe in a part of the
prefix.  This could be part of a document titled 'IPv6 over ADS-B'.

> which unique to each aircraft and never changes. Flightradar24 calls
> this info the “Serial Number”, and it’s usually hidden unless you pay
> them to display it.

That need to pay is a problem to scalability.  It would be difficult to 
have a system that scales to a large number of drones if this Serial 
Number is hidden unless you pay.

Large number of drones means many many implementers.

Maybe they could open the specs of the "Serial Number" ICAO Mode-S Hex 
Code 24bit.

> The 24 bit ICAO addresses were introduced around 1975 with Mode-S
> transponders.
> 
> The mapping between the IACO address the tail number, and finally
> the airline and flight number happens in flightradar24’s servers
> based on publicly available databases run by ATC authorities, IATA,
> and the airlines .  The format of some of those databases change and
> differ from country to country.   Sorting out that puzzle is one of
> the main values of flightradar24.

I didnt know that.

Alex

> 
> Stephan
> 
> *From: *Alexandre Petrescu <[email-masked]> *Date: 
> *Monday, September 14, 2020 at 3:12 AM *To: *Stephan Wenger 
> <[email-masked]>, "shuaiizhao(Shuai Zhao)" <[email-masked]>
>  *Cc: *"[email-masked]" <[email-masked]> *Subject: *Re: [Drip] 
> real-world drone id experience(Internet mail)
> 
> But there is a website that displays live identification of
> aircraft. E.g. flightradar24.com displays 'FBPIK' printed on the tail
> of a small plane near me right now.
> 
> I was thinking there might be a similar website displaying live 
> drones or helicopters or model planes?  Maybe that website says 
> whether they identify drones also by mobile phone number and 
> modeltype.
> 
> (flightradar24.com says that the 'label' of an aicraft could be one 
> of Callsign, FlightNumber, Type&Registration; I suspect none of
> these 'labels' is valid for drones).
> 
> Alex
> 
>  *Date: *Saturday, September 12, 2020 at 12:03 PM *To: 
> *"shuaiizhao(Shuai Zhao)" <[email-masked]> 
> <mailto:[email-masked]> *Cc: *"[email-masked]" 
> <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked]> 
> <[email-masked]> <mailto:[email-masked]> *Date: *Friday, 
> September 11, 2020 at 05:31 *To: *"[email-masked]" 
> <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked]> 
> id

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 16 Sep 2020 10:08:09 -0400

> prefix.  This could be part of a document titled 'IPv6 over ADS-B'.

ICAO is creating a 'walled garden' Internet for commercial aviation.  
Part of that is defined in:

The Global Resilient Aviation Interoperable Network (GRAIN)

GRAIN will get a small IPv6 prefix (TBD) and divvy up that address space 
for various purposes.  I am very much involved with this work.  I CAN 
tell you that one group of addresses will contain the ICAO airplane number.

Don't look for IPv6 addressing over ADS-B.  It would take a major rework 
and thus maybe ADS-C?  :)

Also you need additional information to take this number and construct 
the address.  And for privacy reasons we are recommending that all uses 
of these addresses be in secure tunnels when over untrusted media.

> That need to pay is a problem to scalability.  It would be difficult 
> to have a system that scales to a large number of drones if this 
> Serial Number is hidden unless you pay.
>

24 bits is NOT enough for a UA serial number.  Plus there are other 
complications.  There is a manufacturer serial number standard for 
drones that is generally accepted:  ANSI/CTA 2063A.

It is not so hard to get a manufacturer number so you can serialize the 
UA you are building in your home.  Maybe I will get one myself.

of course, this is a 20 byte value so it will be a bit challenging to 
stuff it into IPv6 addresses.

>> whether they identify drones also by mobile phone number and modeltype.
>>