Subject: Re: [Drip] call for adoption for draft-ietf-drip-uas-rid

From: Daniel Migault <[email-masked]>
Date: Thu, 15 Oct 2020 11:42:34 -0400

This closes the call for adoption. The document has been adopted. Bob
please change the name of the draft maybe draft-ietf-drip-rid
<https://datatracker.ietf.org/doc/draft-ietf-drip-uas-rid/> so the chairs
get the notification to move it from individual to WG document.

Please also update the document by October 28 so the WG has time to review
it for the IETF meeting.

Yours,
Daniel

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 15 Oct 2020 14:37:31 -0400

Thank you Daniel.

I will do a minor update tomorrow with the new name.

Then the full update by the 28th.

On 10/15/20 11:42 AM, Daniel Migault wrote:
> <https://datatracker.ietf.org/doc/draft-ietf-drip-uas-rid/> so the 
> chairs get the notification to move it from individual to WG document.
>
> Please also update the document by October 28 so the WG has time to 
> review it for the IETF meeting.
>
> Yours,
> Daniel
>

---

From: Daniel Migault <[email-masked]>
Date: Thu, 15 Oct 2020 14:43:02 -0400

Great. It sounds like a plan to me. thanks!

Yours,
Daniel

-- 
Daniel Migault
Ericsson

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Thu, 15 Oct 2020 18:56:08 +0000

Hi Stu/Bob,

I am guessing the UAS RID draft has been implemented somewhere?

Best,
Shuai

From: Tm-rid <[email-masked]> on behalf of Daniel Migault <[email-masked]>
Date: Thursday, October 15, 2020 at 11:43
To: Robert Moskowitz <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Stuart W. Card" <[email-masked]>
Subject: Re: [Drip] call for adoption for draft-ietf-drip-uas-rid(Internet mail)

Yours,
Daniel

On Thu, Oct 15, 2020 at 2:37 PM Robert Moskowitz <[email-masked]<mailto:[email-masked]>> wrote:
Thank you Daniel.

Then the full update by the 28th.
On 10/15/20 11:42 AM, Daniel Migault wrote:
This closes the call for adoption. The document has been adopted. Bob please change the name of the draft maybe draft-ietf-drip-rid<https://datatracker.ietf.org/doc/draft-ietf-drip-uas-rid/> so the chairs get the notification to move it from individual to WG document.

Please also update the document by October 28 so the WG has time to review it for the IETF meeting.

Yours,
Daniel

--
Daniel Migault
Ericsson

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 16 Oct 2020 15:08:56 -0400

I just submitted the old draft under the new name.

I had oral surgery yesterday (yet another implant; make sure your 
children take proper care of their teeth!) and am still knocked out from 
the bone drill for installing the implant...

Next week I will get my changes uploaded!

Bob

On 10/15/20 2:43 PM, Daniel Migault wrote:
> On Thu, Oct 15, 2020 at 2:37 PM Robert Moskowitz 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Thank you Daniel.
>
>>     This closes the call for adoption. The document has been adopted.
>>     Bob please change the name of the draft maybe draft-ietf-drip-rid
>>     <https://datatracker.ietf.org/doc/draft-ietf-drip-uas-rid/> so
>>     the chairs get the notification to move it from individual to WG
>>     document.
>>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: "Card, Stu" <[email-masked]>
Date: Fri, 16 Oct 2020 15:11:56 -0400

I encourage everyone to look at Bob's uas-rid draft and our -arch draft,
decide whether we should merge them (I think we should).

In other news... I have completed all the changes to -reqs in response to
all comments and reviews except Fanny's (the most recent extensive one), so
am embarking upon that now, to get you all a hopefully final draft in a
matter of hours.

On Fri, Oct 16, 2020 at 3:09 PM Robert Moskowitz <[email-masked]>
wrote:

> I had oral surgery yesterday (yet another implant; make sure your children
> take proper care of their teeth!) and am still knocked out from the bone
> drill for installing the implant...
>
> Robert Moskowitz
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked]
>
> There's no limit to what can be accomplished if it doesn't matter who gets
> the credit
>

---

From: Daniel Migault <[email-masked]>
Date: Fri, 16 Oct 2020 15:50:47 -0400

just accepted the submission. It seems to me the intent of the arch - even
oriented to rid - should have a larger scope than rid.. but that is good to
bring that discussion.
Yours,
Daniel

On Fri, Oct 16, 2020 at 3:12 PM Card, Stu <[email-masked]> wrote:

>> On Thu, Oct 15, 2020 at 2:37 PM Robert Moskowitz <
>> [email-masked]> wrote:
>>
>>> Thank you Daniel.
>>>

-- 
Daniel Migault
Ericsson

---

From: Robert Moskowitz <[email-masked]>
Date: Sun, 18 Oct 2020 11:01:41 -0400

My premise is they should not be merged.

I have worked in IEEE 802 where everything is one big document that 
grows over the years.  Take a look at 802.3!  These documents have all 
sorts of introductory text before getting into the actual technical part.

The comments can be brutal.  Long delays because the descriptive part 
lacks consensus, or the technical part is not clear.  One can be done 
and held up while the debate rages on the other.

In the IETF we have a long history of separating architecture from 
technology.  It works.  Parts of the tech can be done quickly while the 
architecture gets filled out.  Or the architecture is 'simple' and can 
stand there to frame ongoing technical work.

Here we also have multiple technical parts, as occurs in other IETF 
wgs.  RID is only one piece of the technology, and frames other parts 
itself.

The IETF has rarely been troubled with too many drafts going to RFC 
(well there have been a couple of cases held up as "Lets not do this 
again.").  And some drafts are Informational (like Architecture and Use 
Cases) while others are Standards Track.

My view after been around here for a couple decades +.

On 10/16/20 3:11 PM, Card, Stu wrote:
> I encourage everyone to look at Bob's uas-rid draft and our -arch 
> draft, decide whether we should merge them (I think we should).
>
> In other news... I have completed all the changes to -reqs in response 
> to all comments and reviews except Fanny's (the most recent extensive 
> one), so am embarking upon that now, to get you all a hopefully final 
> draft in a matter of hours.
>
> On Fri, Oct 16, 2020 at 3:09 PM Robert Moskowitz 
>     children take proper care of their teeth!) and am still knocked
>     out from the bone drill for installing the implant...
>
>>>         This closes the call for adoption. The document has been
>>>         adopted. Bob please change the name of the draft maybe
>>>         draft-ietf-drip-rid
>>>         the chairs get the notification to move it from individual
>>>         to WG document.
>>>
>     E: [email-masked] <mailto:[email-masked]>
>
>     There's no limit to what can be accomplished if it doesn't matter
>     who gets the credit
>
>

---

From: Michael Richardson <[email-masked]>
Date: Sun, 18 Oct 2020 18:29:09 -0400

> My premise is they should not be merged.

I agree.

    > The IETF has rarely been troubled with too many drafts going to RFC (well
    > there have been a couple of cases held up as "Lets not do this again.").  And
    > some drafts are Informational (like Architecture and Use Cases) while others
    > are Standards Track.

There is some push back on use-case-only documents being published.
They are worth writing, but sometimes not worth publishing on their own.

I say, do them.  Decide at the last minute whether to roll them into an
appendix somewhere, or just leave them where they were.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide