Subject: Re: [Drip] IPR poll: draft-ietf-drip-reqs-04

From: Daniel Migault <[email-masked]>
Date: Wed, 14 Oct 2020 19:44:49 -0400

Hi Stu,

I think the WG would like to know related IPR *you* are aware of before
adopting the uas-id and authentication drafts. You can proceed to the IPR
disclosure here [1]. The question will be asked in any case upon submitting
the document to the IESG.

Yours,
Daniel

[1] https://datatracker.ietf.org/ipr/

On Wed, Sep 23, 2020 at 10:51 AM <[email-masked]> wrote:

> Hi Stu,
>
> Point noted for the requirements I-D. Thanks.
>
> I have one clarification question, though: do IPR you are aware of apply
> to the solution drafts actually discussed in the WG? I'm particularly
> referring to Bob's UAS-ID + Adam's Authentication and claims drafts.
>
> If so, an IPR disclosure is required in a timely manner.
>
> Cheers,
> Med
>
> > -----Message d'origine-----
> > De : Tm-rid [mailto:[email-masked]] De la part de Stuart W.
> > Card
> > Envoyé : mercredi 23 septembre 2020 16:26
> > À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>; draft-
> > [email-masked]
> > Cc : [email-masked]
> > Objet : Re: [Drip] IPR poll: draft-ietf-drip-reqs-04
> >
> > I have disclosed to my employers and sponsors that I am actively
> > participating in IETF development of open standards; they support my
> > doing so. I am aware of potential future IPR related to
> > _implementation_ of solutions to the requirements (e.g. software
> > source code which my employer may not wish to release openly), but
> > not to any IPR related to the _requirements_ themselves nor the
> > draft-ietf-drip-reqs documents.
> >
> > On 9/9/2020 5:18 AM, [email-masked] wrote:
> > > Hi Authors,
> > >
> > >
> > >
> > > Please reply to this email (with the WG mailing list cced)
> > indicating
> > > whether you are aware of any IPR related to draft-ietf-drip-reqs.
> > >
> > >
> > >
> > > If you are aware of any, can you please confirm that all
> > appropriate
> > > IPR disclosures required for full conformance with the provisions
> > of
> > > BCP 78 and BCP 79 have already been filed?
> > >
> > >
> > >
> > > Thank you.
> > >
> > >
> > >
> > > Cheers,
> > >
> > > Med
> > >
> > >
> > >
> > >
> > >
> > >
> > ____________________________________________________________________
> > __
> > > ___________________________________________________
> > >
> > > Ce message et ses pieces jointes peuvent contenir des informations
> > > confidentielles ou privilegiees et ne doivent donc pas etre
> > diffuses,
> > > exploites ou copies sans autorisation. Si vous avez recu ce
> > message
> > > par erreur, veuillez le signaler a l'expediteur et le detruire
> > ainsi que les pieces jointes. Les messages electroniques etant
> > susceptibles d'alteration, Orange decline toute responsabilite si ce
> > message a ete altere, deforme ou falsifie. Merci.
> > >
> > > This message and its attachments may contain confidential or
> > > privileged information that may be protected by law; they should
> > not be distributed, used or copied without authorisation.
> > > If you have received this email in error, please notify the sender
> > and delete this message and its attachments.
> > > As emails may be altered, Orange is not liable for messages that
> > have been modified, changed or falsified.
> > > Thank you.
> > >
> >
> >
> > --
> > -----------------------------------------
> > Stuart W. Card, PhD, Principal Engineer
> > AX Enterprize, LLC  www.axenterprize.com
> > 4947 Commercial Drive, Yorkville NY 13495
>
>
>
> _________________________________________________________________________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou
> falsifie. Merci.
>
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and
> delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been
> modified, changed or falsified.
> Thank you.
>
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

-- 
Daniel Migault
Ericsson

---

From: "Stuart W. Card" <[email-masked]>
Date: Wed, 14 Oct 2020 21:02:32 -0400

The only intellectual property of which I am aware, to which anyone is
likely to claim any rights, is the actual software source code for the
prototype implementations (developed at AX Enterprize, LLC) of the
protocols, not the protocols themselves nor any algorithms or other
intellectual property needed to implement the protocols. While I will
lobby for the release of at least some of that source code, I have
neither control over whether that happens, nor any concern that lack of
such release would encumber rights to the protocols themselves etc.

On 10/14/2020 7:44 PM, Daniel Migault wrote:
> adopting the uas-id and authentication drafts. You can proceed to the
> IPR disclosure here [1]. The question will be asked in any case upon
> submitting the document to the IESG. 
> 
> Yours, 
> Daniel 
> 
> [1] https://datatracker.ietf.org/ipr/ <https://datatracker.ietf.org/ipr/>
> 
> On Wed, Sep 23, 2020 at 10:51 AM <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Hi Stu,
> 
>     I have one clarification question, though: do IPR you are aware of
>     apply to the solution drafts actually discussed in the WG? I'm
>     particularly referring to Bob's UAS-ID + Adam's Authentication and
>     claims drafts.
> 
>     > De : Tm-rid [mailto:[email-masked]
>     <mailto:[email-masked]>] De la part de Stuart W.
>     > Card
>     > À : BOUCADAIR Mohamed TGI/OLN <[email-masked]
>     <mailto:[email-masked]>>; draft-
>     > [email-masked] <mailto:[email-masked]>
>     > Cc : [email-masked] <mailto:[email-masked]>
>     > On 9/9/2020 5:18 AM, [email-masked]
>     <mailto:[email-masked]> wrote:
>     > > Hi Authors,
>     > >
>     > >
>     > >
>     > AX Enterprize, LLC  www.axenterprize.com <http://www.axenterprize.com>
>     pas etre diffuses, exploites ou copies sans autorisation. Si vous
>     avez recu ce message par erreur, veuillez le signaler
>     a l'expediteur et le detruire ainsi que les pieces jointes. Les
>     messages electroniques etant susceptibles d'alteration,
>     Orange decline toute responsabilite si ce message a ete altere,
>     deforme ou falsifie. Merci.
> 
>     privileged information that may be protected by law;
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tm-rid>
> 
> 
> 
> -- 
> Daniel Migault
> Ericsson

---

From: Daniel Migault <[email-masked]>
Date: Thu, 15 Oct 2020 02:29:40 -0400

Thanks for the clarification. I do not believe the source code causes any
issues.

Yours,
Daniel

On Wed, Oct 14, 2020 at 9:02 PM Stuart W. Card <[email-masked]>
wrote:

> > [1] https://datatracker.ietf.org/ipr/ <https://datatracker.ietf.org/ipr/
> >
> >

-- 
Daniel Migault
Ericsson