Subject: [Drip] Remote ID demo in USA

From: Andrei Gurtov <[email-masked]>
Date: Wed, 9 Dec 2020 16:08:35 +0100

Hi,

Just curious, in this demo they use ASTM specs for drone id + some
security patches, but not from DRIP?

"Phase two of the UAS Traffic Management Pilot Program (UPP) sets the
stage for the future of Remote ID."

"Going beyond what was proposed in the standard, we also tested
cybersecurity measures to ensure that private information could only be
accessed by authorized users. For instance, digital certificates from
the International Aviation Trust Framework were used to sign messages
and access tokens were provided to each UPP participant to ensure the
appropriate level of access."

https://medium.com/faa/welcome-to-the-future-the-next-stage-of-uas-traffic-management-e2faf57d539d

Btw, this week is Single European Sky conference, but not much on
cybersecurity(

https://www.sesarju.eu/sesarinnovationdays

br Andrei

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 9 Dec 2020 10:37:05 -0500

I will jump in here, but really Adam and Stu were there at the NYUAS 
site with their DRIP-RID and Auth code!  Adam covered some of this 
during his slot.  Why he has been so busy not getting much writing done, 
as he has been writing and testing and demoing code....

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Adam Wiethuechter <[email-masked]>
Date: Wed, 9 Dec 2020 16:59:13 +0000

Andrei,

The security patches are on the Network RID side bythe USS's, not the Broadcast RID side like my drafts focus on.

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: Tm-rid <[email-masked]> on behalf of Robert Moskowitz <[email-masked]>
Sent: Wednesday, December 9, 2020 10:37 AM
To: Andrei Gurtov <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Drip] Remote ID demo in USA

I will jump in here, but really Adam and Stu were there at the NYUAS site with their DRIP-RID and Auth code!  Adam covered some of this during his slot.  Why he has been so busy not getting much writing done, as he has been writing and testing and demoing code....

Hi,

br Andrei

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 11 Dec 2020 09:29:06 -0500

NUAIR just email blasted their piece of PR on this event:

https://nuair.org/2020/12/02/new-york-uas-test-site-completes-advanced-drone-operations-for-faa-drone-integration-program/

You will see text in there about IETF DRIP and a pic of Stu's? phone 
with their TM-RID app.

I don't see Adam or Stu in any of the pics, but I think I recognize some 
other AX Enterprize people...

Note it shows pilot location.  Privacy issue unless the Observer is 
authorized!

I would like to see a call to adopt the privacy draft.

---

From: "Card, Stu" <[email-masked]>
Date: Fri, 11 Dec 2020 11:31:02 -0500

In UPP2, at the NY UAS Test Site, _inter alia_, we tested/demonstrated to
FAA:

- ASTM F3411 Network RID, over the Internet (always used for Net-RID
transport);

- ASTM F3411 Broadcast RID, directly over Bluetooth 4 & 5 (not yet WiFi
NAN), w/ & w/o DRIP enhancements per earlier drafts;

- Discovery & Synchronization Service (DSS) and inter-USS communications,
over the Internet (as always), w/ICAO Aviation Trust Framework certificate
based auth;

- "correlation queries" into the FAA's fake database, using as the primary
unique key the Type 2 (aircraft registration number) UAS ID received via
RID, for information beyond RID.

Different access levels were only for USS augmentation of Network RID
w/additional information and FAA database lookups, as ASTM F3411 RID
itself is always cleartext (Bob has a DRIP draft to selectively encrypt
PII).

In most respects, the demo showed that FAA's NASA-derived UTM approach can
work well.

One significant finding was that the UTM architecture needs to be made more
resilient to malfunctions and outages of any of its constituent USS; DRIP
could help here as well.

On Wed, Dec 9, 2020 at 10:08 AM Andrei Gurtov <[email-masked]> wrote:

> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Mon, 14 Dec 2020 16:42:22 +0000

Great accomplishment. Congras for DRIP.

From: Tm-rid <[email-masked]> on behalf of "Card, Stu" <[email-masked]>
Date: Friday, December 11, 2020 at 08:31
To: Andrei Gurtov <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Drip] Remote ID demo in USA(Internet mail)

In UPP2, at the NY UAS Test Site, _inter alia_, we tested/demonstrated to FAA:

- ASTM F3411 Network RID, over the Internet (always used for Net-RID transport);

- ASTM F3411 Broadcast RID, directly over Bluetooth 4 & 5 (not yet WiFi NAN), w/ & w/o DRIP enhancements per earlier drafts;

- Discovery & Synchronization Service (DSS) and inter-USS communications, over the Internet (as always), w/ICAO Aviation Trust Framework certificate based auth;

- "correlation queries" into the FAA's fake database, using as the primary unique key the Type 2 (aircraft registration number) UAS ID received via RID, for information beyond RID.

Different access levels were only for USS augmentation of Network RID w/additional information and FAA database lookups, as ASTM F3411 RID itself is always cleartext (Bob has a DRIP draft to selectively encrypt PII).

In most respects, the demo showed that FAA's NASA-derived UTM approach can work well.

One significant finding was that the UTM architecture needs to be made more resilient to malfunctions and outages of any of its constituent USS; DRIP could help here as well.

On Wed, Dec 9, 2020 at 10:08 AM Andrei Gurtov <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

br Andrei

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid