Subject: [Drip] New Version Notification - draft-ietf-drip-reqs-07.txt

From: [email-masked]
Date: Mon, 15 Feb 2021 20:16:23 -0800

A new version (-07) has been submitted for draft-ietf-drip-reqs:
https://www.ietf.org/archive/id/draft-ietf-drip-reqs-07.txt
https://www.ietf.org/archive/id/draft-ietf-drip-reqs-07.html

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-drip-reqs/

Diff from previous version:
https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-reqs-07

Please note that it may take a couple of minutes from the time of submission
until the diff is available at tools.ietf.org.

IETF Secretariat.

---

From: "Card, Stu" <[email-masked]>
Date: Mon, 15 Feb 2021 23:29:23 -0500

This revision:

- addresses in some manner (as yet TBD whether it was in all cases an
acceptable manner) all the points raised in Med's document shepherd review;

- updates the draft to reflect the JAN 15 publication of the "final" FAA
RID of UA rule;

- updates the draft to reflect current ASTM F38.02 discussions on revising
F3411;

- has been run through the MS-Word spelling/punctuation/grammar checker;

- has been reviewed by the co-authors.

It may still need a new paragraph from Andrei on the ASD-STAN/CEN draft; if
so, I will insert it within the next few days, before FEB 22.

This draft previously passed WGLC and was revised only for the above
reasons.

The arguably substantive changes to the numbered requirements are as
follows.

new preamble:
The following requirements apply to DRIP as a set of related
protocols, various subsets of which, in conjunction with other IETF
and external technical standards, may suffice to comply with the
regulations in any given jurisdiction or meet any given user need.
It is not intended that each and every DRIP protocol alone satisfy
each and every requirement.

ID-4 old: "the global UAS RID identifier space"

ID-4 new: "the applicable global identifier space"

ID-5 old:
Non-spoofability: The DRIP identifier MUST be non-spoofable
within the context of Remote ID broadcast messages (some
collection of messages provides proof of UA ownership of ID).

ID-5 new:
Non-spoofability: The DRIP identifier MUST NOT be spoofable
within the context of a minimal Remote ID broadcast message set
(to be specified within DRIP to be sufficient collectively to
prove sender ownership of the claimed identifier).

REG-4 old:
AAA Policy: DRIP MUST enable closing the AAA-policy registry
loop by governing AAA per registered policies and
administering policies only via AAA.

REG-4 new:
AAA Policy: DRIP AAA MUST be specifiable by policies; the
definitive copies of those policies must be accessible in
registries; administration of those policies and all DRIP
registries must be protected by AAA.

If anyone feels that these changes alter the draft so significantly as to
invalidate the prior WGLC approval, please object immediately, thanks!

On Mon, Feb 15, 2021 at 11:17 PM <[email-masked]> wrote:

> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 16 Feb 2021 08:12:58 +0000

Thank you Stu for the revised I-D as well as the changelog below (BTW, it is common in I-D to put the change log in an appendix but this is optional).

Quick comments of mine:

  *   Unsure whether the move of ATSM explanations about “fees to read doc” was wise
  *   The broadcast/network RID sections are really similar to the ones in the architecture document. Is this repetition on purpose ?
  *   Is the ASTM really normative ? == is it required to read it to understand/implement the requirements ?

The diff are mainly editorial so I do not think that a 2nd WGLC is required except if the WG wants to have a standard track document rather than informational.

Regards,

-éric

From: "Card, Stu" <[email-masked]>
Date: Tuesday, 16 February 2021 at 05:29
To: "[email-masked]" <[email-masked]>
Cc: Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Drip] New Version Notification - draft-ietf-drip-reqs-07.txt

This revision:

- addresses in some manner (as yet TBD whether it was in all cases an acceptable manner) all the points raised in Med's document shepherd review;

- updates the draft to reflect the JAN 15 publication of the "final" FAA RID of UA rule;

- updates the draft to reflect current ASTM F38.02 discussions on revising F3411;

It may still need a new paragraph from Andrei on the ASD-STAN/CEN draft; if so, I will insert it within the next few days, before FEB 22.

This draft previously passed WGLC and was revised only for the above reasons.

The arguably substantive changes to the numbered requirements are as follows.

new preamble:

ID-5 old:

ID-5 new:

REG-4 old:

REG-4 new:

If anyone feels that these changes alter the draft so significantly as to invalidate the prior WGLC approval, please object immediately, thanks!

On Mon, Feb 15, 2021 at 11:17 PM <[email-masked]<mailto:[email-masked]>> wrote:

Please note that it may take a couple of minutes from the time of submission
until the diff is available at tools.ietf.org<http://tools.ietf.org>.

IETF Secretariat.

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

---

From: <[email-masked]>
Date: Tue, 16 Feb 2021 09:55:18 +0000

Hi Stu,

The changes look good to me. Thank you for taking care of the comments.

FWIW, the current write-up is available at:
https://datatracker.ietf.org/doc/draft-ietf-drip-reqs/shepherdwriteup/

Will send the document to Eric as soon as -08 with the new paragraph is out.

Cheers,
Med

De : Card, Stu [mailto:[email-masked]]
Envoyé : mardi 16 février 2021 05:29
À : [email-masked]
Cc : Eric Vyncke (evyncke) <[email-masked]>; BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Objet : Re: [Drip] New Version Notification - draft-ietf-drip-reqs-07.txt

This revision:

new preamble:

ID-5 old:

ID-5 new:

REG-4 old:

REG-4 new:

IETF Secretariat.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Tue, 16 Feb 2021 10:04:35 +0000

Hi Eric,

I don’t think that a 2nd WGLC is needed.

For the ASTM ref, this is something we are struggling with since a while. Citing it as normative is more appropriate as many statements in the document can’t be understood without that spec.

I’d prefer to leave it as normative for the IETF LC and revert back to informative (if valid arguments were raised) rather than the other way around (as it may require another IETF LC).

Thank you.

Cheers,
Med

De : Eric Vyncke (evyncke) [mailto:[email-masked]]
Envoyé : mardi 16 février 2021 09:13
À : Card, Stu <[email-masked]>; [email-masked]
Cc : BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Objet : Re: [Drip] New Version Notification - draft-ietf-drip-reqs-07.txt

Quick comments of mine:
-          Unsure whether the move of ATSM explanations about “fees to read doc” was wise
-          The broadcast/network RID sections are really similar to the ones in the architecture document. Is this repetition on purpose ?
-          Is the ASTM really normative ? == is it required to read it to understand/implement the requirements ?

Regards,

-éric

From: "Card, Stu" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 16 February 2021 at 05:29
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Eric Vyncke <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Drip] New Version Notification - draft-ietf-drip-reqs-07.txt

This revision:

new preamble:

ID-5 old:

ID-5 new:

REG-4 old:

REG-4 new:

IETF Secretariat.

---

From: "Card, Stu" <[email-masked]>
Date: Tue, 16 Feb 2021 09:36:07 -0500

Eric et al --

Thanks for looking at this so promptly & thoroughly!
Redundancy between -reqs & -arch is because they were split from the same
original document.
Description of ASTM F3411 Network & Broadcast RID is essential background
reading for anyone doing anything with UAS RID.
Whether it belongs in -reqs (my slight preference), -arch or both is beyond
me.
I regarded -reqs as reading list #1 & -arch as reading list #2, the latter
addressing needs identified in the former.
That's because, in this case, the overall UAS RID architecture is already
defined outside IETF, so we derive -reqs from that, and -arch is IETF
solution architecture.

On Tue, Feb 16, 2021 at 3:13 AM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> Thank you Stu for the revised I-D as well as the changelog below (BTW, it
> is common in I-D to put the change log in an appendix but this is optional).
>
>
>
> Quick comments of mine:
>
>    - The broadcast/network RID sections are really similar to the ones in
>    the architecture document. Is this repetition on purpose ?
> The diff are mainly editorial so I do not think that a 2nd WGLC is
> required except if the WG wants to have a standard track document rather
> than informational.
>
>
>
> Regards,
>
>
>
> -éric
>
>
>
>
>
> *From: *"Card, Stu" <[email-masked]>
> *Date: *Tuesday, 16 February 2021 at 05:29
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *Eric Vyncke <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [Drip] New Version Notification -
> draft-ietf-drip-reqs-07.txt
>
>
>
> This revision:
>
>
>
> It may still need a new paragraph from Andrei on the ASD-STAN/CEN draft;
> if so, I will insert it within the next few days, before FEB 22.
>
>
>

---

From: <[email-masked]>
Date: Tue, 16 Feb 2021 15:02:19 +0000

Re-,

As mentioned during the WGLC, I do think it is OK to have the Network & Broadcast RID text included in draft-ietf-drip-reqs as it allows the readers to contextualize the requirements.

Cheers,
Med

De : Card, Stu [mailto:[email-masked]]
Envoyé : mardi 16 février 2021 15:36
À : Eric Vyncke (evyncke) <[email-masked]>
Cc : [email-masked]; BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Objet : Re: [Drip] New Version Notification - draft-ietf-drip-reqs-07.txt

Eric et al --

Thanks for looking at this so promptly & thoroughly!
Redundancy between -reqs & -arch is because they were split from the same original document.
Description of ASTM F3411 Network & Broadcast RID is essential background reading for anyone doing anything with UAS RID.
Whether it belongs in -reqs (my slight preference), -arch or both is beyond me.
I regarded -reqs as reading list #1 & -arch as reading list #2, the latter addressing needs identified in the former.
That's because, in this case, the overall UAS RID architecture is already defined outside IETF, so we derive -reqs from that, and -arch is IETF solution architecture.

On Tue, Feb 16, 2021 at 3:13 AM Eric Vyncke (evyncke) <[email-masked]<mailto:[email-masked]>> wrote:
Thank you Stu for the revised I-D as well as the changelog below (BTW, it is common in I-D to put the change log in an appendix but this is optional).

Quick comments of mine:

Regards,

-éric

This revision:

new preamble:

ID-5 old:

ID-5 new:

REG-4 old:

REG-4 new:

IETF Secretariat.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 17 Feb 2021 09:42:18 +0000

Stu,

First thank you for the -08 and for your reply about the -07.

No fundamental problems to have the description of network/broadcast RID duplicated in -reqs and -arch... I am only (slightly) concerned that it means that the two I-D MUST not contradict each other or bring inconsistencies.

About ASTM, if it is indeed ‘essential’ to implement or to ‘understand’ [1], then it is ‘normative’, else if it ‘informative’. So, let it be ‘normative’. Thank you for the clarification.

The ASTM reference should probably be in both I-Ds and at least in -reqs as the requirements are built on the top of ASTM to my understanding.

Regards,

-éric

[1] https://www.ietf.org/about/groups/iesg/statements/normative-informative-references

From: "Card, Stu" <[email-masked]>
Date: Tuesday, 16 February 2021 at 15:36
To: Eric Vyncke <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Drip] New Version Notification - draft-ietf-drip-reqs-07.txt

Eric et al --

Quick comments of mine:

· Unsure whether the move of ATSM explanations about “fees to read doc” was wise

· The broadcast/network RID sections are really similar to the ones in the architecture document. Is this repetition on purpose ?

· Is the ASTM really normative ? == is it required to read it to understand/implement the requirements ?

Regards,

-éric

This revision:

new preamble:

ID-5 old:

ID-5 new:

REG-4 old:

REG-4 new:

IETF Secretariat.