Subject: Re: [Drip] New Version Notification for draft-ietf-drip-arch-10.txt

From: shuai zhao <[email-masked]>
Date: Mon, 22 Feb 2021 13:57:15 -0800

Much thanks to Stu and Adam for your review and proposed text, -10 addressed ~70 comments summarized as following:
To better align with reqs-, replace “UAS Remote ID” with “DRIP entity identifier” where I see fit
Per authors’ agreement, we removed section 7 “DRIP transactions enabling trustworthy” since it was more for solution space. The removed text may end up in the new drip register draft. TBD.
Lots of language tune-up, especially removed the normative wording in sections 4, 5, 6 and 7 per AD’s previous review. 
Added a new reference to FAA concept of operation v2.0 which is used in Annex A.1
Address comments regarding FAA Final Rule in the draft
Capitalize each “observer” to “Observer”.
Updated description text for network RID in sec 1.2.2

Since we are closing to WGLC, please review it and provide concrete comments if you see something you don’t like.  See you all at IETF 110. :)

Best,
Shuai

> On Feb 22, 2021, at 1:44 PM, [email-masked] wrote:
> 
> 
> A new version of I-D, draft-ietf-drip-arch-10.txt
> has been successfully submitted by Shuai Zhao and posted to the
> IETF repository.
> 
> Name:		draft-ietf-drip-arch
> Revision:	10
> Title:		Drone Remote Identification Protocol (DRIP) Architecture
> Document date:	2021-02-22
> Group:		drip
> Pages:		22
> URL:            https://www.ietf.org/archive/id/draft-ietf-drip-arch-10.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-drip-arch/
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch
> Htmlized:       https://tools.ietf.org/html/draft-ietf-drip-arch-10
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-arch-10
> 
> Abstract:
>   This document defines an architecture for protocols and services to
>   support Unmanned Aircraft System Remote Identification and tracking
>   (UAS RID), plus RID-related communications, including required
>   architectural building blocks and their interfaces.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
>

---

From: Daniel Migault <[email-masked]>
Date: Tue, 23 Feb 2021 08:44:07 -0500

great thanks for the update. If you are using markdown I am wondering if
you could upload the mark down version on github. If not you may upload xml
and txt as we are likely to comment on the txt version.

Yours,
Daniel

On Mon, Feb 22, 2021 at 4:57 PM shuai zhao <[email-masked]> wrote:

> Much thanks to Stu and Adam for your review and proposed text, -10
> addressed ~70 comments summarized as following:
>
>    - To better align with reqs-, replace “UAS Remote ID” with “DRIP
>    entity identifier” where I see fit
>    - Per authors’ agreement, we removed section 7 “DRIP transactions
>    enabling trustworthy” since it was more for solution space. The removed
>    text may end up in the new drip register draft. TBD.
>    - Lots of language tune-up, especially removed the normative wording
>    in sections 4, 5, 6 and 7 per AD’s previous review.
>    - Added a new reference to FAA concept of operation v2.0 which is used
>    in Annex A.1
>    - Address comments regarding FAA Final Rule in the draft
>    - Capitalize each “observer” to “Observer”.
>    - Updated description text for network RID in sec 1.2.2
>
>
> Since we are closing to WGLC, please review it and provide concrete
> comments if you see something you don’t like.  See you all at IETF 110. :)
>
> Best,
> Shuai
>
>
> URL:
> https://www.ietf.org/archive/id/draft-ietf-drip-arch-10.txt
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

-- 
Daniel Migault
Ericsson

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 23 Feb 2021 16:57:57 +0000

Hi Daniel and Med

Wondering if we have a public Github repo? If not, would like me to put the draft in my personal Github?

Just minutes ago, version 11 was uploaded with the help of IETF secretary. Version 11 addresses the terminology explanations in section 3.3 as Stu pointed out.

Best,
Shuai

From: Tm-rid <[email-masked]> on behalf of Daniel Migault <[email-masked]>
Date: Tuesday, February 23, 2021 at 5:45 AM
To: shuai zhao <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Drip] New Version Notification for draft-ietf-drip-arch-10.txt(Internet mail)

great thanks for the update. If you are using markdown I am wondering if you could upload the mark down version on github. If not you may upload xml and txt as we are likely to comment on the txt version.

Yours,
Daniel

On Mon, Feb 22, 2021 at 4:57 PM shuai zhao <[email-masked]<mailto:[email-masked]>> wrote:
Much thanks to Stu and Adam for your review and proposed text, -10 addressed ~70 comments summarized as following:
· To better align with reqs-, replace “UAS Remote ID” with “DRIP entity identifier” where I see fit
· Per authors’ agreement, we removed section 7 “DRIP transactions enabling trustworthy” since it was more for solution space. The removed text may end up in the new drip register draft. TBD.
· Lots of language tune-up, especially removed the normative wording in sections 4, 5, 6 and 7 per AD’s previous review.
· Added a new reference to FAA concept of operation v2.0 which is used in Annex A.1
· Address comments regarding FAA Final Rule in the draft
· Capitalize each “observer” to “Observer”.
· Updated description text for network RID in sec 1.2.2

Best,
Shuai

On Feb 22, 2021, at 1:44 PM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

--
Daniel Migault
Ericsson

---

From: Daniel Migault <[email-masked]>
Date: Tue, 23 Feb 2021 12:05:06 -0500

Hi,

Please find the git repo for the WG. Feel free to request access or give me
your github login so I can add you.

https://github.com/ietf-wg-drip

Yours,
Daniel

On Tue, Feb 23, 2021 at 11:58 AM shuaiizhao(Shuai Zhao) <
[email-masked]> wrote:

> Just minutes ago, version 11 was uploaded with the help of IETF secretary.
> Version 11 addresses the terminology explanations in section 3.3 as Stu
> pointed out.
>
>
>
> Best,
>
> Shuai
>
>
>
> *From: *Tm-rid <[email-masked]> on behalf of Daniel Migault <
> [email-masked]>
> *Date: *Tuesday, February 23, 2021 at 5:45 AM
> *To: *shuai zhao <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [Drip] New Version Notification for
> draft-ietf-drip-arch-10.txt(Internet mail)
>
>
>
> · Per authors’ agreement, we removed section 7 “DRIP transactions
> · Lots of language tune-up, especially removed the normative wording in
> sections 4, 5, 6 and 7 per AD’s previous review.
>

-- 
Daniel Migault
Ericsson