Subject: Re: [Drip] WGLC for draft-ietf-drip-arch

From: Daniel Migault <[email-masked]>
Date: Tue, 2 Mar 2021 17:22:45 -0500

Hi,

I have provided my comments in a PR [1]. I thought it might be useful to
use the git interface to follow up the comments. In some cases there is
only a comment, in other cases I added a space to the text I raised
concerned so it appeared in the PR and hopefully can be updated, in other
case I did the update directly.

If this happens to be not useful at all, feel free to let me know.

Yours,
Daniel

[1] https://github.com/ietf-wg-drip/draft-ietf-drip-arch/pull/2/files

On Sat, Feb 27, 2021 at 5:48 AM Stephane Bortzmeyer <[email-masked]>
wrote:

> On Tue, Feb 23, 2021 at 09:57:22AM -0500,
>  Daniel Migault <[email-masked]> wrote
>  a message of 54 lines which said:
>
> > This email starts a WGLC for  draft-ietf-drip-arch available here:
> >  https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-10
> >
> > Please review the document and provide your feed back / comments by March
> > 9.
>
> I've read -11. Drones are clearly not my area of expertise. The draft
> is hard to follow, with a number of acronyms I'm not familiar
> with. Some are in section "3.2.  Abbreviations", some are defined at
> first use. There is certainly a reason for this difference but it does
> not help the reader.
>
> Also, I have the feeling that the draft is quite vague on many
> aspects, and it mixes architectural issues with details which are very
> interesting (such as the discussion about sizes of cryptographic keys
> and signatures) but may be not for an "architecture" document. Also,
> I'm glad there are rationales for some decisions (why HHIT and not HIT
> or CGA) but they should be more separated from the specification of
> the choosen architecture.
>
> Regarding the claim of vagueness, let's take the DNS part as an
> example. "These public information registries can use secure DNS
> transport (e.g.  DNS over TLS)" Is it to become a MAY in the future
> protocol? There is no today an IETF standard about DNS-over-TLS for
> authoritative name servers. Today, it looks like Hand-waving. And why
> DNSSEC disappeared? (It was in -08.)
>

-- 
Daniel Migault
Ericsson

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Mon, 8 Mar 2021 04:47:18 +0000

Hi Stephane, Thanks for reviewing the draft. Please see reply inline. 

Best,
Shuai

On 2/27/21, 2:48 AM, "Tm-rid on behalf of Stephane Bortzmeyer" <[email-masked] on behalf of [email-masked]> wrote:

Shuai/ There were prior comments about two little definitions and too many TLAs. And WG has decided the architecture draft should be an independent draft without referring to the reqs- . Those are the reasons we explicitly give full names for acronyms. And I agree there are lots of them. Do you have specific TLAs you felt confused about? We can make it clear in the next revision.

Shuai/ This is a good comment, and you are not alone.  We will bring this up during IETF 110 DRIP session since this requires a larger discussion and needs WG consensus to make any changes. 

Shuai/ It was taken out from revision 10 during a rewrite for section 5.2.2. This was trying to address AD's comment about fixing normative text in the architecture draft.  Comments about mentioning specification details will be discussed during IETF 110.
    -- 
    Tm-rid mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tm-rid

---

From: <[email-masked]>
Date: Tue, 9 Mar 2021 08:04:11 +0000

Hi all,

Given the overlap with the ongoing IETF meeting, we decided to extend the WGLC till March 23rd.

Please review the document and share your comments.

Cheers,
Daniel & Med

De : Tm-rid [mailto:[email-masked]] De la part de Daniel Migault
Envoyé : mardi 23 février 2021 15:57
À : [email-masked]
Objet : [Drip] WGLC for draft-ietf-drip-arch

Hi,

Please review the document and provide your feed back / comments by March 9.

Yours,
Med and Daniel

--
Daniel Migault
Ericsson

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 9 Mar 2021 08:09:21 +0000

I believe this is the right thing to do. Note the latest revision is https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-11

Best,
Shuai

From: Tm-rid <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Tuesday, March 9, 2021 at 12:04 AM
To: "[email-masked]" <[email-masked]>
Cc: Daniel Migault <[email-masked]>
Subject: Re: [Drip] WGLC for draft-ietf-drip-arch(Internet mail)

Hi all,

Cheers,
Daniel & Med

Hi,

Yours,
Med and Daniel

--
Daniel Migault
Ericsson

Thank you.

---

From: <[email-masked]>
Date: Tue, 9 Mar 2021 08:21:39 +0000

Hi Shuai,

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Tm-rid [mailto:[email-masked]] De la part de
> shuaiizhao(Shuai Zhao)
> Envoyé : lundi 8 mars 2021 05:47
> À : [email-masked]
> Objet : Re: [Drip] WGLC for draft-ietf-drip-arch(Internet mail)
> 
> On 2/27/21, 2:48 AM, "Tm-rid on behalf of Stephane Bortzmeyer" <tm-
> [email-masked] on behalf of [email-masked]> wrote:
> 
> Shuai/ There were prior comments about two little definitions and too
> many TLAs. And WG has decided the architecture draft should be an
> independent draft without referring to the reqs- .

[Med] I may miss your point but the requirements I-D is our reference for these matters. Section 2.2 of draft-ietf-drip-reqs says the following:   

   This section defines a set of terms expected to be used in DRIP
   documents.  This list is meant to be the DRIP terminology reference.

This is ACKed in the arch I-D: 

==
This document uses terms defined in [I-D.ietf-drip-reqs]
==

To address Stéphane's comment, I suggest to remove Section 3.2 from the document + check that all these entries are present in I-D.ietf-drip-reqs.  

 Those are the
> reasons we explicitly give full names for acronyms. And I agree there
> are lots of them. Do you have specific TLAs you felt confused about?
> We can make it clear in the next revision.

[Med] I interpret Stéphane's comment as that the document need to be consistent. I think this can be addressed by my proposal above and expand on first use for all of them. Thanks.

---

From: <[email-masked]>
Date: Fri, 19 Mar 2021 13:09:14 +0000

Hi all,

This a reminder that the WGLC is still open till March 23rd.

Reviews are highly appreciated.

Cheers,
Daniel & Med

De : Tm-rid [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mardi 9 mars 2021 09:04
À : [email-masked]
Cc : Daniel Migault <[email-masked]>
Objet : Re: [Drip] WGLC for draft-ietf-drip-arch

Hi all,

Cheers,
Daniel & Med

De : Tm-rid [mailto:[email-masked]] De la part de Daniel Migault
Envoyé : mardi 23 février 2021 15:57
À : [email-masked]<mailto:[email-masked]>
Objet : [Drip] WGLC for draft-ietf-drip-arch

Hi,

Yours,
Med and Daniel

--
Daniel Migault
Ericsson