Subject: [Drip] [draft-ietf-drip-arch-14]: Section 1.2.2: Resolve Editor-note #2, #3, #4

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 13 Jul 2021 18:28:46 +0000

Section 1.2.2 Network RID,

  *   Editor-note 2 (page 3): Explain the difference with wireless and RF link includes what are the end entities, usages for each transport media. https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/9

Shuai/  I would think Stu’s comment in GitHub explains the difference between RF and internet. What’s more to be done here?

  *   Editor-note 3 (Page 3): Does all UAS support telemetry? explain what are simplest hobby aircraft vs UAS in general. Is it necessary to keep "For all but the simplest hobby aircraft"?  https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/10

Shuai/ Lets drop the sentence, “For All, but the simplest hobby aircraft”. It creates unnecessary confusion.  There is no definition what is a “simplest hobby aircraft”.

  *   Editor-note 4 (Page 4): "DRIP may also..." Specify what protocol DRIP can or will standardize.  https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/11

Shuai/  @Robert Moskowitz<mailto:[email-masked]> this should be an easy thing for you to add more text.

Best,
Shuai

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 13 Jul 2021 18:17:14 -0400

On 7/13/21 2:28 PM, shuaiizhao(Shuai Zhao) wrote:
>   * Editor-note 2 (page 3): Explain the difference with wireless and
>     RF link includes what are the end entities, usages for each
>     transport media.
>     https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/9
>     <https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/9>
>
> Shuai/  I would think Stu’s comment in GitHub explains the difference 
> between RF and internet. What’s more to be done here?
>

Stu's comment is fine.  No more.

>   * Editor-note 3 (Page 3): Does all UAS support telemetry? explain
>     what are simplest hobby aircraft vs UAS in general. Is it
>     necessary to keep "For all but the simplest hobby aircraft"?
>     https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/10
>     <https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/10>
>
> Shuai/ Lets drop the sentence, “For All, but the simplest hobby 
> aircraft”. It creates unnecessary confusion.  There is no definition 
> what is a “simplest hobby aircraft”.
>

First there is the class of UA less than 0.55lbs which are outside the 
RID rules.

And i see the following in the rules:

The proposed description of ‘‘experimental/ hobbyist’’ included three 
characteristics: (1) ‘‘may build or buy dozens of aircraft, many for 
purposes of education, experimentation, or recreation’’; (2) ‘‘life span 
of the unmanned aircraft may be as little as one flight or it may last 
decades’’; (3) ‘‘components are regularly recycled.’’

But I don't think is an official FAA definition.

>   * Editor-note 4 (Page 4): "DRIP may also..." Specify what protocol
>     DRIP can or will standardize.
>     https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/11
>     <https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/11>
>
> Shuai/ @Robert Moskowitz <mailto:[email-masked]> this should be 
> an easy thing for you to add more text.
>

There is also the Observer/DSS? JSON data elements, but no protocol in 
F3411-19.  Where the DSS gets the data, 3411 cares not at all (magic 
happens here).

I should point out that I have the ASTM RID wg, F38.02, tactically 
agreeing to address standardized NRID messaging for v 2.0 (after the 
current 1.1 is balloted, round 1 of balloting due Jul 31).  This is in 
part because of me complaining, but perhaps in larger measure with EU 
(EASA and EUROCAE) saying they want a standard for interoperability.  
Now F38.02 will probably just do messages in some data language.  I am 
pushing for CDDL at a minimum, fighting off JSON (constrained links and 
all that).  So future work for DRIP (2Q22) would be to spec out the 
protocol(s) for this.  Or even 4Q21 to work with F38.02; novel idea....

That said:

{{F3411-19}} prescribes the protocols between the Net-RID SP, Net-RID 
DP, and the Discovery and Synchronization Service (DSS).  It also 
prescribes data elements (in JSON) between Observer and DSS. DRIP may 
address standardization of secure protocols between the UA and GCS (over 
direct wireless and Internet connected), between the UAS and the Net-RID 
SP, and/or between the Net-RID DP and Observer devices.

Not sure about "Observer and DSS" if that should be "and Net-RID DP".  Stu?

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Sun, 18 Jul 2021 19:18:29 +0000

Hi all,

Please see reply inline. I think we can close note #2, #3 and #4

Best,
Shuai

From: Robert Moskowitz <[email-masked]>
Date: Tuesday, July 13, 2021 at 3:17 PM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Robert Moskowitz <[email-masked]>
Subject: [Internet]Re: [draft-ietf-drip-arch-14]: Section 1.2.2: Resolve Editor-note #2, #3, #4

·         Editor-note 2 (page 3): Explain the difference with wireless and RF link includes what are the end entities, usages for each transport media. https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/9

<shuai>
                note 2 is removed.
</shuai>

·         Editor-note 3 (Page 3): Does all UAS support telemetry? explain what are simplest hobby aircraft vs UAS in general. Is it necessary to keep "For all but the simplest hobby aircraft"?  https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/10

First there is the class of UA less than 0.55lbs which are outside the RID rules.

The proposed description of ‘‘experimental/ hobbyist’’ included three characteristics: (1) ‘‘may build or buy dozens of aircraft, many for purposes of education, experimentation, or recreation’’; (2) ‘‘life span of the unmanned aircraft may be as little as one flight or it may last decades’’; (3) ‘‘components are regularly recycled.’’

<shuai>
                Note 3 is removed with following update.
                For All, but the simplest hobby aircraft, Telemetry (at least UA's position and heading) flows from
</shuai>

·         Editor-note 4 (Page 4): "DRIP may also..." Specify what protocol DRIP can or will standardize.  https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/11

There is also the Observer/DSS? JSON data elements, but no protocol in F3411-19.  Where the DSS gets the data, 3411 cares not at all (magic happens here).

I should point out that I have the ASTM RID wg, F38.02, tactically agreeing to address standardized NRID messaging for v 2.0 (after the current 1.1 is balloted, round 1 of balloting due Jul 31).  This is in part because of me complaining, but perhaps in larger measure with EU (EASA and EUROCAE) saying they want a standard for interoperability.  Now F38.02 will probably just do messages in some data language.  I am pushing for CDDL at a minimum, fighting off JSON (constrained links and all that).  So future work for DRIP (2Q22) would be to spec out the protocol(s) for this.  Or even 4Q21 to work with F38.02; novel idea....

That said:

{{F3411-19}} prescribes the protocols between the Net-RID SP, Net-RID DP, and the Discovery and Synchronization Service (DSS).  It also prescribes data elements (in JSON) between Observer and DSS. DRIP may address standardization of secure protocols between the UA and GCS (over direct wireless and Internet connected), between the UAS and the Net-RID SP, and/or between the Net-RID DP and Observer devices.

<shuai>

                {{F3411-19}} prescribes the protocols between the Net-RID SP, Net-RID DP, and the Discovery and Synchronization Service (DSS).  It also prescribes data elements (in JSON) between Observer and DSS. DRIP addresses standardization of secure protocols between the UA and GCS (over direct wireless and Internet connection), between the UAS and the Net-RID SP, and/or between the Net-RID DP and Observer devices.

</shuai>