Subject: [Drip] [draft-ietf-drip-arch-14]: Section 4 : Resolve Editor-note #6

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 13 Jul 2021 18:36:44 +0000

4. HHIT as the Primary DRIP Entity Identifier

Updated Text as follows based on discussion in https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/16.

“
This section describes the DRIP architectural approach to meeting the basic requirements of a DRIP entity identifier within external technical standard ASTM [F3411-19] and regulatory constraints. It justifies and explains the use of Hierarchical Host Identity Tags (HHITs) as self-asserting IPv6 addresses suitable as a UAS ID type and more generally as trustworthy multipurpose remote identifiers.

A HHIT, together with the Host Identity (HI) from which it is partly derived, self-attests to its included explicit registration hierarchy, providing Registrar discovery for a 3rd-party who is looking for ID attestation retrieves the necessary information to the registrar via a DNS request HHIT.
“

Editor-note 6 (page 5) : Is there a need to specify how self-attest works? if yes then where? possible a new section under Section 4}  https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/16

Shuai/ @Robert Moskowitz<mailto:[email-masked]>  I would suggest we add a sentence or two to explain now self-attest works in section either 4.1 or 4.2 when explaining HIT as a DRIP Identifier.

---

From: Daniel Migault <[email-masked]>
Date: Wed, 14 Jul 2021 11:43:38 -0400

I agree with you. The reader needs to be clear how attestation works - at
least from a high level perspective as well as why we call it self
attested.

Yours,
Daniel

On Tue, Jul 13, 2021 at 2:36 PM shuaiizhao(Shuai Zhao) <
[email-masked]> wrote:

> Updated Text as follows based on discussion in
> https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/16.
>
>
>
> “
>
> This section describes the DRIP architectural approach to meeting the
> basic requirements of a DRIP entity identifier within external technical
> standard ASTM [F3411-19] and regulatory constraints. It justifies and
> explains the use of Hierarchical Host Identity Tags (HHITs) as
> self-asserting IPv6 addresses suitable as a UAS ID type and more generally
> as trustworthy multipurpose remote identifiers.
>
>
>
> A HHIT, together with the Host Identity (HI) from which it is partly
> derived, self-attests to its included explicit registration hierarchy,
> providing Registrar discovery for a 3rd-party who is looking for ID
> attestation retrieves the necessary information to the registrar via a DNS
> request HHIT.
>
> “
>
>
>
> Editor-note 6 (page 5) : Is there a need to specify how self-attest works?
> if yes then where? possible a new section under Section 4}
> https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/16
>
>
>
> Shuai/ @Robert Moskowitz <[email-masked]>  I would suggest we add a
> sentence or two to explain now self-attest works in section either 4.1 or
> 4.2 when explaining HIT as a DRIP Identifier.
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

-- 
Daniel Migault
Ericsson

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Wed, 21 Jul 2021 16:44:55 +0000

Here is the updated text from Bob regarding Editor Note #6

> Editor-note 6: Is there a need to specify how self-attest works? if yes then where? possible a new section under {{rid}}}

   This section describes the DRIP architectural approach to meeting the
   basic requirements of a DRIP entity identifier within external
   technical standard ASTM [F3411-19] and regulatory constraints.  It
   justifies and explains the use of Hierarchical Host Identity Tags
   (HHITs) as self-asserting IPv6 addresses suitable as a UAS ID type
   and more generally as trustworthy multipurpose remote identifiers.

   Self-asserting in this usage is given the Host Identity (HI), the
   HHIT ORCHID construction and a signature of the HHIT by the HI can
   both be validated.  The explicit registration hierarchy within the
   HHIT provides registry discovery (managed by a Registrar) to either
   yield the HI for 3rd-party (who is looking for ID attestation)
   validation or prove the HHIT and HI have uniquely been registered.

Best,
Shuai

From: Daniel Migault <[email-masked]>
Date: Wednesday, July 14, 2021 at 8:44 AM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Robert Moskowitz <[email-masked]>, Robert Moskowitz <[email-masked]>
Subject: [Internet]Re: [Drip] [draft-ietf-drip-arch-14]: Section 4 : Resolve Editor-note #6

I agree with you. The reader needs to be clear how attestation works - at least from a high level perspective as well as why we call it self attested.

Yours,
Daniel

On Tue, Jul 13, 2021 at 2:36 PM shuaiizhao(Shuai Zhao) <[email-masked]<mailto:[email-masked]>> wrote:
4. HHIT as the Primary DRIP Entity Identifier

“

Shuai/ @Robert Moskowitz<mailto:[email-masked]>  I would suggest we add a sentence or two to explain now self-attest works in section either 4.1 or 4.2 when explaining HIT as a DRIP Identifier.
--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

--
Daniel Migault
Ericsson

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 21 Jul 2021 13:36:16 -0400

I strongly want "Primary" dropped.

After 2 years, there have been no other proposals.  No where else in 
IETF have I seen the only solution as labeled "primary".

On 7/21/21 12:44 PM, shuaiizhao(Shuai Zhao) wrote:
> > Editor-note 6: Is there a need to specify how self-attest works? if 
> yes then where? possible a new section under {{rid}}}
>
> *From: *Daniel Migault <[email-masked]>
> *Date: *Wednesday, July 14, 2021 at 8:44 AM
> *To: *"shuaiizhao(Shuai Zhao)" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, Robert Moskowitz 
> <[email-masked]>, Robert Moskowitz <[email-masked]>
> *Subject: *[Internet]Re: [Drip] [draft-ietf-drip-arch-14]: Section 4 : 
> Resolve Editor-note #6
>
> I agree with you. The reader needs to be clear how attestation works - 
> at least from a high level perspective as well as why we call it self 
> attested.
>
> Yours,
>
> Daniel
>
> On Tue, Jul 13, 2021 at 2:36 PM shuaiizhao(Shuai Zhao) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     <https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/16>.
>
>     “
>
>     This section describes the DRIP architectural approach to meeting
>     the basic requirements of a DRIP entity identifier within external
>     A HHIT, together with the Host Identity (HI) from which it is
>     partly derived, self-attests to its included explicit registration
>     hierarchy, providing Registrar discovery for a 3rd-party who is
>     looking for ID attestation retrieves the necessary information to
>     the registrar via a DNS request HHIT.
>
>     “
>
>     Editor-note 6 (page 5) : Is there a need to specify how
>     self-attest works? if yes then where? possible a new section under
>     Section 4}
>     <https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/16>
>
>     Shuai/@Robert Moskowitz <mailto:[email-masked]>  I would
>     suggest we add a sentence or two to explain now self-attest works
>     in section either 4.1 or 4.2 when explaining HIT as a DRIP
>     Identifier.
>
>     -- 
>     Tm-rid mailing list
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tm-rid>
>
>
> -- 
>
> Daniel Migault
>
> Ericsson
>
>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Wed, 21 Jul 2021 17:39:40 +0000

Hi Bob,

Let’s ask for the WG,  if there are any objections.  Please comment if there are any objections regarding the following change:

“4.  HHIT as the Primary DRIP Entity Identifier”. • “4.  HHIT as the Primary DRIP Entity Identifier”

Best
Shuai

From: Robert Moskowitz <[email-masked]>
Date: Wednesday, July 21, 2021 at 10:36 AM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Robert Moskowitz <[email-masked]>, Daniel Migault <[email-masked]>
Subject: [Internet]Re: [Drip] Re: [draft-ietf-drip-arch-14]: Section 4 : Resolve Editor-note #6

After 2 years, there have been no other proposals.  No where else in IETF have I seen the only solution as labeled "primary".
On 7/21/21 12:44 PM, shuaiizhao(Shuai Zhao) wrote:
Here is the updated text from Bob regarding Editor Note #6

Best,
Shuai

From: Daniel Migault <[email-masked]><mailto:[email-masked]>
Date: Wednesday, July 14, 2021 at 8:44 AM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]><mailto:[email-masked]>
Cc: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>, Robert Moskowitz <[email-masked]><mailto:[email-masked]>, Robert Moskowitz <[email-masked]><mailto:[email-masked]>
Subject: [Internet]Re: [Drip] [draft-ietf-drip-arch-14]: Section 4 : Resolve Editor-note #6

Yours,
Daniel

“

--
Daniel Migault
Ericsson

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit