Subject: Re: [Drip] [Internet]Re: IETF DRIP Architecture WGLC, revision 13

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Fri, 9 Jul 2021 16:53:35 +0000

Hi Stu and all,

It looks like you have agreed with 22 of my feedback out of 25 of your original comments.

A Github issues was created to keep track of your original comments with my feedback. https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/35.

Things still need discussion are listed in https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues

I will consolidate the remain comments and send out the -14 for authors to review.

Best,
Shuai

From: "Card, Stu" <[email-masked]>
Date: Tuesday, June 29, 2021 at 2:51 PM
To: shuai zhao <[email-masked]>
Cc: Daniel Migault <[email-masked]>, "[email-masked]" <[email-masked]>, "shuaiizhao(Shuai Zhao)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Internet]Re: IETF DRIP Architecture WGLC, revision 13

Thanks very much Shuai!
I have accepted Med's invitation to Github, reviewed all the open issues there, commented on many of them.
Please find attached a file with my original review, updated based on your work and citing the Github issues.
I have trimmed this email and responded in-line to just a few.

On Sun, Jun 27, 2021 at 9:13 PM shuai zhao <[email-masked]<mailto:[email-masked]>> wrote:
...
Hi Stu, see reply inline.  Please look for each of my comment and confirm it...
https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues close or comment back on the issues...

-arch Section 4.2
good, but should be merged with Section 4.4
<shuai>
Just to clarify that you would to merge all text from Section 4.4 and remove the original 4.4, right?
I have no issue with that. Since those text is really trying to explain how HHIT handle crypto for a DRIP ID.
</shuai>
Right.
-arch Section 5
I disagree strongly with removal of definitive specifications here...
leveraging proven Internet domain name registration and lookup processes is fundamental to DRIP.
</shuai> this is a larger issue. We shall discuss this in the WG.
a issue tracker in https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/32
</shuai>
Indeed!
-arch Appendix A.2...
<shuai>
all updated, expect the USSs. F3411-19 does use “USSs” for multiple USS.
Med also has a comments about this in GitHub https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/12.
At this moment, I would suggest lets use USSs if there are more than one….agreeable?
</shuai>
I did not find any of these updated except the first one. Generally I find more instances of USS being used as the plural than USSs, and standard English appends "es" (not "s") to pluralize words ending in "s", but this is not important to me; making this a real architecture specification is.

---

From: "Card, Stu" <[email-masked]>
Date: Sat, 10 Jul 2021 09:28:56 -0400

Thank you very much Shuai! I greatly appreciate your acceptance of the
editor role when the chairs realized I was too overloaded to do the job
timely, and your performance of it since then. I will review your latest
rev this week, focusing only on what I consider to be substantive issues,
especially in the context of Bob's & Adam's related drafts.

On Fri, Jul 9, 2021, 12:53 PM shuaiizhao(Shuai Zhao) <[email-masked]>
wrote:

> A Github issues was created to keep track of your original comments with
> my feedback.
> https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/35.
>
>
>
> Things still need discussion are listed in
> https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues
>
>
>
> *From: *"Card, Stu" <[email-masked]>
> *Date: *Tuesday, June 29, 2021 at 2:51 PM
> *To: *shuai zhao <[email-masked]>
> *Cc: *Daniel Migault <[email-masked]>, "[email-masked]"
> <[email-masked]>, "shuaiizhao(Shuai Zhao)" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *[Internet]Re: IETF DRIP Architecture WGLC, revision 13
>
>
>
> Thanks very much Shuai!
>
> On Sun, Jun 27, 2021 at 9:13 PM shuai zhao <[email-masked]> wrote:
>
> ...
>
> a issue tracker in
> https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/32
>
> </shuai>
>
> Indeed!
>
> -arch Appendix A.2...
>
> <shuai>
>
> Med also has a comments about this in GitHub
> https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/12.
>
> I did not find any of these updated except the first one. Generally I find
> more instances of USS being used as the plural than USSs, and standard
> English appends "es" (not "s") to pluralize words ending in "s", but this
> is not important to me; making this a real architecture specification is.
>
>
>