Subject: [Drip] [offlist] [draft-ietf-drip-arch-14] Section 1.2.2 Resolve Editor-note #1

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 13 Jul 2021 21:17:30 +0000

https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/8
1.2.2.  Network RID

> Editor-note 1:
+ list all the segments mentioned above
+ specify how DRIP provide solutions for each segment

Shuai/ This is also related to Editor’s note 4: https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/11. See yellow highlighted text.

“
A RID data dictionary and data flow for Network RID are defined in [F3411-19]. This data flow is emitted from an UAS via unspecified means (but at least in part over the Internet) to a Network Remote ID Service Provider (Net-RID SP). A Net-RID SP provides the RID data to Network Remote ID Display Providers (Net-RID DP). It is the Net-RID DP that responds to queries from Network Remote ID Observers (expected typically, but not specified exclusively, to be web-based) specifying airspace volumes of interest. Network RID depends upon internet connectivity to fulfill Observers the RID data query to the NET-RID DP.  The summary of network RID data flows work as follows:
1) The UA’s RID data is generated from a UAS.
2) The RID data is transferred from the UA to the GCS
3) the GCS provides UA’s RID data to a NET_RID_SP
4) NET_RID_DP as a NET_RID_SP subscriber and satisfies the Observer’s query request.

……
……

   [F3411-19] prescribes the protocols only between the Net-RID SP, Net-RID DP, and the Discovery and Synchronization Service (DSS).  DRIP
   may also address standardization of protocols between the UA and GCS, between the UAS and the Net-RID SP, and/or between the Net-RID DP and
   Observer devices. DRIP provides a trustworthy RID as well as addresses the RID information registration, lookup and data privacy when used as an network RID.

      Editor-note 4: "DRIP may also..." Specify what protocol DRIP can or will standardize.

“

---

From: Daniel Migault <[email-masked]>
Date: Tue, 13 Jul 2021 17:40:01 -0400

On Tue, Jul 13, 2021 at 5:17 PM shuaiizhao(Shuai Zhao) <
[email-masked]> wrote:

> *1.2.2.  Network RID*
> Shuai/ This is also related to Editor’s note 4:
> https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/11. See
> yellow highlighted text.
>
>
>
> “
>
> A RID data dictionary and data flow for Network RID are defined in
> [F3411-19]. This data flow is emitted from an UAS via unspecified means
> (but at least in part over the Internet) to a Network Remote ID Service
> Provider (Net-RID SP). A Net-RID SP provides the RID data to Network Remote
> ID Display Providers (Net-RID DP). It is the Net-RID DP that responds to
> queries from Network Remote ID Observers (expected typically, but not
> specified exclusively, to be web-based) specifying airspace volumes of
> interest. Network RID depends upon internet connectivity to fulfill
> Observers the RID data query to the NET-RID DP.  The summary of network RID
> data flows work as follows:
>
maybe we should add - if not clearly stated in the section - constituted by
the UA and GCS

> 2) The RID data is transferred from the UA to the GCS
via the represented RF link

> 3) the GCS provides UA’s RID data to a NET_RID_SP
 via a secure internet communication

> 4) NET_RID_DP as a NET_RID_SP subscriber and satisfies the Observer’s
via an internet communication

> ……
>
> ……
>
>
>
>    [F3411-19] prescribes the protocols only between the Net-RID SP,
> Net-RID DP, and the Discovery and Synchronization Service (DSS).  DRIP
>
>    may also address standardization of protocols between the UA and GCS,
> between the UAS and the Net-RID SP, and/or between the Net-RID DP and
>
>    Observer devices. DRIP provides
>
specifies

> a trustworthy RID as well as addresses the RID information registration,
> lookup and data privacy when used as an network RID.
>
maybe:
DRIP specifies a trustworthy RID that includes registration information, a
registration and lookup procedure to register these pieces of information
to a registrar.

> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

-- 
Daniel Migault
Ericsson

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Sun, 18 Jul 2021 19:00:56 +0000

Thanks Daniel,

See following implementation based on the feedback.

1.2.2.  Network RID

   A RID data dictionary and data flow for Network RID are defined in
   [F3411-19].  This data flow is emitted from an UAS via unspecified
   means (but at least in part over the Internet) to a Network Remote ID
   Service Provider (Net-RID SP).  A Net-RID SP provides the RID data to
   Network Remote ID Display Providers (Net-RID DP).  It is the Net-RID
   DP that responds to queries from Network Remote ID Observers
   (expected typically, but not specified exclusively, to be web-based)
   specifying airspace volumes of interest.  Network RID depends upon
   internet connectivity to fulfill Observers the RID data query to the
   NET-RID DP.  The summary of network RID data flows work as follows:

   *  The UA's RID data is generated from a UAS which consists of UAs
      and GCSs.

   *  The RID data is transferred from the UA to the GCS via a RF (Radio
      Frequency) link.

   *  The GCS provides UA's RID data to a NET_RID_SP via a secure
      internet connection.

   *  NET_RID_DP as a NET_RID_SP subscriber and satisfies the Observer's
      query request also via a secure internet connection.

Best,
Shuai

From: Daniel Migault <[email-masked]>
Date: Tuesday, July 13, 2021 at 2:40 PM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Internet]Re: [Drip] [offlist] [draft-ietf-drip-arch-14] Section 1.2.2 Resolve Editor-note #1

On Tue, Jul 13, 2021 at 5:17 PM shuaiizhao(Shuai Zhao) <[email-masked]<mailto:[email-masked]>> wrote:

“
maybe we should add - if not clearly stated in the section - constituted by the UA and GCS

……
……

   [F3411-19] prescribes the protocols only between the Net-RID SP, Net-RID DP, and the Discovery and Synchronization Service (DSS).  DRIP
   may also address standardization of protocols between the UA and GCS, between the UAS and the Net-RID SP, and/or between the Net-RID DP and
   Observer devices. DRIP provides
specifies
a trustworthy RID as well as addresses the RID information registration, lookup and data privacy when used as an network RID.
maybe:
DRIP specifies a trustworthy RID that includes registration information, a registration and lookup procedure to register these pieces of information to a registrar.

“

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

--
Daniel Migault
Ericsson

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 19 Jul 2021 15:31:07 -0400

Net-RID can come from either the GCS or UA.  Most cases of coming from 
the UA is where the UA is operating BVLOS and/or autonomously. In 
particular, Parrot seems to be supporting UA Net-RID among other things 
with their Anafi AI UA over cellular:

https://spectrum.ieee.org/automaton/robotics/drones/parrot-announces-anafi-ai-a-buginspired-4g-drone

So the section:

The GCS provides UA's RID data to a NET_RID_SP via a secure

internet connection.

Should be:

The GCS or UA (e.g. BVLOS and autonomous operation) provides the UA's 
RID data...

Don't know quite what to do with the prior point; probably leave it.

On 7/18/21 3:00 PM, shuaiizhao(Shuai Zhao) wrote:
> *From: *Daniel Migault <[email-masked]>
> *Date: *Tuesday, July 13, 2021 at 2:40 PM
> *To: *"shuaiizhao(Shuai Zhao)" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *[Internet]Re: [Drip] [offlist] [draft-ietf-drip-arch-14] 
> Section 1.2.2 Resolve Editor-note #1
>
> On Tue, Jul 13, 2021 at 5:17 PM shuaiizhao(Shuai Zhao) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     <https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/8>
>
>     *1.2.2.  Network RID*
>
>
>     > Editor-note 1:
>
>     https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/11
>     <https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/11>.
>     See yellow highlighted text.
>
>     “
>
>     means (but at least in part over the Internet) to a Network Remote
>     ID Service Provider (Net-RID SP). A Net-RID SP provides the RID
>     data to Network Remote ID Display Providers (Net-RID DP). It is
>     the Net-RID DP that responds to queries from Network Remote ID
>     Observers (expected typically, but not specified exclusively, to
>     be web-based) specifying airspace volumes of interest. Network RID
>     depends upon internet connectivity to fulfill Observers the RID
>     data query to the NET-RID DP.  The summary of network RID data
>     flows work as follows:
>
>        [F3411-19] prescribes the protocols only between the Net-RID
>     SP, Net-RID DP, and the Discovery and Synchronization Service
>     (DSS). DRIP
>
>        may also address standardization of protocols between the UA
>     and GCS, between the UAS and the Net-RID SP, and/or between the
>     Net-RID DP and
>
>     Observer devices.DRIP provides
>
> specifies
>
>     a trustworthy RID as well as addresses the RID information
>     registration, lookup and data privacy when used as an network RID.
>
> maybe:
>
> DRIP specifies a trustworthy RID that includes registration 
> information, a registration and lookup procedure to register these 
> pieces of information to a registrar.
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tm-rid>
>
>
> -- 
>
> Daniel Migault
>
> Ericsson
>
>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 20 Jul 2021 16:57:29 +0000

Thanks, Bob, that is important information. I will impalement in 15.

Best,
Shuai

From: Robert Moskowitz <[email-masked]>
Date: Monday, July 19, 2021 at 12:31 PM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Daniel Migault <[email-masked]>
Subject: [Internet]Re: [Drip] Re: [offlist] [draft-ietf-drip-arch-14] Section 1.2.2 Resolve Editor-note #1

Net-RID can come from either the GCS or UA.  Most cases of coming from the UA is where the UA is operating BVLOS and/or autonomously.  In particular, Parrot seems to be supporting UA Net-RID among other things with their Anafi AI UA over cellular:

So the section:

Should be:

The GCS or UA (e.g. BVLOS and autonomous operation) provides the UA's RID data...

1.2.2.  Network RID

Best,
Shuai

From: Daniel Migault <[email-masked]><mailto:[email-masked]>
Date: Tuesday, July 13, 2021 at 2:40 PM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]><mailto:[email-masked]>
Cc: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: [Internet]Re: [Drip] [offlist] [draft-ietf-drip-arch-14] Section 1.2.2 Resolve Editor-note #1

“

……
……

“

--
Daniel Migault
Ericsson

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit