Subject: [Drip] [draft-ietf-drip-arch-14]: Resolve Editor-note 13

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 13 Jul 2021 17:29:51 +0000

Hi All,

The current DRIP architecture discussion is in Github https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues. I know most ppl are not active participant in the Github discussion, therefore we put Editor’s note in revision 14 for all the outstanding comments needs to be solved.

There are still 16 open issues. We will be sending out separated threads for group of Editors notes possibly with suggestion solutions. Please Comments if you have new proposed text, suggestions, and criticism in 7 days of thread initialization.   We are trying resolve all of them as soon as possible.

For Editor-note 13 in Section 3 (page 9),

  *   there is proposal to merge section 2 and Section 3 to be consistent with Requirement draft.  As Editor of Architecture, I saw no issues and would like to merge those two sections.
  *   Another comment is regarding Terminology usage in in Section 3. Previous WG agreement (IETF 110) is that all the DRIP terms shall be defined in -reqs, which may or may not be used in -reqs itself, but other documents such as Arch-. And arch- can list terms when they are used in the arch- only.   I would prefer to keep those  terms defined in arch- as it is Unless I heard objections or improvement proposals.

Best,
Shuai

--------------------------------------------------------------------

[Drip] I-D Action: draft-ietf-drip-arch-14.txt

[email-masked] Fri, 09 July 2021 21:45 UTCShow header<https://mailarchive.ietf.org/arch/browse/tm-rid/?q=drip-arch>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

This draft is a work item of the Drone Remote ID Protocol WG of the IETF.

        Title           : Drone Remote Identification Protocol (DRIP) Architecture

        Authors         : Stuart W. Card

                          Adam Wiethuechter

                          Robert Moskowitz

                          Shuai Zhao

                          Andrei Gurtov

         Filename        : draft-ietf-drip-arch-14.txt

         Pages           : 24

         Date            : 2021-07-09

Abstract:

   This document describes an architecture for protocols and services to

   support Unmanned Aircraft System Remote Identification and tracking

   (UAS RID), plus RID-related communications.  This architecture

   adheres to the requirements listed in the DRIP Requirements document.

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-ietf-drip-arch/

There is also an htmlized version available at:

https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14

A diff from the previous version is available at:

https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-arch-14

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/<http://ftp:/ftp.ietf.org/internet-drafts/>

> Internet-Drafts are also available by anonymous FTP at:

> ftp://ftp.ietf.org/internet-drafts/<http://ftp:/ftp.ietf.org/internet-drafts/>

> _______________________________________________

> I-D-Announce mailing list

> [email-masked]<mailto:[email-masked]>

> https://www.ietf.org/mailman/listinfo/i-d-announce

> Internet-Draft directories: http://www.ietf.org/shadow.html<https://www.ietf.org/shadow.html> or

> ftp://ftp.ietf.org/ietf/1shadow-sites.txt<http://ftp:/ftp.ietf.org/ietf/1shadow-sites.txt>

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 13 Jul 2021 18:22:42 +0000

Here is the Github link for Editor-note 13: https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues/29

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tuesday, July 13, 2021 at 10:29 AM
To: "[email-masked]" <[email-masked]>
Subject: [draft-ietf-drip-arch-14]: Resolve Editor-note 13

Hi All,

·         there is proposal to merge section 2 and Section 3 to be consistent with Requirement draft.  As Editor of Architecture, I saw no issues and would like to merge those two sections.

·         Another comment is regarding Terminology usage in in Section 3. Previous WG agreement (IETF 110) is that all the DRIP terms shall be defined in -reqs, which may or may not be used in -reqs itself, but other documents such as Arch-. And arch- can list terms when they are used in the arch- only.   I would prefer to keep those  terms defined in arch- as it is Unless I heard objections or improvement proposals.

Best,
Shuai

        Authors         : Stuart W. Card

                          Adam Wiethuechter

                          Robert Moskowitz

                          Shuai Zhao

                          Andrei Gurtov

         Pages           : 24

         Date            : 2021-07-09

Abstract:

---

From: Daniel Migault <[email-masked]>
Date: Wed, 14 Jul 2021 11:39:48 -0400

On Tue, Jul 13, 2021 at 1:30 PM shuaiizhao(Shuai Zhao) <
[email-masked]> wrote:

> Hi All,
>
>
>
> The current DRIP architecture discussion is in Github
> https://github.com/ietf-wg-drip/draft-ietf-drip-arch/issues. I know most
> ppl are not active participant in the Github discussion, therefore we put
> Editor’s note in revision 14 for all the outstanding comments needs to be
> solved.
>
>
>
> There are still 16 open issues. We will be sending out separated threads
> for group of Editors notes possibly with suggestion solutions. *Please*
> Comments if you have new proposed text, suggestions, and criticism in 7
> days of thread initialization.   We are trying resolve all of them as soon
> as possible.
>
>
>
>    - there is proposal to merge section 2 and Section 3 to be consistent
>    with Requirement draft.  As Editor of Architecture, I saw no issues and
>    would like to merge those two sections.
>    - Another comment is regarding Terminology usage in in Section 3.
>    Previous WG *agreement* (IETF 110) is that all the DRIP terms shall be
>    defined in -reqs, which may or may not be used in -reqs itself, but other
>    documents such as Arch-. And arch- can list terms when they are used in the
>    arch- only.   I would prefer to keep those  terms defined in arch- as it is
>    Unless I heard objections or improvement proposals.
>
>
>
looks good to me, please proceed.

> [email-masked] Fri, 09 July 2021 21:45 UTCShow header
> <https://mailarchive.ietf.org/arch/browse/tm-rid/?q=drip-arch>
>
> ftp://ftp.ietf.org/internet-drafts/ <http://ftp:/ftp.ietf.org/internet-drafts/>
>
>
>
>
>
> >
>
> > ftp://ftp.ietf.org/internet-drafts/ <http://ftp:/ftp.ietf.org/internet-drafts/>
>
> >
>
> >
>
> > [email-masked]
> > Internet-Draft directories: http://www.ietf.org/shadow.html <https://www.ietf.org/shadow.html> or
>
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt <http://ftp:/ftp.ietf.org/ietf/1shadow-sites.txt>
>
>
>
>
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

-- 
Daniel Migault
Ericsson

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Sun, 18 Jul 2021 19:31:53 +0000

The following is implemented based on feedback. Section 3 is now a separated section per Bob’s preference.

  2.  Terms and Definitions . . . . . . . . . . . . . . . . . . . .   9
     2.1.  Architecture Terminology  . . . . . . . . . . . . . . . .   9
     2.2.  Abbreviations . . . . . . . . . . . . . . . . . . . . . .   9
     2.3.  Additional Definitions  . . . . . . . . . . . . . . . . .  10
   3.  Claims, Assertions, Attestations, and Certificates  . . . . .  10

Vs previous revisions:
   2<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#section-2>.  Conventions . . . . . . . . . . . . . . . . . . . . . . . . .   9<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#page-9>
   3<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#section-3>.  Definitions and Abbreviations . . . . . . . . . . . . . . . .   9<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#page-9>
     3.1<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#section-3.1>.  Additional Definitions  . . . . . . . . . . . . . . . . .   9<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#page-9>
     3.2<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#section-3.2>.  Abbreviations . . . . . . . . . . . . . . . . . . . . . .   9<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#page-9>
     3.3<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#section-3.3>.  Claims, Assertions, Attestations, and Certificates  . . .  10<https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-14#page-10>

Best
Shuai

From: Daniel Migault <[email-masked]>
Date: Wednesday, July 14, 2021 at 8:40 AM
To: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Internet]Re: [Drip] [draft-ietf-drip-arch-14]: Resolve Editor-note 13

On Tue, Jul 13, 2021 at 1:30 PM shuaiizhao(Shuai Zhao) <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

[email-masked]<mailto:[email-masked]> Fri, 09 July 2021 21:45 UTCShow header<https://mailarchive.ietf.org/arch/browse/tm-rid/?q=drip-arch>

        Authors         : Stuart W. Card

                          Adam Wiethuechter

                          Robert Moskowitz

                          Shuai Zhao

                          Andrei Gurtov

         Pages           : 24

         Date            : 2021-07-09

Abstract:

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

--
Daniel Migault
Ericsson