Subject: [Drip] I-D Action: draft-ietf-drip-rid-10.txt

From: [email-masked]
Date: Tue, 14 Sep 2021 13:10:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Drone Remote ID Protocol WG of the IETF.

        Title           : DRIP Entity Tag (DET) for Unmanned Aircraft System Remote Identification (UAS RID)
        Authors         : Robert Moskowitz
                          Stuart W. Card
                          Adam Wiethuechter
                          Andrei Gurtov
	Filename        : draft-ietf-drip-rid-10.txt
	Pages           : 28
	Date            : 2021-09-14

Abstract:
   This document describes the use of Hierarchical Host Identity Tags
   (HHITs) as self-asserting IPv6 addresses and thereby a trustable
   identifier for use as the Unmanned Aircraft System Remote
   Identification and tracking (UAS RID).  Within the context of RID,
   HHITs will be called DRIP Entity Tags (DET).  HHITs self-attest to
   the included explicit hierarchy that provides Registrar discovery for
   3rd-party identifier attestation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-drip-rid/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-drip-rid-10.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-rid-10

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 14 Sep 2021 16:16:06 -0400

This ver has the DET Privacy section and reference to the github stored 
hhit-gen.py script.

With this ver I am posting to cfrg for review.  Also saag about the 
non-privacy of DETs.  Or limited privacy.  SAAG is where the privacy 
advocates live, more than cfrg.

Bob

---

From: <[email-masked]>
Date: Wed, 15 Sep 2021 14:35:34 +0000

Hi Bob, 

Thank you for taking care of the comments on the DET privacy section. 

Can you please confirm that this revision takes into account all the points raised in the secdir review (other than requesting a cfrg review)? Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : Tm-rid [mailto:[email-masked]] De la part de Robert
> Moskowitz
> Envoyé : mardi 14 septembre 2021 22:16
> À : [email-masked]
> Objet : Re: [Drip] I-D Action: draft-ietf-drip-rid-10.txt
> 
> With this ver I am posting to cfrg for review.  Also saag about the non-
> privacy of DETs.  Or limited privacy.  SAAG is where the privacy
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 24 Sep 2021 07:07:20 +0000

Hi Bob, all, 

Thank you for sending the messages to both SAAG and SFRG. Much appreciated. 

FWIW, 
* the message to SAAG can be found at: https://mailarchive.ietf.org/arch/msg/saag/5tyVqtjCGKVcSeX9gpS4_feI7YQ/. Unfortunately, no follow-up so far.  
* the CFRG discussion is happening at: https://mailarchive.ietf.org/arch/msg/cfrg/56XscYjs_GprhS0wxvVDWNincPg/. From where I sit, the comments in https://mailarchive.ietf.org/arch/msg/cfrg/tAJJq60W6TlUv7_pde5cw5TDTCU/ are worth to be assessed.  

Bob, please cc the drip mailing list in future replies to these threads so that the WG can follow the discussion. 

Thank you. 

Cheers,
Med