Subject: [Drip] Help with DRIP github

From: Robert Moskowitz <[email-masked]>
Date: Fri, 10 Sep 2021 10:04:27 -0400

Help!

I am very unskilled with github and have hit a wall here with the DRIP 
github.

https://github.com/ietf-wg-drip/draft-ietf-drip-rid

Is an empty repo.  I am logged in with my github account, but I do not 
see any upload option.  I have some python script to add...

thanks for any pointers.

Bob

---

From: Daniel Migault <[email-masked]>
Date: Fri, 10 Sep 2021 10:38:11 -0400

Hi,

Here is one way to proceed:
on your PC
1. git clone https://github.com/ietf-wg-drip/draft-ietf-drip-rid
this creates a directory: draft-ietf-drip-rid

2.put your text into that directory
3. go into the directory
4. git add <you file>
5.  git commit -a
6. git push origin
your text should appear on github.

Yours,
Daniel

On Fri, Sep 10, 2021 at 10:04 AM Robert Moskowitz <[email-masked]>
wrote:

> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

-- 
Daniel Migault
Ericsson

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 10 Sep 2021 15:12:00 -0400

Almost worked:

$ git push origin
remote: Support for password authentication was removed on August 13, 
2021. Please use a personal access token instead.
remote: Please see 
https://github.blog/2020-12-15-token-authentication-requirements-for-git-operations/ 
for more information.
fatal: Authentication failed for 
'https://github.com/ietf-wg-drip/draft-ietf-drip-rid/'

so looks like I have to learn about access tokens.

:(

On 9/10/21 10:38 AM, Daniel Migault wrote:
> <https://github.com/ietf-wg-drip/draft-ietf-drip-rid>
> On Fri, Sep 10, 2021 at 10:04 AM Robert Moskowitz 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Help!
>
>     <https://github.com/ietf-wg-drip/draft-ietf-drip-rid>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tm-rid>
>
>
>
> -- 
> Daniel Migault
> Ericsson
>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 10 Sep 2021 16:39:25 -0400

This is NOT working.  It is going to be an major undertaking, it seems.  
Somehow I think I will have to switch to using ssh.

Sigh.

---

From: Daniel Migault <[email-masked]>
Date: Fri, 10 Sep 2021 16:52:29 -0400

I think you need the token anyhow when pushing the document. Maybe there is
a manual way to handle this.
When you log in and find yourself on the empty repo, do you see the quick
setup with the following sentence ?
"Get started by creating a new file
<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main> or uploading
an existing file
<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/upload>. We recommend
every repository include a README
<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main?readme=1>,
LICENSE
<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main?filename=LICENSE.md>,
and .gitignore
<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main?filename=.gitignore>
.""

Maybe that will work for you, further editing may also be done via the GUI,
editing and copy pasting the text.

Yours,
Daniel

On Fri, Sep 10, 2021 at 4:39 PM Robert Moskowitz <[email-masked]>
wrote:

> fatal: Authentication failed for '
> https://github.com/ietf-wg-drip/draft-ietf-drip-rid/'
>
> On Fri, Sep 10, 2021 at 10:04 AM Robert Moskowitz <
> [email-masked]> wrote:
>
>> Help!
>>
> Robert Moskowitz
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked]
>
> There's no limit to what can be accomplished if it doesn't matter who gets
> the credit
>
>
> --
> Robert Moskowitz
> Owner
> HTT Consulting
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked]
>
> There's no limit to what can be accomplished if it doesn't matter who gets
> the credit
>

-- 
Daniel Migault
Ericsson

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 13 Sep 2021 10:44:36 -0400

I switched to ssh connection.  That ALMOST is working, but reveals that 
I don't have permission to update the repo:

$ git push origin
Warning: Permanently added the RSA host key for IP address 
'140.82.113.3' to the list of known hosts.
Enter passphrase for key '/home/rgm/.ssh/id_ed25519':
ERROR: Permission to ietf-wg-drip/draft-ietf-drip-rid.git denied to rgmhtt.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

My git ID, rgmhtt is tied to both my emails, this one and 
[email-masked]

So I guess to the chairs to add my id to the drip repo so I can update?  
Or what do I need to do?

thanks

On 9/10/21 4:52 PM, Daniel Migault wrote:
> I think you need the token anyhow when pushing the document. Maybe 
> there is a manual way to handle this.
> When you log in and find yourself on the empty repo, do you see the 
> quick setup with the following sentence ?
> <https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main> or 
> uploading an existing file 
> <https://github.com/ietf-wg-drip/draft-ietf-drip-rid/upload>. We 
> recommend every repository include a README 
> <https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main?filename=.gitignore>.""
>
> Maybe that will work for you, further editing may also be done via 
> the GUI, editing and copy pasting the text.
>
> Yours,
> Daniel
>
> On Fri, Sep 10, 2021 at 4:39 PM Robert Moskowitz 
>     This is NOT working.  It is going to be an major undertaking, it
>     seems.  Somehow I think I will have to switch to using ssh.
>
>     Sigh.
>
>>     remote: Support for password authentication was removed on August
>>     13, 2021. Please use a personal access token instead.
>>     remote: Please see
>>     <https://github.blog/2020-12-15-token-authentication-requirements-for-git-operations/>
>>     for more information.
>>     'https://github.com/ietf-wg-drip/draft-ietf-drip-rid/
>>     <https://github.com/ietf-wg-drip/draft-ietf-drip-rid/>'
>>
>>     E: [email-masked] <mailto:[email-masked]>
>>
>>     There's no limit to what can be accomplished if it doesn't matter
>>     who gets the credit
>>
>
>     -- 
>     Robert Moskowitz
>     Owner
>     HTT Consulting
>     C: 248-219-2059
>     F: 248-968-2824
>     E: [email-masked] <mailto:[email-masked]>
>
>     There's no limit to what can be accomplished if it doesn't matter
>     who gets the credit
>
>
>
> -- 
> Daniel Migault
> Ericsson
>

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 14 Sep 2021 05:22:19 +0000

Have you set the SSH keys in your github account? Account-> Settings -> SSH and GPG keys…

If you have not done so, you might need to click “new ssh key” and copy the public key text from /home/rgm/.ssh/id_ed25519.pub' into the key section.

Best,
Shuai

From: Tm-rid <[email-masked]> on behalf of Robert Moskowitz <[email-masked]>
Date: Monday, September 13, 2021 at 7:45 AM
To: Daniel Migault <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Internet][Drip] Now it is down to permissions - Re: Help with DRIP github

I switched to ssh connection.  That ALMOST is working, but reveals that I don't have permission to update the repo:

$ git push origin
Warning: Permanently added the RSA host key for IP address '140.82.113.3' to the list of known hosts.
Enter passphrase for key '/home/rgm/.ssh/id_ed25519':
ERROR: Permission to ietf-wg-drip/draft-ietf-drip-rid.git denied to rgmhtt.
fatal: Could not read from remote repository.

My git ID, rgmhtt is tied to both my emails, this one and [email-masked]<mailto:[email-masked]>

So I guess to the chairs to add my id to the drip repo so I can update?  Or what do I need to do?

thanks

On 9/10/21 4:52 PM, Daniel Migault wrote:
I think you need the token anyhow when pushing the document. Maybe there is a manual way to handle this.
When you log in and find yourself on the empty repo, do you see the quick setup with the following sentence ?
"Get started by creating a new file<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main> or uploading an existing file<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/upload>. We recommend every repository include a README<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main?readme=1>, LICENSE<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main?filename=LICENSE.md>, and .gitignore<https://github.com/ietf-wg-drip/draft-ietf-drip-rid/new/main?filename=.gitignore>.""

Maybe that will work for you, further editing may also be done via the GUI, editing and copy pasting the text.

Yours,
Daniel

On Fri, Sep 10, 2021 at 4:39 PM Robert Moskowitz <[email-masked]<mailto:[email-masked]>> wrote:
This is NOT working.  It is going to be an major undertaking, it seems.  Somehow I think I will have to switch to using ssh.

Sigh.

$ git push origin
remote: Support for password authentication was removed on August 13, 2021. Please use a personal access token instead.
remote: Please see https://github.blog/2020-12-15-token-authentication-requirements-for-git-operations/ for more information.
fatal: Authentication failed for 'https://github.com/ietf-wg-drip/draft-ietf-drip-rid/'

:(

Yours,
Daniel

On Fri, Sep 10, 2021 at 10:04 AM Robert Moskowitz <[email-masked]<mailto:[email-masked]>> wrote:
Help!

thanks for any pointers.

Bob

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

--
Daniel Migault
Ericsson

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit

--
Daniel Migault
Ericsson