Subject: [Drip] More drip github confusion

From: Robert Moskowitz <[email-masked]>
Date: Mon, 13 Sep 2021 11:04:13 -0400

when I just go into my github home, I see that I am part of the 
IETF-DRIP organization.

When I go to: https://github.com/IETF-DRIP

only 4 repos, not including drip-rid?  Yet there is:

https://github.com/ietf-wg-drip/draft-ietf-drip-rid

??

I don't know how I got this url, but it is there and not in the 
IETF-DRIP list of repos.

Now what?

thanks

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 13 Sep 2021 18:09:24 +0200

Hi Bob.

it seems somewhere around Jan 26th this year someone triggered the 
creation of a redundant github organization. They question is why?

The name of the original org could have just been relabeled, I guess? 
How do we remediate this?

Viele Grüße,

Henk

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 13 Sep 2021 18:23:48 +0200

> How do we remediate this?

Move over all repos?  Really easy.  (*)

(To the org with the RFC 8875 name.)

Grüße, Carsten

(*) the last time I did this, github put in a redirect, so you don’t even have to do the “git remote add … “ dance.

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 13 Sep 2021 14:01:09 -0400

> (*) the last time I did this, github put in a redirect, so you don’t even have to do the “git remote add … “ dance.

So how do we get this done?

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Tue, 14 Sep 2021 05:15:55 +0000

Hi Bob,

Use https://github.com/ietf-wg-drip as DRIP's official Git repo. 

I created https://github.com/IETF-DRIP long time ago before DRIP Chair created https://github.com/ietf-wg-drip. To avoid future confusion, I have closed https://github.com/IETF-DRIP.

Best,
Shuai

On 9/13/21, 8:05 AM, "Tm-rid on behalf of Robert Moskowitz" <[email-masked] on behalf of [email-masked]> wrote:

    ??

    Now what?

    thanks

    -- 
    Tm-rid mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tm-rid

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 14 Sep 2021 08:54:52 +0200

> On 13. Sep 2021, at 20:01, Robert Moskowitz <[email-masked]> wrote:
> 

Someone who is admin in both organisations moves over each repo.

Go to https://github.com/IETF-DRIP/repo-name/settings
Scroll to the bottom
Click “Transfer”

See also:
https://docs.github.com/en/repositories/creating-and-managing-repositories/transferring-a-repository

Grüße, Carsten