Subject: [Drip] I-D Action: draft-ietf-drip-rid-13.txt

From: [email-masked]
Date: Sun, 07 Nov 2021 05:31:12 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Drone Remote ID Protocol WG of the IETF.

        Title           : DRIP Entity Tag (DET) for Unmanned Aircraft System Remote Identification (UAS RID)
        Authors         : Robert Moskowitz
                          Stuart W. Card
                          Adam Wiethuechter
                          Andrei Gurtov
	Filename        : draft-ietf-drip-rid-13.txt
	Pages           : 27
	Date            : 2021-11-07

Abstract:
   This document describes the use of Hierarchical Host Identity Tags
   (HHITs) as self-asserting IPv6 addresses and thereby a trustable
   identifier for use as the Unmanned Aircraft System Remote
   Identification and tracking (UAS RID).  Within the context of RID,
   HHITs will be called DRIP Entity Tags (DET).  HHITs self-attest to
   the included explicit hierarchy that provides Registrar discovery for
   3rd-party identifier attestation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-drip-rid/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-drip-rid-13.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-rid-13

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Robert Moskowitz <[email-masked]>
Date: Sun, 7 Nov 2021 08:34:48 -0500

This fixes the final pieces of drip-rid and it is now ready for wglc. So 
give this ver a serious read-through.

This is what I will be presenting in our session this week.

I am working with Adam on drip-auth-03 to get it out shortly.  Edits 
there MAY result in minor editorial changes here...

Bob

---

From: "Card, Stu" <[email-masked]>
Date: Wed, 10 Nov 2021 01:09:14 -0500

'In some cases it is advantageous to encode HHITs as a CTA 2063-A
   Serial Number [CTA2063A].  For example, the FAA Remote ID Rules
   [FAA_RID] state that a Remote ID Module (i.e. not integrated with UA
   controller) must only use "the serial number of the unmanned
   aircraft"; CTA 2063-A meets this requirement.'

I think the modules are required to transmit their own SN;
there is not supposed to be a user accessible method
of changing any Broadcast RID data, which would be needed
by a module not interfaced to the UA flight controller
to know the SN of the UA.

On Sun, Nov 7, 2021 at 8:35 AM Robert Moskowitz <[email-masked]>
wrote:

> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 10 Nov 2021 05:54:24 -0500

Correct.  We discussed this when we were looking at how modules could 
use DRIP.

So I might add text that the DET based 2063 SN *IS* the manufacturers SN 
for the device.  So no conflict.  Only challenge would be that the HDA 
selection by the manufacturer, not the owner.

And in an ASTM call recently, FAA noted that the modules can't really be 
one way.  They need data from the GCS to meet Operator location 
requirements.  So either (in my view), they would have to receive data 
from the GCS, or be wired into the UA to get the info from there, but 
would the UA HAVE that info.  Fun problem for the FAA (and ASTM) to solve.

On 11/10/21 1:09 AM, Card, Stu wrote:
> On Sun, Nov 7, 2021 at 8:35 AM Robert Moskowitz 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     On 11/7/21 8:31 AM, [email-masked]
>     <mailto:[email-masked]> wrote:
>     >          Title           : DRIP Entity Tag (DET) for Unmanned
>     Aircraft System Remote Identification (UAS RID)
>     <https://datatracker.ietf.org/doc/draft-ietf-drip-rid/>
>     >
>     <https://www.ietf.org/archive/id/draft-ietf-drip-rid-13.html>
>     >
>     <https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-rid-13>
>     >
>     >
>     <ftp://ftp.ietf.org/internet-drafts/>
>     >
>     >
>
>     -- 
>     Tm-rid mailing list
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tm-rid>
>
>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit