Subject: Re: [Drip] Volunteers to contribute to drip-registries I-D

From: "Gould, James" <[email-masked]>
Date: Tue, 21 Dec 2021 13:21:16 +0000

Adam,

The method I usually follow in implementing the EPP extension(s) is:

  1.  Determine the target structure of the EPP extension(s) based on options defined in https://datatracker.ietf.org/doc/html/rfc3735.  I would stick to the Object-level Extension in defining new EPP objects and Command-Response Extension to define new command response attributes for EPP objects.
  2.  Define a set of example XML command and responses with a referenced XML schema.  You can see an example of this in https://github.com/james-f-gould/EPP-Change-Poll.
     *   The “sample” directory contains the set of good (valid) example XML that is validated by executing validategood.sh, which executes validatexml.sh for each XML file, using the pre-cached XML schemas defined in xmlschemas.txt.  Negative sample XML can be included to implement negative testing.
     *   The “xmlvalidator-1.1.0.0” directory contains a Java program that pre-caches the XML schemas and validates the XML using schema validation.  Setting the JAVA_HOME environment variable is needed to a JRE with version 8 or above.
     *   The “xsd” directory contains the XML schemas that are used for validation.
  3.  Prototype implementation of the EPP extensions
     *   The Verisign EPP SDK (https://www.verisign.com/en_US/channel-resources/domain-registry-products/epp-sdks/), with the latest version being 1.15.0.2, includes both a framework for defining a CODEC (Packet Encoder/Decoder), a CODEC testing approach, a client interface approach, and a EPP Stub Server framework.
     *   I generally create a EPP SDK directory per EPP extension that can be independently unit tested.
     *   If you need help with this, please let me know since I can do it in my sleep now ☺
  4.  Create the draft, leveraging the structure of similar EPP extensions (Object-level and Command-Response) using the samples from the “sample” directory.

Let me know if you have any questions.

Thanks,

--

JG

James Gould
Fellow Engineer
[email-masked]<applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

From: Tm-rid <[email-masked]> on behalf of Adam Wiethuechter <[email-masked]>
Date: Monday, December 20, 2021 at 11:57 AM
To: "Hollenbeck, Scott" <shollenbeck=[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] Re: [Drip] Volunteers to contribute to drip-registries I-D

Scott,

One area that you could investigate is the EPP side. We have a working implementation of one endpoint using EPP but looking at other RFCs I am unsure how we are supposed to specify the EPP format and what it should look like. So text in that area on specifying and requesting things would be great. I am not sure if RDAP needs this as well.

I will send to you in a separate email the example EPP stuff to see if we are adhering to convention. Then we need to make the rest of the EPP stuff for the other endpoints based on the information in sections 8 and 9.

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: Tm-rid <[email-masked]> on behalf of Hollenbeck, Scott <shollenbeck=[email-masked]>
Sent: Friday, December 17, 2021 10:55 AM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Drip] Volunteers to contribute to drip-registries I-D

I may be interested. I’ve got experience with the DNS, EPP, RDAP, and registry/registrar bits. What kind of help do you need?

Scott

From: Tm-rid <[email-masked]> On Behalf Of Card, Stu
Sent: Friday, December 17, 2021 9:33 AM
To: [email-masked]
Cc: [email-masked]
Subject: [EXTERNAL] Re: [Drip] Volunteers to contribute to drip-registries I-D

Caution: This email originated from outside the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

We need help from volunteers with knowledge & experience in any of the following areas:

DNS

EPP

RDAP

domain registrar operations

domain registry operations

Regional Internet Registry operations

aircraft registration

anything I forgot

On Fri, Dec 17, 2021, 09:03 <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

We are looking for two additional co-authors to join the drip-registries team, hence this call.

If you are interested to co-author the drip-registries specification, please drop an email to Daniel and myself using the alias [email-masked]<mailto:[email-masked]>.

Thank you

Cheers,

Daniel & Med

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid<https://secure-web.cisco.com/10yo2C4sND6X83q99Gahx1CVp59vPuZAMABizUhRfTErBXYL-iue_rbRUiQsLOwntWOzvJQWzMLVWsC_HFJC3-X79RGp4GYmCh09X8IZuDDg5oABWyNQbVee-kFwKTLSnKnUJWgXJecWVrTJfYoGn6kF_lcuy296OdOP1Yrw1sGcWkyK321ICIfHw3etRgl11xvJ08I9GZABOErNdehQvsfX8Ly59htOlDf89QLb5rQ12qS-sJ3vKyCxqKwUzcwb8/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftm-rid>

---

From: "Michael Palage" <[email-masked]>
Date: Tue, 21 Dec 2021 09:04:12 -0500

Hello James,

Thanks for sharing this information. I am looping in Len Bayles into this thread to share our current best thinking on how we will be modifying FRED to achieve the goals and objectives that Adam has previously shared with us.

Best regards,

Michael 

From: Tm-rid <[email-masked]> On Behalf Of Gould, James
Sent: Tuesday, December 21, 2021 8:21 AM
To: [email-masked]; shollenbeck=[email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Drip] Volunteers to contribute to drip-registries I-D

Adam,

a.	The “sample” directory contains the set of good (valid) example XML that is validated by executing validategood.sh, which executes validatexml.sh for each XML file, using the pre-cached XML schemas defined in xmlschemas.txt.  Negative sample XML can be included to implement negative testing.   
b.	The “xmlvalidator-1.1.0.0” directory contains a Java program that pre-caches the XML schemas and validates the XML using schema validation.  Setting the JAVA_HOME environment variable is needed to a JRE with version 8 or above.
c.	The “xsd” directory contains the XML schemas that are used for validation.

a.	The Verisign EPP SDK (https://www.verisign.com/en_US/channel-resources/domain-registry-products/epp-sdks/), with the latest version being 1.15.0.2, includes both a framework for defining a CODEC (Packet Encoder/Decoder), a CODEC testing approach, a client interface approach, and a EPP Stub Server framework.  
b.	I generally create a EPP SDK directory per EPP extension that can be independently unit tested.
c.	If you need help with this, please let me know since I can do it in my sleep now ☺

Thanks, 

-- 

JG

James Gould
Fellow Engineer
 <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]> [email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

 <http://verisigninc.com/> Verisign.com

From: Tm-rid <[email-masked] <mailto:[email-masked]> > on behalf of Adam Wiethuechter <[email-masked] <mailto:[email-masked]> >
Date: Monday, December 20, 2021 at 11:57 AM
To: "Hollenbeck, Scott" <shollenbeck=[email-masked] <mailto:shollenbeck=[email-masked]> >, "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Subject: [EXTERNAL] Re: [Drip] Volunteers to contribute to drip-registries I-D

Scott,

--------

73,

Adam T. Wiethuechter

  _____  

From: Tm-rid <[email-masked] <mailto:[email-masked]> > on behalf of Hollenbeck, Scott <shollenbeck=[email-masked] <mailto:shollenbeck=[email-masked]> >
Sent: Friday, December 17, 2021 10:55 AM
To: [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Drip] Volunteers to contribute to drip-registries I-D 

Scott

From: Tm-rid <[email-masked] <mailto:[email-masked]> > On Behalf Of Card, Stu
Sent: Friday, December 17, 2021 9:33 AM
To: [email-masked] <mailto:[email-masked]> 
Cc: [email-masked] <mailto:[email-masked]> 
Subject: [EXTERNAL] Re: [Drip] Volunteers to contribute to drip-registries I-D

DNS

EPP

RDAP

aircraft registration

anything I forgot

On Fri, Dec 17, 2021, 09:03 <[email-masked] <mailto:[email-masked]> > wrote:

Hi all, 

If you are interested to co-author the drip-registries specification, please drop an email to Daniel and myself using the alias [email-masked] <mailto:[email-masked]> .

Thank you

Cheers,

Daniel & Med

 

-- 
Tm-rid mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/tm-rid <https://secure-web.cisco.com/10yo2C4sND6X83q99Gahx1CVp59vPuZAMABizUhRfTErBXYL-iue_rbRUiQsLOwntWOzvJQWzMLVWsC_HFJC3-X79RGp4GYmCh09X8IZuDDg5oABWyNQbVee-kFwKTLSnKnUJWgXJecWVrTJfYoGn6kF_lcuy296OdOP1Yrw1sGcWkyK321ICIfHw3etRgl11xvJ08I9GZABOErNdehQvsfX8Ly59htOlDf89QLb5rQ12qS-sJ3vKyCxqKwUzcwb8/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftm-rid>