Subject: [Drip] drip-rid-18 items

From: Robert Moskowitz <[email-masked]>
Date: Mon, 28 Mar 2022 08:33:22 -0400

I am going through the changes I missed needed since decreasing the HID 
to 28 bits.

Just caught that sec 4.2, CTA 2063-A needs to be reworked.  Need 4 more 
bits, it MAY be easy, I have not done the work yet, but heads up on this 
one...

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 29 Mar 2022 08:22:17 -0400

On 3/28/22 08:33, Robert Moskowitz wrote:
> I am going through the changes I missed needed since decreasing the 
> HID to 28 bits.
>
> Just caught that sec 4.2, CTA 2063-A needs to be reworked.  Need 4 
> more bits, it MAY be easy, I have not done the work yet, but heads up 
> on this one...

I have time to think more on this.

If I stay with the Base32 encoding, I will have to use 2 bits from the 
1st character in the Serial Number field.  This would work if we reserve 
values of W,X,Y, and Z (first 3 bits 1s) for that encoding.

This approach would allow manufactures to still have 7 possible 14 
character encodings under their manufacturing code. (0 - V)

I do note, now one 'error' in this section.  I say to avoid using 'Z' as 
it is too similar to '2':

"Thus, here a Base32 encoding will be used by also excluding the letters 
Z and S (too similar to the digits 2 and 5)."

Yet then I go and use it to identify HHIT encoded in 2063!

"The first character after the Length Code MUST be 'Z', followed by the 
14 characters of the encoded HIT Suite ID and ORCHID hash."

Argh.

Suggestions?  Should I thus use V, W, X, and Y to encode 11100, 11101, 
11110, and 11111?

Or I can use the Base34 encoding and then there is plenty of space in 14 
characters for 72 bits.

Comments please.

I would like to get this done by end of week, and Friday I have 3 
grandchildren (and their parents :) ) descending on the house! Won't get 
too much writing done then as the youngest (5 mo) uses my office for her 
bedroom.

Bob

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 29 Mar 2022 09:06:41 -0400

OOPs.  One small correction.

The manufacturer can have 24 SN encodings in the Base32 approach as 2^5 
- 2^3 is 24.

On 3/29/22 08:22, Robert Moskowitz wrote:
> 1st character in the Serial Number field.  This would work if we 
> reserve values of W,X,Y, and Z (first 3 bits 1s) for that encoding.
>
> I do note, now one 'error' in this section.  I say to avoid using 'Z' 
> as it is too similar to '2':
>
> "Thus, here a Base32 encoding will be used by also excluding the 
> letters Z and S (too similar to the digits 2 and 5)."
>
> "The first character after the Length Code MUST be 'Z', followed by 
> the 14 characters of the encoded HIT Suite ID and ORCHID hash."
>
> Argh.
>
> Or I can use the Base34 encoding and then there is plenty of space in 
> 14 characters for 72 bits.
>
> Comments please.
>
> grandchildren (and their parents :) ) descending on the house! Won't 
> get too much writing done then as the youngest (5 mo) uses my office 
> for her bedroom.
>
> Bob
>

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 29 Mar 2022 09:10:13 -0400

ARGH!!!!

I need a nap....

2^5 - 2^2 = 28.

Sigh.

Signing off for an hour.  Too short of a night.  Us septarians (speeling 
? 70-year olds :) ) need our sleep....

On 3/29/22 09:06, Robert Moskowitz wrote:
> The manufacturer can have 24 SN encodings in the Base32 approach as 
> 2^5 - 2^3 is 24.
>
>>> more bits, it MAY be easy, I have not done the work yet, but heads 
>>> up on this one...
>>
>> If I stay with the Base32 encoding, I will have to use 2 bits from 
>> the 1st character in the Serial Number field.  This would work if we 
>> Suggestions?  Should I thus use V, W, X, and Y to encode 11100, 
>> 11101, 11110, and 11111?
>>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Adam Wiethuechter <[email-masked]>
Date: Tue, 29 Mar 2022 15:19:33 +0000

For whatever reason Outlook hates how you respond in these email threads and it's a jumbled mess for me to view.

But to clarify CTA encoding is broken and we need to fix it to fit the new 8-bit Suite ID. 'Z' is a letter that is unusable and was a general oversight that we still used it.

I personally prefer the simple approach of using a Base34 encoding into 14 characters so that the first character can remain in use for the indicator of a DRIP Serial Number.

Allocating multiple characters to signal use seems overly complex and limits standard use of the Serial Number's max characters.

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: Tm-rid <[email-masked]> on behalf of Robert Moskowitz <[email-masked]>
Sent: Tuesday, March 29, 2022 9:10 AM
To: [email-masked] <[email-masked]>
Subject: Re: [Drip] drip-rid-18 - CTA 2063-A encoding changes

ARGH!!!!

I need a nap....

2^5 - 2^2 = 28.

Sigh.

Signing off for an hour.  Too short of a night.  Us septarians (speeling ? 70-year olds :) ) need our sleep....

The manufacturer can have 24 SN encodings in the Base32 approach as 2^5 - 2^3 is 24.

On 3/28/22 08:33, Robert Moskowitz wrote:
I am going through the changes I missed needed since decreasing the HID to 28 bits.

Just caught that sec 4.2, CTA 2063-A needs to be reworked.  Need 4 more bits, it MAY be easy, I have not done the work yet, but heads up on this one...

If I stay with the Base32 encoding, I will have to use 2 bits from the 1st character in the Serial Number field.  This would work if we reserve values of W,X,Y, and Z (first 3 bits 1s) for that encoding.

This approach would allow manufactures to still have 7 possible 14 character encodings under their manufacturing code. (0 - V)

I do note, now one 'error' in this section.  I say to avoid using 'Z' as it is too similar to '2':

"Thus, here a Base32 encoding will be used by also excluding the letters Z and S (too similar to the digits 2 and 5)."

"The first character after the Length Code MUST be 'Z', followed by the 14 characters of the encoded HIT Suite ID and ORCHID hash."

Argh.

Suggestions?  Should I thus use V, W, X, and Y to encode 11100, 11101, 11110, and 11111?

Or I can use the Base34 encoding and then there is plenty of space in 14 characters for 72 bits.

Comments please.

I would like to get this done by end of week, and Friday I have 3 grandchildren (and their parents :) ) descending on the house! Won't get too much writing done then as the youngest (5 mo) uses my office for her bedroom.

Bob

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 29 Mar 2022 11:34:59 -0400

One vote for Base34 encoding.  And a heavy 1 vote as Adam writes code!

On 3/29/22 11:19, Adam Wiethuechter wrote:
> For whatever reason Outlook hates how you respond in these email 
> threads and it's a jumbled mess for me to view.

I always hated Outlook....

>
> But to clarify CTA encoding is broken and we need to fix it to fit the 
> new 8-bit Suite ID. 'Z' is a letter that is unusable and was a general 
> oversight that we still used it.

I should have caught my mis-use of 'Z' earlier and used 'Y' instead.  
Moving to Base34 means it can stay as 'Z'.

>
> I personally prefer the simple approach of using a Base34 encoding 
> into 14 characters so that the first character can remain in use for 
> the indicator of a DRIP Serial Number.
>
> Allocating multiple characters to signal use seems overly complex and 
> limits standard use of the Serial Number's max characters.
>
> --------
> 73,
> Adam T. Wiethuechter
> ------------------------------------------------------------------------
> *From:* Tm-rid <[email-masked]> on behalf of Robert Moskowitz 
> <[email-masked]>
> *Sent:* Tuesday, March 29, 2022 9:10 AM
> *To:* [email-masked] <[email-masked]>
> *Subject:* Re: [Drip] drip-rid-18 - CTA 2063-A encoding changes
> ARGH!!!!
>
> I need a nap....
>
> 2^5 - 2^2 = 28.
>
> Sigh.
>
> Signing off for an hour.  Too short of a night.  Us septarians 
> (speeling ? 70-year olds :) ) need our sleep....
>
> E: [email-masked] <mailto:[email-masked]>
>

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 29 Mar 2022 12:16:10 -0400

Just did some math, and I don't think that Base34 will work in 14 
characters:

34^14 = 2.76E+21
2^72 = 4.72E+21

71 bits can be encoded in 14 Base34 characters.  :(

Thus only a 7-bit OGA would fit.

Need some more drawings and ideas!

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 29 Mar 2022 17:55:19 -0400

Recomputing....

After 3.5 hours in the dental chair....

Choices are:

All 15 characters used to encode OGA|Hash with Base32

Only support 7 bits of OGA with Base34.

Vote please.

---

From: Adam Wiethuechter <[email-masked]>
Date: Tue, 29 Mar 2022 22:06:01 +0000

Use all 15 then and keep base 32

Get Outlook for Android<https://aka.ms/AAb9ysg>
________________________________
From: Robert Moskowitz <[email-masked]>
Sent: Tuesday, March 29, 2022 5:55:19 PM
To: Adam Wiethuechter <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Drip] drip-rid-18 - CTA 2063-A encoding changes

Recomputing....

Choices are:

Vote please.

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: Tm-rid <[email-masked]><mailto:[email-masked]> on behalf of Robert Moskowitz <[email-masked]><mailto:[email-masked]>
Sent: Tuesday, March 29, 2022 9:10 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: Re: [Drip] drip-rid-18 - CTA 2063-A encoding changes

ARGH!!!!

I need a nap....

2^5 - 2^2 = 28.

Sigh.

Argh.

Comments please.

Bob