Subject: [Drip] Need some coding help for HHIT

From: Robert Moskowitz <[email-masked]>
Date: Mon, 21 Mar 2022 11:45:40 -0400

We have what is now an old python script to create HHITs:

github.com/ietf-wg-drip/draft-ietf-drip-rid/blob/master/hhit-gen.py

It is basically orphaned, so I am looking for someone willing/able to 
update it or totally replace it.

Please let me know, or I will just cut this out of the draft.

thanks

Bob

---

From: <[email-masked]>
Date: Tue, 22 Mar 2022 10:37:51 +0000

Hi Bob, 

I guess you are referring to these two parts from the draft:

(1)

A python script is available for generating HHITs [hhit-gen].

(2)

A
   Python script is available to randomly generate 1M HHITs that did not
   produce a hash collision which is a simpler attack than a first or
   second pre-image attack.

Right?

Cheers,
Med

> -----Message d'origine-----
> De : Tm-rid <[email-masked]> De la part de Robert Moskowitz
> Envoyé : lundi 21 mars 2022 16:46
> À : [email-masked]
> Objet : [Drip] Need some coding help for HHIT
> 
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 22 Mar 2022 08:06:09 -0400

Med,

That is correct.  The second is not so important to maintain any more, 
but the HHIT generating script should be of value...

I am not a coder; really haven't coded since I worked with 'B' in the 
late '80s (Honeywell L6 and L66).

So if no one can step forward and at least change the script to support 
the 8-bit OGA, I will have to drop it.

Bob

---

From: <[email-masked]>
Date: Tue, 22 Mar 2022 12:22:26 +0000

Re-,

Agree to remove (2). 

I also see a value in having a pointer to the script. What about the following:

NEW:
 A script for generating HHITs based on an early version of this specification is available at [hhit-gen]. 

Cheers,
Med

> De : Robert Moskowitz <[email-masked]>
> Envoyé : mardi 22 mars 2022 13:06
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>; tm-
> [email-masked]
> Objet : Re: [Drip] Need some coding help for HHIT
> 
> Med,
> 
> >> Envoyé : lundi 21 mars 2022 16:46 À : [email-masked] Objet : [Drip]
> >> Need some coding help for HHIT
> >>
> > ______________________________________________________________________
> > ___________________________________________________
> >
> > Ce message et ses pieces jointes peuvent contenir des informations
> > confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> > exploites ou copies sans autorisation. Si vous avez recu ce message
> > par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> que les pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or
> > privileged information that may be protected by law; they should not
> be distributed, used or copied without authorisation.

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 22 Mar 2022 08:36:13 -0400

> Agree to remove (2).

Maintain text that we had a script for doing the test.

>   A script for generating HHITs based on an early version of this specification is available at [hhit-gen].

This works if no one steps forward.

I mean, I do write simple bash scripts and played around with some java 
scripting.  But none of this will get me able to work in python.  Or 
build this as a bash script and openssl...

>> De : Robert Moskowitz<[email-masked]>
>> À : BOUCADAIR Mohamed INNOV/NET<[email-masked]>; tm-
>> [email-masked]
>> On 3/22/22 06:37,[email-masked]  wrote:
>>> Hi Bob,
>>>
>>>> De : Tm-rid<[email-masked]>  De la part de Robert Moskowitz
>>>> Envoyé : lundi 21 mars 2022 16:46 À :[email-masked]  Objet : [Drip]

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: "Card, Stu" <[email-masked]>
Date: Tue, 22 Mar 2022 14:47:16 -0400

The problem arises due to regulatory and contractual constraints on "public
release of information" under which Adam and I labor.
We could try to get permission, but usually it takes so long (at a minimum
60 days), by the time we get it, the code is obsolete. :-(
This code is primarily an illustrative example, and secondarily a research
tool, so obsolescence may be less of an issue.
Should we again request permission?

On Tue, Mar 22, 2022 at 8:36 AM Robert Moskowitz <[email-masked]>
wrote:

> scripting.  But none of this will get me able to work in python.  Or build
> this as a bash script and openssl...
>
>
>
>
> Cheers,
> Med
>
>
> De : Robert Moskowitz <[email-masked]> <[email-masked]>
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]> <[email-masked]>; [email-masked]
>     Python script is available to randomly generate 1M HHITs that did
>
> not
>
> De : Tm-rid <[email-masked]> <[email-masked]> De la part de Robert Moskowitz
> Tm-rid mailing [email-masked]://www.ietf.org/mailman/listinfo/tm-rid
>
> If you have received this email in error, please notify the sender and
>
> delete this message and its attachments.
>
> As emails may be altered, Orange is not liable for messages that have
>
> been modified, changed or falsified.
>
> Thank you.
>
>
> Robert Moskowitz
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked]
>
> There's no limit to what can be accomplished if it doesn't matter who gets
> the credit
> --
> Tm-rid mailing list
> [email-masked]