Subject: [Drip] I-D Action: draft-ietf-drip-auth-05.txt

From: [email-masked]
Date: Mon, 07 Mar 2022 11:26:31 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Drone Remote ID Protocol WG of the IETF.

        Title           : DRIP Authentication Formats & Protocols for Broadcast Remote ID
        Authors         : Adam Wiethuechter
                          Stuart Card
                          Robert Moskowitz
	Filename        : draft-ietf-drip-auth-05.txt
	Pages           : 48
	Date            : 2022-03-07

Abstract:
   This document describes how to include trust into the ASTM Remote ID
   specification defined in ASTM F3411 under Broadcast Remote ID (RID).
   It defines a few message schemes (sent within the Authentication
   Message) that can be used to authenticate past messages sent by a
   unmanned aircraft (UA) and provide proof of UA trustworthiness even
   in the absence of Internet connectivity at the receiving node.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-drip-auth/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-drip-auth-05.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-auth-05

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: <[email-masked]>
Date: Tue, 8 Mar 2022 08:37:28 +0000

Hi Adam, all,

FYI, I requested a security review for this version to make sure that potential security issues are tagged early in the process. I indicated March 22 as a tentative date, but this will depend on the reviewers availability. 

One quick question about ICAO-related matters:

The draft says:
==
   The SAM Type field is maintained by the International Civil Aviation
   Organization (ICAO) and for DRIP four are allocated:
==

but also: 

==
8.  ICAO Considerations

   DRIP requests the following SAM Type's to be allocated:
==

Which seems to be conflicting. 

Can you please report about the currents status of these assignments? If the assignments are already made, then removing Section 8 would make sense.  

Thanks. 

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce <[email-masked]> De la part de
> [email-masked]
> Envoyé : lundi 7 mars 2022 20:27
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action: draft-ietf-drip-auth-05.txt
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Adam Wiethuechter <[email-masked]>
Date: Tue, 8 Mar 2022 18:08:20 +0000

Hi Med,

This is an error. We have not contacted ICAO about this and AFAIK they have yet to stand up the registration process. I will fix the sentence accordingly to match Section 8.

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: [email-masked] <[email-masked]>
Sent: Tuesday, March 8, 2022 3:37 AM
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: RE: I-D Action: draft-ietf-drip-auth-05.txt

Hi Adam, all,

The draft says:
==

but also:

==
8.  ICAO Considerations

Thanks.

Cheers,
Med

---

From: "Card, Stu" <[email-masked]>
Date: Tue, 8 Mar 2022 18:19:01 -0500

"We" in this case being first ASTM to set up the process (after F3411-22
passes ballot), then IETF to register codes via that process.

On Tue, Mar 8, 2022, 13:08 Adam Wiethuechter <
[email-masked]> wrote:

> Hi Med,
>
> This is an error. We have not contacted ICAO about this and AFAIK they
> have yet to stand up the registration process. I will fix the sentence
> accordingly to match Section 8.
>
> --------
> 73,
> Adam T. Wiethuechter
> ------------------------------
> *From:* [email-masked] <[email-masked]>
> *Sent:* Tuesday, March 8, 2022 3:37 AM
> *To:* [email-masked] <[email-masked]>
> *Cc:* [email-masked] <[email-masked]>
> *Subject:* RE: I-D Action: draft-ietf-drip-auth-05.txt
>
> Hi Adam, all,
>
> FYI, I requested a security review for this version to make sure that
> potential security issues are tagged early in the process. I indicated
> March 22 as a tentative date, but this will depend on the reviewers
> availability.
>
> Can you please report about the currents status of these assignments? If
> the assignments are already made, then removing Section 8 would make
> sense.
>
> Thanks.
>
> Cheers,
> Med
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: <[email-masked]>
Date: Wed, 9 Mar 2022 07:37:39 +0000

Hi Adam, Stu,

Thanks you for clarifying.

Stu, do you have an idea by when that process will be set and put into effect?

Cheers,
Med

De : Card, Stu <[email-masked]>
Envoyé : mercredi 9 mars 2022 00:19
À : Adam Wiethuechter <[email-masked]>
Cc : BOUCADAIR Mohamed INNOV/NET <[email-masked]>; [email-masked]; [email-masked]
Objet : Re: I-D Action: draft-ietf-drip-auth-05.txt

"We" in this case being first ASTM to set up the process (after F3411-22 passes ballot), then IETF to register codes via that process.

On Tue, Mar 8, 2022, 13:08 Adam Wiethuechter <[email-masked]<mailto:[email-masked]>> wrote:
Hi Med,

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 8, 2022 3:37 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: RE: I-D Action: draft-ietf-drip-auth-05.txt

Hi Adam, all,

The draft says:
==

but also:

==
8.  ICAO Considerations

Thanks.

Cheers,
Med

> De : I-D-Announce <[email-masked]<mailto:[email-masked]>> De la part de
> [email-masked]<mailto:[email-masked]>
> À : [email-masked]<mailto:[email-masked]>
> Cc : [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

---

From: "Card, Stu" <[email-masked]>
Date: Wed, 9 Mar 2022 08:42:54 -0500

ASTM F3411-22 ballot submission window closes soon, I think MAR 15. If
there are no negative ballots, this should be very soon thereafter, as ASTM
approached ICAO with this many months ago and there is already agreement in
principle. The F3411-22 draft has an appendix, written primarily by Bob,
based on how IETF and IANA coordinate, specifying the procedure for ASTM
and ICAO to do likewise. :-) May I have 5 minutes at our IETF 113 DRIP
session to update everyone on F3411?

On Wed, Mar 9, 2022, 02:37 <[email-masked]> wrote:

> *De :* Card, Stu <[email-masked]>
> *Envoyé :* mercredi 9 mars 2022 00:19
> *À :* Adam Wiethuechter <[email-masked]>
> *Cc :* BOUCADAIR Mohamed INNOV/NET <[email-masked]>;
> [email-masked]; [email-masked]
> *Objet :* Re: I-D Action: draft-ietf-drip-auth-05.txt
>
>
>

---

From: <[email-masked]>
Date: Wed, 9 Mar 2022 14:16:05 +0000

Re-,

Thanks, Stu.

We have 5mn that we secured in the agenda in case there are last minute issue with -arch or rid. If there are no issues, the slot will be yours to briefly update the WG on F3411.

Cheers,
Med

De : Card, Stu <[email-masked]>
Envoyé : mercredi 9 mars 2022 14:43
À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>
Cc : Adam Wiethuechter <[email-masked]>; [email-masked]; [email-masked]
Objet : Re: I-D Action: draft-ietf-drip-auth-05.txt

ASTM F3411-22 ballot submission window closes soon, I think MAR 15. If there are no negative ballots, this should be very soon thereafter, as ASTM approached ICAO with this many months ago and there is already agreement in principle. The F3411-22 draft has an appendix, written primarily by Bob, based on how IETF and IANA coordinate, specifying the procedure for ASTM and ICAO to do likewise. :-) May I have 5 minutes at our IETF 113 DRIP session to update everyone on F3411?

On Wed, Mar 9, 2022, 02:37 <[email-masked]<mailto:[email-masked]>> wrote:
Hi Adam, Stu,

Cheers,
Med

De : Card, Stu <[email-masked]<mailto:[email-masked]>>
Envoyé : mercredi 9 mars 2022 00:19
À : Adam Wiethuechter <[email-masked]<mailto:[email-masked]>>
Cc : BOUCADAIR Mohamed INNOV/NET <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Objet : Re: I-D Action: draft-ietf-drip-auth-05.txt

--------
73,
Adam T. Wiethuechter

Hi Adam, all,

The draft says:
==

but also:

==
8.  ICAO Considerations

Thanks.

Cheers,
Med

Thank you.