Subject: [Drip] I-D Action: draft-ietf-drip-rid-17.txt

From: [email-masked]
Date: Sat, 19 Mar 2022 19:13:18 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Drone Remote ID Protocol WG of the IETF.

        Title           : DRIP Entity Tag (DET) for Unmanned Aircraft System Remote Identification (UAS RID)
        Authors         : Robert Moskowitz
                          Stuart W. Card
                          Adam Wiethuechter
                          Andrei Gurtov
	Filename        : draft-ietf-drip-rid-17.txt
	Pages           : 33
	Date            : 2022-03-19

Abstract:
   This document describes the use of Hierarchical Host Identity Tags
   (HHITs), updating both [RFC7401] and [RFC7343], as self-asserting
   IPv6 addresses and thereby a trustable identifier for use as the
   Unmanned Aircraft System Remote Identification and tracking (UAS
   RID).  Within the context of RID, HHITs will be called DRIP Entity
   Tags (DET).  HHITs self-attest to the included explicit hierarchy
   that provides Registrar discovery for 3rd-party identifier
   attestation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-drip-rid/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-drip-rid-17.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-rid-17

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Robert Moskowitz <[email-masked]>
Date: Sat, 19 Mar 2022 22:16:26 -0400

This matchs the txt on my server.

It will be the basis for my update comments during our session on Wed.

---

From: <[email-masked]>
Date: Mon, 21 Mar 2022 06:36:21 +0000

Hi Bob, 

The 5mn slot in the agenda is a provision to discuss any last minute issues with arch and rid. I'm not sure we have such an issue for rid. Do we?

If what you have in mind is a status update, I suggest you send a message to the list with the points you wanted to report. Thanks. 

We only have one hour and we would like that Andrei and Adam have their full time budget. 

Thank you.

Cheers,
Daniel & Med

> -----Message d'origine-----
> De : Tm-rid <[email-masked]> De la part de Robert Moskowitz
> Envoyé : dimanche 20 mars 2022 03:16
> À : [email-masked]
> Objet : Re: [Drip] I-D Action: draft-ietf-drip-rid-17.txt
> 
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 21 Mar 2022 05:52:27 -0400

"some organization with knowledge of aviation, e.g. ICAO, will take on 
managing the RAA number assignment".

So not restarting wglc, I an good with that, and what I will say.

I can go through these slides in 5 min.  But if everyone here reads 
them, then I can just say:  "see my slides, they are self-explanatory."

Does this cover things?

I am heading out and will be back a bit before 8ET.

On 3/21/22 02:36, [email-masked] wrote:
>> De : Tm-rid<[email-masked]>  De la part de Robert Moskowitz
>> À :[email-masked]
>> On 3/19/22 22:13,[email-masked]  wrote:

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: <[email-masked]>
Date: Mon, 21 Mar 2022 10:16:50 +0000

Bob,

ICAO is already cited as an example for the DNS part, even if we shouldn’t as per existing guidelines.

I don’t think there is a value in citing again ICAO in the section under discussion nor having the mention about “with knowledge of aviation”. Please remember that the conclusion of one full month to discuss this particular point was to remove the mention of ICAO there.

I prefer we go for a neutral wording. The registry draft is where to have this discussion. That draft may consider/decide leaving some control of the RAA range to the IETF/IANA. Let’s do things in the right order.

Thank you.

Cheers,
Med

De : Robert Moskowitz <[email-masked]>
Envoyé : lundi 21 mars 2022 10:52
À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>
Cc : [email-masked]
Objet : Re: [Drip] I-D Action: draft-ietf-drip-rid-17.txt

"some organization with knowledge of aviation, e.g. ICAO, will take on managing the RAA number assignment".

I can go through these slides in 5 min.  But if everyone here reads them, then I can just say:  "see my slides, they are self-explanatory."

Does this cover things?

I am heading out and will be back a bit before 8ET.
On 3/21/22 02:36, [email-masked]<mailto:[email-masked]> wrote:

Hi Bob,

Thank you.

Cheers,

Daniel & Med

-----Message d'origine-----

De : Tm-rid <[email-masked]><mailto:[email-masked]> De la part de Robert Moskowitz

À : [email-masked]<mailto:[email-masked]>

On 3/19/22 22:13, [email-masked]<mailto:[email-masked]> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts

directories.

This draft is a work item of the Drone Remote ID Protocol WG of the

IETF.

         Title           : DRIP Entity Tag (DET) for Unmanned Aircraft

System Remote Identification (UAS RID)

                           Stuart W. Card

                           Adam Wiethuechter

                           Andrei Gurtov

    Pages           : 33

    Date            : 2022-03-19

Abstract:

    attestation.

Internet-Drafts are also available by rsync at

rsync.ietf.org::internet-drafts

--

Tm-rid mailing list

[email-masked]<mailto:[email-masked]>

Thank you.

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 21 Mar 2022 07:45:03 -0400

I will get you some revised slides this afternoon.

I also realized I left off changing the examples to the 28-bit HID 
format.  So a bit of work for -18.

On 3/21/22 06:16, [email-masked] wrote:
> Standard
> I don’t think there is a value in citing again ICAO in the section 
> under discussion nor having the mention about “with knowledge of 
> aviation”. Please remember that the conclusion of one full month to 
> discuss this particular point was to remove the mention of ICAO there.
>
> I prefer we go for a neutral wording. The registry draft is where to 
> have this discussion. That draft may consider/decide leaving some 
> control of the RAA range to the IETF/IANA. Let’s do things in the 
> right order.
>
> Thank you.
>
> Cheers,
>
> Med
>
> *De :* Robert Moskowitz <[email-masked]>
> *Envoyé :* lundi 21 mars 2022 10:52
> *À :* BOUCADAIR Mohamed INNOV/NET <[email-masked]>
> *Cc :* [email-masked]
> *Objet :* Re: [Drip] I-D Action: draft-ietf-drip-rid-17.txt
>
>         De : Tm-rid<[email-masked]>  <mailto:[email-masked]>  De la part de Robert Moskowitz
>
> E: [email-masked]
>

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 21 Mar 2022 08:08:46 -0400

I will review drip-registries with Adam and align text for rid-18 and 
registries-02