Subject: [Tools-discuss] Author Tools Update

From: Kesara Rathnayake <[email-masked]>
Date: Fri, 22 Oct 2021 16:13:13 +1300

Version 0.2.1 of both Author Tools UI and API are released now.

Website: https://author-tools.ietf.org/
API documentation: https://author-tools.ietf.org/doc/

Notable additions:
  * Ability to validate Internet Drafts. This provides idnits output.
  * Author tools now support both goat and aasvg for kramdown-rfc2629.

ID validation accepts XML (both v3 and v2), IDs in plain text and 
Markdown with kramdown-rfc2629 or mmark.
Under the hood, these IDs gets converted to v3 schema and text using 
xml2rfc.
ID validation output consists of warnings and errors generated by 
xml2rfc and idnits output of the text version.

Release notes of Author Tools can be found here:
  * https://github.com/ietf-tools/ietf-at/releases
  * https://github.com/ietf-tools/ietf-at-ui/releases

For bugs and feature requests, create a new issue on the GitHub project.

   --Kesara

-- 
Kesara Rathnayake
Senior Software Development Engineer - IETF LLC
[email-masked]

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 21 Oct 2021 23:42:02 -0400

Just wanted to say this looks like an excellent start!

Note to those who validate their draft via the API, pipe your output into
| jq -r ".idnits"
and have nicely printed idnits output.

tim

On Thu, Oct 21, 2021 at 11:16 PM Kesara Rathnayake <[email-masked]>
wrote:

> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>