Subject: [Tools-discuss] Mockup of mailing list subscription interface

From: Jay Daley <[email-masked]>
Date: Tue, 12 Oct 2021 11:45:52 +1300

Hi

As previously advised, Robert and I are working on a series of design workshops [1] , one of which we hope to plan around mail management and user interfaces.  As part of the preparation for that we have worked on a detailed mockup of a mail subscription interface for Datatracker:

	https://www.ietf.org/media/documents/Mail_Subscription_Mockup_2021-10-12.pdf

This interface is intended to solve a number of issues:

a) (primary issue) the time/effort required to manage multiple mailing list subscriptions and the various ways people do that using multiple email addresses
b) the ongoing issue of one notification list to rule them or multiple smaller lists, which is heavily influenced by a) above
c) the inadequacy of the default listing of mailing lists and the subsequent effect on discoverability, compounded by some lists being hosted under other domains
d) finding out easily if a list is barely used, wildly high volume, or something in between
e) subscribing to read-only lists

Comments most welcome now or at tomorrow’s meeting, with the main discussion expected to be at the planned workshop.

Jay

[1]  https://mailarchive.ietf.org/arch/msg/tools-discuss/WuhwUDI56QkB6EznPMjvPBus8n4/

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 12 Oct 2021 08:08:22 -0400

Jay,

Just coincidentally I recently did a clean-up/garbage collection of my IETF
list subscriptions, and it was somewhat of a laborious process, even when
using the mailman feature that shows you what other lists you're on once
you've logged into mailman for one of your subscriptions. This would have
made it SO much simpler. You and the tools team are commended for looking
out for ways to make things easier for the folks in the trenches ....

Cheers,
Andy

On Mon, Oct 11, 2021 at 6:46 PM Jay Daley <[email-masked]> wrote:

> Hi
>
> As previously advised, Robert and I are working on a series of design
> workshops [1] , one of which we hope to plan around mail management and
> user interfaces.  As part of the preparation for that we have worked on a
> detailed mockup of a mail subscription interface for Datatracker:
>
>
> a) (primary issue) the time/effort required to manage multiple mailing
> list subscriptions and the various ways people do that using multiple email
> addresses
> b) the ongoing issue of one notification list to rule them or multiple
> smaller lists, which is heavily influenced by a) above
> c) the inadequacy of the default listing of mailing lists and the
> subsequent effect on discoverability, compounded by some lists being hosted
> under other domains
> Comments most welcome now or at tomorrow’s meeting, with the main
> discussion expected to be at the planned workshop.
>
> Jay
>
>
> [1]
> https://mailarchive.ietf.org/arch/msg/tools-discuss/WuhwUDI56QkB6EznPMjvPBus8n4/
>
> --
> Jay Daley
> IETF Executive Director
> [email-masked]
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 12 Oct 2021 14:24:32 +0200

> Comments most welcome now or at tomorrow’s meeting, with the main discussion expected to be at the planned workshop.

There would be an advantage in a capability for smooth migrating of an 
email list from one name to another.

Many email lists at IETF start with a preliminary name such as 'foo' and 
matures into a 'bar' WG stage; the difficulty with 'bar' is that 
currently it is impossible to change the name of the email list so the 
WG 'bar' ends with a 'foo' email list.

Examples abound at IETF: 'shmoo' WG with 'manycouches' email list, 
'ipwave' with 'its', and more.

Ideally, the WG 'bar' would be served by 'bar' email list too, instead 
of 'foo'.

There are many quirky ways in which this problem is currently addressed 
but all solutions are always creating confusions: automated mass 
migration, or mass requests of change of members' email addresses from 
old to new lists, dynamic setting of the [WG name] in the Subject, and 
more.  People then routinely continue to talk about an old 'foo' and 
mean the new 'bar', look into directories like 
ietf.org/mailman/listinfo/[*], or like datatracker, for an old 'foo' 
even if only 'bar' is present, and more other confusions.

('bar' not to be confused with the bar in bar BoF :-)

Alex

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 12 Oct 2021 14:38:20 +0200

Le 12/10/2021 à 14:08, Andrew G. Malis a écrit :
> Jay,
> 
> Just coincidentally I recently did a clean-up/garbage collection of my 
> IETF list subscriptions, and it was somewhat of a laborious 
> process, even when using the mailman feature that shows you what other 
> lists you're on once you've logged into mailman for one of your 
> subscriptions. This would have made it SO much simpler. You and the 
> tools team are commended for looking out for ways to make things easier 
> for the folks in the trenches ....

Facing such difficulties of laborious processes others consider entire 
remakes.

A complete replacing of mailman with something else would probably hurt, 
or be an opportunity.  It depends on many factors that I dont know.

Alex

> 
> Cheers,
> Andy
> 
> 
> On Mon, Oct 11, 2021 at 6:46 PM Jay Daley <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Hi
> 
>     As previously advised, Robert and I are working on a series of
>     design workshops [1] , one of which we hope to plan around mail
>     management and user interfaces.  As part of the preparation for that
>     we have worked on a detailed mockup of a mail subscription interface
>     for Datatracker:
> 
>     <https://www.ietf.org/media/documents/Mail_Subscription_Mockup_2021-10-12.pdf>
> 
>     a) (primary issue) the time/effort required to manage multiple
>     mailing list subscriptions and the various ways people do that using
>     multiple email addresses
>     b) the ongoing issue of one notification list to rule them or
>     multiple smaller lists, which is heavily influenced by a) above
>     subsequent effect on discoverability, compounded by some lists being
>     hosted under other domains
>     <https://mailarchive.ietf.org/arch/msg/tools-discuss/WuhwUDI56QkB6EznPMjvPBus8n4/>
> 
>     -- 
>     Jay Daley
>     IETF Executive Director
>     [email-masked] <mailto:[email-masked]>
> 
>     <mailto:[email-masked]>
>     * Report datatracker and mailarchive bugs to:
>     [email-masked] <mailto:[email-masked]>
>     * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tools-discuss>
> 
> 
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 16 Oct 2021 17:06:57 +1300

Generally looks good to me. Two questions:

1) Will *all* the per-list-per-user options in mailman be exposed? (If not, will there be a one-click way to get to them?)

2) What about mailman password management? It can be a nightmare.

Regards
   Brian Carpenter

---

From: Michael Richardson <[email-masked]>
Date: Sat, 16 Oct 2021 17:41:18 -0400

What's the private domain stuff?
+notation is not well supported outside of people who run their own mail server.
Those of us who use it, already know how.  It doesn't seem important enough
to put so prominently.

(And + is regularly rejected by all manner of services out there, which is
very much wrong, but nothing to do with the IETF's mailman)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "John Levine" <[email-masked]>
Date: 16 Oct 2021 18:12:40 -0400

>+notation is not well supported outside of people who run their own mail server.

It works at Gmail and AOLhoo, which together are probably half of the mail users in the world.

But I agree that it doesn't seem worth it.  In my experience, if you can set up a rule
to sort mail based on +extension you can just as easily sort on List-ID.

R's,
John

---

From: Michael Richardson <[email-masked]>
Date: Sat, 16 Oct 2021 20:00:49 -0400

> It works at Gmail and AOLhoo, which together are probably half of the mail users in the world.

I wish more of them would use it then, so that other places would stop claiming my
email addresses are invalid.

    > to sort mail based on +extension you can just as easily sort on List-ID.

I probably agree.
List-Id: is also (ab)used by github to mark all emails relating to github
issues/pull-requests.  I noticed this when I changed my inbox view to include
ListId before Subject.

But, my point is that it shouldn't be so prominent as I think it will confuse
more than it will help.

---

From: Jay Daley <[email-masked]>
Date: Sun, 17 Oct 2021 21:43:50 +1300

> On 16/10/2021, at 5:07 PM, Brian E Carpenter <[email-masked]> wrote:
> 

If the APIs of Mailman 3 support item then yes, but maybe not all at the start. 
> 2) What about mailman password management? It can be a nightmare.

As above, depends on the APIs.

Jay

-- 
Jay Daley
IETF Executive Director 
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Sun, 17 Oct 2021 21:46:12 +1300

> On 17/10/2021, at 10:41 AM, Michael Richardson <[email-masked]> wrote:
> 
> 

Enough people already use it for IETF mailing lists that it seems friendly to help them with that.  The prominence could be adjusted by hiding it in an ‘advanced’ panel but what IETF’r isn’t going to look at that immediately?

Jay

-- 
Jay Daley
IETF Executive Director 
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 18 Oct 2021 08:41:35 +1300

On 17-Oct-21 21:43, Jay Daley wrote:
>> 1) Will *all* the per-list-per-user options in mailman be exposed? (If 
not, will there be a one-click way to get to them?)
> If the APIs of Mailman 3 support item then yes, but maybe not all at the start. 

What could be done quite easily, I think, is providing a link to 

https://www.ietf.org/mailman/options/LISTNAME/EMAIL%40ADDRESS

   Brian

---

From: Michael Richardson <[email-masked]>
Date: Sun, 17 Oct 2021 16:25:13 -0400

Jay Daley <[email-masked]> wrote:
    > Enough people already use it for IETF mailing lists that it seems
    > friendly to help them with that.  The prominence could be adjusted by
    > hiding it in an ‘advanced’ panel but what IETF’r isn’t going to look at
    > that immediately?

The new ones who are just joining, and who we want to support :-)

I am curious how many use [email-masked],
vs just [email-masked] as I do.
(I use mcr+ietf@ on RIPE and ARIN lists too, because I need to tweak my From:
header when sending, and there is a limit to how many things I want in that
menu item... although: M-x ietf for me)

[I still even use [email-masked] to subscribe to stuff.
Nobody under 30 probably has a clue that it's a thing.]

---

From: "John Levine" <[email-masked]>
Date: 17 Oct 2021 23:55:03 -0400

>Enough people already use it for IETF mailing lists that it seems friendly to help them with that.  The prominence could be adjusted by hiding it in an ‘advanced’ panel but what IETF’r isn’t going t…

Do they have a different +address for each list or one address they use for all lists, e.g., [email-masked]?  My impression
is that it's mostly the latter.

R's,
John

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 18 Oct 2021 14:07:26 +0000

I have seen at least one person who does "+wgname" as opposed to "+ietf"; Viktor Dukhovni.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 18 Oct 2021 10:20:49 -0400

+1, my WG has at least one member that uses "+wgname".

Cheers,
Andy