Subject: [Tools-discuss] author tools api and webservice

From: Robert Sparks <[email-masked]>
Date: Fri, 8 Oct 2021 13:54:36 -0500

All -

Please spend a few minutes exploring https://author-tools.ietf.org/

This is the webservice that will replace xml2rfc.tools.ietf.org soon.

It will allow, but not require, login. At the moment, logging in has no 
effect.

It is built on top of an API that you can also use directly - see 
https://author-tools.ietf.org/doc.

To use the API, you'll need a personal API key from the datatracker, 
which you can get from

https://datatracker.ietf.org/accounts/apikey

once you are logged in (the entry "API keys" in the menu under your 
login name takes you to that URI).

Please send feedback directly to Kesara or me, or open issues at

https://github.com/ietf-tools/ietf-at-ui for the UI page at 
https://author-tools.ietf.org/

https://github.com/ietf-tools/ietf-at for the api

RjS

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 8 Oct 2021 15:22:52 -0400

Robert,

The page looks great, very simple to get what you need! And on the "About"
page, I like the pointers to the various sources.

You say, at the top, to contact the tools team for questions and comments,
but don't say how.  I know how, but other people may not. :-)

Along similar lines, at the bottom of the email you reference "
[email-masked]", but I believe that's been replaced by "
[email-masked]".

Thanks,
Andy

On Fri, Oct 8, 2021 at 2:54 PM Robert Sparks <[email-masked]> wrote:

> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Kesara Rathnayake <[email-masked]>
Date: Sat, 9 Oct 2021 21:21:49 +1300

On 9/10/21 8:22 am, Andrew G. Malis wrote:
> Robert,
> 
> The page looks great, very simple to get what you need! And on the 
> "About" page, I like the pointers to the various sources.
> 
> You say, at the top, to contact the tools team for questions and 
> comments, but don't say how.  I know how, but other people may not. :-)

Thanks for the feedback.
I'll update the web UI to provide better information on how to submit 
bug reports and comments.
See: https://github.com/ietf-tools/ietf-at-ui/issues/13

   --Kesara
> 
> Along similar lines, at the bottom of the email you reference 
> "[email-masked] <mailto:[email-masked]>", but I 
> believe that's been replaced by "[email-masked] 
> <mailto:[email-masked]>".
> 
> Thanks,
> Andy
> 
> 
> On Fri, Oct 8, 2021 at 2:54 PM Robert Sparks <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     All -
> 
>     <https://author-tools.ietf.org/>
> 
>     This is the webservice that will replace xml2rfc.tools.ietf.org
>     <http://xml2rfc.tools.ietf.org> soon.
> 
>     https://author-tools.ietf.org/doc <https://author-tools.ietf.org/doc>.
> 
>     <https://datatracker.ietf.org/accounts/apikey>
> 
>     https://github.com/ietf-tools/ietf-at-ui
>     <https://github.com/ietf-tools/ietf-at-ui> for the UI page at
>     https://author-tools.ietf.org/ <https://author-tools.ietf.org/>
> 
>     https://github.com/ietf-tools/ietf-at
>     <https://github.com/ietf-tools/ietf-at> for the api
> 
>     RjS
> 
> 
>     <mailto:[email-masked]>
>     * Report datatracker and mailarchive bugs to:
>     [email-masked] <mailto:[email-masked]>
>     * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tools-discuss>
> 
> 
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
> 

-- 
Kesara Rathnayake
Senior Software Development Engineer - IETF LLC
[email-masked]