Subject: [Tools-discuss] idnits and rfcdiff MIA?

From: Brian E Carpenter <[email-masked]>
Date: Tue, 12 Oct 2021 09:03:55 +1300

Hi,

For a long time I've been using

https://www.ietf.org/tools/idnits/
and
https://www.ietf.org/tools/rfcdiff/

Just recently they have started redirecting from the current tools to legacy versions at www6.

Where are the current versions hiding?

Regards
   Brian

---

From: Robert Sparks <[email-masked]>
Date: Mon, 11 Oct 2021 16:17:00 -0500

> Just recently they have started redirecting from the current tools to legacy versions at www6.

No - they haven't changed in a long time. Something must have happened 
to cause you to re-notice the www6 window-dressing. Maybe you've been 
useing https://www.ietf.org/rfcdiff which has the dressing removed already?

The wrappers at /tools/ have been like they are for some time, and 
remain a task item to correct for the versions that are being served 
from www.ietf.org.

I'll be making some further changes to rfcdiff's wrapper later today or 
tomorrow to get it to take its metadata from the datatracker rather than 
from tools.ietf.org and will look at unifying the wrappers.

In the not-too-distant future (this may overtake the updates on the 
versions running at www.ietf.org, both of these tools will move to a 
service similar to the one we are building at https://author-tools.ietf.org/

RjS

> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 12 Oct 2021 10:21:07 +1300

Also, https://www.ietf.org/links/ points to https://tools.ietf.org/tools/idnits/

I did find https://www.ietf.org/rfcdiff

Regards
   Brian