Subject: [Tools-discuss] Reminder: tools.ietf.org is shutting down before IETF 113

From: IETF Chair <[email-masked]>
Date: Tue, 19 Oct 2021 09:46:11 +0300

Last May we announced that tools.ietf.org would be wound down. See https://mailarchive.ietf.org/arch/msg/ietf/0n-6EXEmkTp3Uv_vj-5Vnm3o0bo/.

In that announcement, we anticipated shutdown before IETF 111. That was over-ambitious, but we are getting close to ready to complete the transition, and expect to finalize it before IETF 113.

As expected, most functionality has moved to the datatracker. A few services have, or will be, moved elsewhere.

We are tracking the moved services at https://github.com/ietf-tools/tools-transition-plan. If there are features at tools.ietf.org that you find important that are not yet available elsewhere or captured on that page, please send a note to [email-masked]. If you are more comfortable doing so, send a note to me ([email-masked]) or to Robert Sparks ([email-masked]).

Thank you for your patience as we complete this transition.

Robert Sparks, Tools Team Lead
Lars Eggert, IETF Chair

---

From: Tony Finch <[email-masked]>
Date: Tue, 19 Oct 2021 15:41:46 +0100

IETF Chair <[email-masked]> wrote:

> Last May we announced that tools.ietf.org would be wound down. See
> https://mailarchive.ietf.org/arch/msg/ietf/0n-6EXEmkTp3Uv_vj-5Vnm3o0bo/.

Are the http redirects going to remain in place? There are huge amounts of
links to the tools RFC pages out there.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  https://dotat.at/
The Minch: South or southeast 3 to 5 veering southwest 6 to gale 8,
then becoming cyclonic later. Slight or moderate becoming moderate or
rough, occasionally very rough in southwest. Rain then showers,
perhaps thundery. Moderate or good, occasionally poor.

---

From: Robert Sparks <[email-masked]>
Date: Tue, 19 Oct 2021 11:36:53 -0500

> links to the tools RFC pages out there.
Yes, they will.

---

From: Tony Finch <[email-masked]>
Date: Tue, 19 Oct 2021 19:12:31 +0100

Robert Sparks <[email-masked]> wrote:
> > Are the http redirects going to remain in place?
> Yes, they will.

Super, good to hear, thanks!

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  https://dotat.at/
Isle of Man: West or southwest 4 to 6, veering west or northwest 3 or
4 for a time. Moderate or rough becoming slight or moderate. Showers.
Good, occasionally moderate.

---

From: Jay Daley <[email-masked]>
Date: Wed, 20 Oct 2021 08:28:23 +1300

> On 20/10/2021, at 7:12 AM, Tony Finch <[email-masked]> wrote:
> 

I believe (Robert can correct me if I’m wrong) that these redirects will change from a 302 Moved temporarily to a 310 Moved permanently.

Jay

> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 20 Oct 2021 10:29:23 +1100

Hi,

Two things come to mind:

1) The Tools site has a 'latest' resource for the HTML and TXT versions of each I-D. For example:
  https://tools.ietf.org/id/draft-ietf-httpbis-targeted-cache-control.txt
... currently redirects to:
  https://tools.ietf.org/id/draft-ietf-httpbis-targeted-cache-control-02.txt
... whereas datatracker does not. This is useful for links in e-mail and web pages where you want to direct people to the latest version of a document, not a specific revision.

2) The Tools site has (scant) homepages for idnits and rfcdiff. While the services themselves have moved to ietf.org, what about information regarding them? I note that xml2rfc has a separate hostname under tools.ietf.org -- is that going to be the pattern going forward?

Cheers and thanks for all of the work here,

> On 19 Oct 2021, at 5:46 pm, IETF Chair <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Robert Sparks <[email-masked]>
Date: Tue, 19 Oct 2021 18:36:36 -0500

On 10/19/21 6:29 PM, Mark Nottingham wrote:
> ... whereas datatracker does not.

This exists for htmlized documents.

Try 
https://datatracker.ietf.org/doc/html/draft-ietf-httpbis-targeted-cache-control

Right now, the datatracker doesn't serve the raw text, the www.ietf.org 
website does. It is on the list to work out whether that's really the 
best thing to do, and work out a 'latest' service in the process.

>   This is useful for links in e-mail and web pages where you want to direct people to the latest version of a document, not a specific revision.
>
> 2) The Tools site has (scant) homepages for idnits and rfcdiff. While the services themselves have moved to ietf.org, what about information regarding them?
I am tracking this, and will reply later with the final decision on this.
> I note that xml2rfc has a separate hostname under tools.ietf.org -- is that going to be the pattern going forward?
xml2rfc.tools.ietf.org will be replaced as well. The bibxml service 
replacement will be delivered soon. We have an early implementation of 
the replacement for the ui running already at author-tools.ietf.org.

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 20 Oct 2021 23:00:51 +1100

On Wed, Oct 20, 2021, at 10:29, Mark Nottingham wrote:
> 2) The Tools site has (scant) homepages for idnits and rfcdiff. While 
> the services themselves have moved to ietf.org, what about information 
> regarding them? I note that xml2rfc has a separate hostname under 
> tools.ietf.org -- is that going to be the pattern going forward?

I opened https://github.com/ietf-tools/tools-transition-plan/issues/3 to track this, but I also have a toolchain that depended on tools.ietf.org for retrieving these tools for installation.  If releases of these tools become available elsewhere, that would be nice.  For now, I've stopped installing these tools because tools.ietf.org is no longer serving the resources I was relying on.

To be clear, this is less of a big deal than the other things Mark raised.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 20 Oct 2021 13:00:51 -0400

Is there a replacement for the old tools page that had descriptions of 
and links to all sorts of tools? It wasn't well organized but it was my 
go to place to find tools.

Also, will Bap be rehosted somewhere?

	Thanks,
	Paul

---

From: Jay Daley <[email-masked]>
Date: Thu, 21 Oct 2021 10:46:25 +1300

> On 21/10/2021, at 6:00 AM, Paul Kyzivat <[email-masked]> wrote:
> 
> Is there a replacement for the old tools page that had descriptions of and links to all sorts of tools? It wasn't well organized but it was my go to place to find tools.

We have a wiki under development that takes a more structured approach but provide the same data.  See the "tools for authors" section of pages at authors.ietf.org.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 20 Oct 2021 18:31:22 -0400

> We have a wiki under development that takes a more structured approach but provide the same data.  See the "tools for authors" section of pages at authors.ietf.org.

The tools-catalog seems to be what I am looking for. But at the moment, 
while it gives info on tools it doesn't seem to link to them. Is that 
just a matter of it being a work in progress?

>> Also, will Bap be rehosted somewhere?

I see it is mentioned in the tools catalog. Still seeking a link.
But I don't have a current need for it, so I'm not in a rush, as long as 
it isn't forgotten.

	Thanks,
	Paul

---

From: Jay Daley <[email-masked]>
Date: Thu, 21 Oct 2021 11:33:54 +1300

> On 21/10/2021, at 11:31 AM, Paul Kyzivat <[email-masked]> wrote:
> 
> The tools-catalog seems to be what I am looking for. But at the moment, while it gives info on tools it doesn't seem to link to them. Is that just a matter of it being a work in progress?

Yes.

Jay

> But I don't have a current need for it, so I'm not in a rush, as long as it isn't forgotten.
> 
> 	Thanks,
> 	Paul
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]