Subject: [Tools-discuss] Draft not found in rsync version of xml2rfc

From: Martine Sophie Lenders <[email-masked]>
Date: Thu, 21 Oct 2021 14:40:59 +0200

Hi,

In our research group we use the rsync to synchronize our local bibtex 
files with https://xml2rfc.tools.ietf.org/. However, one of our latest 
drafts draft-lenders-dns-over-coap can not be found in the list of 
downloaded XML files and is as such not added to our own bibtex database:

$ rsync -avz --del -f "+ */" -f "+ *.xml" -f "- *" 
xml2rfc.tools.ietf.org::xml2rfc.bibxml /tmp/xml2rfc/
$ find /tmp/xml2rfc/ -name "*lenders*"

yields no results and also searching manually shows the file 
corresponding XML file to not be there.

Via HTTPS it exists: 
https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-lenders-dns-over-coap.xml. 
Any idea, what is happening?

Best regards,
Martine

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Oct 2021 16:39:42 +0200

Possible workaround:

kramdown-rfc-cache-i-d-bibxml

(gem install kramdown-rfc2629 to obtain that.
Set KRAMDOWN_REFCACHEDIR to ~/.cache/xml2rfc, which is also where xml2rfc caches.)

Grüße, Carsten

> On 2021-10-21, at 14:40, Martine Sophie Lenders <[email-masked]> wrote:
> 
> Hi,
> 
> In our research group we use the rsync to synchronize our local bibtex files with https://xml2rfc.tools.ietf.org/. However, one of our latest drafts draft-lenders-dns-over-coap can not be found in the list of downloaded XML files and is as such not added to our own bibtex database:
> 
> $ rsync -avz --del -f "+ */" -f "+ *.xml" -f "- *" xml2rfc.tools.ietf.org::xml2rfc.bibxml /tmp/xml2rfc/
> yields no results and also searching manually shows the file corresponding XML file to not be there.
> 
> Via HTTPS it exists: https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-lenders-dns-over-coap.xml. Any idea, what is happening?
> 
> Best regards,
> Martine
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss