Subject: RE: Sending a Cancel Message to the Server from the Client

From: David Burdett <[email-masked]>
Date: Thu, 19 Nov 1998 19:04:39 -0000

Masaaki

I agree with the need for a cancel function so that the server is
informed if the user cancels a transaction. 

I am more inclined to your CancelLogNetLocn idea since this is really a
business error rather than a technical error but couldn't we just send a
message back to the "xxxRequestLocn" instead since the location is
probably expecting a reply anyway?

As it is a business error, I think the Consumer should send message
containing a Status Component to the appropriate trading role with the
"ProcessState" attribute set to "Failed" and the "CompletionCode"
attribute set to say "Cancelled". This could be included in a simple
Cancel Block.

Thoughts?

David

>----------
>From: 	Masaaki Hiroyo
>Sent: 	19 November 1998 02:02
>To: 	David Burdett
>Cc: 	[email-masked]
>Subject: 	Sending a Cancel Message to the Server from the Client
>
>
>David,
>
>As far as I read in the OTP specification, I couldn't find
>how to send to a server a message which indicates the transaction
>was cancelled by the consumer.
>
>There are some cases where the consumer wants to quit the 
>transaction (at the time of selecting brands, confirming an invoice,
>inserting an electronic cash card to its reader/writer, or confirming
>payment information, because he/she changes his/her mind or finds 
>some mistakes in his/her order.
>
>If there is no element which indicates "cancel" in OTP sent from 
>the client to the server, the server has to wait for a message or
>until a "timeout" event occurs.
>
>Therefore, I think a message should be sent to the CancelLogNetLocn.
>The CancelLogNetLocn would have a similar syntax and role as the 
>ErrorLogNetLocn.  Besides we have to define a "cancel component".
>An alternative solution is to send a message to the ErrorNetLocn
>with an ErrorCode = "Cancel" or a Severity = "Cancel".
>
>Any comments?
>
>Regards
>Masaaki
>
>
>-----
>Masaaki Hiroya
>Systems Development Laboratory
>Hitachi, Ltd.
>email: [email-masked]
>tel: +81-44-966-9111(ext.3552)
>fax: +81-44-966-1796
>
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: Masaaki Hiroya <[email-masked]>
Date: Fri, 20 Nov 1998 10:44:27 +0900

David

I agree with your idea to send a cancel message back to the
"xxxRequestLocn" with the Status Component in the Cancel Block.

Masaaki

-----
Masaaki Hiroya

---

From: David Burdett <[email-masked]>
Date: Mon, 23 Nov 1998 17:47:24 -0000

Thanks for your comments.

Do you think this is a change needed for version 1.0 or should/could it
wait for version 2.0?

David

>----------
>From: 	Masaaki Hiroyo
>Sent: 	19 November 1998 17:44
>To: 	David Burdett
>Cc: 	[email-masked]'
>Subject: 	RE: Sending a Cancel Message to the Server from the Client
>
>
>David
>

---

From: Masaaki Hiroya <[email-masked]>
Date: Tue, 24 Nov 1998 16:03:29 +0900

If possible, I'd like you to put it in version 1.0, but if it delays
releasing version 1.0, I'll wait for version 2.0.

Masaaki

At 17:47 98/11/23 -0000, David Burdett wrote:
> Do you think this is a change needed for version 1.0 or should/could 
> it wait for version 2.0?
> 
> David
> 
> ----------
> From: 	Masaaki Hiroyo
> 復元された添付ファイル："c:¥program
 files¥eudora¥attach¥RESendingaCancelMessageto1"
-----
Masaaki Hiroya