Subject: RE: Issues on Currency Code Types in IOTP

From: David Burdett <[email-masked]>
Date: Mon, 15 Mar 1999 00:24:25 -0000

I've received this reply from Milton Anderson.

On this basis I think we should *definitely* go for the alpha codes.

Does anybody disagree?

David

> ----------
> From: 	Milton M. Anderson[SMTP:[email-masked]]
> Sent: 	13 March 1999 14:44
> To: 	David Burdett
> Subject: 	Re: Issues on Currency Code Types in IOTP
> 
> David,
> 
> OFX, Integrion Gold, IFX from BITS,
> FSTC echeck and FSTC BIPS all used
> the 3 alpha codes.  
> 
> Milt
> 
> Milton M. Anderson
> Technical Projects Director
> Financial Services Technology Consortium
> 276 Dartmouth Avenue
> Fair Haven, NJ 07704-3121
> +1 732 747 1514
> [email-masked]
> 
> 
> -----Original Message-----
> From: David Burdett <[email-masked]>
> To: Ietf Trade WG <[email-masked]>
> Date: Friday, March 12, 1999 9:56 PM
> Subject: RE: Issues on Currency Code Types in IOTP
> 
> 
> >Kent said ...
> >
> >> Assuming an implementor would get the ISO4217 Spec and cut and paste
> the
> >> codes for implementation, I don't see any problem in putting in both
> >> 
> >I agree but ...
> >* New codes are occasionally added, e.g. for the euro, therefore the
> >table would need to be maintained
> >* the look up table takes up space and if you're on a thin client you
> >*might* not want to have to include it.
> >
> >David
> >
> >> ----------
> >> From: Kent M. Davidson[SMTP:[email-masked]]
> >> Sent: 12 March 1999 10:38
> >> To: [email-masked]
> >> Subject: RE: Issues on Currency Code Types in IOTP
> >> 
> >> However, from an implementation point of view, an implementor must then
> >> put in lookup tables for *both* character and digit codes.
> >> 
> >> Not that it really makes that much of a difference in the
> implementation.
> >> You are correct that it is clear and unambiguous.
> >> 
> >> Assuming an implementor would get the ISO4217 Spec and cut and paste
> the
> >> codes for implementation, I don't see any problem in putting in both.
> >> 
> >> However, if it comes down to choosing one or another, I'll agree with
> >> Donald and agree with the preference for letters in lieu of digits.
> >> 
> >> -Kent.
> >> 
> >> At 11:30 AM 3/12/99 -0500, Smith, Chris wrote:
> >> >
> >> >Is this actually a problem?
> >> >
> >> >Note that any given currency code will either be a numeric or
> alphabetic 
> >> >code. As such, the type of ISO4217 code can be quickly determined by 
> >> >looking at the actual code provided.
> >> >
> >> >Put another way:
> >> >
> >> >   ISO4217: USD
> >> >
> >> >and
> >> >
> >> >   ISO4217: 840
> >> >
> >> >are both clear and unambiguous, and it is possible to translate
> without 
> >> >loss from one to the other and back again.
> >> >
> >> >...Chris
> >> >
> >> 
> >> _____________________________
> >> Kent M. Davidson
> >> Vice President of Engineering
> >> Differential, Inc.
> >> direct (408)864-0604 
> >> fax    (408)864-0601             
> >> mailto:[email-masked]
> >> http://www.differential.com
> >> 
> >> 
> >> -----------------------------------------------------------------------
> >> Message addressed to: [email-masked]
> >> Archive available at: http://www.elistx.com/archives/ietf-trade/
> >> To (un)subscribe send a message with "subscribe" or "unsubscribe" in
> the
> >> body to: [email-masked]
> >> 
> >-----------------------------------------------------------------------
> >Message addressed to: [email-masked]
> >Archive available at: http://www.elistx.com/archives/ietf-trade/
> >To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
> >body to: [email-masked]
> 
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: Yoshiaki KAWATSURA <[email-masked]>
Date: Mon, 15 Mar 1999 13:32:39 +0900 (JST)

Unfortunately, SET uses three digit code as the currency codes.
Does anybody know other protocols which is used three digit code
 as the currency codes?

--
Yoshiaki Kawatsura
Hitachi, Ltd.

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Mon, 15 Mar 1999 04:04:44 -0500

I think ISO 8583 does....

From:  Yoshiaki KAWATSURA <[email-masked]>
To:  [email-masked]
Cc:  [email-masked]
In-Reply-To:  Your message of "Mon, 15 Mar 1999 00:24:25 -0000"
	     	<[email-masked]>
References:  <[email-masked]>
Content-Type:  Text/Plain; charset=us-ascii
Content-Transfer-Encoding:  7bit
Message-Id:  <[email-masked]>
Date:  Mon, 15 Mar 1999 13:32:39 +0900 (JST)
X-Dispatcher:  imput version 980905(IM100)
Lines:  17
Sender:  [email-masked]
Precedence:  bulk
X-elistx:  ietf-trade
Source-Info:   From (or Sender) name not authenticated.