Subject: RE: Issues on Currency Code Types in IOTP

From: "Smith, Chris" <[email-masked]>
Date: Fri, 12 Mar 1999 11:30:00 -0500

Is this actually a problem?

Note that any given currency code will either be a numeric or alphabetic 
code. As such, the type of ISO4217 code can be quickly determined by 
looking at the actual code provided.

Put another way:

   ISO4217: USD

and

   ISO4217: 840

are both clear and unambiguous, and it is possible to translate without 
loss from one to the other and back again.

...Chris

______________________________ Reply Separator
_________________________________
Subject: Issues on Currency Code Types in IOTP
Author:  "Masaaki Hiroya" [SMTP:[email-masked]] at Internet
Date:    1999-03-12 00:33

According to the IOTP specification, the currency code type should 
be set to "ISO4217".  However, there are two types of currency codes 
in "ISO4217".  One of them is a 3-letter alphabetic code such
as "USD", "GBP" and "JPY". The other is a 3-digit numeric code 
such as 840, 826 and 392.

As far as I know, Mondex uses alphabetic codes, but SET uses numeric codes.

Can both types defined in ISO4217 be used by IOTP?
If so, I think that the two currency code types should be distinguished 
by IOTP systems by using CurrencyCodeType Attributes in IOTP messages, 
for example: "ISO4217-Alphabet" and "ISO4217-Number"

Otherwise, we should define which currency code type should be used 
in IOTP, just the alphabetic one or just the numeric one.

David's comments are as follows:
> The pros andcons as I see it are:
> *     using numbers. Follow the SET approach of using a numeric code. This

> might be a good idea, especially in the light of recent discussions on the

> SET-discuss which highlighted that EUR was the old mnmnonic for the ECO as

> well as the new mnemonic for the Euro. However new currencies aren't
> invented very often so this might not be a practical problem!
> *     using letters. On the other hand USD is actually immediately
> recognisable whereas 840 is not. This means that if we use a number, then
we 
> would need a table to translate it into a name
>

Any comments?

Masaaki

-----
Masaaki Hiroya
Systems Development Laboratory
Hitachi, Ltd.
email: [email-masked]
tel: +81-44-966-9111(ext.3552)
fax: +81-44-966-1796
----------------------------------------------------------------------- 
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the 
body to: [email-masked]
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Fri, 12 Mar 1999 14:21:44 -0500

While I suppose it is possible to understand either way, I think having
one as canconical form is best...

Thanks,
Donald

From:  "Smith, Chris" <[email-masked]>
To:  "[email-masked]" <[email-masked]>
Date:  Fri, 12 Mar 1999 11:30:00 -0500
Content-Type:  text/plain
Message-ID:   <[email-masked]>
Sender:  [email-masked]
Precedence:  bulk
X-elistx:  ietf-trade
Source-Info:   From (or Sender) name not authenticated.

---

From: "Kent M. Davidson" <[email-masked]>
Date: Fri, 12 Mar 1999 10:38:39 -0800

However, from an implementation point of view, an implementor must then put in lookup tables for *both* character and digit codes.

Not that it really makes that much of a difference in the implementation. You are correct that it is clear and unambiguous.

Assuming an implementor would get the ISO4217 Spec and cut and paste the codes for implementation, I don't see any problem in putting in both.

However, if it comes down to choosing one or another, I'll agree with Donald and agree with the preference for letters in lieu of digits.

-Kent.

>loss from one to the other and back again.

_____________________________
Kent M. Davidson
Vice President of Engineering
Differential, Inc.
direct (408)864-0604 
fax    (408)864-0601             
mailto:[email-masked]
http://www.differential.com

---

From: Tom Arnold <[email-masked]>
Date: Sat, 13 Mar 1999 16:48:21 -0800

We run a gateway and must provide applications and interfaces that support
both ISO4217 forms. I would agree with Donald on this, but would also
suggest that support for both forms not be mandated in the specification.
An either or condition would be preferred.

At 10:38 AM 3/12/99 -0800, Kent M. Davidson wrote:
>However, from an implementation point of view, an implementor must then
put in lookup tables for *both* character and digit codes.
>
>Not that it really makes that much of a difference in the implementation.
You are correct that it is clear and unambiguous.
>
>Assuming an implementor would get the ISO4217 Spec and cut and paste the
codes for implementation, I don't see any problem in putting in both.
>
>However, if it comes down to choosing one or another, I'll agree with
Donald and agree with the preference for letters in lieu of digits.
>>loss from one to the other and back again.

Tom Arnold
Chief Technical Officer
CyberSource Corporation
[email-masked]

---

From: Tom Arnold <[email-masked]>
Date: Sun, 14 Mar 1999 15:23:03 -0800

In the same manner that ISO4217 is specified for currency codes, should
country codes be specified to ISO3166? Also, does it matter if two or three
character codes are used?

Tom Arnold