Subject: RE: Issues on Currency Code Types in IOTP

From: David Burdett <[email-masked]>
Date: Fri, 12 Mar 1999 18:57:44 -0000

I don't think we should require *both* numeric and alpha to be implemented
as I can't see any benefit and it would make it more complex to implement.
On this basis I'd go for the alpha code on ground of understandability.

If every implementer knew that in OTP the currency code was always alpha,
then it could be relied upon. However I do think that making the currency
code type "ISO4217-A" as Don suggests is a good idea.

David

> ----------
> From: 	Donald E. Eastlake 3rd[SMTP:[email-masked]]
> Sent: 	12 March 1999 08:49
> To: 	Masaaki Hiroya
> Cc: 	[email-masked]
> Subject: 	Re: Issues on Currency Code Types in IOTP 
> 
> 
> I like the alphabetic codes much more, myself, because they are easily
> understood as the two letter ISO 3166 country code followed by a
> letter for the currency.  This handles the admittedly rare case of
> "currency rollover" or multiple currencies in a country quite
> naturally.  The three digit currency codes are really just the three
> digit ISO 3166 country codes.  This allows only one curreny per
> country and is harder to understand.  Both have some problems with
> transnational currencies but manage to handle it.
> 
> SET uses numeric codes because the actually back end bank credit card
> networks, as I understand it, use numeric codes.  (And they probably
> were originally set up to do that to save a few bits in encoding.)
> 
> I suggest that the spec be changed to specify "ISO4217-A" as the
> mandatory to implement alpha codes and define "ISO4217-N" as the
> numeric codes which could be optional.
> 
> Thanks,
> Donald
> 
> From:  Masaaki Hiroya <[email-masked]>
> Message-Id:  <[email-masked]>
> X-Sender:  [email-masked]
> Date:  Fri, 12 Mar 1999 14:33:28 +0900
> To:  [email-masked]
> 
> >According to the IOTP specification, the currency code type should
> >be set to "ISO4217".  However, there are two types of currency codes
> >in "ISO4217".  One of them is a 3-letter alphabetic code such 
> >as "USD", "GBP" and "JPY". The other is a 3-digit numeric code
> >such as 840, 826 and 392.
> >
> >As far as I know, Mondex uses alphabetic codes, but SET uses numeric
> codes.
> >
> >Can both types defined in ISO4217 be used by IOTP?
> >If so, I think that the two currency code types should be distinguished 
> >by IOTP systems by using CurrencyCodeType Attributes in IOTP messages, 
> >for example: "ISO4217-Alphabet" and "ISO4217-Number"
> >
> >Otherwise, we should define which currency code type should be used
> >in IOTP, just the alphabetic one or just the numeric one.
> >
> >David's comments are as follows:
> >> The pros andcons as I see it are:
> >> *	using numbers. Follow the SET approach of using a numeric code. This
> >> might be a good idea, especially in the light of recent discussions on
> the
> >> SET-discuss which highlighted that EUR was the old mnmnonic for the ECO
> as
> >> well as the new mnemonic for the Euro. However new currencies aren't
> >> invented very often so this might not be a practical problem!
> >> *	using letters. On the other hand USD is actually immediately
> >> recognisable whereas 840 is not. This means that if we use a number,
> then we
> >> would need a table to translate it into a name
> >> 
> >
> >Any comments?
> >
> >Masaaki
> >
> >
> >-----
> >Masaaki Hiroya
> >Systems Development Laboratory
> >Hitachi, Ltd.
> >email: [email-masked]
> >tel: +81-44-966-9111(ext.3552)
> >fax: +81-44-966-1796
> >-----------------------------------------------------------------------
> >Message addressed to: [email-masked]
> >Archive available at: http://www.elistx.com/archives/ietf-trade/
> >To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
> >body to: [email-masked]
> -----------------------------------------------------------------------
> Message addressed to: [email-masked]
> Archive available at: http://www.elistx.com/archives/ietf-trade/
> To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
> body to: [email-masked]
> 
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: David Burdett <[email-masked]>
Date: Sat, 13 Mar 1999 02:48:11 -0000

Kent said ...

> Assuming an implementor would get the ISO4217 Spec and cut and paste the
> codes for implementation, I don't see any problem in putting in both
> 
I agree but ...
*	New codes are occasionally added, e.g. for the euro, therefore the
table would need to be maintained
*	the look up table takes up space and if you're on a thin client you
*might* not want to have to include it.

David

> ----------
> From: 	Kent M. Davidson[SMTP:[email-masked]]
> Sent: 	12 March 1999 10:38
> Subject: 	RE: Issues on Currency Code Types in IOTP
> 
> However, from an implementation point of view, an implementor must then
> put in lookup tables for *both* character and digit codes.
> 
> Not that it really makes that much of a difference in the implementation.
> You are correct that it is clear and unambiguous.
> 
> Assuming an implementor would get the ISO4217 Spec and cut and paste the
> codes for implementation, I don't see any problem in putting in both.
> 
> However, if it comes down to choosing one or another, I'll agree with
> Donald and agree with the preference for letters in lieu of digits.
> 
> -Kent.
> 
> At 11:30 AM 3/12/99 -0500, Smith, Chris wrote:
> >
> >Is this actually a problem?
> >
> >Note that any given currency code will either be a numeric or alphabetic 
> >code. As such, the type of ISO4217 code can be quickly determined by 
> >looking at the actual code provided.
> >
> >Put another way:
> >
> >   ISO4217: USD
> >
> >and
> >
> >   ISO4217: 840
> >
> >are both clear and unambiguous, and it is possible to translate without 
> >loss from one to the other and back again.
> >
> >...Chris
> >
> 
> _____________________________
> Kent M. Davidson
> Vice President of Engineering
> Differential, Inc.
> direct (408)864-0604 
> fax    (408)864-0601             
> mailto:[email-masked]
> http://www.differential.com
> 
>

---

From: "Milton M. Anderson" <[email-masked]>
Date: Mon, 15 Mar 1999 08:28:10 -0500

David

See also http://www.unece.org/cefact/index.htm
Select "Code Lists"
Select "Currency Codes"

This leads me to believe that EDI
uses 3 alpha currency codes.  
There are also example 820s on the
web that show 3 alpha codes.

Milt

-----Original Message-----
From: David Burdett <[email-masked]>
To: Milton M. Anderson <[email-masked]>
Cc: Ietf Trade WG <[email-masked]>
Date: Sunday, March 14, 1999 7:25 PM
Subject: RE: Issues on Currency Code Types in IOTP

>I've received this reply from Milton Anderson.
>
>On this basis I think we should *definitely* go for the alpha codes.
>
>Does anybody disagree?
>
>David
>

---

From: Steven Sims <[email-masked]>
Date: Mon, 15 Mar 99 10:02:43 +0000

>Unfortunately, SET uses three digit code as the currency codes.
>Does anybody know other protocols which is used three digit code
> as the currency codes?

The widest used electronic purse card in the world, Proton, also uses the 
three digit currency codes.

Steve