Subject: Re: Using XML as well as HTML

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Mon, 10 May 1999 22:56:39 -0400

It seems to me that the solution for this involves, among other things,
the Offer Request message we have defered until after v1.0...

I suggest we go for simplicity in v1.0 and just say that support of
XML is recommended even though your point about XML support at some
level being implied since IOTP uses XML syntax...

Thanks,
Donald

From:  David Burdett <[email-masked]>
Message-Id:  <[email-masked]>
Date:  Fri, 30 Apr 1999 20:04:09 +0100

>I agree that XML should be recommended, the problem is how do you discover
>if the consumer has XML/XSL support in their IOTP implementation? 
>
>If a merchant or one of the other trading roles is unsure, then they'll
>never send order descrciptions, etc, in XML to the consumer. On the other
>hand if a particular IOTP consumer client software becomes highly popular
>that supports XML/XSL, then it is reasonable safe for merchants to use XML
>and more might do so.
>
>Finally, you could argue that since to do IOTP at all, there must be XML
>support then at least half the solution *must* be there. In this case, you
>could recommend displaying a message to the user of the problem and
>displaying XML in a very simple way.
>
>David
>
>
>> ----------
>> From: 	Donald E. Eastlake 3rd[SMTP:[email-masked]]
>> Sent: 	29 April 1999 10:04
>> To: 	Ietf Trade WG
>> Subject: 	Re: Using XML as well as HTML 
>> 
>> I believe that support for XML should be recommended but not required.
>> 
>> Thanks,
>> Donald
>> 
>> From:  David Burdett <[email-masked]>
>> Message-Id:  <[email-masked]>
>> To:  Ietf Trade WG <[email-masked]>
>> Date:  Thu, 29 Apr 1999 17:17:05 +0100
>> 
>> >Following on from my other email on using HTML, the spec doesn't
>> currently
>> >describe how XML could be used. I think that it should. We could provide
>> >similar guidelines for XML/XSL to the ones for HTML. 
>> >
>> >Who thinks this is a good idea?
>> >
>> >David
>> >
>> >THIS EMAIL IS FOR UNRESTRICTED DISTRIBUTION
>> >> mailto:<[email-masked]>
>> >> Mondex International, US Advanced Technology Office
>> >> 111 Pine St, 6th Floor, San Francisco, CA 94111
>> >> Tel/Voicemail: +1 415 645 6973	Fax: +1 415 956 9370
>> -----------------------------------------------------------------------
>> Message addressed to: [email-masked]
>> Archive available at: http://www.elistx.com/archives/ietf-trade/
>> To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
>> body to: [email-masked]
>> 
>
>************************************************************************************
**********
>
>This Email and any attached files are confidential and may also be privileged. 
>If you are not the intended recipient, please notify the postmaster using email 
>address [email-masked] or call +44 171 557 5000 and ask for the 
>IT Helpdesk.  You should not copy this email and any attached files, use them 
>for any purpose or disclose the contents to any other person; all copies of the 
>Email and associated files in your possession should be destroyed.
>
>Mondex International Limited
>47-53 Cannon Street
>London EC4M 5SQ
>United Kingdom
>Registered No: 3122085, England
>
>Phone:          +44 171 557 5000
>Fax:            +44 171 557 5200
>Email:          [email-masked]
>WebSite:        http://www.mondexinternational.com
>
>************************************************************************************
*********
>-----------------------------------------------------------------------
>Message addressed to: [email-masked]
>Archive available at: http://www.elistx.com/archives/ietf-trade/
>To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
>body to: [email-masked]
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: David Burdett <[email-masked]>
Date: Tue, 18 May 1999 02:17:01 +0100

The problem is that the XML style sheet (XSL) specifications are not
finalised. Specifically:
*	"Associating stylesheets with XML documents" at
http://www.w3.org/TR/xml-stylesheet is a proposed recommendation and
requires comments to be submitted by 26 May, and
*	"Extensible Stylesheet Language (XSL) Specification" at
http://www.w3.org/TR/WD-xsl is just a working draft.

The first document also states  " ... the technology explained in this
Proposed Recommendation is not the only one for its task. There are others
available or under development that allow the link to be outside the XML
document ..." which means that further changes can be anticipated.

Therefore I suggest that the a "XML Packaging" section is added to the IOTP
specification after the existing section on "HTML packaging" that says ...

"Support for XML is recommended. When XML needs to be displayed, for example
to display the content of an Order Description to a Consumer, then the
method employed is at the discretion of the implementer.

	[Note]	At the time of writing this specification, standards are
under development that specify XML style sheets that show how XML documents
should be displayed. See:
				*	"Extensible Stylesheet Language
(XSL) Specification" at http://www.w3.org/TR/WD-xsl, and
				*	"Associating stylesheets with XML
documents" at http://www.w3.org/TR/xml-stylesheet.
				Once these standards become W3C
"Recommendations", then it is anticipated that this specification will be
amended if practical.
	[Note End]	 "

... and change references to "plain text and HTML" to additionally refer to
XML  for instance ...

"For interoperability, implementations must support Plain Text, HTML and XML
as a minimum so that it can be easily displayed."

This applies to the sections on: "Order Description Content", "Payment Note"
and "Delivery Note"

Any comments?

David
> Sent: 	10 May 1999 19:56
> >> Message-Id:
> <[email-masked]>

**********************************************************************************************

Phone:          +44 171 557 5000
Fax:            +44 171 557 5200

*********************************************************************************************

---

From: [email-masked]
Date: Thu, 20 May 1999 15:44:21 -0400

While it is true that XSL and how to link it to an XML document isn't finalized
yet, I'm not sure how much we should worry about that.  It seems very likely
there will be some way to link style sheets out of an XML document so as long as
the full documents in the XML syntax sense are included.  I don't think it is a
good idea to just say "at the discretion of the implementer".  How about just
saying "implementers should follow the latest recommendations of the W3C"?

Thanks,
Donald

Donald E. Eastlake, 3rd
17 Skyline Drive, Hawthorne, NY 10532 USA
[email-masked]   tel: 1-914-784-7913, fax: 1-914-784-3833

home: 65 Shindegan Hill Road, RR#1, Carmel, NY 10512 USA
[email-masked]   tel: 1-914-276-2668

David Burdett <[email-masked]> on 05/17/99 09:17:01 PM

To:   Ietf Trade WG <[email-masked]>, Don Eastlake
      <[email-masked]>
cc:    (bcc: Donald Eastlake/Hawthorne/IBM)
Subject:  RE: Using XML as well as HTML

Any comments?

David

---

From: David Burdett <[email-masked]>
Date: Fri, 21 May 1999 15:24:38 +0100

OK

David
> ----------
> From: 	[email-masked][SMTP:[email-masked]]
> Sent: 	20 May 1999 12:44
> To: 	[email-masked]
> <[email-masked]>

Phone:          +44 171 557 5000
Fax:            +44 171 557 5200