Subject: ErrorLocation Component

From: Masaaki Hiroya <[email-masked]>
Date: Mon, 26 Jul 1999 21:33:47 +0900

David,

The current spec in 7.20.3 says as follows:

<!ELEMENT ErrorLocation EMPTY >
<!ATTLIST ErrorLocation
 ElementType        NMTOKEN #REQUIRED
 IotpMsgRef          NMTOKEN #REQUIRED
 BlkRef             NMTOKEN #IMPLIED
 CompRef            NMTOKEN #IMPLIED
 ElementRef         NMTOKEN #IMPLIED
 AttName            NMTOKEN #IMPLIED >

ElementType         This is the "type" (see [XML]) of the Element in
                    the message in error where the error is located.

I could find the definition of the type of Element in XML spec.
What kind of values will be set to ElementType?

Furthermore, the DTD of ErrorLocation in Chapter 13 is different from
the one in 7.20.3.  Is IotpMsgRef #IMPLIED or #REQUIRED?

Masaaki

-----
Masaaki Hiroya
Systems Development Laboratory
Hitachi, Ltd.
email: [email-masked]
tel: +81-44-549-1531
fax: +81-44-549-1640
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: [email-masked]
Date: Wed, 28 Jul 1999 03:40:15 +0100

Masaaki

See comments below.

David

-----Original Message-----
From: Masaaki Hiroya [mailto:[email-masked]]
Sent: Monday, July 26, 1999 5:34 AM
To: [email-masked]; [email-masked]
Subject: ErrorLocation Component

David,

I could find the definition of the type of Element in XML spec.
What kind of values will be set to ElementType?
## If you had an element with a declaration of, say ...

<!ELEMENT Org ...

then its element type would be "Org", so really its just the name of the
element.

I've clarified the defintion as follows ...

This is the name of the type of the element where the error is located. For
example if the element was declared as <!ELEMENT Org ... then its name is
"Org".

##

Furthermore, the DTD of ErrorLocation in Chapter 13 is different from
the one in 7.20.3.  Is IotpMsgRef #IMPLIED or #REQUIRED?
## Its IMPLIED as if your can't find the Message Id Component then you can't
specify a value. ##
Masaaki

-----
Masaaki Hiroya

**********************************************************************************************

This Email and any attached files are confidential and may also be privileged. 
If you are not the intended recipient, please notify the postmaster using email 
address [email-masked] or call +44 171 557 5000 and ask for the 
IT Helpdesk.  You should not copy this email and any attached files, use them 
for any purpose or disclose the contents to any other person; all copies of the 
Email and associated files in your possession should be destroyed.

Mondex International Limited
47-53 Cannon Street
London EC4M 5SQ
United Kingdom
Registered No: 3122085, England

Phone:          +44 171 557 5000
Fax:            +44 171 557 5200
Email:          [email-masked]
WebSite:        http://www.mondexinternational.com

*********************************************************************************************