Subject: Numeric currency codes

From: [email-masked]
Date: Wed, 28 Jul 1999 03:40:08 +0100

Yoshiaki asks ...

> 7.7.4 Currency Amount Element
> Could you register "ISO4217-N" on IANA also because this is used in
> the SMILE Project?
> 
I'm wondering why since:
*	we debated at some length earlier this year whether to go for alpha
or numeric and concluded that alpha was to be preferred
*	having just one type of code makes it easier to develop clients
since there is no need to support (and keep up to date) both types
*	since there is a one-to-one correspondence between the alpha and the
numeric you can always map between the two

... but on the other hand if there's a good reason ... Yoshiaki, can  you
explain?

Thanks

David

Mondex International
Email: [email-masked]

**********************************************************************************************

This Email and any attached files are confidential and may also be privileged. 
If you are not the intended recipient, please notify the postmaster using email 
address [email-masked] or call +44 171 557 5000 and ask for the 
IT Helpdesk.  You should not copy this email and any attached files, use them 
for any purpose or disclose the contents to any other person; all copies of the 
Email and associated files in your possession should be destroyed.

Mondex International Limited
47-53 Cannon Street
London EC4M 5SQ
United Kingdom
Registered No: 3122085, England

Phone:          +44 171 557 5000
Fax:            +44 171 557 5200
Email:          [email-masked]
WebSite:        http://www.mondexinternational.com

*********************************************************************************************
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: Yoshiaki KAWATSURA <[email-masked]>
Date: Thu, 29 Jul 1999 22:03:58 +0900 (JST)

David,
Ok, we will only use "ISO4217-A" in the IOTP Message.
Thanks,

--
Yoshiaki Kawatsura    Hitachi, Ltd.

>>>>> Wed, 28 Jul 1999 03:40:08 +0100,

---

From: Yoshiaki KAWATSURA <[email-masked]>
Date: Fri, 30 Jul 1999 15:58:47 +0900 (JST)

Kent,
I have sent the following my comments in July 1st but it seems to me
that there is no response....

No.1:
I do not know why but it seems to me that your draft has dropped "="
in the whole your XML example
for example:
   <Digest DigestAlgorithmRef "D.1">
       <Locator href "resource locator"/>
       <Value>
            (Digest value)
       </Value>
   </Digest>  .

You should revise this for conforming to XML Specification as follows;
   <Digest DigestAlgorithmRef="D.1">
       <Locator href="resource locator"/>
       <Value>
            (Digest value)
       </Value>
   </Digest>  .

Additional,
In 4.3.8 Prameter:
   <Algorithm ID A1 type "digest" name "urn:ibm:dom-hash">
           <Parameter type 'AlgorithmRef'>A2</Parameter>
   </Algorithm>
   <Algorithm ID A2 type "digest" name "urn:fips:sha1">
   </Algorithm>
   <Algorithm ID A3 type "signature" name "urn:ibm:hmac">
           <Parameter type 'AlgorithmRef'>A1</Parameter>
   </Algorithm>

This has been dropped quotation. Please change as follows:

   <Algorithm ID="A1" type="digest" name="urn:ibm:dom-hash">
           <Parameter type='AlgorithmRef'>A2</Parameter>
   </Algorithm>
   <Algorithm ID="A2" type="digest" name="urn:fips:sha1">
   </Algorithm>
   <Algorithm ID="A3" type="signature" name="urn:ibm:hmac">
           <Parameter type='AlgorithmRef'>A1</Parameter>
   </Algorithm>

----------------------
No.2:
In 4.3.8 Parameter:

On one hand, the type attribute is defined as PCDATA in 4.3.8, on the
other hand, this attribute is defined as CDATA in Chapter7(Signature
DTD)
Which is correct?

---------------------
No.3:
In 5.1.2 SHA1:
--
5.1.2 SHA1

   Surface string digest algorithm designed by hte US government for use
                                               ^^^
   with the Digital Signature Standard. This algorithm produces a 160-
   bit hash value.
--
What does "hte" mean?

---------------------
No.4:
On one hand, the child element of Parameter is defined as ANY in
4.3.5, on the other hand, this element is defined as #PCDATA in
Chapter7(Signature DTD)

Which is correct?

-------------------
No.5:
Why did you swap between Certificate Component and Signature Component?

S.T.

Old Draft: <!ELEMENT IOTPSignatures (Signature+, Certificate*) >
->
Current Draft: <!ELEMENT IOTPSignatures (Certificate*, Signature+) > 

------------------

Yoshiaki Kawatsura : E-mail [email-masked]
 Business & Information Systems Development Division, Hitachi,Ltd.
Voice: +81-44-549-1713(direct) Fax: +81-44-549-1721
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]