Subject: RE: Bug in IOTP's DTD

From: David Burdett <[email-masked]>
Date: Thu, 14 Oct 1999 17:54:53 -0700

Masaaki

I accept that there is a mistake in the IOTP DTD, however this part of the
IOTP DTD was copied **directly** from the the IOTP dsig spec at

http://www.ietf.org/internet-drafts/draft-ietf-trade-iotp-v1.0-dsig-03.txt

which contains the same error. The only changes made when copying were the
removal of some blank lines and page headers and footers.

The reason for copying in the IOTP dsig DTD is to avoid having to use
namespaces in IOTP.

So really what I think we should do is:
1. Fix the DTD in the IOTP dsig spec (Yoshiaki ?) and then
2. Fix the DTD in the IOTP spec.

Regards

David

-----Original Message-----
From: Masaaki Hiroya [mailto:[email-masked]]
Sent: Thursday, October 14, 1999 3:33 AM
To: David Burdett
Cc: [email-masked]
Subject: Bug in IOTP's DTD

David

There is a bug in ietf.org/draft-ietf-trade-iotp-v1.0-protocol-06.

>  <!ELEMENT Value ( #PCDATA ) >
>  <!ATTLIST Value
>          ID               ID           #IMPLIED
>          encoding    (base64|none)    #IMPLIED      'base64'

I think #IMPLIED in the "encoding" attribute should be removed.

Draft-ietf-trade-iotp-v1.0-dsig-03.txt defines the Value element as follows:

>    <!ELEMENT Value ( #PCDATA ) >
>    <!ATTLIST Value
>            ID                 ID            #IMPLIED
>            encoding      (base64|none)     'base64'

Please correct the DTD in iotp-v1.0-protocol-06.

Masaaki

-----
Masaaki Hiroya
Systems Development Laboratory
Hitachi, Ltd.
tel: +81-44-549-1531
fax: +81-44-549-1640
email: [email-masked]

---

From: Yoshiaki KAWATSURA <[email-masked]>
Date: Fri, 15 Oct 1999 13:08:02 +0900 (JST)

David and Masaaki,
I am very sorry.
I will change ASAP.
Thanks,

>>>>> Thu, 14 Oct 1999 17:54:53 -0700,

> email: [email-masked]

-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]