Subject: RE: Bug in IOTP's DTD

From: "Smith, Chris " <[email-masked]>
Date: Fri, 15 Oct 1999 10:32:05 -0400

Interesting. The following is a rather subtle point, easily missed
when viewing the DTD (and NOT actually an error), but...

IOTP PackagedContent has

 <!ELEMENT PackagedContent (#PCDATA) >
 <!ATTLIST PackagedContent
  Name        CDATA            #IMPLIED
  Content     NMTOKEN          "PCDATA"
  Transform   (NONE|BASE64)    "NONE" >

while IOTP,DSIG has (corrected with removing the #IMPLIED)

 <!ELEMENT Value (#PCDATA) >
 <!ATTLIST Value
  ID          ID               #IMPLIED
  encoding    (base64|none)    'base64' >

Is there a specific reason that the attributes 
"encoding" and "Transform" don't agree on parameter
content and the default value of the parameter,
even though they are almost exactly the same
thing? Also, I can live with 'encoding' but this
is risking confusion with 'encoding' as it refers
to character sets like ISO-8859-1 (and as used on
the <?xml ...> XML declaration).

I realize that IOTP and DSIG are being worked on
independently, but could we have them be a little
less independent?

------------------------------------------------------------
 Chris Smith                                +1.416.348.6090
 Royal Bank                       [email-masked]

> -----Original Message-----
> From: David Burdett [mailto:[email-masked]]
> Sent: October 14, 1999 08:55 PM
> To: [email-masked]'
> Cc: IETF Trade (E-mail); [email-masked]';
> [email-masked]'
> Subject: RE: Bug in IOTP's DTD
> 
> 
> Masaaki
> 
> I accept that there is a mistake in the IOTP DTD, however 
> this part of the IOTP DTD was copied **directly** from the 
> the IOTP dsig spec at
> 
> 	
> http://www.ietf.org/internet-drafts/draft-ietf-trade-iotp-v1.0
> -dsig-03.txt
> 
> which contains the same error. The only changes made when 
> copying were the removal of some blank lines and page headers 
> and footers.
> 
> The reason for copying in the IOTP dsig DTD is to avoid 
> having to use namespaces in IOTP.
> 
> So really what I think we should do is:
> 1. Fix the DTD in the IOTP dsig spec (Yoshiaki ?) and then
> 2. Fix the DTD in the IOTP spec.
> 
> Regards
> 
> David
> 
> -----Original Message-----
> From: Masaaki Hiroya [mailto:[email-masked]]
> Sent: Thursday, October 14, 1999 3:33 AM
> To: David Burdett
> Cc: [email-masked]
> Subject: Bug in IOTP's DTD
> 
> 
> 
> David
> 
> There is a bug in ietf.org/draft-ietf-trade-iotp-v1.0-protocol-06.
> 
> >  <!ELEMENT Value ( #PCDATA ) >
> >  <!ATTLIST Value
> >          ID               ID           #IMPLIED
> >          encoding    (base64|none)    #IMPLIED      'base64'
> 
> 
> I think #IMPLIED in the "encoding" attribute should be removed.
> 
> Draft-ietf-trade-iotp-v1.0-dsig-03.txt defines the Value 
> element as follows:
> 
> >    <!ELEMENT Value ( #PCDATA ) >
> >    <!ATTLIST Value
> >            ID                 ID            #IMPLIED
> >            encoding      (base64|none)     'base64'
> 
> Please correct the DTD in iotp-v1.0-protocol-06.
> 
> Masaaki
> 
> -----
> Masaaki Hiroya
> Systems Development Laboratory
> Hitachi, Ltd.
> tel: +81-44-549-1531
> fax: +81-44-549-1640
> email: [email-masked]
>

---

From: David Burdett <[email-masked]>
Date: Fri, 15 Oct 1999 08:22:14 -0700

Chris

The reasons are historical to do with the way the digital signatues for IOPT
were developed.

Firstly the IOTP specification with its own digital signature specification
as part of the spec. Later, it was realised that the digital signature part
should be removed and made a separate standard. At the same time as this was
going on the idea of a "Packaged Content" element was being developed in the
main IOTP specification with a default of "NONE"

Then around a year ago it was agreed to base the IOTP digital signature
specification on the work being done by Richard Brown of Globeset as part of
the W3C/IETF digital signature work.

As IOTP couldn't wait for the IETF/W3C group to finish it work we took an
early version of Richard Brown's specification, and built the IOTP dsig from
that. However, this specification had defined "value" differently from the
way it was done in IOTP with a default of "base64".

Hence the difference.

David

-----Original Message-----
From: Smith, Chris [mailto:[email-masked]]
Sent: Friday, October 15, 1999 7:32 AM
To: David Burdett; [email-masked]'
Cc: IETF Trade (E-mail); [email-masked]';
[email-masked]'

IOTP PackagedContent has

> email: [email-masked]
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]