Subject: Re: Draft new TRADE WG Charter

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Wed, 08 Dec 1999 00:28:40 -0500

From:  David Burdett <[email-masked]>
Message-ID:  <123B7EB05559D311B0D900A0C9EA3D7604F574@NEPTUNE>
To:  "[email-masked]'" <[email-masked]>, [email-masked]
Date:  Wed, 24 Nov 1999 17:23:55 -0800

>Folks
>
>Apologies for the delay in responding to this but I've at last had the time
>to get to it. Anyway comments are included below marked with a ##.
>
>David
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Tuesday, November 16, 1999 11:43 AM
>To: [email-masked]
>Subject: Draft new TRADE WG Charter
>
>
>Our current charter is way out of date.  Appended below for discussion is
>the new TRADE WG Charter which reflects the consensus of those in
>attendance at the Wasington, DC, IETF Meeting...
>
>Thanks,
>Donald
>
>Donald E. Eastlake, 3rd
>17 Skyline Drive, Hawthorne, NY 10532 USA
>[email-masked]   tel: 1-914-784-7913, fax: 1-914-784-3833
>
>home: 65 Shindegan Hill Road, RR#1, Carmel, NY 10512 USA
>[email-masked]   tel: 1-914-276-2668
>
>
>
>Chair(s):
>Donald Eastlake 3rd <[email-masked]>
>
>Applications Area Advisor:
>Patrik Faltstrom <[email-masked]>
>
>Editor(s):
>David Burdett <[email-masked]>
>
>Mailing Lists:
>General Discussion:[email-masked]
>To Subscribe: [email-masked]
>In Body: (un)subscribe
>Archive: http://www.eListX.com/archives/ietf-trade
>
>The TRADE Working Group will further develop the Internet Open Trading
>Protocol (IOTP) and the Electronic Commerce Modeling Language (EMCL)
>specifications and investigate digital rights trading equirements.
>
>##There will be four main threads to the activity:
>1. IOTP version 2.0
>2. XML Messaging
>3. ECML, and
>4. Digital Rights Trading Requirements.

I'll try incorporating some of this, but IETF WG charters are usually
short and sweet without much internal subheadings in the main body...

>Each of these is discussed in more detail below.
>
>IOTP Version 2.0
>================
>##
>IOTP is an interoperable framework for Internet commerce. It is
>optimized for the case where the buyer and the merchant do not have
>a prior acquaintance and is payment system independent. It can
>encapsulates and supports payment systems such as SET, Mondex,
>secure channel card payment, GeldKarte, etc. IOTP is able to
>handle cases where such merchant roles as the shopping site,
>the payment handler, the deliverer of goods or services, and
>the provider of customer support are performed by different
>Internet sites.
>
>The  working group will document interoperability experience with
>IOTP version 1 and develop the requirements for IOTP transport and
>IOTP version 2.
>
>Selection of items for inclusion in version requirements 2 is to
>be from the following ## to be varied based on implementation experience##:

I'm not sure how much effect "implementation" experience could have on
the desireability of some of these.  At least it does not seem reasonable
that implementation would be the sole input for deciding...

>- Separation of a content independent Messaging Layer
>- Dynamic Definition of Trading Sequences
>- Offer Request Block
>- Improved Problem Resolution (extend to cover presentation of
>signed receipt to customer support party, etc.)
>- Server to Server messages
>
>Legal or regulatory issues surrounding the implementation of the
>protocol or information systems using it are out of scope for IOTP
>v2.
>
>##XML Messaging
>=============
>XML Messaging is based on the messaging ideas contained inside IOTP version 
>1.0, and will aim to develop a specification for the the reliable, 
>resilient, secure, tamper resistant, authenticated exchange of XML or other 
>electronic documents over insecure transport mechanisms.

Once you have said "secure", I think "tamper resistant" and "authenticated"
are redundant.

>The goal of the working group is to develop first a set of requirements and 
>then the full specification that meets the above objectives.
>
>ECML
>====
>##
>ECML version 1 provides a standard set of hierarchical field names
>and content specifications plus a few procedural guidelines for
>the transmission of basic address and payment information from a
>customer to a merchant.
>
>The goal of the working group is to develop ECML version 2 which
>may include corrections to version 1 and may include additions in
>the following areas:
>- Merchant to Consumer communications fields including purchase
>amount, receipt information, package tracking information,
>- Additional Consumer to Merchant fields including Corporate
>procurement cards, Other payment systems, Travel and entertainment,
>Affinity, frequent flyer, and other customer loyalty programs,
>Business-to-business commerce
>- Improved internationalization
>- Coordination with privacy standards
>- Specifications for exchange of ECML data using XML
>
>Milestones:
>99 Dec - First Internet Draft publication of
>     Secure Channel Credit Debit Supplement
>     Architecture and Payment API Supplement
>00 Jan - First Internet Draft publication of
>     Requirements for XML Messaging Layer
>     Requirements for Digital Rights Trading
>     SET Supplement
>00 Feb - Initiate Last Call on
>     SCCD, Architecture, SET, and HTTP Supplements
>00 Feb - First Internet Draft publication of
>     ECML v2 Requirements
>(00 Mar, IETF Meeting Adelaide)
>00 Apr - To IESG for Publication
>     SCCD, Architecture, SET, and HTTP Supplements
>     ECML v2 Requirements
>00 Apr - First Internet Draft publication of
>     IOTP Version 2.0 Requirements
>     ECML v2 Specification
>     XML Messaging Specification
>00 Apr - To Last Call
>     Requirements for XML Messaging
>     Requirements for Digital Rights Trading
>00 May - First Internet Draft publication of
>     IOTP Version 2.0 Specification
>00 May - To Last Call
>     IOTP Version 2.0 Requirements
>00 Jul - To Last Call
>     ECML v2 Specification
>(00 Jul/Aug, IETF Meeting Pittsburgh)
>00 Aug - Last Call
>     XML Messaging Specification
>00 Sep - Last Call
>     IOTP Vesion 2 Specification

Thanks,
Donald
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Wed, 08 Dec 1999 00:33:26 -0500

I'll add something like that...

Donald

From:  Ko Fujimura <[email-masked]>
Date:  Thu, 25 Nov 1999 21:56:26 +0900
Message-ID:  <[email-masked]>
To:  [email-masked]
Cc:  [email-masked], [email-masked]
In-Reply-To:  In your message of "Wed, 24 Nov 1999 17:23:55 -0800"
	     	<123B7EB05559D311B0D900A0C9EA3D7604F574@NEPTUNE>
References:  <123B7EB05559D311B0D900A0C9EA3D7604F574@NEPTUNE>
User-Agent:  Wanderlust/2.1.5 (Unbelievable) SEMI/1.13.4 (Terai) Chao/1.13.0 (JR Fuji
nomori) MULE XEmacs/21.2 (beta1) (Aeolus) (sparc-sun-solaris2.6)

>Hi Don and David,
>
>My comment is to add the following paragraph at the end of the
>draft: 
>
>Digital Rights Requirements
>===========================
>In the purchase or other trading transactions, it is often required to
>credit loyalty points, collect digital coupons, check membership of a
>certain group, and so on. The working group invenstigates how these
>activities can be generalized using the concept of "digital-right",
>which is a digital representation of right to claim goods or services,
>and describles the requirements on the following areas: 
>  - The digital rights trading model
>  - The language to describe diverse type of digital rights
>
>Thanks,
>
>Ko