Subject: future OTP transactions

From: David Bourget <[email-masked]>
Date: Tue, 06 Jan 1998 09:15:22 -0500

Hi,

First question:
I'd like to know if there is plans for future OTP transactions
supporting negociation of promotional offers and prices. Example : I've
got a gift certificate, which is only a reference number, and I'd like
to know its real value. This kind of interaction would allow current
web-based promotional offers to be used in an OTP context.

Second question:
Where can I find information about the current work related to SCCD ? I
can't find anything on the web or the working group site.

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Thu, 09 Mar 2000 23:06:06 -0500

Truly different structured transactions will probably wait until IOTP
v2.

Digital Right such as promotional offers are also being a topic which
has been discussed at TRADE WG meetings.  See
<ftp://ftp.ietf.org//internet-drafts/draft-ietf-trade-drt-requirements-00.txt>.

I post an additonal response on SCCD shortly.

Donald

From:  David Bourget <[email-masked]>
Resent-From:  [email-masked]
Resent-date:  Thu, 09 Mar 2000 08:15:40 -0500 (EST)
Date:  Tue, 06 Jan 1998 09:15:22 -0500
Sender:  [email-masked]
To:  [email-masked]
Reply-to:  [email-masked]
Resent-message-id:  <[email-masked]>
Message-id:  <[email-masked]>

---

From: David Bourget <[email-masked]>
Date: Wed, 07 Jan 1998 17:13:50 -0500

Hi,

Thank you for the information Donald.

I'm presently studying the specification and two other questions arises that you or
other people on this mailing list might be able to answer :

- First, trivial question: is there a version of the 1.0 draft in word, html or any
kind of browsable format that would make the experience more enjoyable than
scrolling in a 200 pages ASCII file ? I can't find any. That is, can I have the
source ? (I have found the version on otp.org to be not enaught current)

- Second, the real one: What are the expectations of the WG about merchants
adoption of the protocol ? I'm talking about e-retailing sites like Amazon, Cdnow
etc. Do you consider "baseline" OTP to fullfil most of their requirements, i.e will
they have to wait until v2 ?

- Finaly, a third question : I'm trying to fit the baseline purchase transaction on
current .com merchants purchase transaction model and the following questions arise
:
    - Can a baseline purchase transaction happen as follow  :
    [ client
]
[ merchant ]
    shop
    select shipping     --- I wanna
buy-->                                              start transaction here
                               <-----order,brandslist
etc----                                prepare order
    select payment    -------(
                                very simple
payment                                         process payment, generate delivery
note
                                protocol, that is : here's my card number
                                )----->
    happy customer     <---------delivery note--------

In fact, I'm trying to figure out what is the simplest form of a purchase
transaction supported by an OTP agent.
It seems to me that being able to do such simples transactions is a priority for
online merchants who wants to save bandwidth and streamline the buying process.

regards,
David