Subject: IOTP and Coupons (was RE: future OTP transactions)

From: "Smith, Chris " <[email-masked]>
Date: Fri, 10 Mar 2000 14:35:34 -0500

Because the blocks in a PaymentRequest (the included
payment system data) have names, it would be possible
to add additional out-ot-payment-protocol blocks that
contained the needed information.

This would be fine for IOTP, but some payment systems
might consider these additional blocks to be non-standard.

In a more general case, you could take advantage of a
couple of other features:

1) IOTP allows Authentication transactions prior to
   any other transaction. Also, the final version
   provided a way to send several Authentication
   types in the same request.

   A coupon is a form of authorization/authentication,
   so a special Authentication Supplement could be
   created to handle them.

   Thus a single Auth up front could be the equivalent
   of the merchant asking "Do you have AirMiles", "Do
   you have coupons", "Are you a club member" - all in
   one step.

   Since the AUth precedes the OfferResponse generation,
   any information returned on the Auth can be used to
   make changes in pricing.

2) IOTP does allow for brand-dependent offers as well,
   where the payment brand selection precedes the final
   generation of the OfferResponse.

------------------------------------------------------------ 
 Chris Smith                                +1.416.348.6090 
 Royal Bank                       [email-masked] 

P.S. Unless you have some psychic ability that allowed you
to phrase such coherent questions over two years ago, you
need to reset the clock on your system -- see the Sent:
line below.

> -----Original Message-----
> From: David Bourget [mailto:[email-masked]]
> Sent: January 6, 1998 09:15 AM
> To: [email-masked]
> Subject: future OTP transactions
> 
> 
> Hi,
> 
> First question:
> I'd like to know if there is plans for future OTP transactions
> supporting negociation of promotional offers and prices. 
> Example : I've
> got a gift certificate, which is only a reference number, and I'd like
> to know its real value. This kind of interaction would allow current
> web-based promotional offers to be used in an OTP context.
> 
> Second question:
> Where can I find information about the current work related 
> to SCCD ? I
> can't find anything on the web or the working group site.
> 
> 
> 
> 
> 
> 
>

---

From: Ko Fujimura <[email-masked]>
Date: Mon, 13 Mar 2000 15:45:27 +0900

Hi,

At Fri, 10 Mar 2000 14:35:34 -0500,
Smith, Chris  <[email-masked]> wrote:
> 
> [1  <text/plain; iso-8859-1 (7bit)>]

Yes, the current IOTP spec allows several ways to process coupons,
gift certificates, or loyality points. 

Redemption of a coupon, for example, can be implemented as the Offer,
Payment, and/or Authentication Exchanges depending on the Merchant
decision as Chris pointed out. Issuance of a coupon can also be
implemented as the Delivery Exchanges. 

I would like to mention my understanding of the relationship between
the Digital-Right Trading (DRT) and IOTP model. In short, I think
that DRT is a component which can be commonly used within the IOTP
Exchanges. In other words, I think that the DRT is layered under the
IOTP Exchanges.  

> > web-based promotional offers to be used in an OTP context.

Since one of the goals of the Digital-Right Trading is to provide a
common language to exchange such a promotional offer information
needed in the IOTP exchanges, such kind of gift certificates should/can
be covered in the DRT model and language. Using the language, it might
be roughly defined as below, although the protocols might be left
vendor-specific.  

<DigitalRight>
  <Issuer ...>
  <Promise ReferenceNumber=00001>
  <Holder AuthenticateInfo=...>
</DigitalRight>

Thanks,

Ko
----------------------------------------------------------
Ko Fujimura, NTT Information Sharing Platform Laboratories
1-1 Hikarinooka, Yokosuka-shi, Kanagawa 239-0847, JAPAN
Tel: +81-(0)468-59-3814, Fax: +81-(0)468-59-8329
Email: [email-masked]