Subject: RE: New Brand/Brand ID: Credits

From: "Burdett, David" <[email-masked]>
Date: Wed, 24 Oct 2001 13:59:33 -0700

Ronald
 
I think that "Credits" is too general a term (what do other people think?).
It's a bit like trying to make the plural of "Cash" a BrandId except that it
does not have one. I think that "Credits" should have some prefix or suffix.
What do you think would work?
 
David

-----Original Message-----
From: Ronald Duncan [mailto:[email-masked]]
Sent: Wednesday, October 24, 2001 11:47 AM
To: [email-masked]
Subject: RE: New Brand/Brand ID: Credits

Personally, I dislike substituting 'at' for the @ and prefer to just drop
the @. 
 
This has evolved into a standard procedure since we currently have
approximately 350 @ branded companies.  In all cases we drop the @ and just
use the name for the domain name, phone directory and other systems and the
@ comes back in for email addresses.
 
We would prefer to use just 'credits' and should another company wish to use
a brand based on 'credits' they could add a suffix or prefix to distinguish
the entries.
 
Regards -- Ronald

-----Original Message-----
From: Burdett, David [mailto:[email-masked]]
Sent: 24 October 2001 18:02
To: 'Ronald Duncan'; [email-masked]
Subject: RE: New Brand/Brand ID: Credits

Ronald 

How about a Brand Id of "AtCredits" as it sounds like your real brand name
"@Credits" yet should avoid all the problems of using the "@" (e.g. in
certificates) and would avoid the confusion of using "Credits" which is too
general a name in my view.

Regards 

David Burdett 

-----Original Message----- 
From: Ronald Duncan [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Wednesday, October 24, 2001 12:42 AM 
To: [email-masked] 
Subject: RE: New Brand/Brand ID: Credits 

Thanks for the comments. 

The reason for applying for a BrandId of credits vs @credits (which is the 
brand we use and is our trademark) is the number of systems that have 
problems with the @ symbol as you discovered with the search engines. 

E.G. Our secure certificate is in the name of 'at UK PLC' because a bug in 
the verisign software that causes it to crash if there is an @ or other 
unusual characters in the name. 

Hence our general policy of dropping the @ where it is going to be used in 
systems and might cause interoperability problems in the future. 

You are right that the use of descriptive names is a two edged sword.  E.g. 
@UK PLC has significant problems with search engines since both UK and PLC 
are common and the combination is non unique.  This is combined with the 
problems associated with the @ symbol which is generally dropped. 

-- 
Regards  --  [email-masked] http://www.ukplc.net
<http://www.ukplc.net>  
+44 (0) Tel 0118 963 7000     Mobile 07973 754 817     Fax 0118 963 7350 
@UK PLC, 5 Jupiter House, Calleva Park, Reading, RG7 8NN, England 

-----Original Message----- 
From: Chris Smith [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: 24 October 2001 07:34 
To: [email-masked]; Ronald Duncan 
Subject: Re: New Brand/Brand ID: Credits 

Given that the company holding the brand 
is @Credits PLC, wouldn't it make more 
sense to apply for the BrandId of "@Credits" ? 

Keep in mind that - as far as I know - the 
assignment of a BrandId under IOTP confers 
no standing of any kind. It's just a keyword 
used for matching, not a trademark registration. 
Users won't ever see it - they will see the 
BrandName. 

Not only that, it's going to make you hard 
to find. Standard search engines don't seem 
to locate you when I search on @UK PLC, 
and searching on @Credits acts like the @ 
isn't even there. 

It might seem like a cool idea to have 
common words as brands, but it doesn't 
always work well. My experience is just 
the opposite - look at my last name. 
It does not make me easier to find - it 
makes me much harder to find, even for 
people who know where to look. 

...Chris Smith 

On Oct 23, 2001 at 10:40pm, Ronald Duncan wrote: 

> We would like to apply for the brand ID 'Credits' for our Internet 
Currency 
> 'Credits' 
> 
> The ultimate holding company is @UK PLC http://www.uk-plc.net
<http://www.uk-plc.net> .  The 
> subsidiary holding the brand is @Credits PLC. 
> 
> Thank you. 
> 
> -- 
> Regards  --  [email-masked] http://www.ukplc.net
<http://www.ukplc.net>  
> +44 (0) Tel 0118 963 7000     Mobile 07973 754 817     Fax 0118 963 7350 
> @UK PLC, 5 Jupiter House, Calleva Park, Reading, RG7 8NN, England 

---------------------------------------------------------------------- 
Chris Smith                                       <[email-masked]>

---

From: Ofer Avineri <[email-masked]>
Date: Wed, 24 Oct 2001 23:30:26 +0200

Ronald,

I think “Credits” would be too generic brand to use. I would support David’s
offer to add a distinguished prefix or suffix.

Ofer

-----Original Message-----
From: Burdett, David [mailto:[email-masked]]
Sent: Wednesday, October 24, 2001 23:00
To: 'Ronald Duncan'; [email-masked]
Subject: RE: New Brand/Brand ID: Credits

Ronald

David
-----Original Message-----
From: Ronald Duncan [mailto:[email-masked]]
Sent: Wednesday, October 24, 2001 11:47 AM
To: [email-masked]
Subject: RE: New Brand/Brand ID: Credits

Regards -- Ronald
-----Original Message-----
From: Burdett, David [mailto:[email-masked]]
Sent: 24 October 2001 18:02
To: 'Ronald Duncan'; [email-masked]
Subject: RE: New Brand/Brand ID: Credits
Ronald
-----Original Message-----
From: Ronald Duncan [ mailto:[email-masked]]
Sent: Wednesday, October 24, 2001 12:42 AM
To: [email-masked]
Subject: RE: New Brand/Brand ID: Credits

Thanks for the comments.

-----Original Message-----
From: Chris Smith [ mailto:[email-masked]]
Sent: 24 October 2001 07:34
To: [email-masked]; Ronald Duncan
Subject: Re: New Brand/Brand ID: Credits

Currency
> 'Credits'
>
> The ultimate holding company is @UK PLC http://www.uk-plc.net.  The