Subject: [tram] Question about scope of TRAM

From: Harald Alvestrand <[email-masked]>
Date: Wed, 23 Apr 2014 14:33:47 +0200

On the RTCWEB list, the following claim was made:

> Here, in TRAM we want to go beyond Level 4 QoS (already available and
> working as good as it can on the Internet), to give quality demanding WebRTC
> real-time traffic better QoE by:
> a. Forcing real-time traffic into IP-pipes having Level 2 QoS (using
> auto-discovered TURN servers)
> or
> b. Forcing real-time traffic into IP-pipes having Level 3 QoS (using
> auto-discovered TURN servers). Here we must have traffic shaping mechanisms
> working, and with correct and sufficient information to do the job. This is
> why we in TRAM discuss DISCUSS/MALICE,
> draft-thomson-tram-turn-bandwidth-00.txt attributes and recreating the
> payload type (PT) idea/intent in RTP packets (by now conveying bandwidth and
> traffic type in the RTP extension header
> http://www.ietf.org/mail-archive/web/rtcweb/current/msg09129.html.
>

Before reacting to that, I want to check:

Is it the opinion of the TRAM chairs that this is a fair description of 
a subject that is being actively discussed in the TRAM WG?

         Harald

---

From: Simon Perreault <[email-masked]>
Date: Wed, 23 Apr 2014 09:09:39 -0400

> a subject that is being actively discussed in the TRAM WG?

QoS is out of TRAM's scope.

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: "Karl Stahl" <[email-masked]>
Date: Wed, 23 Apr 2014 21:09:26 +0200

Please disregard my TRAM-references. I missed to delete them when copying
this technical text from early March into the rtcweb discussion now. Sorry.
/Karl 

-----Ursprungligt meddelande-----
Från: tram [mailto:[email-masked]] För Simon Perreault
Skickat: den 23 april 2014 15:10
Till: [email-masked]
Ämne: Re: [tram] Question about scope of TRAM

Le 2014-04-23 08:33, Harald Alvestrand a écrit :
>> working as good as it can on the Internet), to give quality demanding 
>> WebRTC real-time traffic better QoE by:
>> auto-discovered TURN servers) or b. Forcing real-time traffic into 
>> IP-pipes having Level 3 QoS (using auto-discovered TURN servers). 
>> Here we must have traffic shaping mechanisms working, and with 
>> correct and sufficient information to do the job.
>> This is
>> draft-thomson-tram-turn-bandwidth-00.txt attributes and recreating 
>> the payload type (PT) idea/intent in RTP packets (by now conveying 
>> bandwidth and traffic type in the RTP extension header 
> Is it the opinion of the TRAM chairs that this is a fair description 
> of a subject that is being actively discussed in the TRAM WG?

Simon

_______________________________________________
tram mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tram