Subject: Re: [tram] Two new authentication mechanisms

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 30 Jun 2014 17:53:05 +0000

I support adoption of both drafts. I think there is no interaction required between these two drafts. For example If third party authorization is used then ORIGIN attribute could be used by the TURN server for logging purpose.

-Tiru

> -----Original Message-----
> From: tram [mailto:[email-masked]] On Behalf Of Simon Perreault
> Sent: Friday, June 27, 2014 6:51 PM
> To: [email-masked]
> Subject: [tram] Two new authentication mechanisms
> 
> TRAMsters,
> 
> We are soliciting discussion on the potential adoption as working-group
> documents of these two drafts:
> 
> http://tools.ietf.org/html/draft-johnston-tram-stun-origin
> http://tools.ietf.org/html/draft-reddy-tram-turn-third-party-authz
> 
> They would be targeted at fulfilling milestone 4 ("Nov 2014 - Send new
> authentication mechanism(s) to IESG for publication as Proposed Standard").
> 
> If you would like to see one or both of the drafts adopted, or if you are opposed,
> please explain why. Authors, we will assume you are for adoption of your own
> drafts.
> 
> Please consider the interactions between the two drafts. Is there anything
> interesting or problematic? What about overlap in function? Is there any? If so,
> is it necessary or problematic?
> 
> Let's take two weeks to discuss this.
> 
> Thanks,
> Simon & Gonzalo
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram

---

From: Alan Johnston <[email-masked]>
Date: Mon, 30 Jun 2014 13:46:29 -0500

Agree with Tiru on both points.

- Alan -

On Mon, Jun 30, 2014 at 12:53 PM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

> I support adoption of both drafts. I think there is no interaction
> required between these two drafts. For example If third party authorization
> is used then ORIGIN attribute could be used by the TURN server for logging
> purpose.
>
> -Tiru
>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Mon, 30 Jun 2014 18:58:02 +0000

+1

Support adoption of both docs and they should be left as separate.

Cheers,

Gonzalo

On Jun 30, 2014, at 2:46 PM, Alan Johnston <[email-masked]> wrote:

> On Mon, Jun 30, 2014 at 12:53 PM, Tirumaleswar Reddy (tireddy) <[email-masked]> wrote:

---

From: Oleg Moskalenko <[email-masked]>
Date: Mon, 30 Jun 2014 12:43:00 -0700

I agree that two drafts can be kept independently.

As for the ORIGIN attribute in the third-party authorization environment -
don't we still need realm in the third-party authorization ? Am I missing
something ? I was under impression that we still have realms, together with
the tokens.

Thanks
Oleg