Subject: [tram] Chrome STUN Origin proof-of-concept...

From: "Yoakum, John H (John)" <[email-masked]>
Date: Thu, 26 Jun 2014 01:11:05 +0000

We now have a proof-of-concept version of the Chrome browser (nicknamed 'Chromeo') that sends Origin insight in STUN and TURN messages (hopefully in full compliance with the proposed standards draft).  It uses a new STUN attribute with a value of 0x802F as initially proposed.  It has been implemented with a Chrome flag to enable and disable this unique feature (and is by default disabled to prevent any non-intentional use of this feature until the standard is finalized).

We have built 'Chromeo' for Linux and have verified with WireShark that proper STUN Origin attributes are being included in STUN/TURN messages sent by the browser to servers (screen captures of STUN messages illustrating the Origin attribute and content are available however I was not sure if it is considered appropriate to attach any images to a post of this nature).

Coordinated changes to both the WebRTC and Chromium open source projects have been submitted for consideration.  The two submitted change lists together implement a proof-of-concept of the browser portion of the STUN Origin draft: http://tools.ietf.org/html/draft-johnston-tram-stun-origin-02 and Oleg has previously posted that he has provided a proof-of-concept for the TURN sever end of the solution.

Hopefully these two proof-of-concept efforts will help us quickly drive the STUN Origin standard effort to fruition and help browsers quickly implement STUN Origin enhancements.

Cheers,
John

AVAYA
1.919.425.8446

---

From: Simon Perreault <[email-masked]>
Date: Thu, 26 Jun 2014 09:06:08 -0400

This is great!

You need to add an Implementation Status section to your draft!
http://tools.ietf.org/html/rfc6982

Simon

Le 2014-06-25 21:11, Yoakum, John H (John) a écrit :
> We now have a proof-of-concept version of the Chrome browser (nicknamed
> ‘Chromeo’) that sends Origin insight in STUN and TURN messages
> (hopefully in full compliance with the proposed standards draft).  It
> uses a new STUN attribute with a value of 0x802F as initially proposed. 
> It has been implemented with a Chrome flag to enable and disable this
> unique feature (and is by default disabled to prevent any
> non-intentional use of this feature until the standard is finalized). 
> 
>  
> 
> We have built ‘Chromeo’ for Linux and have verified with WireShark that
> proper STUN Origin attributes are being included in STUN/TURN messages
> sent by the browser to servers (screen captures of STUN messages
> illustrating the Origin attribute and content are available however I
> was not sure if it is considered appropriate to attach any images to a
> post of this nature).
> 
>  
> 
> Coordinated changes to both the WebRTC and Chromium open source projects
> have been submitted for consideration.  The two submitted change lists
> together implement a proof-of-concept of the browser portion of the STUN
> Origin draft:
> http://tools.ietf.org/html/draft-johnston-tram-stun-origin-02 and Oleg
> has previously posted that he has provided a proof-of-concept for the
> TURN sever end of the solution.
> 
>  
> 
> Hopefully these two proof-of-concept efforts will help us quickly drive
> the STUN Origin standard effort to fruition and help browsers quickly
> implement STUN Origin enhancements.
> 
>  
> 
>  
> 
> Cheers,
> 
> /John/
> 
>  
> 
> AVAYA
> 1.919.425.8446
> 
>  
> 
> 
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram
>

---

From: Alan Johnston <[email-masked]>
Date: Thu, 26 Jun 2014 08:58:02 -0500

Will do.  We are working on a revision now.

- Alan -