Subject: [tram] Suggestion for STUNbis: informative reference on CRC32 sample code

From: Jonathan Lennox <[email-masked]>
Date: Tue, 20 Dec 2016 18:32:57 +0000

Hi, all — 

I had a suggestion for RFC 5389bis.  I think it would be helpful if, in the definition of FINGERPRINT, we added an informative reference to Appendix 8 of RFC 1952, which contains sample code for implementing the V.42 CRC-32.

For people not familiar with CRC generator polynomials, the definition we currently have in the code is pretty opaque. (I know I was baffled by it.)

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Tue, 20 Dec 2016 18:35:15 +0000

Thanks, Jonathan.  We can certainly add that.

Cheers,

Gonzalo

> On Dec 20, 2016, at 1:32 PM, Jonathan Lennox <[email-masked]> wrote:
> 
> Hi, all — 
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram