Subject: [tram] Review of draft-ietf-tram-stun-pmtud-03

From: Simon Perreault <[email-masked]>
Date: Tue, 13 Dec 2016 16:08:53 -0500

Just one question about this part:

> 4.2.3.  Receiving a Probe Indication and Report Request
> 
>    A server supporting this specification will keep the identifiers of
>    all packets received in a chronologically ordered list.  The same
>    identifier can appear multiple times in the list because of
>    retransmissions.  The maximum size of this list is calculated such
>    that when the list is added to the Report Response, the total size of
>    the packet does not exceed the unknown Path MTU, as defined in
>    [RFC5389] Section 7.1.  Older identifiers are removed when new
>    identifiers are added to a list that is already full.

Is there only one global list, or one per client? If one per client, how
does the server associate packets to clients?

-- 
Simon Perreault
Director of Engineering, Platform | Jive Communications, Inc.
https://jive.com | +1 418 478 0989 ext. 1241 | [email-masked]

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 14 Dec 2016 03:42:25 -0800

Hi Simon,

Thanks for the review.

> does the server associate packets to clients?

One per client.  The way the STUN transaction/indications will be associated with the protocol packets will have to be defined for each protocol, and we will add some text explaining that.  That said there is maybe a need to carry an additional opaque identifier in the Probe Indication/Report Request to make that association easier, e.g. when a combination of IP address, port and transport is not enough to differentiate two different clients for a specific protocol destination.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug