Subject: Re: [tram] I-D Action: draft-ietf-tram-turnbis-18.txt

From: Brandon Williams <[email-masked]>
Date: Fri, 1 Jun 2018 10:01:24 -0400

I re-reviewed. Since you incorporate all of my suggested changes, it 
looks like no additional follow-up is required from me.

My hope has been to see comments from a few others on-list indicating 
that the new content has received adequate WG review. I haven't seen any 
such feedback yet.

Chairs, I wonder whether a renewed last call might be appropriate, just 
to re-enforce for people that this is their last opportunity to comment 
on the draft before it progresses forward to the IESG.

--Brandon

On 05/29/2018 06:52 AM, Konda, Tirumaleswar Reddy wrote:
> This revision incorporates editorial changes proposed by Brandon to allow the TURN server to forward inbound STUN connectivity checks without explicit permissions.
> More comments and suggestions are welcome.
> 
> Cheers,
> -Tiru
> 
>> -----Original Message-----
>> From: tram [mailto:[email-masked]] On Behalf Of internet-
>> [email-masked]
>> Sent: Tuesday, May 29, 2018 4:18 PM
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: [tram] I-D Action: draft-ietf-tram-turnbis-18.txt
>>
>>
>>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the TURN Revised and Modernized WG of the IETF.
>>
>>          Title           : Traversal Using Relays around NAT (TURN): Relay Extensions
>> to Session Traversal Utilities for NAT (STUN)
>>          Authors         : Tirumaleswar Reddy
>>                            Alan Johnston
>>                            Philip Matthews
>>                            Jonathan Rosenberg
>> 	Filename        : draft-ietf-tram-turnbis-18.txt
>> 	Pages           : 84
>> 	Date            : 2018-05-29
>>
>> Abstract:
>>     If a host is located behind a NAT, then in certain situations it can
>>     be impossible for that host to communicate directly with other hosts
>>     (peers).  In these situations, it is necessary for the host to use
>>     the services of an intermediate node that acts as a communication
>>     relay.  This specification defines a protocol, called TURN (Traversal
>>     Using Relays around NAT), that allows the host to control the
>>     operation of the relay and to exchange packets with its peers using
>>     the relay.  TURN differs from some other relay control protocols in
>>     that it allows a client to communicate with multiple peers using a
>>     single relay address.
>>
>>     The TURN protocol was designed to be used as part of the ICE
>>     (Interactive Connectivity Establishment) approach to NAT traversal,
>>     though it also can be used without ICE.
>>
>>     This document obsoletes RFC 5766 and RFC 6156.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-tram-turnbis/
>>
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-tram-turnbis-18
>> https://datatracker.ietf.org/doc/html/draft-ietf-tram-turnbis-18
>>
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turnbis-18
>>
>>
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> tram mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tram
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram
> 

-- 
Brandon Williams; Chief Architect
Cloud Networking; Akamai Technologies Inc.

---

From: Nils Ohlmeier <[email-masked]>
Date: Fri, 1 Jun 2018 11:47:12 -0700

I reviewed the diff between version 17 and 18 and the changes to allow a TURN server to forward inbound STUN messages if configured so look good to me.

Best
  Nils Ohlmeier

> On May 29, 2018, at 03:52, Konda, Tirumaleswar Reddy <[email-masked]> wrote:
>

---

From: Justin Uberti <[email-masked]>
Date: Fri, 1 Jun 2018 16:56:50 -0700

I reviewed the diff as well and have the following comments:
- In the initial discussion of allowing STUN packets, it mentions that STUN
checks can occur while the client is preparing permission requests. I think
this could be worded more clearly, e.g.
"... addressing the race condition that exists when the remote peer sends
connectivity checks before the local client has had a chance to create
permissions in the TURN server for the remote peer IP addresses."

- Nit: In Section 19, 'atrributes' typo

On Fri, Jun 1, 2018 at 11:47 AM Nils Ohlmeier <[email-masked]> wrote:

> I reviewed the diff between version 17 and 18 and the changes to allow a
> TURN server to forward inbound STUN messages if configured so look good to
> me.
>
> Best
>   Nils Ohlmeier
>
> > On May 29, 2018, at 03:52, Konda, Tirumaleswar Reddy
> <[email-masked]> wrote:
> >
> > This revision incorporates editorial changes proposed by Brandon to
> allow the TURN server to forward inbound STUN connectivity checks without
> explicit permissions.

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Sat, 2 Jun 2018 06:12:30 +0000

Thanks Nil and Justin for the review. Updated draft to address the comment and Nit.

-Tiru

From: tram [mailto:[email-masked]] On Behalf Of Justin Uberti
Sent: Saturday, June 2, 2018 5:27 AM
To: Nils Ohlmeier <[email-masked]>
Cc: [email-masked]
Subject: Re: [tram] I-D Action: draft-ietf-tram-turnbis-18.txt

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
I reviewed the diff as well and have the following comments:
- In the initial discussion of allowing STUN packets, it mentions that STUN checks can occur while the client is preparing permission requests. I think this could be worded more clearly, e.g.
".... addressing the race condition that exists when the remote peer sends connectivity checks before the local client has had a chance to create permissions in the TURN server for the remote peer IP addresses."

On Fri, Jun 1, 2018 at 11:47 AM Nils Ohlmeier <[email-masked]<mailto:[email-masked]>> wrote:
I reviewed the diff between version 17 and 18 and the changes to allow a TURN server to forward inbound STUN messages if configured so look good to me.

Best
  Nils Ohlmeier

> On May 29, 2018, at 03:52, Konda, Tirumaleswar Reddy <[email-masked]<mailto:[email-masked]>> wrote:
>
>> From: tram [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of internet-
>> [email-masked]<mailto:[email-masked]>
>> To: [email-masked]<mailto:[email-masked]>
>> Cc: [email-masked]<mailto:[email-masked]>
>> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>>
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tram