Subject: [tram] [Technical Errata Reported] RFC8489 (6290)

From: RFC Errata System <[email-masked]>
Date: Mon, 14 Sep 2020 07:55:35 -0700 (PDT)

The following errata report has been submitted for RFC8489,
"Session Traversal Utilities for NAT (STUN)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6290

--------------------------------------
Type: Technical
Reported by: Jared Williams <[email-masked]>

Section: 18.1

Original Text
-------------
Bits are assigned starting from the most significant side of the bit
set, so Bit 0 is the leftmost bit and Bit 23 is the rightmost bit.

Corrected Text
--------------
Bits are assigned starting from the least significant side of the bit
set, so Bit 0 is the rightmost bit, and Bit 23 is the leftmost bit.

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8489 (draft-ietf-tram-stunbis-21)
--------------------------------------
Title               : Session Traversal Utilities for NAT (STUN)
Publication Date    : February 2020
Author(s)           : M. Petit-Huguenin, G. Salgueiro, J. Rosenberg, D. Wing, R. Mahy, P. Matthews
Category            : PROPOSED STANDARD
Source              : TURN Revised and Modernized
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 14 Sep 2020 15:57:28 +0000

Hi,

Is this now correct and I can verify it?

Thanks Jared for submitting it. 

Cheers

Magnus

> "Session Traversal Utilities for NAT (STUN)".
https://protect2.fireeye.com/v1/url?k=86a26016-d8028082-86a2208d-86d2114eab2f-4a803493d845ed24&q=1&e=8ee7295d-0e64-451c-8c17-33ed77d82771&u=https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid6290
-- 
Cheers

Magnus Westerlund 

----------------------------------------------------------------------
Networks, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Mobile +46 73 0949079
Torshamnsgatan 23           |
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 14 Sep 2020 10:05:24 -0700

Yes, this errata is correct.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug