Subject: [Trans] Infrastructure for logs?

From: Ben Laurie <[email-masked]>
Date: Thu, 17 Apr 2014 18:07:58 +0100

My team is considering doing some work on the open source log
implementation to make it less of a reference implementation and more
something that you could consider running in (or adapting for) a
production environment.

It would help guide our thinking of those CAs (and others) who are
considering running logs would give us some hints about the kind of
production environment they would like to run in. In particular:

1. Operating systems.

2. Database managers.

3. Any other constraints you might have on a production environment.

Public discussion would be useful, but if you would rather tell me
privately that is also fine. Bear in mind that what we learn will
probably influence open source code, though that's obviously very
unlikely to reveal anything about anyone in particular.

-- 
Certificate Transparency is hiring! Let me know if you're interested.

---

From: Tomas Gustavsson <[email-masked]>
Date: Fri, 18 Apr 2014 06:45:47 +0200

If we would set up a log today we would go for:

1. Linux (Ubuntu or RHEL) 

2. MariaDB Galera

3. Stateless load balancing? IPv4/v6? Possible to test on one core (I mention this because some products are not). 

Cheers, 
Tomas 

On April 17, 2014 7:07:58 PM CEST, Ben Laurie <[email-masked]> wrote:
>_______________________________________________
>Trans mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/trans

-- 
PrimeKey Solutions AB
Internet: www.primekey.se
Twitter: twitter.com/primetomas
Mob: +46 (0)707421096

---

From: Dmitry Belyavsky <[email-masked]>
Date: Fri, 18 Apr 2014 17:20:49 +0400

Hello Ben,

> unlikely to reveal anything about anyone in particular.
1. Linux (We prefer Debian).
2. PostgreSQL, MySQL?
3. It seems to be not a constraint but there should be a list of
Nagios/Icinga checks for the log instance.

Thank you!
-- 
SY, Dmitry Belyavsky

---

From: Rick Andrews <[email-masked]>
Date: Mon, 21 Apr 2014 14:22:19 -0700

1.	Web Server - Apache on Linux; App Server - Tomcat (Web application - java based REST APIs) on Linux
2.	Oracle db
3.	Stateless load balancing so that machines can be brought up and down at will without missing any certs or corrupting the logs

-Rick

-----Original Message-----
From: Trans [mailto:[email-masked]] On Behalf Of Ben Laurie
Sent: Thursday, April 17, 2014 10:08 AM
To: CABFPub; [email-masked]
Subject: [Trans] Infrastructure for logs?

My team is considering doing some work on the open source log implementation to make it less of a reference implementation and more something that you could consider running in (or adapting for) a production environment.

It would help guide our thinking of those CAs (and others) who are considering running logs would give us some hints about the kind of production environment they would like to run in. In particular:

1. Operating systems.

2. Database managers.

Public discussion would be useful, but if you would rather tell me privately that is also fine. Bear in mind that what we learn will probably influence open source code, though that's obviously very unlikely to reveal anything about anyone in particular.

---

From: Rob Stradling <[email-masked]>
Date: Tue, 22 Apr 2014 15:28:10 +0100

1. Linux (Gentoo and/or Debian).
2. PostgreSQL.
3. Stateless load balancing.

-- 
Rob Stradling
Senior Research & Development Scientist
COMODO - Creating Trust Online

---

From: [email-masked]
Date: Wed, 23 Apr 2014 12:00:02 +0200

Hi Ben,

1.- Linux (CentOS, Ubuntu)
2.- MySQL
3.- none at this moment

Iñigo Barreira
Responsable del Área técnica
[email-masked]
945067705

ERNE! Baliteke mezu honen zatiren bat edo mezu osoa legez babestuta egotea. Mezua badu bere hartzailea. Okerreko helbidera heldu bada (helbidea gaizki idatzi, transmisioak huts egin) eman abisu igorleari, korreo honi erantzuna. KONTUZ!
ATENCION! Este mensaje contiene informacion privilegiada o confidencial a la que solo tiene derecho a acceder el destinatario. Si usted lo recibe por error le agradeceriamos que no hiciera uso de la informacion y que se pusiese en contacto con el remitente.

-----Mensaje original-----
De: Trans [mailto:[email-masked]] En nombre de Ben Laurie
Enviado el: jueves, 17 de abril de 2014 19:08
Para: CABFPub; [email-masked]
Asunto: [Trans] Infrastructure for logs?

1. Operating systems.

2. Database managers.