Subject: Re: [Trans] [trans] #28 (rfc6962-bis): Algorithm agility

From: "trans issue tracker" <[email-masked]>
Date: Wed, 18 Feb 2015 14:17:30 -0000

#28: Algorithm agility

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 I believe that cert algorithms are already specified by reference to the
 relevant RFCs, and whatever agility mechanisms those have.

 For the log algorithms, fixed in https://github.com/google/certificate-
 transparency-rfcs/commit/0c5b808345812946d8d36c692f0607b5262ca9a3.

-- 
-------------------------+-------------------------------------------------
 Reporter:               |       Owner:  draft-ietf-trans-
  [email-masked]           |  [email-masked]
     Type:  defect       |      Status:  closed
 Priority:  major        |   Milestone:
Component:  rfc6962-bis  |     Version:
 Severity:  -            |  Resolution:  fixed
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/trans/trac/ticket/28#comment:1>
trans <http://tools.ietf.org/trans/>

---

From: Stephen Kent <[email-masked]>
Date: Thu, 26 Feb 2015 15:37:35 -0500

I disagree with the explanation provided below.

referencing an RFC that defines an alg does not satisfy the need to
specify how a system like CT transitions to using a new alg, signaling
the transition to all affected parties, etc.
> #28: Algorithm agility
>
> Changes ([email-masked]):
>
>   * status:  new => closed
>   * resolution:   => fixed
>
>
> Comment:
>
>   For the log algorithms, fixed inhttps://github.com/google/certificate-