Subject: [Trans] [trans] #94 (client-behavior): Fetching of inclusion proofs: Why and when are clients expected to do this?

From: "trans issue tracker" <[email-masked]>
Date: Thu, 23 Jul 2015 08:22:52 -0000

#94: Fetching of inclusion proofs: Why and when are clients expected to do this?

 The introduction implies that clients asynchronously check for inclusion
 proofs.

 A rough suggestion by Steve Kent:
 "If clients check for the presence of SCTs, this is a good start because
 gives them some confidence the certificate is logged if the log is
 behaving. They can gain additional confidence by demanding an inclusion
 proof. We recognise it puts additional burden on clients"

 We should also point out that a client directly contacting the log to
 request an inclusion proof discloses private information to the log (the
 website the client has visited) and so other, indirect methods of
 contacting the log may be required.

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-ietf-trans-
  [email-masked]       |  [email-masked]
     Type:  defect       |     Status:  new
 Priority:  major        |  Milestone:
Component:  client-      |    Version:
  behavior               |   Keywords:
 Severity:  -            |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/trans/trac/ticket/94>
trans <http://tools.ietf.org/trans/>

---

From: "trans issue tracker" <[email-masked]>
Date: Thu, 23 Jul 2015 10:29:08 -0000

Changes (by [email-masked]):

 * component:  client-behavior => rfc6962-bis

Comment:

 I note that this question is addressed in the gossip I-D, and perhaps is
 better left there?

-- 
-------------------------+-------------------------------------------------
 Reporter:               |       Owner:  draft-ietf-trans-
  [email-masked]       |  [email-masked]
     Type:  defect       |      Status:  new
 Priority:  major        |   Milestone:
Component:  rfc6962-bis  |     Version:
 Severity:  -            |  Resolution:
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/trans/trac/ticket/94#comment:1>
trans <http://tools.ietf.org/trans/>

---

From: Stephen Kent <[email-masked]>
Date: Fri, 24 Jul 2015 08:48:52 +0200

Ben,

>   I note that this question is addressed in the gossip I-D, and perhaps is
We should remember that gossip is an Experimental vs. Standards track 
doc for now.

Steve

---

From: Ben Laurie <[email-masked]>
Date: Fri, 24 Jul 2015 11:24:34 +0000

> We should remember that gossip is an Experimental vs. Standards track

OK, but given yesterday's discussion, seems like the architecture doc is an
even better home.

>
> Steve
>
> _______________________________________________
> Trans mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trans
>

---

From: Stephen Kent <[email-masked]>
Date: Fri, 24 Jul 2015 17:25:44 +0200

Ben,

>
>
> On Fri, 24 Jul 2015 at 07:49 Stephen Kent <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Ben,
>
>     > Changes (by [email-masked] <mailto:[email-masked]>):
>     >
> OK, but given yesterday's discussion, seems like the architecture doc 
> is an even better home.
works for me.

Steve