Subject: Re: [Trans] TRANS Draft minutes for IETF-93

From: Daniel Kahn Gillmor <[email-masked]>
Date: Wed, 05 Aug 2015 16:56:56 -0400

On Fri 2015-07-24 07:28:53 -0400, Ben Laurie wrote:
> On Thu, 23 Jul 2015 at 20:59 Salz, Rich <[email-masked]> wrote:
>> Steve raised issue of exposing what certs a client is interested in if
>> size of get-entries can shrink to one, for example.
>
> My response was omitted: this doesn't matter so long as the client
> continues to request entries until it has all the ones it originally
> decided to fetch.

as a concrete example, if a client says "give me entries from 1000 to
2000" while knowing it actually only wants entry 1223, and the server
dribbles them back one at a time instead of 1000 at a time, then the
client which stops at 1223 has effectively lost privacy.

If the client continues with the next 777 fetches anyway, then it should
be identical privacy-wise to the initial request (albeit at a likely
higher expense in terms of latency and network traffic)

       --dkg

---

From: Stephen Kent <[email-masked]>
Date: Tue, 11 Aug 2015 15:56:09 -0400

Rich,

Sorry for the late comment, but I just returned from vacation after IETF.
> Please send/post corrections.
>
> ...
>
> Steve Kent, attack model
> Name changed on doc, even if filename can't easily be changed. Not a threat model, we don't know what the attackers are thinking, but we do know possible actions so it's an attack model.
> Includes an intro to CT, he prefers it move into an arch document but if not it will stay.
> "CT is a set of mechanisms, designed to detect, deter, and facilitate remediation of certificate mis-issuance"
> Semantic mis-issuance: name in the cert refers to an entity incorrectly.
> Syntactic mis-issuance: violation of certificate profile(s) that apply.
> Reviewed a taxonomy of attacks.  Read the doc.  Discussion of additions and bigger picture needs.
> Incorporated all (but one) comments.
> Wants WG agreement via list on goals, definitions, attacks.
> We have a half-dozen people commit to read and review the document.
> Ben agrees about having an arch doc; Steve and Ben will collaborate on an arch doc
I recall saying that I would be happy to author such a doc, starting by
extracting some text from the attack model.  I recall that Ben agreed that
having an arch doc was a good idea, but I do not recall that we agreed 
to co-author
the doc.

BTW, I expected to see a message from our chairs raising this issue on the
list, to see if there was general support for this new doc.  I'm still 
catching up
on e-mail, but did not see such a message.

Steve

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 11 Aug 2015 19:58:36 +0000

> having an arch doc was a good idea, but I do not recall that we agreed to co-
> author the doc.

I am certain this is more accurate than what I wrote.  I hope the chairs can make the necessary update.

---

From: Paul Wouters <[email-masked]>
Date: Wed, 12 Aug 2015 06:59:37 -0400 (EDT)

> I am certain this is more accurate than what I wrote.  I hope the chairs can make the necessary update.

I will make the change and get the minutes out ASAP,

Thanks everyone

Paul