Subject: [Trans] Tutorial on how to deploy an internal CT log server?

From: Ronald del Rosario <[email-masked]>
Date: Thu, 3 Sep 2015 22:13:23 +0000

Hi,

I am looking for any doc/post/blog on the web that provides a step-by-step guide on how to deploy a local CT log server?

Thank you,

Ron F. del Rosario

________________________________

CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential information of Five9 and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Five9 and/or its affiliated entities.

---

From: Adam Eijdenberg <[email-masked]>
Date: Fri, 04 Sep 2015 00:11:46 +0000

+certificate-transparency <[email-masked]>

Hi Ronald,

The open source implementation provided by Google has some documentation on
how to build and get started here:
https://github.com/google/certificate-transparency/blob/master/docs/ClusterHowto.md
https://github.com/google/certificate-transparency/blob/master/README.md

>From the introduction section:

"This HOWTO is intended to get you started running a clustered CT "Super
Duper" log server. The scripts in the rep referenced below are targetted at
running a log cluster in Google Compute Engine , but since it's all based
around Docker images it shouldn't be too hard to use the scripts as a
reference for getting a log running on any other infrastructure where you
can easily run Docker containers."

If you encounter issues getting the server to work, please do reach out
(mail to [email-masked] would be the best way)
and we should be able to help.

Cheers, Adam

On Fri, Sep 4, 2015 at 8:13 AM Ronald del Rosario <[email-masked]>
wrote:

> Hi,
>
> I am looking for any doc/post/blog on the web that provides a step-by-step
> guide on how to deploy a local CT log server?
>
> Thank you,
>
>
> Ron F. del Rosario
>
>
>
> ------------------------------
>
> CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain
> confidential information of Five9 and/or its affiliated entities. Access by
> the intended recipient only is authorized. Any liability arising from any
> party acting, or refraining from acting, on any information contained in
> this e-mail is hereby excluded. If you are not the intended recipient,
> please notify the sender immediately, destroy the original transmission and
> its attachments and do not disclose the contents to any other person, use
> it for any purpose, or store or copy the information in any medium.
> Copyright in this e-mail and any attachments belongs to Five9 and/or its
> affiliated entities.
> _______________________________________________
> Trans mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trans
>

---

From: Ronald del Rosario <[email-masked]>
Date: Fri, 4 Sep 2015 00:45:46 +0000

Adam,

Thanks!  I will have a fun weekend of hacking then!

The group should release an official docker container so us not-so-technically-inclined can just pull the image and play around with it :-)

Ron
@guerilla7

From: Adam Eijdenberg <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 3, 2015 at 5:11 PM
To: "Ronald F. del Rosario" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Trans] Tutorial on how to deploy an internal CT log server?

+certificate-transparency<mailto:[email-masked]>

Hi Ronald,

The open source implementation provided by Google has some documentation on how to build and get started here:
https://github.com/google/certificate-transparency/blob/master/docs/ClusterHowto.md
https://github.com/google/certificate-transparency/blob/master/README.md

>From the introduction section:

"This HOWTO is intended to get you started running a clustered CT "Super Duper" log server. The scripts in the rep referenced below are targetted at running a log cluster in Google Compute Engine , but since it's all based around Docker images it shouldn't be too hard to use the scripts as a reference for getting a log running on any other infrastructure where you can easily run Docker containers."

If you encounter issues getting the server to work, please do reach out (mail to [email-masked]<mailto:[email-masked]> would be the best way) and we should be able to help.

Cheers, Adam

On Fri, Sep 4, 2015 at 8:13 AM Ronald del Rosario <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thank you,

Ron F. del Rosario

CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential information of Five9 and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Five9 and/or its affiliated entities.
_______________________________________________
Trans mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/trans

---

From: Pierre Phaneuf <[email-masked]>
Date: Fri, 4 Sep 2015 13:37:45 +0100

If it's for testing only, there's the
--i_know_stand_alone_mode_can_lose_data flag, which makes etcd
unnecessary (and will lose any unsequenced submissions in case of a
crash).

On Fri, Sep 4, 2015 at 1:11 AM, 'Adam Eijdenberg' via
certificate-transparency <[email-masked]>
wrote:
> +certificate-transparency
>
> Hi Ronald,
>
>> its attachments and do not disclose the contents to any other person, use it
>> for any purpose, or store or copy the information in any medium. Copyright
>> in this e-mail and any attachments belongs to Five9 and/or its affiliated
>> entities.
> --
> You received this message because you are subscribed to the Google Groups
> "certificate-transparency" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> For more options, visit https://groups.google.com/d/optout.