Subject: Re: [Trans] Log Monitoring API

From: Jeremy Rowley <[email-masked]>
Date: Wed, 2 Nov 2016 16:05:29 +0000

We're happy to be involved. Clint Wilson will be contributing from our side.

-----Original Message-----
From: Trans [mailto:[email-masked]] On Behalf Of Zakir Durumeric
Sent: Thursday, October 27, 2016 8:49 AM
To: Andrew Ayer <[email-masked]>
Cc: Rob Stradling <[email-masked]>; [email-masked]
Subject: Re: [Trans] Log Monitoring API

I would be happy to be involved, and the Censys Project would be interested
in implementing an agreed API as part of its CT monitoring.

Zakir

> On Oct 25, 2016, at 12:36 PM, Andrew Ayer <[email-masked]> wrote:
> 
> On Thu, 6 Oct 2016 16:21:59 +0100
> Rob Stradling <[email-masked]> wrote:
> 
>> Now we've completed WGLC for 6962-bis, I'd like to pick this thread 
>> back up again.
>> 
>> Several different public CT monitoring services now exist (crt.sh, 
>> Cert Spotter, Censys.io, etc).  ISTM that it would be useful to 
>> define a common API that could be implemented by each monitor, so 
>> that end-users don't have to implement multiple APIs in order to talk 
>> to multiple monitors.
>> 
>> Matt Palmer and I made a start on a (very drafty) draft a while ago:
>> https://github.com/tobermorytech/ct-monitor-api-rfc/blob/master/draft
>> -palmer-ct-monitor-api.md
>> 
>> Who's interested in working on this?
> 
> Count me in.
> 
> Regards,
> Andrew
> 
> _______________________________________________
> Trans mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trans
> 

_______________________________________________
Trans mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/trans

---

From: Clint Wilson <[email-masked]>
Date: Wed, 02 Nov 2016 21:40:26 +0000

We're very excited to see this discussed and looking forward to
participating.

---

From: Matt Palmer <[email-masked]>
Date: Thu, 3 Nov 2016 09:40:36 +1100

Great to see there's a broad set of people looking to work on this.

What I'd like to do first up is to try and get as broad a range of use cases
as possible enumerated and defined.  There's currently a set of actors and
use cases in the draft document
(https://github.com/tobermorytech/ct-monitor-api-rfc/blob/master/draft-palmer-ct-monitor-api.md,
section "Desired Features").  If anyone has any use cases not covered
already, or if you think any existing use case needs to be expanded, please
drop a PR or raise it here.

- Matt

> -- 

-- 
Java/XML are the hammer and the Internet is the thumb.
		-- rone, in a place that does not exist