Subject: [Trans] Privacy-preserving proof of sct exclusion

From: Saba Eskandarian <[email-masked]>
Date: Sat, 25 Mar 2017 22:39:16 +0000

Hello,

I'm on the agenda for Tuesday's meeting to share a privacy-preserving proof of sct exclusion from a log (I think Eran alluded to this work in a message a while ago).

My posted slides will not include many words, so I wanted to share a link to the preprint of our academic paper on the subject in case anyone wants to read the details there. The paper is targeted at a somewhat different audience, but it can be found here: https://arxiv.org/abs/1703.02209

Thanks and looking forward to meeting you all next week!

~saba

---

From: Ben Laurie <[email-masked]>
Date: Sun, 26 Mar 2017 17:46:21 +0100

On 25 March 2017 at 22:39, Saba Eskandarian <[email-masked]> wrote:

> Hello,
>
> I'm on the agenda for Tuesday's meeting to share a privacy-preserving
> proof of sct exclusion from a log (I think Eran alluded to this work in a
> message a while ago).
>
> My posted slides will not include many words, so I wanted to share a link
> to the preprint of our academic paper on the subject in case anyone wants
> to read the details there. The paper is targeted at a somewhat different
> audience, but it can be found here: https://arxiv.org/abs/1703.02209
>

Cool, but I immediately see a problem - you require logs to be in timestamp
order, but they aren't. I can't immediately think of a way to get that
property without also considerably increasing time to inclusion in the log.

That seems undesirable - in fact, we're trying to go the other way, i.e.
reduce time to inclusion, in general.

Also, engineering reality doesn't change, so increasing time to inclusion
is also likely to increase MMD.

Secondly, its interesting, but doesn't seem particularly useful: when an
SCT corresponds to a cert that has not been included, you want to reveal
the cert, not hide it. What you want to hide is who is revealing it.

~saba
>
> _______________________________________________
> Trans mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trans
>
>

---

From: Saba Eskandarian <[email-masked]>
Date: Mon, 27 Mar 2017 04:16:52 +0000

Thanks for the prompt feedback! I'll make sure to address these comments in my talk, and I'm looking forward to discussing design options in person. I suspect that the flexibility of the tools and techniques we use as well as the associated engineering and privacy tradeoffs will make for an interesting discussion.

Thanks,

~saba

________________________________
From: Ben Laurie <[email-masked]>
Sent: Sunday, March 26, 2017 9:46:21 AM
To: Saba Eskandarian
Cc: [email-masked]
Subject: Re: [Trans] Privacy-preserving proof of sct exclusion

On 25 March 2017 at 22:39, Saba Eskandarian <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Cool, but I immediately see a problem - you require logs to be in timestamp order, but they aren't. I can't immediately think of a way to get that property without also considerably increasing time to inclusion in the log.

That seems undesirable - in fact, we're trying to go the other way, i.e. reduce time to inclusion, in general.

Also, engineering reality doesn't change, so increasing time to inclusion is also likely to increase MMD.

Secondly, its interesting, but doesn't seem particularly useful: when an SCT corresponds to a cert that has not been included, you want to reveal the cert, not hide it. What you want to hide is who is revealing it.

~saba

_______________________________________________
Trans mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/trans

---

From: Ben Laurie <[email-masked]>
Date: Mon, 27 Mar 2017 10:48:11 +0100

On 27 March 2017 at 05:16, Saba Eskandarian <[email-masked]> wrote:

> Thanks for the prompt feedback! I'll make sure to address these comments
> in my talk, and I'm looking forward to discussing design options in person.
> I suspect that the flexibility of the tools and techniques we use as well
> as the associated engineering and privacy tradeoffs will make for an
> interesting discussion.
>

Afraid I won't be there, but looking forward to hearing more.

>
> Thanks,
>
> ~saba
> ------------------------------
> *From:* Ben Laurie <[email-masked]>
> *Sent:* Sunday, March 26, 2017 9:46:21 AM
> *To:* Saba Eskandarian
> *Cc:* [email-masked]
> *Subject:* Re: [Trans] Privacy-preserving proof of sct exclusion
>
>
>
> Cool, but I immediately see a problem - you require logs to be in
> timestamp order, but they aren't. I can't immediately think of a way to get
> that property without also considerably increasing time to inclusion in the
> log.
>