Subject: Re: [Trans] RFC 7320 and draft-ietf-trans-rfc6962-bis-24

From: Eran Messeri <[email-masked]>
Date: Fri, 7 Apr 2017 10:05:36 +0100

>From discussing in-person with Richard Barnes, and the trans wg meeting, it
seems there's consensus on not having a 'directory' endpoint for dynamic
discovery of all the methods the log exposes.

Instead, we could:
(1) Clarify why BCP 190 may not apply here (based on experience deploying
V1 logs)
(2) Remove the 'ct/v2' portion from all the URIs.

Any preferences? Mine would be for (2), but it's not a strong preference.

On Mon, Mar 20, 2017 at 2:50 PM, Eran Messeri <[email-masked]> wrote:

> FYI this has been documented in https://trac.ietf.org/trac/
> trans/ticket/185.
>
> On Wed, Mar 15, 2017 at 8:46 PM, Melinda Shore <[email-masked]>
> wrote:
>
>> On 3/15/17 12:29 PM, Martin Thomson wrote:
>> > I am not following this work, but this and the original RFC 6962 both
>> > run afoul of the (good) guidance in RFC 7320.
>> >
>> > Has the working group solicited feedback from the HTTP community on
>> > the use of HTTP in this protocol?
>>
>> No, we haven't.
>>
>> For what it's worth, 6962 reflects implementation and
>> deployment prior to CT having been brought to the IETF
>> for standardization, so any concerns regarding URL
>> syntax or HTTP transport in the work being done by this
>> working group are necessarily limited to the -bis and
>> related documents.
>>
>> To be honest, I'm personally not convinced of the applicability
>> of 7320 in this case but if there's a specific problem it does
>> need to be discussed.
>>
>> Melinda
>>
>>
>> _______________________________________________
>> Trans mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/trans
>>
>>
>

---

From: Melinda Shore <[email-masked]>
Date: Mon, 10 Apr 2017 11:15:18 -0800

On 4/7/17 1:05 AM, Eran Messeri wrote:
> Instead, we could:
> (1) Clarify why BCP 190 may not apply here (based on experience
> deploying V1 logs)

I think that in general, when there's a deviation from a BCP
it's a good idea to document why it's inapplicable - the question
is very likely to come up at some point during the review process.
I don't think that removing the ct/v2 portion would be sufficient to
resolve the conflict with BCP 190, although it may be
desirable for other reasons.

Melinda