Subject: [Trans] Draft minutes

From: Melinda Shore <[email-masked]>
Date: Fri, 20 Jul 2018 14:48:16 -0400

Hi, all:

Thanks for an excellent meeting yesterday.  There are a few
questions coming out of it that we'll be bringing to the mailing
list next week, once most people are home.

The draft minutes have been posted at
https://datatracker.ietf.org/meeting/102/materials/minutes-102-trans-00.
Please send comments, corrections, etc. to the mailing list.

Melinda

-- 
Software longa, hardware brevis

PGP key fingerprint  4F68 2D93 2A17 96F8 20F2
                     34C0 DFB8 9172 9A76 DB8F

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 25 Jul 2018 15:52:22 -0500

> Please send comments, corrections, etc. to the mailing list.

% 4) Fotis Loukos requested that we clarify what we mean by
%    "current NTP time."  There is no proposed text.  Given
%    how late this is in the process, if someone doesn't give
%    us text there's nothing to talk about, so if someone
%    feels strongly about this they should contribute text.
%    Nobody expressed concern.  Fotis should produce text, or
%    we'll drop it.

("NTP Time" appears twice in the document.)

It seems like the concern here is that NTP is a protocol for conveying time
information from one location/system to another, but there is not
necessarily a single universal/global consensus "NTP Time".  That is, I can
run a clock over here with free-running quartz and use NTP to synchronize a
different machine with it, but it will be quite disjoint from "reality".
So it seems like we need to indicate what pool(s) of servers are
authoritative for the time that we want to be using, or just say it's UTC
or GPS or whatever.

% Trans threat analysis
% ---------------------
% 
% There hasn't been much progress and we don't want to keep
% the working group open for just this document.  There
% doesn't seem to be much interest among working group
% participants.  Rich Salz thinks we should flip a coin to
% settle the difference - he thinks the document has value.
% Paul and Melinda will discuss it after the meeting and take
% it back out to the mailing list.

Is there an outcome of the discussion to report yet?

Thanks,

Ben

---

From: Melinda Shore <[email-masked]>
Date: Wed, 25 Jul 2018 20:49:00 -0400

> Is there an outcome of the discussion to report yet?

No - I'm just heading home right now after a short post-meeting
visit with family.

In the interest of transparency, I do feel pretty strongly
that documents need to reflect working group consensus, and
that moving them forward without that consensus tends not
to discourage the kind of behavior that got us here in the
first place.  But Paul and I will discuss next steps and let
you all know where we are.

Melinda

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 26 Jul 2018 02:00:59 +0100

On 26/07/18 01:49, Melinda Shore wrote:
> first place. 

Well said.

That, plus the improbability that the sky will fall if the
draft is question is not published, convinces me that just
letting it linger as an I-D is fine. The text and analysis
is not lost, the RFC number is not needed, so don't we have
to let it linger? (With apologies to the Cranberries:-)

S.

---

From: Robin Wilton <[email-masked]>
Date: Thu, 26 Jul 2018 11:04:59 +0000

> On 25 Jul 2018, at 21:52, Benjamin Kaduk <[email-masked]> wrote:
> 

Isn’t there a case, here, for asking the tictoc WG for advice about a canonical reference or chunk of text that could be used?

Yrs.,
Robin

---

From: Robin Wilton <[email-masked]>
Date: Thu, 26 Jul 2018 11:31:13 +0000

Yrs.,
Robin

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 26 Jul 2018 08:50:12 -0500

> Isn’t there a case, here, for asking the tictoc WG for advice about a canonical reference or chunk of text that could be used?

Seems likely.  Are the chairs interested in making such a request?

-Ben

---

From: Melinda Shore <[email-masked]>
Date: Thu, 26 Jul 2018 22:19:20 -0800

On 7/26/18 5:50 AM, Benjamin Kaduk wrote:
>> Isn’t there a case, here, for asking the tictoc WG for advice about
>> a canonical reference or chunk of text that could be used?

Sure, although I'd like to hear from the authors and/or
from implementers, first.  My understanding is that that
piece of data is used to provide a sanity check (i.e. an
STH cannot have a timestamp earlier than that of any SCT
in the tree) and it seems to me that the level of rigor
being expected of the timestamp should probably align
with its actual application.  So, let's make sure we agree
on what we're asking for before making a request.

Melinda

---

From: Ryan Sleevi <[email-masked]>
Date: Sat, 28 Jul 2018 12:25:10 +0900

On Fri, Jul 27, 2018 at 3:19 PM Melinda Shore <[email-masked]>
wrote:

> _______________________________________________
> Trans mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trans

<https://www.ietf.org/mailman/listinfo/trans>

Just to make sure: We’re talking about the feedback on
https://www.ietf.org/mail-archive/web/trans/current/msg03155.html , correct?

I’m having trouble squaring that feedback with what’s being discussed here,
since it wasn’t a question about the rigor of a globally consistent time,
but rather a question about the encoding and wire format being left
ambiguously unclear. That is, this is about format and not semantics, and
proposed text to try to disambiguate a little more was included.

---

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 28 Jul 2018 10:02:52 -0500

Hi Ryan,

> proposed text to try to disambiguate a little more was included.

Thanks for pulling up the primary source; I was just going on the chairs'
summary of the issues and apparently only noticed an unrelated potential issue.
Clarifying that the 64-bit timestamp format (with callout to Sectino 6 of
RFC 5905) is the correct one sounds like a fine thing to do.

-Ben

---

From: Melinda Shore <[email-masked]>
Date: Sat, 28 Jul 2018 14:37:16 -0800

> RFC 5905) is the correct one sounds like a fine thing to do.

D'oh!  But in fairness the what was under discussion was in
response to the meeting minutes, which do accurately capture
the discussion in Montreal.  I'll bug the authors.

Melinda

---

From: Nico Williams <[email-masked]>
Date: Sat, 28 Jul 2018 19:05:56 -0500

On Wed, Jul 25, 2018 at 03:52:22PM -0500, Benjamin Kaduk wrote:
> It seems like the concern here is that NTP is a protocol for conveying
> time information from one location/system to another, but there is not
> necessarily a single universal/global consensus "NTP Time".  That is,
> I can run a clock over here with free-running quartz and use NTP to
> synchronize a different machine with it, but it will be quite disjoint
> from "reality".  So it seems like we need to indicate what pool(s) of
> servers are authoritative for the time that we want to be using, or
> just say it's UTC or GPS or whatever.

My guess is the authors mean "current time" and "use NTP to get current
time".  If they mean anything else then that should be clarified for
sure.  Even if that's what they mean, it would be easy enough to make
that change, even as late as AUTH48.