Subject: [Trans] YABQ (yet another Ben question)

From: "Salz, Rich" <[email-masked]>
Date: Sun, 28 Mar 2021 20:54:49 +0000

In section 2.1.4.1,

>   If m <= k, the right subtree entries D[k:n] only exist in the current
>   tree.  We prove that the left subtree entries D[0:k] are consistent
>   and add a commitment to D[k:n]:
>
>   SUBPROOF(m, D_n, b) = SUBPROOF(m, D[0:k], b) : MTH(D[k:n])
>
>This 'b' is always 'false', right?

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 28 Mar 2021 21:50:19 +0000

In section 2.1.4.1,

>This 'b' is always 'false', right?

I think no.  Looking at the sample code that’s in the repo https://github.com/google/certificate-transparency-rfcs/blob/master/test_rfc_algorithms.py#L55:

      if m <= k:
        return self.subproof(m, start_n, start_n + k, b) + [(start_n + k, end_n)]