Subject: [Trans] picking up draft-ietf-trans-rfc6962-bis

From: Paul Wouters <[email-masked]>
Date: Fri, 5 Mar 2021 08:59:29 -0500 (EST)

Dear WG,

It has been a while since there has been activity in the trans working
group. We are going to pick up the last remaining issues over the few
days and see if we can wrap up the draft-ietf-trans-rfc6962-bis
document. If needed, I will act as a Document Editor to assist Rob
Stradling as Author. The other Authors have let us know that they
are no longer able to give this document their further attention.

https://datatracker.ietf.org/doc/draft-ietf-trans-rfc6962-bis/

The current status is that the document needs a revision after
some comments from the IESG. There are two DISCUSSes open which
we will try to summarize below. Hopefully, we can then start
a discussion where the WG provides new text, and then we will
get that out in an updated draft. Please remember it is important
to provide actual text, as the authors of the document are either
unavailable or severely limtied in time. So Rob or the chairs will
make updating the documents, but it is really up to the working
group to provide the text.

https://datatracker.ietf.org/doc/draft-ietf-trans-rfc6962-bis/ballot/

(Alexey Melnikov) Discuss

1)  The "urn:ietf:params:trans:error:" needs to be registered at
      https://www.iana.org/assignments/params/params.xhtml#params-1

This requires new text in the IANA Considerations section.

2)  Does "error" need a registry too ?

If so, this requires new text in the IANA Considerations section.
If not, there needs to be clarifying text to make that obvious.

(Benjamin Kaduk) Discuss

3) inconsistency / conflicts about the minimum array size of NodeHash

This requires modifing existing text.

4) Section 6 on OCSP contains language no longer applicable for the
     latest TLS version 1.3.

This should be extended to cover 1.3 (or replaced to only cover 1.3
and no earlier versions??)

5) Need for "greater clarity on the (non-)usage of CT for TLS client 
certificates"

Perhaps Benjamin can clarify this request with some more details?

There are still a number of Comments open, that ideally should also
be resolved. Once we have the DISCUSS items resolved, we will try
to send these Comment items to the lists for improvement/resolving,
or leaving them as is if we don't get feedback.

There isn't that much work left. Perhaps during IETF 110, we can get
some people together and work on these last few items? If interested,
let us know and we will try to find a time slot that works.

Paul & Melinda

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 5 Mar 2021 15:54:22 +0000

None of these items look particularly difficult (pending clarification).  I can propose wording if Rob wants it.

Where is the source doc, and how is it maintained?

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 5 Mar 2021 15:59:29 +0000

Hi!

> -----Original Message-----
> From: Trans <[email-masked]> On Behalf Of Salz, Rich
> Sent: Friday, March 5, 2021 10:54 AM
> To: Paul Wouters <[email-masked]>; Trans <[email-masked]>
> Subject: Re: [Trans] picking up draft-ietf-trans-rfc6962-bis
> 

https://github.com/google/certificate-transparency-rfcs

Regards,
Roman

> 
> _______________________________________________
> Trans mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trans

---

From: Paul Wouters <[email-masked]>
Date: Fri, 5 Mar 2021 12:31:23 -0500 (EST)

> None of these items look particularly difficult (pending clarification).  I can propose wording if Rob wants it.

Rob has very little time for this, and the other authors have even less
time for this. So as chair let me say that _we_ want you to propose
wording :)

Paul

---

From: Watson Ladd <[email-masked]>
Date: Sun, 7 Mar 2021 19:20:17 -0800

> let us know and we will try to find a time slot that works.

I've been a lurker, but point me at the repo and I can give it a good try
with some text.

---

From: Roman Danyliw <[email-masked]>
Date: Mon, 8 Mar 2021 11:27:53 +0000

From: Trans <[email-masked]> On Behalf Of Watson Ladd
Sent: Sunday, March 7, 2021 10:20 PM
To: Paul Wouters <[email-masked]>
Cc: Trans <[email-masked]>
Subject: Re: [Trans] picking up draft-ietf-trans-rfc6962-bis

> let us know and we will try to find a time slot that works.

I've been a lurker, but point me at the repo and I can give it a good try with some text.

[Roman] https://github.com/google/certificate-transparency-rfcs
Thanks,
Roman

> [email-masked]<mailto:[email-masked]>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 8 Mar 2021 15:18:48 +0000

1)  The "urn:ietf:params:trans:error:" needs to be registered at
          https://urldefense.com/v3/__https://www.iana.org/assignments/params/params.xhtml*params-1__;Iw!!GjvTz_vk!BN2WHDW_M9IoCTe2l3F3oG4K1nLr_Wu5JyrffpMlTLzAitJgm_7GwSNLv_rw$ 

Please see https://github.com/google/certificate-transparency-rfcs/pull/317

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 8 Mar 2021 16:12:51 +0000

(Benjamin Kaduk) Discuss

I don't see any issue.  I looked for NodeHash and found three places:

a) 4.9 Merkle Tree Head
	opaque NodeHash<32..2^8-1>
which says the size MUST match the log's HASH_SIZE

b) 4.11 Merkle Consistency Proofs
	NodeHash consistency_path<1..2^16-1>;
This is a vector (array) of NodeHash items, as the text mentions.	

c) 4.12 Merkle Inclusion Proofs
	NodeHash inclusion_path<1..2^16-1>;
This is also a vector (array) as described in the text.

I think Ben is wrong here.

https://github.com/google/certificate-transparency-rfcs/pull/320

https://github.com/google/certificate-transparency-rfcs/pull/319

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 25 Mar 2021 19:25:55 +0000

> or leaving them as is if we don't get feedback.

Can you please post the Comment items, or a link to them?  I think all the DISCUSS items are resolved.