Subject: RE: [Trigtran] TCP & Link Outages

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 27 Nov 2002 10:21:05 -0600

Reiner is raising a topic Sally mentioned in her talk at TRIGTRAN last week - do we need explicit triggers, or would implicit triggers be sufficient? Retransmitting a packet when an interface becomes active looks like an implicit trigger to me.

I think the key question here is whether we think there are additional interesting triggers beyond link up/link down. If (no), the implicit trigger mechanism described in the PILC LINK document would be sufficient, if (yes), we're probably looking at an explicit trigger.

Sally also raised a minor question - is the retransmitted packet useful, or just the fact that it was sent? I assume that the answer is "yes for TCP, no for most other packets", but am still thinking about this, and welcome other views.

Spencer

> -----Original Message-----
> From: Reiner Ludwig [mailto:[email-masked]]
> Sent: Wednesday, November 27, 2002 6:27 AM
> To: [email-masked]
> Subject: [Trigtran] TCP & Link Outages
> 

[ deleted down to ]

> If you would like to see real world measurements that show 
> how nicely this 
> works for TCP, you can check slide no. 12 from a talk I gave 
> at the PILC WG 
> meeting in San Diego. It's available here 
> http://pilc.grc.nasa.gov/ and the 
> link is titled "Flow Adaptive ARQ Proposal".
> 
> Slide no. 13 shows how poorely TCP performs if this advice is 
> not followed.
> 
> Having said this, I'm not convinced that we need a "Link UP" 
> trigger, nor a 
> "Link DOWN trigger.
_______________________________________________
Trigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/trigtran

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Wed, 27 Nov 2002 11:47:33 -0500 (EST)

On Wed, 27 Nov 2002, Spencer Dawkins wrote:

> Reiner is raising a topic Sally mentioned in her talk at TRIGTRAN last
> week - do we need explicit triggers, or would implicit triggers be
> sufficient? Retransmitting a packet when an interface becomes active
> looks like an implicit trigger to me.
>
> I think the key question here is whether we think there are additional
> interesting triggers beyond link up/link down. If (no), the implicit
> trigger mechanism described in the PILC LINK document would be
> sufficient, if (yes), we're probably looking at an explicit trigger.

Since I haven't read all the documents and haven't followed all the work
very closely, please feel free correct/stop me...

My interest in triggers stems from the issue of doing AIMD congestion
control on connections which involve at least one mobile host. I believe
that when a host moves to a new domain, its TCP connections should slow
start again. I am not sure yet how this behavior would fit into the
planned framework, but I believe explicit triggers would be needed.

~armando

0--                                                --0
| Armando L. Caro Jr.     |       [email-masked] |
| University of Delaware  |  www.cis.udel.edu/~acaro |
0--                                                --0

---

From: Pasi Sarolahti <[email-masked]>
Date: Wed, 27 Nov 2002 19:44:23 +0200 (EET)

> planned framework, but I believe explicit triggers would be needed.

Exactly. It could be as simple as a new ICMP "reinitialize congestion 
control" message type. If a firewall blocks it, that wouldn't be too fatal 
since the standard TCP/SCTP/DCCP congestion control rules would still be 
applied.

- Pasi