Subject: [rbridge] PS Issue #11 -> now ARCH issue #6

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Mon, 19 Dec 2005 12:49:17 -0500

Erik,

	I agree with dropping the definitions for the terms
internal and external.  For the most part, where people
have been using the terms, the meaning intended could be
either explicitly or implicitly determined from context.
It has largely been the fact that we had defined these
terms in at least one document, expected everyone to use 
them as defined and were having difficulty doing so that
has caused a lot of the confusion.

--
Eric

--> -----Original Message-----
--> From: rbridge-bounces at postel.org 
--> [mailto:rbridge-bounces at postel.org] On Behalf Of Erik Nordmark
--> Sent: Monday, December 19, 2005 7:01 AM
--> To: Developing a hybrid router/bridge.
--> Subject: Re: [rbridge] PS Issue #11 -> now ARCH issue #6
--> 
--> Joe Touch wrote:
--> 
--> > Internal/external as used in the PS doc is specific to protocols
--> > 'inside' the solution. It is not used the same way in the 
--> arch document
--> > (internal/external interfaces).
--> > 
--> > That difference needs to be made more clear.
--> 
--> 
--> Or maybe not. Having two different definitions of internal 
--> and external 
--> in different documents doesn't improve comprehension.
--> 
--> Do we even need any such terms? If not, then we can get rid of any 
--> confusion by just deleting the terms. Where are the terms 
--> actually used 
--> and useful?
--> 
--> A rbridge device will be capable of interaction with end 
--> nodes (station) 
--> on any interface, by sending and receiving non-encapsulated 
--> frames. And 
--> in general it must assume that an end node can exist on any of its 
--> interfaces, since there can be hubs.
--> A rbridge device will also be capable of interaction with 
--> other rbridges 
--> on any interface, as part of some rbridge discovery/hello 
--> mechanism as 
--> well as sending and receiving encapsulate frames.
--> 
--> Also, the rbridges in a campus create an overlay topology 
--> through their 
--> operation.
--> 
--> But I'm pretty sure we can describe all this without needing any 
--> "internal" or "external" terms.
--> 
--> 
--> Later you wrote:
--> > The issue isn't that the meaning is hard to understand; 
--> the issue is
--> > that the term is inaccurate. Hosts can - and will - sit on that
--> > interface. I was trying to reserve internal/external for 
--> a distinction
--> > between traffic between rbridges and traffic from 
--> ingress/egress to
--> > hosts - where inside/outside meant 'inside the campus' 
--> (invisible to
--> > hosts) and 'outside to the hosts' (visible to hosts).
--> 
--> This is the distinction between encapsulated and non-encapsulated 
--> frames, right?
--> 
--> 
-->     Erik
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Tue, 20 Dec 2005 18:40:43 +0100

I agree. The terms should be cristal clear to get efficient shared use.
Guillermo

Gray, Eric wrote:

>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>
>  
>

-- 
Guillermo Ib??ez
Departamento de Ingenier?a Telem?tica
Universidad Carlos III de Madrid
1.1.B.11 Colmenarejo 91-6241393
4.1.F.13 Legan?s 91-6248794