Subject: [rbridge] it's time to summarize things

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Fri, 16 Dec 2005 18:23:33 -0500

Joe, et al,

--> Guillermo Ib??ez wrote:
--> >> My understanding was that Rbridges would do ARP proxying and would 
--> >> forward ARP requests to other Rbridges. Am I still right?.
--> 
--> Not proxying; they forward ARPs like all other L2 traffic. They don't
--> generate ARPs directed at their own L2 addresses in response to seeing
--> other ARPs (proxying).
--> 
--> Joe 

Just to be clear, no device generates ARPs directed at their own L2 address.

Ethernet ARP responses contain the MAC address to be used (as a MAC DA) to 
reach a specific (usually higher layer) non-MAC address.  In this
discussion,
we are pretty much exclusively talking about IP ARP.

--> -----Original Message-----
--> From: rbridge-bounces at postel.org 
--> [mailto:rbridge-bounces at postel.org] On Behalf Of Joe Touch
--> Sent: Friday, December 16, 2005 10:09 AM
--> To: Developing a hybrid router/bridge.
--> Subject: Re: [rbridge] it's time to summarize things
--> 
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: touch at ISI.EDU (Joe Touch)
Date: Fri, 16 Dec 2005 15:34:38 -0800

> Just to be clear, no device generates ARPs directed at their own L2 address.

Sure -

Proxy ARP =

1. device sees ARP responses (and sometimes infers MAC:IP correlactions
from other packets, such as ARP requests or other traffic) on one
interface and caches the MAC:IP data.

2. device sees ARP requests for IP addresses in its MAC:IP cache on a
different interface, and sends ARP responses with its own MAC address

- ---

Replay ARP

1. device sees .... (as above) on one interface

2. device sends a spoofed ARP response (either a replay of a seen ARP
response, or a new response based on its MAC:IP cache), i.e., with the
MAC address from the cache (NOT its own MAC address)

> we are pretty much exclusively talking about IP ARP.

Agreed.

Joe

> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge

---

From: touch at ISI.EDU (Joe Touch)
Date: Fri, 16 Dec 2005 16:45:16 -0800

> Just to be clear, no device generates ARPs directed at their own L2 address.

Also, devices DO issue ARPs sent to broadcast asking about their own L2s
(though that's not what I meant above). They're called "gratuitous
ARPs", and are used to check for machines on the net with colliding IP
addresses.

Joe