Subject: [rbridge] it's time to summarize things

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Thu, 15 Dec 2005 12:26:14 -0500

Joe,

	Taking things too litterally - so as to make them seem
ridiculous - is an argument style, not a communication skill.
Are we arguing to a purpose, or are we trying to communicate?

	The phrase "like being a router" is a very far cry from 
"being exactly like a router", and the phrase "the destination 
is a layer 2 address rather than an IP address" implies a lot 
of things about the differences between a router and an RBridge.

--
Eric

--> Routers do NOT propagate broadcasts at either L2 or L3.
--> 
--> So being an rbridge breaks broadcast, so ARP, DHCP, etc. won't work.
--> 
--> Joe
-->
--> Gray, Eric wrote:
--> Radia,
-->  
--> 	Very well put.
--> 
--> --> Being an RBridge is really like being a router, but the
--> --> destination is a layer 2 address rather than an IP address.
--> --> 
--> --> Radia
--> --> 
--> 
--> --
--> Eric
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge

--> -----Original Message-----
--> From: rbridge-bounces at postel.org 
--> [mailto:rbridge-bounces at postel.org] On Behalf Of Joe Touch
--> Sent: Thursday, December 15, 2005 11:08 AM
--> To: Developing a hybrid router/bridge.
--> Cc: Radia.Perlman at Sun.COM
--> Subject: Re: [rbridge] it's time to summarize things
--> 
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: touch at ISI.EDU (Joe Touch)
Date: Thu, 15 Dec 2005 09:37:53 -0800

> of things about the differences between a router and an RBridge.

Agreed, but it has already proven useful in eliciting the idea that
rbridges have external addresses that external hosts know about (which I
disagree with).

I have been very specific about the idea of being "like a bridge" or
"like a hub"; it allows me to encapsulate a lot of rules about what the
campus would do, w.r.t. nodes, bridges, etc.

If a campus is not "like" either a bridge or a hub, someone needs to
describe what it does - either in terms of another viable L2 analog, or
in terms of how it interacts with each level of protocol:

	- do external nodes address traffic to the ingress?
		I have been assuming NO.
		if they do, then a lot of protocols are affected
		and need modification and/or proxying.

	- do external bridges address traffic to rbridges?
	(basically BPDUs)
		I have been assuming YES.
		if not, then how do bridges know to forward
		traffic to the ingresses?

		if not, then can there be broadcast storms?
		if not, then will broadcast be supported?

(this is not necessarily a complete list, but it's a start; anyone want
to answer it?)

Joe

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 250 bytes
Desc: OpenPGP digital signature
Url : http://www.postel.org/pipermail/rbridge/attachments/20051215/2b8d27f8/signature.bin