Subject: [rbridge] Arch Issue #1

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Thu, 8 Dec 2005 13:36:34 -0500

--> 
--> #1 resolve recommendations for the three modes of BSTP messages:
-->    (is this part of the PS or ARCH?)
--> 	participate
--> 	forward
--> 	block

Block by default.  Optional configuration for forwarding and/or
participating MAY be allowed but SHOULD be considered sub-optimal.

---

From: touch at ISI.EDU (Joe Touch)
Date: Thu, 08 Dec 2005 13:40:14 -0800

> participating MAY be allowed but SHOULD be considered sub-optimal.

Forward maps to what hubs do.

Participate maps to what bridges do.

As a result, either of those can easily be considered as default cases,
though forward is clearly suboptimal.

As to block:

1. it seems clear that it works only under a certain set of assumptions
about ALL other L2 devices:

	a) ALL other L2 devices MUST pass rbridge's HELLO messages

	b) ALL other L2 devices MUST NOT also BLOCK

Neither rule can be assumed about an rbridge; by symmetry, why can we
assume them about all past and future L2 devices?

2. BLOCK + HELLO is basically just a variant of an STP where the rbridge
is in a privileged position of 'ultimate root' (which is why it works
when the two assumptions above are valid).

We can already assume that STP (or MSTP) works where STP (/MSTP) is
supported; why not just PARTICIPATE in STP at that point?

The HELLOs are just equivalent to BPDUs that discover which edge ports
are connected on the outside anyway. Why not just BPDUs at that point?

Joe

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Fri, 09 Dec 2005 10:57:30 +0100

Joe Touch wrote:

>-----BEGIN PGP SIGNED MESSAGE-----
>Hash: SHA1
>
>
>
>Gray, Eric wrote:
>  
>
>>--> 
So the DR election might be replaced by root bridge election. This is in 
line with my proposal related with the edge Rbridge being root bridge of 
the link.

>Joe
>-----BEGIN PGP SIGNATURE-----
>Version: GnuPG v1.2.4 (MingW32)
>Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org
>
>iD8DBQFDmKg+E5f5cImnZrsRAku1AKCNmYMTRjr1gRToob+Uh6LV443DcgCffQ1Q
>0DAGlCFmevHRYsQ6yyHgHeY=
>=4ck0
>-----END PGP SIGNATURE-----
>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>
>  
>

-- 
Guillermo Ib??ez
Departamento de Ingenier?a Telem?tica
Universidad Carlos III de Madrid
1.1.B.11 Colmenarejo 91-6241393
4.1.F.13 Legan?s 91-6248794