Subject: [rbridge] Should we optimize the common case?

From: jrrivers at nuovasystems.com (J. R. Rivers)
Date: Sat, 11 Nov 2006 08:39:09 -0800

Hierarchical addresses assume that a single rbridge "owns" a station.  With the current concept of universal mac addresses with rbridge advertisement, a single station can be reached through multiple rbriges... allowing effective dual homing.

I think that hierarchical station addresses require very careful thinking.

JR

> -----Original Message-----
> From: rbridge-bounces at postel.org 
> [mailto:rbridge-bounces at postel.org] On Behalf Of Silvano Gai
> Sent: Saturday, November 11, 2006 8:13 AM
> To: Guillermo Ib??ez; Caitlin Bestler
> Cc: rbridge at postel.org; Radia Perlman
> Subject: Re: [rbridge] Should we optimize the common case?
> 
> 
> This is something we should consider: it also gives the 
> possibility to introduce the LID in the hierarchy.
> 
> -- Silvano
> 
> > -----Original Message-----
> > From: rbridge-bounces at postel.org 
> [mailto:rbridge-bounces at postel.org] On
> > Behalf Of Guillermo Ib??ez
> > Sent: Friday, November 10, 2006 2:37 PM
> > To: Caitlin Bestler
> > Cc: rbridge at postel.org; Radia Perlman
> > Subject: Re: [rbridge] Should we optimize the common case?
> > 
> > 
> > 
> > Caitlin Bestler escribi?:
> > > rbridge-bounces at postel.org wrote:
> > >
> > >> Looking at this proposal, I get the impression that we are
> > >> somehow building a hierarchy, which is essential to get
> > >> scalability. However a more generic solution would have more
> > >> widespread applicability. See the attached slide with a
> > >> proposal from J. Morales for  a hierarchical structure usage
> > >> of MAC addresses (using the Local half of MAC addresses (U/L
> > >> bit set to Local) with  hierarchical structure).
> > >> Lack of hierarchical Ethernet (not replacing current
> > >> universal MACs) addresses is one of the main current
> > >> obstacles for Ethernet scalability at Metro level.
> > >> Guillermo
> > >>
> > >>
> > >
> > > How would a local hierarchical MAC address be assigned?
> > > Particularly, how would one be associated with a permanent
> > > global MAC address that an existing end node continued to use?
> > > Wouldn't this just replace one set of tables with another?
> > >
> > >
> > >
> > Perhaps the less disruptive implementation is to assign a local
> > hierarchical port MAC address to each port of a 
> "hierarchically capable"
> > RBridge.
> > The advantage of replacing many universal flat MAC addresses with
> > hierarchical MACs is that aggregation of the routes to 
> hosts is possible
> > (prefix announcement instead of host lists announcement between
> > RBRidges). And it is quite close to what has just been 
> proposed  if the
> > hierarchical MAC addresses include the RBridge nick-names 
> and/or other
> > shared "regional" identifier.
> > Address assignment may (and should) be of varied types: based on
> > topology discovery protocols, on spanning tree, management (OS)
> > controlled, etc. It is a matter of the network owner.
> > Regarding handling of the two types of MAC addresses,  I see two
> > mechanisms possible  in a mixed network, at ingress and 
> egress points:
> > - MAC swapping. The hierarchical bridge port replaces the 
> incoming MAC
> > by the hierarchically assigned local MAC. This seems mainly 
> convenient
> > for "leaf" ports where only one host is connected. Host is not aware
> > that the MAC is replaced by a hierarchical address.
> >  - MAC encapsulation.The "ingress" "hierarchical" bridge 
> encapsulates
> > the frame with the hierarchical MAC addresses in the outer 
> header. When
> > the link is shared by several hosts this looks the  most 
> straightforward
> > approach. This is more in line with the current 
> encapsulation scheme of
> > RBridges.
> > Regards
> > Guillermo
> > 
> > _______________________________________________
> > rbridge mailing list
> > rbridge at postel.org
> > http://mailman.postel.org/mailman/listinfo/rbridge
> 
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://mailman.postel.org/mailman/listinfo/rbridge
>

---

From: caitlinb at broadcom.com (Caitlin Bestler)
Date: Sat, 11 Nov 2006 19:20:25 -0800

J. R. Rivers wrote:
> Hierarchical addresses assume that a single rbridge "owns" a
> station.  With the current concept of universal mac addresses
> with rbridge advertisement, a single station can be reached
> through multiple rbriges... allowing effective dual homing.
> 

There are possible deployments of rbridges where the rbridge does
indeed "own" the end nodes, or perhaps it "owns" them in collaboration
with a partner rbridge. Prime examples would include an "rbridge"
implemented by a hypervisor and/or NIC to support multiple virtual
NICs, and a bridge connecting blades on a backplane with external
ethernet links.

But even in these environments, the individual OSs may want to
configure their MAC addresses individually. So hierarchical addresses
would seem to be a possible enhancement, but there is no obvious
path to using them generally.

As an option it would probably take the form of allowing
announcements of ranges of MAC addresses, rather than
requiring the  rbridge to announce each individually.

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Sun, 12 Nov 2006 21:31:03 +0100

Hierarchical address corresponds to the port of bridge where the station 
is attached, not to the station.
Guillermo