Subject: [rbridge] Comments on: http://www.ietf.org/internet-drafts/dr aft-ietf-trill-rbridge-arch-01.txt

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Wed, 1 Nov 2006 12:32:08 -0500

Silvano,

	Let's leave-off restating our cases, and simply let others 
comment on what they think is meant by this phrase in the charter.

--
Eric

--> -----Original Message-----
--> From: Silvano Gai [mailto:sgai at nuovasystems.com] 
--> Sent: Wednesday, November 01, 2006 12:22 PM
--> To: Gray, Eric
--> Cc: rbridge at postel.org
--> Subject: RE: [rbridge] Comments on: 
--> http://www.ietf.org/internet-drafts/draft-ietf-trill-rbridge
-arch-01.txt
--> 
--> Eric,
--> 
--> If the sentence "load-splitting among multiple paths", does not mean
--> Layer 2 ECMP, what does it mean?
--> 
--> How can I split the load among multiple paths, without doing
--> multipathing?
--> 
--> To split the load, I need at least two paths, If they are not Equal
--> Cost, what are they?
--> 
--> -- Silvano
--> 
--> > -----Original Message-----
--> > From: Gray, Eric [mailto:Eric.Gray at marconi.com]
--> > Sent: Wednesday, November 01, 2006 9:09 AM
--> > To: Silvano Gai
--> > Cc: rbridge at postel.org
--> > Subject: RE: [rbridge] Comments on: http://www.ietf.org/internet-
--> > drafts/draft-ietf-trill-rbridge-arch-01.txt
--> > 
--> > Silvano,
--> > 
--> > 	There is a difference.  I've been participating in this working
--> > group for some time, and I have not heard anyone suggest 
--> using L2 ECMP
--> > is what the charter means by "load-splitting among 
--> multiple paths."
--> > 
--> > 	However, I agree we need to be fair.  Consequently, let's ask
--> > other people to weigh in on this issue.  You assert that 
--> the charter
--> > means to include L2 ECMP as an explicit requirement of 
--> the TRILL work.
--> > I assert that it does not.
--> > 
--> > 	What do other people say?
--> > 
--> > --
--> > Eric
--> > 
--> > --> -----Original Message-----
--> > --> From: Silvano Gai [mailto:sgai at nuovasystems.com]
--> > --> Sent: Wednesday, November 01, 2006 11:29 AM
--> > --> To: Gray, Eric
--> > --> Cc: rbridge at postel.org
--> > --> Subject: RE: [rbridge] Comments on:
--> > --> http://www.ietf.org/internet-drafts/draft-ietf-trill-rbridge
--> > --> -arch-01.txt
--> > -->
--> > --> Eric,
--> > -->
--> > --> When I propose something that is not in the charter, it is
--> > --> out of scope
--> > --> because not in the charter; when I propose something 
--> that is in
--> the
--> > --> charter, it is out of scope because "this is not what 
--> the charter
--> is
--> > --> meant to
--> > --> describe."
--> > -->
--> > --> Let's be fair!
--> > -->
--> > --> IMHO, if TRILL does not support Layer 2 ECMP, it is not
--> > --> interesting at
--> > --> all for us. All the interest in replacing Spanning Tree is
--> > --> to get Layer
--> > --> 2 ECMP.
--> > -->
--> > --> -- Silvano
--> > -->
--> > --> > -----Original Message-----
--> > --> > From: Gray, Eric [mailto:Eric.Gray at marconi.com]
--> > --> > Sent: Wednesday, November 01, 2006 8:20 AM
--> > --> > To: Silvano Gai
--> > --> > Cc: rbridge at postel.org
--> > --> > Subject: RE: [rbridge] Comments on:
--> http://www.ietf.org/internet-
--> > --> > drafts/draft-ietf-trill-rbridge-arch-01.txt
--> > --> >
--> > --> > Silvano,
--> > --> >
--> > --> > 	As I said in my other reply, this is not what the
--> charter is
--> > --> meant
--> > --> > to
--> > --> > describe.
--> > --> >
--> > --> > --
--> > --> > Eric
--> > --> >
--> > --> > --> -----Original Message-----
--> > --> > --> From: Silvano Gai [mailto:sgai at nuovasystems.com]
--> > --> > --> Sent: Wednesday, November 01, 2006 1:08 AM
--> > --> > --> To: Gray, Eric
--> > --> > --> Cc: rbridge at postel.org
--> > --> > --> Subject: RE: [rbridge] Comments on:
--> > --> > --> 
--> http://www.ietf.org/internet-drafts/draft-ietf-trill-rbridge
--> > --> > --> -arch-01.txt
--> > --> > -->
--> > --> > -->
--> > --> > --> Eric,
--> > --> > -->
--> > --> > --> The charter says:
--> > --> > --> "load-splitting among multiple paths"
--> > --> > --> The pragmatic way to achieve this is to 
--> implement Layer 2
--> ECMP
--> > --> > -->
--> > --> > --> -- Silvano
--> > --> > -->
--> > --> > -->
--> > --> > --> > -----Original Message-----
--> > --> > --> > From: Gray, Eric [mailto:Eric.Gray at marconi.com]
--> > --> > --> > Sent: Tuesday, October 31, 2006 9:25 AM
--> > --> > --> > To: Silvano Gai
--> > --> > --> > Cc: rbridge at postel.org
--> > --> > --> > Subject: RE: [rbridge] Comments on:
--> > --> http://www.ietf.org/internet-
--> > --> > --> > drafts/draft-ietf-trill-rbridge-arch-01.txt
--> > --> > --> >
--> > --> > --> > Silvano,
--> > --> > --> >
--> > --> > --> > 	See below...
--> > --> > --> >
--> > --> > --> > --
--> > --> > --> > Eric
--> > --> > --> >
--> > --> > --> > -- [snip] --
--> > --> > --> > -->
--> > --> > --> > --> Sgai 2> I think we should explicitly 
--> mention layer 2
--> > --> > --> multipath.
--> > --> > --> > -->
--> > --> > --> > -- [snip] --
--> > --> > --> > -->
--> > --> > --> >
--> > --> > --> > What do you mean by layer 2 multipath?
--> > --> > --> >
--> > --> > --> > Do you mean "link bundling" or something else?
--> > --> > --> >
--> > --> > --> > Are we trying now to apply ECMP to routing 
--> advertisements
--> > --> > --> for layer
--> > --> > --> > two reachability?  That's a big step, particularly
--> > --> when we need
--> > --> to
--> > --> > --> > retain compatibility with existing 802.1 bridges.
--> > --> > --> >
--> > --> > --> > I don't recall seeing anything about this in 
--> the problem
--> > --> statement
--> > --> > --> > document, so I don't know of any reason why we should
--> > --> > --> include it in
--> > --> > --> > the architecture.
--> > --> > --> >
--> > --> > --> > --
--> > --> > --> > Eric
--> > --> > -->
--> > -->
-->

---

From: jmh at joelhalpern.com (Joel M. Halpern)
Date: Wed, 01 Nov 2006 12:45:31 -0500

With regard to the multiple path support, my understanding of the 
charter was that it was intended to permit the usage of multiple 
paths by traffic from different places.  I.e. to lift the restriction 
of STP to a single tree for the entire bridged network.
I did not think that it meant that traffic from a given ingress to a 
given egress was supposed to be able to use multiple paths, although 
I can see how a reader would get that.

Yours,
Joel M. Halpern

---

From: caitlinb at broadcom.com (Caitlin Bestler)
Date: Wed, 1 Nov 2006 10:03:12 -0800

rbridge-bounces at postel.org wrote:
> With regard to the multiple path support, my understanding of
> the charter was that it was intended to permit the usage of
> multiple paths by traffic from different places.  I.e. to
> lift the restriction of STP to a single tree for the entire bridged
> network. I did not think that it meant that traffic from a given
> ingress to a given egress was supposed to be able to use
> multiple paths, although I can see how a reader would get that.
> 

My take is that RBridges should not break any existing scheme that
spreads traffic across multiple paths, and I cannot think of any
way in which it might do so.

It is concievable that RBridges *could* be specced to load balance
traffic between any two rbridges, but it would be challenging to
do so in a way that maintained in-order delivery. Therefore I 
think most people would agree that such functionality should
not be part of the base protocol.