Subject: [rbridge] Should we optimize the common case?

From: sanjays at cisco.com (Sanjay Sane (sanjays))
Date: Sun, 12 Nov 2006 21:54:59 -0800

Guillermo:

We could have the end stations participate in a dhcp-like protocol to get their hierarchical mac addresses assigned to them by the edge switch. (or anyone who knows where they are attached to). The obvious benefit of the hiearchically assigned mac addresses is to obviate the need to do any mac learning for these addresses, thereby improving the scalability of mac learning/distribution in TRILL. 

In spite of having such end-stations that have hierarchically assigned mac addresses, we would still need to support end-stations with globally-assigned mac addresses. Thus, we would still need the shim "encapsulation" header of the outer MAC addresses that have the ingress & egress rbridge Ids (& other rbridge-related fields in the MAC header). 

Thus, im, we should have 2 pairs of MAC addresses as part of addressing. Outer for rbridge-id & rbridge related fields, inner for end-stations addresses. Having the end-station addresses hierarchical in nature would mostly help in the protocol learning / MAC distribution aspect of TRILL. 

-Sanjay

-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On Behalf Of Guillermo Ib??ez
Sent: Sunday, November 12, 2006 12:31 PM
To: J. R. Rivers
Cc: rbridge at postel.org; Radia Perlman
Subject: Re: [rbridge] Should we optimize the common case?

Hierarchical address corresponds to the port of bridge where the station is attached, not to the station.
Guillermo

J. R. Rivers escribi?:
> Hierarchical addresses assume that a single rbridge "owns" a station.  With the current concept of universal mac addresses with rbridge advertisement, a single station can be reached through multiple rbriges... allowing effective dual homing.
>
> I think that hierarchical station addresses require very careful thinking.
>
> JR
>  
>
>   
>> -----Original Message-----
>> From: rbridge-bounces at postel.org
>> [mailto:rbridge-bounces at postel.org] On Behalf Of Silvano Gai
>> Sent: Saturday, November 11, 2006 8:13 AM
>> To: Guillermo Ib??ez; Caitlin Bestler
>> Cc: rbridge at postel.org; Radia Perlman
>> Subject: Re: [rbridge] Should we optimize the common case?
>>
>>
>> This is something we should consider: it also gives the possibility 
>> to introduce the LID in the hierarchy.
>>
>> -- Silvano
>>
>>     
>>> -----Original Message-----
>>> From: rbridge-bounces at postel.org
>>>       
>> [mailto:rbridge-bounces at postel.org] On
>>     
>>> Behalf Of Guillermo Ib??ez
>>> Sent: Friday, November 10, 2006 2:37 PM
>>> To: Caitlin Bestler
>>> Cc: rbridge at postel.org; Radia Perlman
>>> Subject: Re: [rbridge] Should we optimize the common case?
>>>
>>>
>>>
>>> Caitlin Bestler escribi?:
>>>       
>>>> rbridge-bounces at postel.org wrote:
>>>>
>>>>         
>>>>> Looking at this proposal, I get the impression that we are somehow 
>>>>> building a hierarchy, which is essential to get scalability. 
>>>>> However a more generic solution would have more widespread 
>>>>> applicability. See the attached slide with a proposal from J. 
>>>>> Morales for  a hierarchical structure usage of MAC addresses 
>>>>> (using the Local half of MAC addresses (U/L bit set to Local) with  
>>>>> hierarchical structure).
>>>>> Lack of hierarchical Ethernet (not replacing current universal 
>>>>> MACs) addresses is one of the main current obstacles for Ethernet 
>>>>> scalability at Metro level.
>>>>> Guillermo
>>>>>
>>>>>
>>>>>           
>>>> How would a local hierarchical MAC address be assigned?
>>>> Particularly, how would one be associated with a permanent global 
>>>> MAC address that an existing end node continued to use?
>>>> Wouldn't this just replace one set of tables with another?
>>>>
>>>>
>>>>
>>>>         
>>> Perhaps the less disruptive implementation is to assign a local 
>>> hierarchical port MAC address to each port of a
>>>       
>> "hierarchically capable"
>>     
>>> RBridge.
>>> The advantage of replacing many universal flat MAC addresses with 
>>> hierarchical MACs is that aggregation of the routes to
>>>       
>> hosts is possible
>>     
>>> (prefix announcement instead of host lists announcement between 
>>> RBRidges). And it is quite close to what has just been
>>>       
>> proposed  if the
>>     
>>> hierarchical MAC addresses include the RBridge nick-names
>>>       
>> and/or other
>>     
>>> shared "regional" identifier.
>>> Address assignment may (and should) be of varied types: based on 
>>> topology discovery protocols, on spanning tree, management (OS) 
>>> controlled, etc. It is a matter of the network owner.
>>> Regarding handling of the two types of MAC addresses,  I see two 
>>> mechanisms possible  in a mixed network, at ingress and
>>>       
>> egress points:
>>     
>>> - MAC swapping. The hierarchical bridge port replaces the
>>>       
>> incoming MAC
>>     
>>> by the hierarchically assigned local MAC. This seems mainly
>>>       
>> convenient
>>     
>>> for "leaf" ports where only one host is connected. Host is not aware 
>>> that the MAC is replaced by a hierarchical address.
>>>  - MAC encapsulation.The "ingress" "hierarchical" bridge
>>>       
>> encapsulates
>>     
>>> the frame with the hierarchical MAC addresses in the outer
>>>       
>> header. When
>>     
>>> the link is shared by several hosts this looks the  most
>>>       
>> straightforward
>>     
>>> approach. This is more in line with the current
>>>       
>> encapsulation scheme of
>>     
>>> RBridges.
>>> Regards
>>> Guillermo
>>>
>>> _______________________________________________
>>> rbridge mailing list
>>> rbridge at postel.org
>>> http://mailman.postel.org/mailman/listinfo/rbridge
>>>       
>> _______________________________________________
>> rbridge mailing list
>> rbridge at postel.org
>> http://mailman.postel.org/mailman/listinfo/rbridge
>>
>>     
_______________________________________________
rbridge mailing list
rbridge at postel.org
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Mon, 13 Nov 2006 11:55:01 +0100

Sanjay,
Thanks for your feedback. Just a few comments interleaved, because I did 
not fully understand your reasoning.

> We could have the end stations participate in a dhcp-like protocol to get their hierarchical mac addresses assigned to them by the edge switch. (or anyone who knows where they are attached to). The…
I do agree
> In spite of having such end-stations that have hierarchically assigned mac addresses, we would still need to support end-stations with globally-assigned mac addresses. Thus, we would still need the…
I think that, if the ingress and egress RBridges had also "hierarchical" 
RBridge IDs (some kind of hierarchical "prefix" as RBridge ID, shorter 
than the end ports MAC addresses),  the outer MAC addresses would also 
be hierarchical, extending the benefits of hierarchy to inter RBridges 
routing.

> Thus, im, we should have 2 pairs of MAC addresses as part of addressing. Outer for rbridge-id & rbridge related fields, inner for end-stations addresses. Having the end-station addresses hierarchic…
I do not have a fixed position on whether the hierarchical MAC addresses 
belong to the end station or to the "leaf" ports, but I think that 
hierarchical MAC addresses somehow express a layer two "point of 
attachment" to network, rather than an station or interface identity. 
Other aspects regarding interoperability look simpler with hierarchical 
address assigned to switch port rather than to end node.
Regards
Guillermo