Subject: [rbridge] New shim header proposal---without F-tag field

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Wed, 1 Nov 2006 12:17:19 -0500

Silvano,

	Actually these sort of "scaling questions" are exactly why we don't
currently include necessarily making the TRILL/RBridge solution "more  
scalable" than Ethernet is now.  It is unlikely that we will ever agree
on exactly what is and is not "feasible."  

	However, we do have an implied goal of not deliberately limiting 
scalability of a TRILL/RBridge solution - at least for arbitrary reasons 
- and I maintain that trying to fit the SHIM into a 48-bit alignment (as 
opposed to the 32-bit alignment usually preferred in the IETF) is a pretty 
arbitrary reason.

--
Eric

--> -----Original Message-----
--> From: Silvano Gai [mailto:sgai at nuovasystems.com] 
--> Sent: Wednesday, November 01, 2006 11:55 AM
--> To: Russ White
--> Cc: Gray, Eric; Radia Perlman; rbridge at postel.org
--> Subject: RE: [rbridge] New shim header proposal---without 
--> F-tag field
--> 
--> 
--> What is a stretch is 32K trees of 32K nodes, which is what 
--> you need if
--> you want to deploy the current TRILL proposal with 32K RBridges.
--> 
--> Eric says that we need to accommodate half a million RBridges.
--> Half a million tree of half a million nodes is unfeasible.
--> 
--> If we want to support such a large number of Rbridges, we 
--> need to modify
--> the current Trill proposal, reducing the number of trees 
--> that need to be
--> computed.
--> 
--> Agreed?
--> 
--> -- Silvano
--> 
--> 
--> > -----Original Message-----
--> > From: Russ White [mailto:riw at cisco.com]
--> > Sent: Wednesday, November 01, 2006 8:35 AM
--> > To: Silvano Gai
--> > Cc: Gray, Eric; Radia Perlman; rbridge at postel.org
--> > Subject: Re: [rbridge] New shim header proposal---without 
--> F-tag field
--> > 
--> > -----BEGIN PGP SIGNED MESSAGE-----
--> > Hash: SHA1
--> > 
--> > 
--> > >> 	I don't think there is consensus yet that we 
--> only need 16 bits
--> > >> for RBridge IDs.
--> > >
--> > > With 16 bits, using 1 bit to indicate unicast, we can have 32K
--> switches.
--> > > According to the current definition of TRILL, there is 
--> the need to
--> run
--> > > Djikstra on a database with 32K records, one time for the core
--> instance
--> > > and 32K times for the IRTs. This is clearly out of 
--> reach even for
--> the
--> > > most powerful CPU.
--> > 
--> > ?? Perhaps 32k trees is a stretch, but 32k nodes in a 
--> tree? I don't
--> > think that's really a stretch on today's processors, from 
--> the scaling
--> > work I've seen done in IS-IS.
--> > 
--> > :-)
--> > 
--> > Russ
--> > 
--> > - --
--> > riw at cisco.com CCIE <>< Grace Alone
--> > 
--> > -----BEGIN PGP SIGNATURE-----
--> > Version: GnuPG v1.4.2.2 (MingW32)
--> > Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
--> > 
--> > iD8DBQFFSMypER27sUhU9OQRAqLwAJ9FLN2YNP2mrB6i0ZcV1fxLzAT0hgCfYHYj
--> > 6mJCA68nQLjCD8US9nRZZag=
--> > =kwzq
--> > -----END PGP SIGNATURE-----
-->

---

From: Donald.Eastlake at motorola.com (Eastlake III Donald-LDE008)
Date: Wed, 1 Nov 2006 14:06:35 -0500

Personally, I'm reluctant to go below 18 bits. We don't want to
necessarily allocate the values too densely, we don't really know what
future heuristics will come along, etc.

How would I handle the ingress trees if there were N Rbridges for some
large N (like 500,000) if I had to? The first idea that comes to mind is
to adopt a heuristic to select a subset of the Rbridges, say about
SQRT(N) (which would be 708 in this case), perhaps on the basis of the
richness of their connectivity and other heuristic factors. Then I'd
compute trees just for those Rbridges and, using the marvelous
capability you have successfully argued for, have frames that need
multicast/broadcast distribution directed to that much smaller number of
trees rather than the tree rooted at the Rbridge where they are
encapsulated.

Donald

--> -----Original Message-----
--> From: Silvano Gai [mailto:sgai at nuovasystems.com]
--> Sent: Wednesday, November 01, 2006 11:55 AM
--> To: Russ White
--> Cc: Gray, Eric; Radia Perlman; rbridge at postel.org
--> Subject: RE: [rbridge] New shim header proposal---without F-tag 
--> field
--> 
--> 
--> What is a stretch is 32K trees of 32K nodes, which is what you need 
--> if you want to deploy the current TRILL proposal with 32K RBridges.
--> 
--> Eric says that we need to accommodate half a million RBridges.
--> Half a million tree of half a million nodes is unfeasible.
--> 
--> If we want to support such a large number of Rbridges, we need to 
--> modify the current Trill proposal, reducing the number of trees that

--> need to be computed.
--> 
--> Agreed?
--> 
--> -- Silvano
--> 
--> 
_______________________________________________
rbridge mailing list
rbridge at postel.org
http://mailman.postel.org/mailman/listinfo/rbridge