Subject: [rbridge] DRB Priority

From: Eric Gray <[email-masked]>
Date: Fri, 18 Sep 2009 11:38:30 -0400

I have one or two dumb questions.

At several points in the base protocol specification, it states that DRB election depends
on (priority, MAC)  This information is presumably carried in TRILL-Hello messages.

The MAC SA of a message sender is easy enough, but where is the priority carried?

Since it is not explicitly listed as part of the information that MUST appear in all TRILL-
Hello messages, I assume it is part of the fixed header of IS-IS LAN Hello messages.
I further assume that the format and contents of the fixed header is defined in ISO/IEC
10589:2002 (since it does not make sense that this would be defined in either of the
other two references related to IS-IS in sections 8 and 9 - i.e. - IS-IS Cryptographic
Authentication, or IS-IS extensions for Traffic Engineering).

That's a "reaching assumption" because I cannot find anywhere that the draft equates
DRB priority to IS-IS DR priority.

If that assumption is true, why is there not an explicit reference near the text in section
4.4.2 referring to the "fixed header" of "an IS-IS LAN Hello" message?

If the assumption is not true, where would I look to find out where the priority field is
defined, and how it is carried in a TRILL-Hello message?

--
Eric
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 18 Sep 2009 13:41:59 -0400

Hi Eric,

> on (priority, MAC)  This information is presumably carried in TRILL-Hello

Yes.

> Authentication, or IS-IS extensions for Traffic Engineering).

Yes, the 7-bit priority field in the IS-IS LAN Hello fixed header in
specified ISO 10589 on page 66, Section 9.5.

> DRB priority to IS-IS DR priority.

DRB (Designated RBridge) is the the TRILL dialect for DIS (Designated
Intermediate System). They name the same thing. Probably a few words
should be added so that it is clear that the DRB determination
priority is the IS-IS DIS determination priority.

> 4.4.2 referring to the "fixed header" of "an IS-IS LAN Hello" message?

? When I look at draft -13, the very first paragraph of Section 4.4.2
is as follows:

   The TRILL-Hello has a new IS-IS message type. It starts with the same
   fixed header as an IS-IS LAN Hello.

> defined, and how it is carried in a TRILL-Hello message?

Thanks,
Donald

---

From: Eric Gray <[email-masked]>
Date: Fri, 18 Sep 2009 14:10:35 -0400

Donald,

	Thanks!  There is one reference to ISO 10589 that is
driectly related to DRB election, so I guess that it makes
sense that DRB priority is included.  Like you said, it 
could be a little clearer.

	Size was the information I was looking for.  I don't
know that I actually have access to the ISO standard itself,
but I needed to know the size of the field.

Thanks again...
--
Eric

-----Original Message-----
From: Donald Eastlake [mailto:[email-masked]] 
Sent: Friday, September 18, 2009 1:42 PM
To: Eric Gray
Cc: TRILL
Subject: Re: [rbridge] DRB Priority
Importance: High

Hi Eric,

Yes.

Thanks,
Donald