Subject: Re: [rbridge] multiple ports on same link

From: Radia Perlman <[email-masked]>
Date: Wed, 06 Jan 2010 15:49:57 -0800

Yes, I agree we need such a portId in the hello.

Additionally, we might say something like:

"If on port pa, you see a Hello with System ID=yours and port = pb, 
then if pb> pa, stop
transmitting anything (including Hellos) on pa (until Listen Time 
expires on port pa)."

Perhaps at some point someone might want to have an implementation that
load splits encapsulation/decapsulation (based on VLANs) among such parallel ports,
but as long as doing that is invisible to the other RBridges on the link, I don't
think we need to specify how to do that.

So I think either should do

a) just add the field portID in the hello, and not say anything more
b) or, in addition to adding the field, saying to stop transmitting
anything on all but one of such parallel ports, with something like
the wording above.

Radia

Jeff Pickering wrote:
>  
>  
>
> RB1 might have
>
>    one set of ports, say { p1, p2, p3 } on one link, and another set of
>
>    ports { p4, p5 } on a second link, and yet other ports, say p6, p7,
>
>    p8, that are each on distinct links.  Let us call a set of ports on
>
>    the same link as a "port group".
>
>  
>
> Ports dont know which port group they are in a-priori since this is 
> determined
>
> by external connectivity. Port group membership can only be determined by
>
> examination of received pdus.
>
> But since the hello pdus sent out all ports are currently identical, 
> (if all
>
> ports have the same mac, which is most common), there is no way for a 
> port to
>
> determine which "port group" it is in.
>
> If we add a portId, like in a bpdu, to the trill hello this problem 
> could be solved.
>
> The spec currently doesnt mention such an identifier. What is the 
> thinking here?
>
>  
>
> Jeff
>
>  
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://mailman.postel.org/mailman/listinfo/rbridge
>   

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: JR Rivers <[email-masked]>
Date: Wed, 6 Jan 2010 19:51:10 -0800

Seems like you'd just add the portId... that way the parallel links can be used as part of the ECMP.  Clearly, if there is 802.3ad trunking occurring on the links, they would be reported as a single logical link.

JR

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 8 Jan 2010 16:31:30 -0500

To be specific, I suggest adding an item to the list of data which must be
included in a TRILL Hello (Section 4.4.2) such as:

"A 16-bit port ID assigned by the sending RBridge to the port the
TRILL-Hello is sent on such that no two ports of that RBridge have the same
port ID."

Then adding at the end of Section 4.4.4:

"If an RBridge has more than one port connected to a link and those ports
have the same MAC address, they can be distinguished by the port ID contain
in TRILL-Hellos."

Thanks,
Donald
=============================
Donald E. Eastlake 3rd   +1-508-634-2066 (home)
155 Beaver Street
Milford, MA 01757 USA
[email-masked]