Subject: Re: [rbridge] Request for review ofdraft-ietf-trill-rbridge-mib-01.txt

From: Anil Rijhsinghani <[email-masked]>
Date: Wed, 26 Jan 2011 11:42:52 -0500

Hi Dan,

> 1. The relationship with other MIB module sections refer to the IETF RFCs.
> However, since 2006 the development of the Bridge MIB modules and their
> successors were transferred to IEEE 802.1. I suggest to define the
> relationship sections in relation to the IEEE MIB modules defined in
> IEEE 802.1ap

Will do.

> 2. Some of the objects with read-create MAX-ACCESS need DEFAULT clauses.
> In some cases the default is mention in the DESCRIPTION clause - this is not
> sufficient

OK, I'll add these clauses.

> 3. MIB structure - better group all MIB groups that define objects under one
> sub-tree
> rbridgeObjects           OBJECT IDENTIFIER ::= { rbridgeMIB 1 }

In other words, define a single sub-tree for objects, one for
notifications & one for conformance? It adds another level, but can certainly
be done. I’ve structured it in a manner parallel to earlier versions of the
Bridge MIB.

> 4. The current level of detail in the Security Considerations section is not
> sufficient.

Yes, will expand this section.

> 5. running libsmi compilation leads to a number of errors and warnings that need
> to be fixed. 

I compiled with a commercial manager prior to publication; will try libsmi. It would
be nice to have a MIB compiler on the IETF tools directory to check compliance,
if at all possible.

Regards,
Anil

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: January 3, 2011 11:09:55 AM EST
To: "Donald Eastlake" <[email-masked]>, "Developing a hybrid router/bridge." <[email-masked]>
Subject: Re: [rbridge] Request for review ofdraft-ietf-trill-rbridge-mib-01.txt

I did not have time for a full review, but here are my comments from a first quick examination of the document

1. The relationship with other MIB module sections refer to the IETF RFCs. However, since 2006 the development of the Bridge MIB modules and their successors were transferred to IEEE 802.1. I suggest to define the relationship sections in relation to the IEEE MIB modules defined in IEEE 802.1ap

2. Some of the objects with read-create MAX-ACCESS need DEFAULT clauses. In some cases the default is mention in the DESCRIPTION clause - this is not sufficient

3. MIB structure - better group all MIB groups that define objects under one sub-tree 

rbridgeObjects           OBJECT IDENTIFIER ::= { rbridgeMIB 1 } 

4. The current level of detail in the Security Considerations section is not sufficient. 

5. running libsmi compilation leads to a number of errors and warnings that need to be fixed. 

Regards,

Dan

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 26 Jan 2011 18:48:12 +0100

Hi Anil,

Thank you for your response and for addressing my comments. 

To your last point - libsmi
http://www.ibr.cs.tu-bs.de/projects/libsmi/tools/ is not maintained by
the IETF tools team but by volunteers from a German university. It is
however referenced from the OPS Area wiki page - see
https://svn.tools.ietf.org/area/ops/trac/wiki/mib-review-tools

Regards,

Dan

> -----Original Message-----
> From: Anil Rijhsinghani [mailto:[email-masked]] 
> Sent: Wednesday, January 26, 2011 6:43 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> > However, since 2006 the development of the Bridge MIB modules and 
> > their successors were transferred to IEEE 802.1. I suggest 
> to define 
> > the relationship sections in relation to the IEEE MIB 
> modules defined 
> > in IEEE 802.1ap
> 
> Will do.
> 
> > In some cases the default is mention in the DESCRIPTION 
> clause - this 
> > is not sufficient
> 
> notifications & one for conformance? It adds another level, 
> but can certainly be done. I've structured it in a manner 
> parallel to earlier versions of the Bridge MIB.
> 
> > 4. The current level of detail in the Security 
> Considerations section 
> > is not sufficient.
> 
> > 5. running libsmi compilation leads to a number of errors 
> and warnings 
> > that need to be fixed.
> 
> I compiled with a commercial manager prior to publication; 
> will try libsmi. It would be nice to have a MIB compiler on 
> the IETF tools directory to check compliance, if at all possible.
> 
> Regards,
> Anil
> 
> To: "Donald Eastlake" <[email-masked]>, "Developing a 
> hybrid router/bridge." <[email-masked]>
> I did not have time for a full review, but here are my 
> comments from a first quick examination of the document
> 
> 1. The relationship with other MIB module sections refer to 
> the IETF RFCs. However, since 2006 the development of the 
> Bridge MIB modules and their successors were transferred to 
> IEEE 802.1. I suggest to define the relationship sections in 
> relation to the IEEE MIB modules defined in IEEE 802.1ap
> 
> 2. Some of the objects with read-create MAX-ACCESS need 
> DEFAULT clauses. In some cases the default is mention in the 
> DESCRIPTION clause - this is not sufficient
>