Subject: [trill] New draft: draft-mizrahi-trill-loss-delay-00

From: Tal Mizrahi <[email-masked]>
Date: Mon, 18 Feb 2013 16:47:23 +0200

Hi,

We have uploaded a new draft titled "Loss and Delay Measurement in TRILL".

http://tools.ietf.org/html/draft-mizrahi-trill-loss-delay

Comments will be welcome.

Thanks,
Tal.

---

From: Gagan Mohan Goel <[email-masked]>
Date: Tue, 19 Feb 2013 08:24:25 +0000

Hi Tal,

Following are my views on the draft http://tools.ietf.org/html/draft-mizrahi-trill-loss-delay.

1) Section 4.2.3 SLR Message Reception

<snip>    The receiver computes the one-way packet delay with respect to a measurement interval. A measurement interval includes a sequence of
   1SLM message. The one-way packet delay is performed by comparing the counter values TXp and RXp at the beginning of the measurement
   interval, and the counter values TXc and RXc at the end of the  measurement interval (Figure 2):
<snip>

I understand that receiver can only calculate the one way packet loss (and not packet delay) with incoming SLM message. I think the above can be modified to:

 The receiver computes the one-way packet loss with respect to a measurement interval. A measurement interval includes a sequence of
   SLM message. The one-way packet loss is performed by comparing the counter values TXp and RXp at the beginning of the measurement
   interval, and the counter values TXc and RXc at the end of the  measurement interval (Figure 2):

2) 4.1.2<http://tools.ietf.org/html/draft-mizrahi-trill-loss-delay-00#section-4.1.2>. 1SLM Message Reception

<snip> The receiver MUST maintain a reception counter for each peer MEP and test ID. Upon receiving a 1SLM packet, the receiver MUST verify that:

   o The 1SLM packet is destined to the current MEP.

   o The packet's MD level matches the MEP's MD level.

<snip>
May be another criteria that can be added to handle any transient network loop scenario:
Ø  Discard the message if counter received in the incoming 1SLM message is lower than current RX count for same testID.
Regards
Gagan Mohan Goel

From: [email-masked] [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Monday, February 18, 2013 8:17 PM
To: [email-masked]
Cc: [email-masked]; Donald Eastlake ([email-masked]); Samer Salam (ssalam) ([email-masked])
Subject: [trill] New draft: draft-mizrahi-trill-loss-delay-00

Hi,

Thanks,
Tal.

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Tal Mizrahi <[email-masked]>
Date: Tue, 19 Feb 2013 11:34:07 +0200

Hi Gagan,

Thanks for your comments.
Please see my responses inline.

Tal.

From: Gagan Mohan Goel [mailto:[email-masked]]
Sent: Tuesday, February 19, 2013 10:24 AM
To: Tal Mizrahi
Cc: [email-masked]; Donald Eastlake ([email-masked]); Samer Salam (ssalam) ([email-masked]); [email-masked]
Subject: RE: New draft: draft-mizrahi-trill-loss-delay-00

Hi Tal,

[TM] Right. It is indeed a typo.

<snip>
May be another criteria that can be added to handle any transient network loop scenario:
Ø  Discard the message if counter received in the incoming 1SLM message is lower than current RX count for same testID.
[TM] Since packets can in some cases be received out-of-order, this filter may discard 1SLM packets that should be counted.

Regards
Gagan Mohan Goel

Hi,

Thanks,
Tal.

---

From: Gagan Mohan Goel <[email-masked]>
Date: Tue, 19 Feb 2013 10:14:36 +0000

Hi Tal,

Thanks for the reply.

Please find my views inline.

Thanks,
Gagan Mohan Goel

From: Tal Mizrahi [mailto:[email-masked]]
Sent: Tuesday, February 19, 2013 3:04 PM
To: Gagan Mohan Goel
Cc: [email-masked]; Donald Eastlake ([email-masked]); Samer Salam (ssalam) ([email-masked]); [email-masked]
Subject: RE: New draft: draft-mizrahi-trill-loss-delay-00

Hi Gagan,

Tal.

From: Gagan Mohan Goel [mailto:[email-masked]]
Sent: Tuesday, February 19, 2013 10:24 AM
To: Tal Mizrahi
Cc: [email-masked]<mailto:[email-masked]>; Donald Eastlake ([email-masked]<mailto:[email-masked]>); Samer Salam (ssalam) ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>
Subject: RE: New draft: draft-mizrahi-trill-loss-delay-00

Hi Tal,

<snip>
May be another criteria that can be added to handle any transient network loop scenario:
Ø  Discard the message if counter received in the incoming 1SLM message is lower than current RX count for same testID.
[TM] Since packets can in some cases be received out-of-order, this filter may discard 1SLM packets that should be counted.
[Gagan] I agree. Thanks for clarification. I was considering scenario where due to transient network loop, 1SLM packet (with same testID) is received more than once on the receiver. Receiver may also include the criteria to filter such duplicate packets.
Regards
Gagan Mohan Goel

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Monday, February 18, 2013 8:17 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Donald Eastlake ([email-masked]<mailto:[email-masked]>); Samer Salam (ssalam) ([email-masked]<mailto:[email-masked]>)
Subject: [trill] New draft: draft-mizrahi-trill-loss-delay-00

Hi,

Thanks,
Tal.