Subject: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

From: Donald Eastlake <[email-masked]>
Date: Tue, 3 Sep 2013 22:56:42 -0400

This is a call for WG comment on adopting
draft-mizrahi-trill-loss-delay-01.txt as a TRILL WG draft. Please
respond within two weeks. Comments suggesting improvements in the
draft will, unless they say otherwise, be interpreted as favoring WG
adoption.

Thanks,
Donald, Co-Chair
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Radia Perlman <[email-masked]>
Date: Thu, 5 Sep 2013 09:32:13 -0700

I support adopting it as a WG document.  It's a bit full of acronyms for my
taste, but at least they are all defined in one place.  The concepts seem
good and other than having to keep going back to the acronym expansion in
order to read the document, it seems well written too.

Radia

On Tue, Sep 3, 2013 at 7:56 PM, Donald Eastlake <[email-masked]> wrote:

> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 5 Sep 2013 13:31:53 -0400

On Sep 5, 2013, at 12:32 PM, Radia Perlman <[email-masked]> wrote:
> I support adopting it as a WG document.  It's a bit full of acronyms for my taste, but at least they are all defined in one place.  The concepts seem good and other than having to keep going back to the acronym expansion in order to read the document, it seems well written too.

As your AD, I should warn you that if this isn't fixed prior to publication, I will probably push back on it.   But that's not a reason not to adopt the document!

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 12 Sep 2013 08:45:20 +0300

I support WG adoption, as one of the authors.

As a side note, we realized that sections 8.1 and 8.2 would probably be more appropriately placed in the TRILL OAM MIB draft, and we plan to remove these sections in the next version of the loss-delay draft, and include them in the MIB draft.

Regards,
Tal.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Donald Eastlake
Sent: Wednesday, September 04, 2013 5:57 AM
To: [email-masked]
Subject: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

This is a call for WG comment on adopting draft-mizrahi-trill-loss-delay-01.txt as a TRILL WG draft. Please respond within two weeks. Comments suggesting improvements in the draft will, unless they say otherwise, be interpreted as favoring WG adoption.

Thanks,
Donald, Co-Chair
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA  [email-masked] _______________________________________________
trill mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/trill

---

From: gayle noble <[email-masked]>
Date: Thu, 12 Sep 2013 00:06:05 -0700

I'll second this.  Being a nubie I'm not real found of acronyms as I 
get lost a lot quicker, but it's the content that is important.
gayle

At 09:32 AM 9/5/2013, Radia Perlman wrote:
>I support adopting it as a WG document.  It's a bit full of acronyms 
>for my taste, but at least they are all defined in one place.  The 
>concepts seem good and other than having to keep going back to the 
>acronym expansion in order to read the document, it seems well written too.
>
>Radia

---

From: "Samer Salam (ssalam)" <[email-masked]>
Date: Thu, 12 Sep 2013 15:13:07 +0000

As co-author, would like to echo Tal's message. With the change to
sections 8.1 & 8.2, I think this draft is ready for workgroup adoption.

Regards,
Samer

On 13-09-11 10:45 PM, "Tal Mizrahi" <[email-masked]> wrote:

>As a side note, we realized that sections 8.1 and 8.2 would probably be
>more appropriately placed in the TRILL OAM MIB draft, and we plan to
>remove these sections in the next version of the loss-delay draft, and
>include them in the MIB draft.
>
>Regards,
>Tal.
>
>
>draft-mizrahi-trill-loss-delay-01.txt as a TRILL WG draft. Please respond
>within two weeks. Comments suggesting improvements in the draft will,
>unless they say otherwise, be interpreted as favoring WG adoption.
>
>Thanks,
>Donald, Co-Chair
> 155 Beaver Street, Milford, MA 01757 USA  [email-masked]

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Thu, 12 Sep 2013 21:08:40 +0000

Hi,

As co-author, I also echo with Tal's message.

Thanks,
Deepak

---

From: Jon Hudson <[email-masked]>
Date: Thu, 12 Sep 2013 15:38:47 -0700

Support for Working Group adoption.

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 12 Sep 2013 15:42:15 -0700

I support the adoption as WG doc.

-sam

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 12 Sep 2013 22:51:23 +0000

Support. 

Linda

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 12 Sep 2013 20:08:31 -0400

Hi Linda/Sam/Jon,

Sorry to pick on you and I guess it is partly my fault for not
reminding people of this when I issued the call for adoption below.

But the IETF is not a voting process. Just saying "support" or
"oppose" is pretty much meaningless and will have almost no effect.
See https://datatracker.ietf.org/doc/draft-resnick-on-consensus/

If you don't have some actual comment on the contents or on some
previous comment, it generally isn't worth posting, even if it is just
a call for adoption. I'll try to remind people of this in future calls
for adoption or the like.

Thanks,
Donald

---

From: Liyizhou <[email-masked]>
Date: Sat, 14 Sep 2013 10:05:23 +0000

I support to adopt it as delay measurement is a mandatory part for OAM. 

I would like to see some text to be added to the draft in future on real data traffic loss monitoring. Current only synthetic loss measurement was covered. Most OAM has both, synthetic and real traffic loss measurement, e.g. Y1731.

I understand it would be difficult for multicast. Was there any discussion for unicast?

Thanks,
Yizhou

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Donald Eastlake
Sent: Wednesday, September 04, 2013 10:57 AM
To: [email-masked]
Subject: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

Thanks,
Donald, Co-Chair

---

From: Haoweiguo <[email-masked]>
Date: Mon, 16 Sep 2013 11:12:34 +0000

Support!

________________________________________
发件人: Sam Aldrin [[email-masked]]
发送时间: 2013年9月13日 6:42
收件人: Donald Eastlake
抄送: [email-masked]
主题: Re: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

-sam

---

From: "Samer Salam (ssalam)" <[email-masked]>
Date: Mon, 16 Sep 2013 21:06:34 +0000

Hi Yizhou,

Loss Measurement using user (real) data traffic requires a 1:1
relationship between the transmitter and receiver which correspond to the
measurement endpoints. This can be guaranteed only when the connectivity
between endpoints is point-to-point. For TRILL, since the connectivity is
multi-point to multi-point, relying on user data traffic for loss
monitoring will yield erroneous results, and this goes beyond multicast: a
unicast frame may be flooded by an ingress Rbridge if the destination
address is unknown.

Regards,
Samer

On 13-09-14 3:05 AM, "Liyizhou" <[email-masked]> wrote:

>I would like to see some text to be added to the draft in future on real
>data traffic loss monitoring. Current only synthetic loss measurement was
>covered. Most OAM has both, synthetic and real traffic loss measurement,
>e.g. Y1731.
>

---

From: Liyizhou <[email-masked]>
Date: Tue, 17 Sep 2013 01:57:54 +0000

Hi Samer,

For unicast, if the measurement is based on VLAN, unknown unicast will cause problems as you described. If the measurement is based on finer granularity, say, flow based, it should be ok. The receiver end will compare the flow characteristic first and then decide if the frame should be counted. In this case, receiver will not count frames delivered to him but not from the intended transmitter. 

Thanks,
Yizhou

-----Original Message-----
From: Samer Salam (ssalam) [mailto:[email-masked]] 
Sent: Tuesday, September 17, 2013 5:07 AM
To: Liyizhou
Cc: Donald Eastlake; [email-masked]
Subject: Re: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

Hi Yizhou,

Loss Measurement using user (real) data traffic requires a 1:1 relationship between the transmitter and receiver which correspond to the measurement endpoints. This can be guaranteed only when the connectivity between endpoints is point-to-point. For TRILL, since the connectivity is multi-point to multi-point, relying on user data traffic for loss monitoring will yield erroneous results, and this goes beyond multicast: a unicast frame may be flooded by an ingress Rbridge if the destination address is unknown.

Regards,
Samer

On 13-09-14 3:05 AM, "Liyizhou" <[email-masked]> wrote:

>I would like to see some text to be added to the draft in future on 
>real data traffic loss monitoring. Current only synthetic loss 
>measurement was covered. Most OAM has both, synthetic and real traffic 
>loss measurement, e.g. Y1731.
>
>respond within two weeks. Comments suggesting improvements in the draft 
>will, unless they say otherwise, be interpreted as favoring WG adoption.
>
>Thanks,
>Donald, Co-Chair

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Tue, 17 Sep 2013 02:13:10 +0000

Measuring loss delay for real data is lot more complicated than comparing to a flow. Like it is done in Data Driven CFM in 8021 would require very sophisticated mechanisms. AFIK, these are not widely used. Hence as pointed out below statement to elaborate that this covers synthetic  flows is sufficient,  in my opinion.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Liyizhou
Sent: Monday, September 16, 2013 6:58 PM
To: Samer Salam (ssalam)
Cc: Donald Eastlake; [email-masked]
Subject: Re: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

Hi Samer,

Thanks,
Yizhou

-----Original Message-----
From: Samer Salam (ssalam) [mailto:[email-masked]]
Sent: Tuesday, September 17, 2013 5:07 AM
To: Liyizhou
Cc: Donald Eastlake; [email-masked]
Subject: Re: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

Hi Yizhou,

Regards,
Samer

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 26 Sep 2013 19:34:12 -0400

The TRILL WG has adopted draft-mizrahi-trill-loss-delay-01.txt as a WG document.

Based on the comments received, the authors should:
    Reduce the use of acronyms.
    Remove Sections 8.1 and 8.2.
    Make any corresponding editorial adjustments.

Thanks,
Donald