Subject: [trill] AD review and progressing of draft-ietf-trill-rfc6439bis-03

From: Alia Atlas <[email-masked]>
Date: Tue, 20 Dec 2016 17:28:20 -0500

As is customary, I have done my AD review of draft-ietf-trill-rfc6439bis-03.

First, I would like to thank the authors - Donald, Yizhou, Mohammed, Ayan
and Fengwei - for their work on thsi well-written document.

I do not have any specific comments on the draft from my review.   I have
requested IETF Last Call and placed the draft on the January 19 telechat.

I am slightly concerned by the complexity and number of different options
that TRILL has in most aspects - but given that there is WG consensus and
plans to implement, I am merely expressing my concerns.

Regards,
Alia

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 20 Dec 2016 19:13:51 -0500

Hi Alia,

On Tue, Dec 20, 2016 at 5:28 PM, Alia Atlas <[email-masked]> wrote:
> First, I would like to thank the authors - Donald, Yizhou, Mohammed, Ayan and Fengwei - for their work on thsi well-written document.
>
> I do not have any specific comments on the draft from my review.   I have requested IETF Last Call and placed the draft on the January 19 telechat.

Thanks for you review of this draft and of
draft-ietf-trill-directory-assist-mechanisms.

> I am slightly concerned by the complexity and number of different options that TRILL has in most aspects - but given that there is WG consensus and plans to implement, I am merely expressing my concerns.

I would guess you are primarily talking about the various methods by
which the Designated RBridge on a link can appoint forwarders in a
loop safe way. The design in the TRILL base protocol (RFC 6325) used
the non-framentable Appointed Forwarders TLV in non-fragmentable IS-IS
Hello PDUs that have a limited size. This was recognized as a problem.
So when IS-IS was extended to provide link (circuit) local link state
in RFC 7356, the forwarder appointment mechanism was specified via the
link local link state. There is additional complexity in making this
backwards compatible. It would have been cleaner to do it that way
from the start but the link local link state was not available.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]