Subject: Re: TSV-DIR review of draft-ietf-6man-ipv6-atomic-fragments-03

From: Joe Touch <[email-masked]>
Date: Thu, 24 Jan 2013 11:35:05 -0800

FWIW, this document includes text that somewhat defeats the previous 
recommendations of TCPM regarding RFC5927.

RFC5927 includes specific text indicating that the techniques described 
are being documented, but that the TCP standard was NOT being changed to 
include those ICMP validation checks.

This document states that:

       Many implementations fail to perform validation checks on the
       received ICMPv6 error messages, as recommended in Section 5.2 of
       [RFC4443] and [RFC5927].

I.e., the second RFC does NOT recommend changes; it documents them. This 
document should be VERY carefully reviewed to ensure that it does not 
undo the previous TCPM concerns about these techniques.

Joe

---

From: Fernando Gont <[email-masked]>
Date: Thu, 24 Jan 2013 18:24:01 -0300

Joe,

>       received ICMPv6 error messages, as recommended in Section 5.2 of

Are we fine if I remove "and [RFC5927]"? -- Because RFC4443 does
recommend that ICMPv6 messages be validated.

> undo the previous TCPM concerns about these techniques.

We can remove "and [RFC5927]" or change it to "...Section 5.2 of
[RFC4443] and documented in [RFC5927]"

Thoughts?

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Joe Touch <[email-masked]>
Date: Thu, 24 Jan 2013 16:19:32 -0800

> recommend that ICMPv6 messages be validated.

Sure.

> [RFC4443] and documented in [RFC5927]"

That might do it, but it would be useful if another pair of eyes would 
check.

Joe

---

From: Joe Touch <[email-masked]>
Date: Thu, 24 Jan 2013 17:59:00 -0800

Thanks - I wasn't positive about the second one. Glad to have it 
resolved quickly.

Joe

On 1/24/2013 5:57 PM, Allison Mankin wrote:
> Joe and Fernando,
>
> I just looked at how RFC 5297 is handled in the draft, to be that other
> pair of eyes.
>
> The first fix is right, to remove reference to RFC 5297 from that
> sentence entirely.
>
> Allison
>
> On Jan 24, 2013 7:19 PM, "Joe Touch" <[email-masked]
> <mailto:[email-masked]>> wrote:
>  >
>  >
>  >
>  > That might do it, but it would be useful if another pair of eyes
> would check.
>  >
>  > Joe
>  >
>  >>
>  >> Thoughts?
>  >>
>  >> Thanks,
>  >>
>