Subject: Re: AD sponsoring draft-masotta-tftpexts-windowsize-opt-09

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 5 Apr 2014 01:10:24 +0000

On Mar 13, 2014, at 11:50 PM, Eggert, Lars <[email-masked]> wrote:

> have there been any substantive changes addressing the lack of congestion control? If I recall correctly, that was the critical issue in the past. (The diff at the URL below doesn't seem to do that.)

The draft refers to RFC 5405, and indicates that while the specification doesn’t identify an upper bound on loss, any given implementation should.

For a single-packet-outstanding protocol, what would you like to see in congestion control? At most, I could imagine a comment on exponential backoff...

---

From: "Eggert, Lars" <[email-masked]>
Date: Sat, 5 Apr 2014 08:25:23 +0000

> For a single-packet-outstanding protocol, what would you like to see in congestion control? At most, I could imagine a comment on exponential backoff...

This extension takes TFTP way beyond "single-packet outstanding". That's what all the concern is about.

Lars