Subject: Re: Fw: Fw: I-D Action: draft-qin-tsvwg-uatnut-00.txt

From: Linlin Zhou <[email-masked]>
Date: Fri, 12 Jun 2015 14:11:31 +0800

Hi Xiaowei,

- Regardless of the UATN approach you mentioned in the document, I
feel like this is something like a reverse CDN. So I am wondering why
CDN providers do not have motivation to to this work? Is it technical
issues or not a problem at all.

- According to the report in [1], throughput measurements
   from over 1.5 million mobile devices have shown that compared with an
   average downstream throughput of over 1860 Kbps, the average upstream
   throughput is only about 430 Kbps.  This is because of the adoption
   of cache techniques such as CDNs to acelerate downloading large
   content that moves the "content" closer to end users.

I think the numbers you listed are not enough to prove the conclusion.
Do you have more detailed examples?

- typo in Figure 5
No arrow III is indicated in the paragraph.

> From: [email-masked]
> Date: 2015-05-29 11:47
> To: tsvwg; tsv-area
> Subject: Fw: Fw: I-D Action: draft-qin-tsvwg-uatnut-00.txt
> Dear all,
> I proposed an approach to upload acceleration transport network for upstream
> traffics, and the drafts was submitted.
>
> This is the link, http://datatracker.ietf.org/doc/draft-qin-tsvwg-uatnut/
>
> Any comments are welcome.
>
> Regards,
>
> Xiaowei Qin
>
>
> From: internet-drafts
> Date: 2015-05-29 11:16
> To: [email-masked]
> Subject: I-D Action: draft-qin-tsvwg-uatnut-00.txt
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>   Title           : Upload Acceleration Transport Network for Upstream
> Traffics
> Authors         : Xiaowei Qin
>                           Ning Kong
>                           Xiaodong Lee
> Filename        : draft-qin-tsvwg-uatnut-00.txt
> Pages           : 12
> Date            : 2015-05-28
>
> Abstract:
>    Photos, videos and other upstream traffics generated by end users are
>    rapidly increasing these days and expected to continue doing so in
>    the future.  A lot of factors, such as long round-trip-time (RTT),
>    low robustness of delivery, and transport bottlenecks, etc., lead to
>    low upload rate, which cause poor user experiences.  This draft
>    discusses an Upload Acceleration Transport Network(UATN) for upstream
>    traffics that use distributed cache servers and separates the upload
>    transaction into two parts for greater network efficiency.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-qin-tsvwg-uatnut/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-qin-tsvwg-uatnut-00
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 15 Jun 2015 15:46:51 +0800

hi, Linlin
Thanks again for you review and suggestion.

>Do you have more detailed examples?

The test is only for mobile devices, and the the report comes from: 
http://testmyiphone.com/stats.

This is the latest stats:
Download:
Download tests taken 3,140,257 
Average speed 3585.44 kbps
Upload:
Upload tests taken 708,158
Average speed 630.56 kbps

In order to validate the analysis described above, I have also take a practical measurement in China Mobile Labs (located in Beijing) which is the department of the China Mobile Limited. A data server deployed in Shenzhen, situated immediately north of Hong Kong (about 2500 kilometers away from Beijing) is used to continuously wait for packets from mobile devices. 
The mobile devices is connected to Internet via TD-LTE, and content generated by mobile devices is directly uploaded to the receiver without any acceleration processing. The average upstream throughput is about 180 kbps. 
I also deploy a data server in Beijing,  the average upstream throughput can be up to 860 kbps. 
Therefore, "moving content closer to end users results in greater network efficiency, increased robustness of delivery, and lower latency.

>Regardless of the UATN approach you mentioned in the document, I

The existing CDN is used to distribute content to end users, however, may not directly receive the content generated by end users.  For example, in downloading，when the user types a URL into his/her browser, the request will be redirected to the CDN through “CNAME” by the DNS.
However, in uploading, a "mechanism" is needed to redirect the requests of end users to UATN.  That is to say, the request of uploading content to data center will be redirected to an appropriate Edge Server to serve this uploading.

Regards,
Xiaowei Qin

From: Linlin Zhou
Date: 2015-06-12 14:11
To: qinxiaowei
CC: tsvwg; tsv-area
Subject: Re: Fw: Fw: I-D Action: draft-qin-tsvwg-uatnut-00.txt
Hi Xiaowei,

 
 
- typo in Figure 5