Subject: [Tsv-art] Fwd: Re: Flood of subscription requests to IETF mailing lists

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 1 Sep 2015 11:24:41 -0500

Just FYI. If you're seeing new patterns, Kathleen and Suresh had a policy
solution.

Spencer

---------- Forwarded message ----------
From: "Kathleen Moriarty" <[email-masked]>
Date: Aug 31, 2015 08:04
Subject: Re: Flood of subscription requests to IETF mailing lists
To: "Scott O. Bradner" <[email-masked]>
Cc: "WG Chairs" <[email-masked]>

> You just need to change subscribe_policy from "Require approval" to
> "Confirm and approve".
>
> Hopefully it keeps working once we all are doing the same thing :-)
>
> On Mon, Aug 31, 2015 at 8:20 AM, Scott O. Bradner <[email-masked]> wrote:
> > what do you do to change the subscription policy? (i.e. what are the
major buttons)
> >
> > Scott
> >
> >
> >
> >> On Aug 31, 2015, at 7:48 AM, Kathleen Moriarty <
[email-masked]> wrote:
> >>
> >> Loa,
> >>
> >> FYI - The filters Suresh posted suffer from the changing address
issue, changing the subscription policy does not and is still working.
> >>
> >> Best regards,
> >> Kathleen
> >>
> >> Sent from my iPhone
> >>
> >>> On Aug 31, 2015, at 5:55 AM, Loa Andersson <[email-masked]> wrote:
> >>>
> >>> Benoit,
> >>>
> >>> Yes, it works. As long as they keep sending from the same mail
address.
> >>> We just got the first 50 from a new set of addresses.
> >>>
> >>> And there is no pattern (other than gmail) that I can detect that
would
> >>> really help. I think that for the list we have under attack we could
ban
> >>> "gmail" without any real problem, but for a wg mailing list that would
> >>> not work.
> >>>
> >>> /Loa
> >>>
> >>>> On 2015-08-31 10:16, Benoit Claise wrote:
> >>>>> On 26/08/2015 01:07, Kathleen Moriarty wrote:
> >>>>> We were having the same problem with the same set of addresses on
> >>>>> another list, so my co-list manager changed the subscription to
> >>>>> confirm then approve.  It seems to be working.
> >>>> Thanks. I see 100 new requests / day on my directorate lists.
> >>>> I will apply your proposed trick.
> >>>>
> >>>> Regards, Benoit
> >>>>>
> >>>>> Thanks,
> >>>>> Kathleen
> >>>>>
> >>>>> Sent from my iPhone
> >>>>>
> >>>>> On Aug 25, 2015, at 7:01 PM, Andrew G. Malis
> >>>>> <<mailto:[email-masked]>[email-masked]> wrote:
> >>>>>
> >>>>>> Suresh,
> >>>>>>
> >>>>>> Thanks!
> >>>>>>
> >>>>>> I hadn't yet seen a problem with the PALS list, but I just added
> >>>>>> those entries to its ban_list just in case.
> >>>>>>
> >>>>>> Cheers,
> >>>>>> Andy
> >>>>>>
> >>>>>> On Tue, Aug 25, 2015 at 6:20 PM, Suresh Krishnan
> >>>>>> <<mailto:[email-masked]>[email-masked]>
> >>>>>> wrote:
> >>>>>>
> >>>>>>   Hi all,
> >>>>>>      One of the lists I moderate was inundated with a flood of
> >>>>>>   subscribe
> >>>>>>   messages from emails of the pattern
> >>>>>>
> >>>>>>   [email-masked] <mailto:[email-masked]>
> >>>>>>   [email-masked] <mailto:
[email-masked]>
> >>>>>>   [email-masked]
> >>>>>>   <mailto:[email-masked]>
> >>>>>>
> >>>>>>   Two other moderators and I cleared up about 60 of these requests
by
> >>>>>>   discarding manually but they kept coming. Looking for a better
> >>>>>>   solution
> >>>>>>   to the problem, we found a ban_list in the Privacy options for
the
> >>>>>>   mailman lists. This ban_list allows a regex for people who will
> >>>>>>   automatically be banned from joining. I added the following
emails to
> >>>>>>   the ban_list and the flood stopped.
> >>>>>>
> >>>>>>   ^kemo\[email-masked] <http://gmail.com>
> >>>>>>   [email-masked] <http://gmail.com>
> >>>>>>   [email-masked] <http://gmail.com>
> >>>>>>
> >>>>>>   I heard there are other lists that are having the same problems.
Hope
> >>>>>>   this can help.
> >>>>>>   Thanks
> >>>>>>   Suresh
> --
> Best regards,
> Kathleen

---

From: Wesley Eddy <[email-masked]>
Date: Tue, 1 Sep 2015 12:34:51 -0400

I put that in place when it was suggested, and it does seem to
be working for now.

On 9/1/2015 12:24 PM, Spencer Dawkins at IETF wrote:
> Just FYI. If you're seeing new patterns, Kathleen and Suresh had a
> policy solution.
> 
> Spencer
> 
> From: "Kathleen Moriarty" <[email-masked]
> <mailto:[email-masked]>>
> Date: Aug 31, 2015 08:04
> To: "Scott O. Bradner" <[email-masked] <mailto:[email-masked]>>
> Cc: "WG Chairs" <[email-masked] <mailto:[email-masked]>>
> 
>> On Mon, Aug 31, 2015 at 8:20 AM, Scott O. Bradner <[email-masked]
> <mailto:[email-masked]>> wrote:
>> >> On Aug 31, 2015, at 7:48 AM, Kathleen Moriarty
> <[email-masked]
> <mailto:[email-masked]>> wrote:
>> >>
>> >> Loa,
>> >>
>> >>> On Aug 31, 2015, at 5:55 AM, Loa Andersson <[email-masked]
> <mailto:[email-masked]>> wrote:
>> >>>
>> >>> Benoit,
>> >>>
>> >>> really help. I think that for the list we have under attack we
> could ban
>> >>>>> <<mailto:[email-masked]
> <mailto:[email-masked]>>[email-masked] <mailto:[email-masked]>>
> wrote:
>> >>>>>
>> >>>>>> Suresh,
>> >>>>>>
>> >>>>>> Thanks!
>> >>>>>>
>> >>>>>> <<mailto:[email-masked]
> <mailto:[email-masked]>>[email-masked]
> <mailto:[email-masked]>>
>> >>>>>> wrote:
>> >>>>>>
>> >>>>>>   Hi all,
> <mailto:[email-masked]
> <mailto:[email-masked]>>
>> >>>>>>   [email-masked]
> <mailto:[email-masked]>
> <mailto:[email-masked]
> <mailto:[email-masked]>>
>> >>>>>>   <mailto:[email-masked]
> <mailto:[email-masked]>>
>> >>>>>>
>> >>>>>>   Two other moderators and I cleared up about 60 of these
> requests by
>> >>>>>>   to the problem, we found a ban_list in the Privacy options
> for the
>> >>>>>>   ^kemo\[email-masked] <http://gmail.com> <http://gmail.com>
>> >>>>>>   [email-masked] <http://gmail.com> <http://gmail.com>
>> >>>>>>   [email-masked] <http://gmail.com> <http://gmail.com>
>> >>>>>>
>> >>>>>>   I heard there are other lists that are having the same
> problems. Hope
>> >>>>>>   this can help.
>> >>>>>>
>> >>>>>>   Thanks
>> >>>>>>   Suresh
>> >>>>
>> >>
>> >
>>
>>
>>
>> --
>>
>> Best regards,
>> Kathleen
>>
> 
> 
> 
> _______________________________________________
> Tsv-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tsv-art
> 

-- 
Wes Eddy
MTI Systems