Subject: [Tsv-art] FW: I-D Action: draft-leymann-banana-ecn-01.txt

From: "Black, David" <[email-masked]>
Date: Mon, 19 Mar 2018 16:40:24 +0000

If BANANA is going anywhere, this draft is going to need early TSV attention/input.  If one views a tunnel as a virtual link, then this draft is using ECN to do what is effectively link flow control in the form of load rebalancing among bonded tunnels.

Spencer/Mirja - what are the current state and likely prognosis of BANANA? 

Thanks, --David

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Sunday, March 18, 2018 9:51 PM
To: [email-masked]
Subject: I-D Action: draft-leymann-banana-ecn-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : BANdwidth Aggregation for interNet Access (BANANA) ECN Operations for Bonding Tunnels
        Authors         : Nicolai Leymann
                          Cornelius Heidemann
                          Jun Shen
                          Liang Geng
                          Lihao Chen
                          Mingui Zhang
                          Xuesong Geng
	Filename        : draft-leymann-banana-ecn-01.txt
	Pages           : 9
	Date            : 2018-03-18

Abstract:
   This document specifies a Bonding Tunnel ECN Mechanism that uses
   Explicit Congestion Notification (ECN) in bonding tunnels to notify
   congestion of a tunnel so that the load-balancing strategy of the
   tunnel ingress can be adjusted accordingly. Attributes for the
   control protocol of BANANA are defined to support this mechanism.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-leymann-banana-ecn/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-leymann-banana-ecn-01
https://datatracker.ietf.org/doc/html/draft-leymann-banana-ecn-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-leymann-banana-ecn-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Mon, 19 Mar 2018 16:54:58 +0000

The working group was not formed and there is currently no activity. So likely to go nowhere.

Not sure what the intention of the authors of this draft is.

Thanks for flagging!

Mirja

> Am 19.03.2018 um 16:40 schrieb Black, David <[email-masked]>:
> 
> Tsv-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tsv-art

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 20 Mar 2018 01:37:38 +0000

Hi, Suresh,

Any thoughts on the future of BANANA?

Thanks!

Spencer

On Mon, Mar 19, 2018, 16:40 Black, David <[email-masked]> wrote:

> If BANANA is going anywhere, this draft is going to need early TSV
> attention/input.  If one views a tunnel as a virtual link, then this draft
> is using ECN to do what is effectively link flow control in the form of
> load rebalancing among bonded tunnels.
>
>         Title           : BANdwidth Aggregation for interNet Access
> (BANANA) ECN Operations for Bonding Tunnels

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 20 Mar 2018 15:27:18 +0000

Hi Spencer,
  Have not heard anything until now but I am planning to meet with the proponents today. I will keep you updated.

Thanks
Suresh
________________________________
From: Spencer Dawkins at IETF <[email-masked]>
Sent: Tuesday, March 20, 2018 1:37:38 AM
To: Suresh Krishnan
Cc: [email-masked]
Subject: Re: [Tsv-art] FW: I-D Action: draft-leymann-banana-ecn-01.txt

Hi, Suresh,

Thanks!

Spencer

On Mon, Mar 19, 2018, 16:40 Black, David <[email-masked]<mailto:[email-masked]>> wrote:
If BANANA is going anywhere, this draft is going to need early TSV attention/input.  If one views a tunnel as a virtual link, then this draft is using ECN to do what is effectively link flow control in the form of load rebalancing among bonded tunnels.

Thanks, --David

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Sunday, March 18, 2018 9:51 PM
To: [email-masked]<mailto:[email-masked]>
Subject: I-D Action: draft-leymann-banana-ecn-01.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

[email-masked]<mailto:[email-masked]>

_______________________________________________
Tsv-art mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tsv-art

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Tue, 20 Mar 2018 16:01:59 +0000

The banana proponents or draft authors?

> Am 20.03.2018 um 15:27 schrieb Suresh Krishnan <[email-masked]>:
> 
> Hi Spencer, 
> https://datatracker..ietf.org/doc/draft-leymann-banana-ecn/
>

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 21 Mar 2018 09:19:16 +0000

Banana proponents. One of them happens to be an author on this draft as well. I have now had this conversation. I asked them to try to refocus on the multi-provider scenario and to try to address the objections raised. Will see if they do.

Thanks
Suresh

> On Mar 20, 2018, at 4:01 PM, Mirja Kuehlewind (IETF) <[email-masked]> wrote:
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 21 Mar 2018 11:29:07 +0000

Hi, Suresh,

On Wed, Mar 21, 2018 at 9:19 AM, Suresh Krishnan <[email-masked]> wrote:

> Banana proponents. One of them happens to be an author on this draft as
> well. I have now had this conversation. I asked them to try to refocus on
> the multi-provider scenario and to try to address the objections raised.
> Will see if they do.
>

Thank you. That's very helpful.

Spencer

> >>  Have not heard anything until now but I am planning to meet with the
> proponents today. I will keep you updated.
> >>
> >> Thanks
> >> Suresh