Subject: Re: [Tsvwg] Re: new I-D for SACK-based recovery

From: venkat venkatsubra <[email-masked]>
Date: Tue, 09 Jan 2001 10:19:30 -0600

Mark & Ethan,
Similarly when you retransmit the first time after
getting three duplicate ACKs (or whichever mechanism
you choose), can't you retransmit more than one segment ?
Step (4) in the algorithm seems to say only the first segment
is retransmitted. For e.g., if your first hole has 4 segments
and you get 3 duplicate ACKs, isn't all the bytes in the hole
eligibile for a retransmit ? If they are,  then how much is  one
allowed to retransmit ?
Thanks!
Venkat

Ethan Blanton wrote:

> venkat venkatsubra spake unto us the following wisdom:
> > In  Section 4 ("Algorithm Details"),  under (D),
> > are we allowed to send only one segment ?
> > Can't we send multiple segments ?
> > In rfc2018 in section 5.1 it mentions about
> > limiting the number of segments sent in response
> > to each ACK.  Can this limit be more than one ?
>
> My gut feeling is that you can send precisely the number of bytes that were
> ACKed...  This may or may not be one segment, I suppose.  Perhaps this needs
> clarification?
>
> Mark, any feelings on this?
> Ethan
>
> --
> *Notice*:  My GPG key has changed.  Please retrieve the new key via:
>             gpg --keyserver wwwkeys.us.pgp.net --recv-key 883C1C14
>            Sorry for the inconvenience.  Please note that the new key
>            is signed with my old key for preliminary verification.
>
>   ------------------------------------------------------------------------
>    Part 1.2Type: application/pgp-signature

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Mark Allman <[email-masked]>
Date: Tue, 09 Jan 2001 12:51:05 -0500

> What am i doing wrong in the following example ?
> Say, 16 segments are transmitted.
> Segments 1 to 4 are dropped.
> Duplicate ACKs for 5 to 13 are dropped.
> Duplicate ACKs for segments 14,15,16 reach the
> sender.
> Now, the new cwnd is 16/2 = 8 segments.
> 'pipe' = 4   (16 - 12 where 12 is the amount  SACKED).
> Won't this allow you to retransmit 4 segments (new cwnd minus pipe) ?

Ah, got it.  Yeah, I'll buy it.  And, in fact I *think* the new
draft (-01) allows for this.

allman

---
Mark Allman -- NASA GRC/BBN -- http://roland.grc.nasa.gov/~mallman/