Subject: Re: [Tsvwg] Re: new I-D for SACK-based recovery

From: Mark Allman <[email-masked]>
Date: Tue, 09 Jan 2001 12:11:20 -0500

> Similarly when you retransmit the first time after
> getting three duplicate ACKs (or whichever mechanism
> you choose), can't you retransmit more than one segment ?

No.  (Because that would be a viloation of the new value of cwnd).

> Step (4) in the algorithm seems to say only the first segment
> is retransmitted. For e.g., if your first hole has 4 segments
> and you get 3 duplicate ACKs, isn't all the bytes in the hole
> eligibile for a retransmit ? If they are,  then how much is  one
> allowed to retransmit ?

Ethan and I have been iterating on the draft and we believe we have
tightened up the specififcation of these details now.  We submitted
rev 01 yesterday afternoon so it will appear in the usual places
soon.  You can also slurp a copy of it from:

    http://roland.grc.nasa.gov/~mallman/papers/draft-allman-tcp-sack-01.txt

Please let us know if you still feel there are problems with the
document.

Thanks,
allman

---
Mark Allman -- NASA GRC/BBN -- http://roland.grc.nasa.gov/~mallman/

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: venkat venkatsubra <[email-masked]>
Date: Tue, 09 Jan 2001 11:37:32 -0600

> No.  (Because that would be a viloation of the new value of cwnd).

What am i doing wrong in the following example ?
Say, 16 segments are transmitted.
Segments 1 to 4 are dropped.
Duplicate ACKs for 5 to 13 are dropped.
Duplicate ACKs for segments 14,15,16 reach the
sender.
Now, the new cwnd is 16/2 = 8 segments.
'pipe' = 4   (16 - 12 where 12 is the amount  SACKED).
Won't this allow you to retransmit 4 segments (new cwnd minus pipe) ?

> Mark Allman -- NASA GRC/BBN -- http://roland.grc.nasa.gov/~mallman/

Venkat