Subject: Re: [Tsvwg] SCTP Sockets Mapping - Closure of TCP-style SCTP sock ets

From: Jonathan Wood <[email-masked]>
Date: Mon, 25 Jun 2001 17:45:52 -0700 (PDT)

> 
> So there are 3 choices to do this:
> 
> 1. Just have a socket level semantics for shutdown().  But it
> does not do anything in the SCTP level.
> 
> 2. In addition to 1, create a SCTP semantics for that.  The natural
> one is for shutdown(SHUT_WR) to initiate the close down sequence,
> SCTP will eventually send out the SHUTDOWN chunk.  But this is not
> compatible with the TCP semantics, which should be noted in the draft.
> This also precludes the use of any new flag in sendmsg() in the TCP
> style socket to do similar thing.
> 
> 3. In addition ot 1, use the same flag with sendmsg() as in UDP style 
> socket to do the close down sequence.
> 
> Note that close() remain to have the same meaning in all choices.
> 
> I think Brian voted for 2 already.  What do other people think?  Or
> is there other alternative?
> 

I think 2 is the way to go.

In addition, we need a way to abort an association and still
leave an open socket descriptor. shutdown() cannot be twisted
to fill this requirement, so I propose including a MSG_ABORT
flag in sendmsg(), just as UDP-style sockets do now.

Jonathan

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 25 Jun 2001 23:47:51 -0500

Jonathan,

What is the need for this?  I just can't think of why
an application would want to abort an association and
leave a the socket open...

--Brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Jacob Heitz <[email-masked]>
Date: Mon, 25 Jun 2001 22:19:23 -0700

> leave a the socket open...

To retrieve unsent and unacked messages.