Subject: RE: [Tsvwg] sctp error check, again

From: Robert Snively <[email-masked]>
Date: Tue, 19 Jun 2001 12:12:49 -0700

Randall,

Maybe this is the time we should spend some cycles to investigate
the behavior of a 32-bit one's complement checksum.  If it is not
only the fastest to calculate, but also works well in hardware
and has powerful checking characteristics, it can't help but beat
CRCs for this purpose.

Bob

>  -----Original Message-----
>  From: Randall Stewart [mailto:[email-masked]]
>  Sent: Tuesday, June 19, 2001 5:01 AM
>  To: Robert Snively
>  Cc: [email-masked]
>  Subject: Re: [Tsvwg] sctp error check, again
>  
>  
>  Bob:
>  
>  I have been meaning to reply to this, and in my
>  scan for missed names I found it again :) 
>  
>  I would have supported a TCP like 32 bit checksum
>  as well since it did prove to ALWAYS be the fastest
>  to implement. The reason I did not is that it is
>  completely unknown and un-studied. Having gone down
>  the Adler-32 path (silently I might add) I just can't see
>  changing from Adler-32 to another checksum that has
>  not been studied at all :-0
>  
>  R
>  
>  
>  Robert Snively wrote:
>  > 
>  > I stand corrected.  I had not realized that the Adler-32 was
>  > the result of keeping it the same.  I support "none of the
>  > above", which is essentially what you have described below.
>  > A desirable candidate would be a 32-bit checksum using the
>  > 32 bit one's complement of the one's
>  > complement sum of all 32 bit words, making the assumption that
>  > any padded bytes have a value of zero.  This is essentially a
>  > 32-bit version of the TCP/IP check sum.
>  > 
>  > I believe that this would facilitate implementations that
>  > make use of constructed packets or that require packet 
>  modification.
>  > 
>  > Bob
>  
>  -- 
>  Randall R. Stewart
>  [email-masked] 815-342-5222 (cell phone)
>  
>  

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 19 Jun 2001 14:25:49 -0500

Robert,

3 iffs in a row: thats a lot of iffs.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/