Subject: Re: [Tsvwg] SCTP shutdown

From: Jonathan Wood <[email-masked]>
Date: Wed, 20 Jun 2001 14:11:40 -0700 (PDT)

>
>I don't see any real technical problems with making SCTP operate
>in this TCP-compatible mode.  Sounds like a useful socket option.
>

Except that each data packet would generate a SACK and a
SHUTDOWN chunk. This is a really inefficient way to do
half-close. I wouldn't support this sort of functionality.

Jonathan

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 20 Jun 2001 17:24:10 -0500

Jonathan,

Well, no.  A SACK is only required with the SHUTDOWN if
gaps or dups need to be reported.  It is clear in the
RFC that if there are no gaps or dups there is no need
to bundle a SACK with a SHUTDOWN.  Now, SHUTDOWN will be
sent on each received packet, but since the sender of
the SHUTDOWN is not sending data, these SHUTDOWNs will
be sent no sooner that a SACK would in a bisymetrical
flow.  The SHUTDOWN chunk is actually smaller than the
SACK chunk and requires less processing.  It is actually
quite efficient: it keeps the ACK clock running and
consumes less control chunk resources to do so.

--Brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦