Subject: RE: [Tsvwg] CRC-Straw Poll Update

From: Robert Snively <[email-masked]>
Date: Tue, 19 Jun 2001 12:09:50 -0700

If people are concerned about detection of marginal hardware
failures, it is only fair to point out that most CRC hardware has
multiple single points of failure, many of which do not "fail safe",
but rather give a false indication that the CRC was valid.  For that
reason, the CRC is almost always supplemented with additional 
verification mechanisms, including verification of start/end
characters, verification of various header contents, and coding
violation checks.  Stuck faults of that nature can be tested using
power-on-self-test routines, but marginal faults and faults that
occur during an extended period of operation where diagnostics 
are not run are not revealed in any consistent manner.

Bob

>  -----Original Message-----
>  From: Randall Stewart [mailto:[email-masked]]
>  Sent: Tuesday, June 19, 2001 5:07 AM
>  To: TSV WG list
>  Subject: [Tsvwg] CRC-Straw Poll Update
>  
>  
>  All:
>  
>  After tabulating some others I had missed (thanks Ian)
>  here is the current standings. 
>  
>  Take a close look for your name and verify that
>  you are in the right class please (if you have
>  specified a preference that is).
>  
>  //////////////////////////////////////////////////
>  PLEASE SOUND OFF IF YOU ARE IN THE WRONG
>  CATAGORY!!!! OR I HAVE MIS-READ YOU.. Or maybe
>  some that are in the 1/2 or 1/3 or 2/3 catagory
>  could declare for only one please... it seems
>  to me that in past elections double punching
>  a vote was not allowed :=>
>  //////////////////////////////////////////////////
>  ***************************************************
>  Not counted/Unspecified
>  ***************************************************
>  Wants Others to decide/No-comment (once bitten twice shy):>
>  --------------
>  Chip Sharp 
>  
>  No preference but wants only 1:
>  -------------------------------
>  Kacheong Poon ( wants only one sum, no options)
>  
>  Still Unsure how to classify (Please speak up :>>):
>  -------------------------------
>  Ran Atkinson (wants justification for any switch)
>  
>  *********************************************************
>  Tabulated votes
>  *********************************************************
>  Keep the same (Option 1):
>  -------------------------
>  Ian Rytina
>  Michael Tuxen
>  Shymall Prasad
>  Hanns J Schwarzbauer
>  Alf Heidermark
>  Klaus Gradischnig (wants keep the same or CRC-32) (.5)
>  Qiaobing Xie (wants the same or Modifed-Alder ) (.5)
>  Javier Pastor-Balbas
>  Robert Snively
>  
>  Use Modified Adler-32 (Option 2):
>  ---------------------------------
>  Gareth Kiely
>  Qiaobing Xie (wants the same or Modifed-Alder ) (.5)
>  Lyndon Ong
>  
>  Use CRC-32 (Option 3):
>  ----------------------
>  Me
>  Michael Ramalho
>  Lloyd Wood
>  Jonathan Wood
>  Jim Williams
>  Stephen Bailey
>  La Monte Yarroll
>  Ivan Arias Rodriguez
>  Andreas Jungmaier
>  David Black
>  David Reed ** with preference for a MD5 Digest?
>  Douglas Otis ** with preference for a MD5 Digest?
>  David Lehmann
>  Brian Bidulock
>  Richard A. Adams
>  Robert Fairlie-Cuninghame
>  Wolfgang Schruefer
>  John Loughney
>  Laurent Glade 
>  Klaus Gradischnig (wants keep the same or CRC-32) (.5)
>  
>  *********************************************************
>  Summary Totals
>  *********************************************************
>  
>  Total 1) 8
>  
>  Total 2) 2.5
>  
>  Total 3) 19.5
>  
>  Total unspecified) 3
>  
>  ---------------------------------------------------
>  Total folks commenting on: 33
>  ---------------------------------------------------
>  
>  
>  R
>  -- 
>  Randall R. Stewart
>  [email-masked] 815-342-5222 (cell phone)
>  
>  _______________________________________________
>  tsvwg mailing list
>  [email-masked]
>  http://www1.ietf.org/mailman/listinfo/tsvwg
>  

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Douglas Otis" <[email-masked]>
Date: Tue, 19 Jun 2001 18:49:55 -0700

Bob,

SCTP has a format that includes length and validation to assist such a fail
safe together with an initial all one's seed within the CRC algorithm.  From
conservative estimates of undetected errors, not based on the higher failure
rates of simple sums in the face of stuck memory bus errors or swapped
blocks, any business transaction would greatly benefit by a CRC algorithm.
Summation does not detect rather simple failures although it is indeed
faster.  What testing do you feel is needed in this area?

Doug