Subject: Re: [Tsvwg] SCTP Sockets Mapping - Closure of TCP-style SCTP sock ets

From: Jonathan Wood <[email-masked]>
Date: Wed, 27 Jun 2001 14:56:29 -0700 (PDT)

Recall that SCTP will not send a SHUTDOWN until all outstanding
data has been ACK's by the peer. So the only way you can get
unsent data when trying to do an orderly shutdown is if the
peer stops responding and the connection times out.

Jonathan
 
>
>I think that it could make sense to allow the app to request the
>delivery of messages after shutdown(fd, SHUT_WR), but not actually
>deliver them up until after SCTP has sent SHUTDOWN or SHUTDOWN-ACK.
>Then there may be no need to try to do this ABORT thing to retrieve
>messages quickly.
>

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 27 Jun 2001 22:05:21 -0500

Jonathan,

No problem.  If there are messages in queue that are holding
back a SHUTDOWN when retrieval is requested, retrieve them
and send a SHUTDOWN immediately (the user has called them 
back, they are no longer in queue, and there is no pending
data).

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/