Subject: RE: [Tsvwg] Another view of the SCTP error check problem

From: Robert Snively <[email-masked]>
Date: Fri, 29 Jun 2001 10:27:39 -0700

My assumption has been that what you are really after is 
a transport mechanism that will allow iSCSI and other framed
activity typical of storage interfaces to be carried with
a minimum of higher level checking.  Storage is not satisfied
with any undetected errors, since they are revealed as
undetected data integrity failures in the returned data.
Such failures can have undetermined and perhaps catastrophic
effects to applications.

If you say that you are guaranteeing 1 undetected error in 10**11 
or 1 error in 10**14 bytes, storage folk will say that is all very 
nice, now send me the name of a real storage transport.  Alternatively,
the storage folk will say that they will do the checking themselves and
TCP will do very nicely as a transport mechanism.  That is the
path that iSCSI is presently taking.

If merely meeting the SS7 error numbers is your goal, then what 
I have said is not relevant and may safely be ignored.

Bob Snively                        e-mail:    [email-masked]
Brocade Communications Systems     phone:  408 487 8135
1745 Technology Drive
San Jose, CA 95110

>  -----Original Message-----
>  From: Adams, Richard Anthony (Richard) [mailto:[email-masked]]
>  Sent: Friday, June 29, 2001 5:38 AM
>  To: TSV WG list
>  Subject: RE: [Tsvwg] Another view of the SCTP error check problem
>  
>  
>  Alternatively...
>  Robert Snively wrote:
>  
>  > I have a goal of less than one undetected error per
>  > million years.  There are pi * (10**7) seconds per year,
>  > so I can tolerate one error per 3 * (10**13) seconds.
>  > At 10 Gbits = 1.2 GBytes, that means that I can tolerate 
>  > roughly one undetected error in 3.6 * (10**22) bytes. 
>  [RAA] Why this strict ? Surely one error per SCTP lifetime 
>  would be good
>  enough ?
>  Anyway, taking the SS7 SCTP requirements, which is one 
>  undetected error per
>  10**10 messages (or 10**9 for ANSI), at a SIF length for 
>  narrow band MTP of
>  272 octets, we have a requirement of 1 undetected error in 
>  ~3 * 10**12 (or
>  10**11) bytes. [raa]

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart at work <[email-masked]>
Date: Fri, 29 Jun 2001 12:42:45 -0500

Robert:

SS7 is the original requirments that we were attempting
to meet with SCTP. Now SCTP's scope has broadened by
a bit :) But I think it is safe to say we do need to
meet these minimum requirments... It looks to me that Richard
has shown that Adler-32 can NOT meet these requirements which
may then change Ian's mind :)

Ian, what do you say to Richards numbers.. maybe he can
supply more details if your still not conviced that there
is a problem :>

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: "Douglas Otis" <[email-masked]>
Date: Fri, 29 Jun 2001 11:28:53 -0700

Bob,

Even if you view any transport as needing additional error checking, if you
examine the iSCSI protocol you will discovery a messy situation involved in
attempting to recover for the transport.  Due the relative weakness of this
transport summation scheme that fails at a far higher rate than the 2^n size
of the summation, when used over the Internet an additional application
mechanism may be invoked many times a day at 10 GE.  If the transport is
protected by CRC-32, then for the Internet this additional mechanism may be
invoked at a yearly rate where this lower rate allows simpler schemes
without a notable reduction in performance.  An alternative to using the
Internet could be a proactively maintained network however where the lower
failure rate also allows this scheme to be practical.

How are you expecting to recover from an error missed by the transport when
using FCIP as example?

Doug