Subject: Re: [Tsvwg] Use of association IDs on UDP-style SCTP sockets (draft-ietf-tsvw g-sctpsocket-00.txt)

From: Jonathan Wood <[email-masked]>
Date: Mon, 25 Jun 2001 11:43:39 -0700 (PDT)

>> This is a very good idea.  Jonathan, do you want me to compose text or
>> do you want to?
>> 
>
>
>I think Jonathan already checked his earlier changes back into the cvs
>tree ... so
>why don't you make the changes...

I concur with Randy :)

>> >
>> > It seems clear to me that we need a new socket option to allow applications
>> > to turn on/off acceptance of incoming associations on UDP sockets.  We
>> > cannot use the suggested method of overloading the SCTP_RECVASSOCEVNT 
socket
>> > option.
>> 
>> This makes sense to me.  Randy, what do you think?  I remember that we
>> had quite a lengthy discussion of controling incoming associations...
>> 
>
>If I remember right, we did the combined GET EVENTS/GET ASSOC's
>automatically
>has a convience. It seems right to me to have a:
>
>SCTP_RECVASSOCEVNT
>and a
>SCTP_INBOUNDASSOC
>
>option...
>

Just one small point: SCTP_INBOUNDASSOC sounds an awful
lot like listen()...

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Mon, 25 Jun 2001 15:26:58 -0500

> Just one small point: SCTP_INBOUNDASSOC sounds an awful

Oh, GAK... you are right... el.yucko...

Of course I did not want to have to turn it on to
begin with :) I would have prefered to always get
associations in no matter what... but of course that
was another hot debate we compromised our way out of :-0

Of course even if we have such an ugly thing, I still do
not have to do accept()'s which is something I object to
much more strongly.. and the main thing I want to
get away from..

Calling it a listen() I think would be confusing...since
when you do a listen() you normally think in terms
of needing to do some number of accept()'s in combination
with this...

If you added listen() to the udp model, it would not
have accepts in combination with it...  

I guess we could just call it listen().. I would not
object.... the more I think on it... but it may
be confusing to a programmer to do a listen and no
accepts...

Jonathan what do you think... will it not confuse
people to have something you did a listen on but
no accept()?

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)