Subject: Re: [Tsvwg] Comments on draft-ietf-tsvwg-sctpsocket-00.txt

From: Randall Stewart <[email-masked]>
Date: Mon, 18 Jun 2001 14:14:10 -0500

Jonathan Wood wrote:
>
> 
> Hmm but the normal behavior now for TCP-style sockets
> is to not ignore the address if present.
> 
> I still think we get the same functionality by not
> including the flag. It's actually simpler for socket
> API callers too, since the API is simpler without
> the flag (1/2 the number of combos to consider):
> 
>                          flag set           flag unset
> 
> msg_name is NULL         send to primary    send to primary
> 
> msg_name is non-NULL     send to alternate  send to primary
> 
> vs.
> 
> msg_name is NULL         send to primary
> 
> msg_name is non-NULL     send to alternate
> 
> I suspect that if we include the flag for TCP-style
> sockets, a common programming error will be to
> include the address but then forget to set the flag.
> Let's nip this one in the bud.
> 
> Jonathan

Sounds good to me.. Having msg-name set to me is
equivalant to the flag...

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Jonathan Wood <[email-masked]>
Date: Mon, 18 Jun 2001 12:08:06 -0700 (PDT)

>this behavior. In fact even thought Jonathan commented that
>it was redundant in TCP, I think maybe if he thinks on it
>he may agree that it is needed here too. 
>
>I don't see that the stack should ever use addresses for anything
>but locating the association in the UDP side unless this flag

For UDP-sockets, I agree.

>is set. For the TCP flag, I would think this flag would indicate,
>"ok, I now have to look at this address, since normally I ignore it
> and as long as it is valid I will override the primary with it".
>

                         flag set           flag unset

vs.

Jonathan