Subject: RE: [Tsvwg] I-D ACTION:draft-tuexen-tsvwg-tls-over-sctp-00.txt

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Wed, 27 Jun 2001 04:10:38 -0700

Hi Michael,

I guessed as much - shame. What if the application asserts the unordered
delivery flag in a particular datagram (or the stream is configured for
U-SCTP)? At the very least I think this should be mentioned/disallowed in
the draft.

Cheers,

Robert.

-----Original Message-----
From:	Tuexen Michael [mailto:[email-masked]]
Sent:	Wednesday, June 27, 2001 11:12 AM
To:	'Fairlie-Cuninghame, Robert'; Tuexen Michael;
[email-masked]'
Cc:	[email-masked]
Subject:	RE: [Tsvwg] I-D
ACTION:draft-tuexen-tsvwg-tls-over-sctp-00.txt

Dear Robert,

SCTP provides the support of the multiple streams to avoid head of line
blocking. We thought that this feature should also be available to the
(TLS/SCTP)-user.

We also wanted to keep TLS as it is. TLS needs a guaranteed and in sequence
delivery service from its lower layer. This service is provided by a stream,
but NOT by an assocaition. So a connection maps to a bi directional stream.

We also thought about having only one connection for an association (with
multiple streams) but this needs some changes/adaptions of TLS. So we
decided
to use the simpler solution unless we see the need for the more complex one.

Best regards
Michael

Michael Tuexen    Tel.:   +49 89 722 47210
Siemens AG        Fax:    +49 89 722 48212
ICN WN CS SE 5    E-mail: [email-masked]

> -----Original Message-----
> From:	Fairlie-Cuninghame, Robert [SMTP:[email-masked]]
> Sent:	Wednesday, June 27, 2001 12:03 PM
> To:	[email-masked]'; [email-masked]'
> Cc:	[email-masked]
> Subject:	RE: [Tsvwg] I-D
ACTION:draft-tuexen-tsvwg-tls-over-sctp-00.txt
> 
> Hi Michael & Andreas, 
> 
> Why was the decision made to map each TLS connection  to an SCTP stream to
a rather than an SCTP association? To me this would seem to be the natural
overlay of TLS onto SCTP. I'm not very familiar with the workings of TLS, is
there a technical problem in doing this ? 
> Regards, 
> Robert.

---

From: Andreas Jungmaier <[email-masked]>
Date: Wed, 27 Jun 2001 16:59:10 -0400

> U-SCTP)? At the very least I think this should be mentioned/disallowed in

It is exactly as Michael put it: 
the user of SCTP in that case is TLS, which does not have provisions
for unreliable data transmission.

Regards,

- -- 

Andreas Jungmaier

- ----------------------------------------------------------------------------
 \|/ _____ \|/    Andreas Jungmaier, Dipl.-Ing. 
 "@'/ , . \`@"    University of Essen           [email-masked]
 /_| \___/ |__\   -> Computer Networking        Tel. : +49 (0201) 183-7636
    \___U_/          Technology Group <-
- ----------------------------------------------------------------------------
PGP Public Key and Fingerprint: see http://www.exp-math.uni-essen.de/~ajung
- ----------------------------------------------------------------------------

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart at work <[email-masked]>
Date: Wed, 27 Jun 2001 10:59:07 -0500

Andreas Jungmaier wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

Or un-ordered which I think was the point.. NOT u-sctp but

SCTP with the U bit set :)

R

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.5 (GNU/Linux)
> Comment: For info see http://www.gnupg.org
> 
> iD8DBQE7Okked2Uw+xBvGUIRAo90AJ4juSaYran5gVP6cp7UvRwVdhAAcQCbBnbE
> ROH9BFPRYtdK5egnJ9hBi7Q=
> =Um3l
> -----END PGP SIGNATURE-----
> 

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 27 Jun 2001 11:43:56 -0500

> for unreliable data transmission.

If un-ordered and/or un-reliable data transfer is the focal point of the
application, then IPsec, instead of TLS, should be considered.

TLS has no difficulty dealing with SCTP multi-homing (if used as
proposed in the tls-over-sctp draft), but won't support un-ordered and
un-reliable data operation. While IPsec has full support to both
un-ordered and un-reliable features, it does interact with SCTP
multi-homing and is a little tricky to setup (see
draft-ietf-ipsec-sctp-00.txt).

-Qiaobing

---

From: Andreas Jungmaier <[email-masked]>
Date: Wed, 27 Jun 2001 19:02:49 -0400

> SCTP with the U bit set :)

Yep, you got me there, that is what I actually meant ;-)
"The user of SCTP in this case is TLS, which does not have provisions
 for _unordered_ data transmission."

Regards,

- -- 

Andreas Jungmaier