Subject: Re: [Tsvwg] Use of association IDs on UDP-style SCTP sockets (draft-ietf-tsvw g-sctpsocket-00.txt)

From: Jonathan Wood <[email-masked]>
Date: Mon, 25 Jun 2001 14:01:32 -0700 (PDT)

>Of course even if we have such an ugly thing, I still do
>not have to do accept()'s which is something I object to
>much more strongly.. and the main thing I want to
>get away from..

Right.

>Jonathan what do you think... will it not confuse
>people to have something you did a listen on but
>no accept()?
>

I think it's a bit more intuitive to call listen()...
If someone gets confused by this, then chances are
they don't understand the UDP-style sockets programming
model, and will soon encounter much greater trouble.

Also, if accept() returns something like EOPNOTSUPP on a
UDP-style socket, a confused programmer will quickly have
the path to greater trouble blocked off.

j

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Mon, 25 Jun 2001 17:09:37 -0500

> the path to greater trouble blocked off.
Ok,

good point... La Monte.. lets go ahead and not add it
has a sockopt but instead let us go with listen() for
the udp model.

And of course ye ole EOPNOTSUPP is a path unto greater understanding :)

R
-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)